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Quick Reference 

Toolbox overview
 Shift      
 Function

Toolbar shortcuts
•      Alt + click tool or  + press shortcut key to cycle through hidden tools (except 

 
 
 
 

).
•      Double-click tool or select tool and press Return to display Options palette.
•      Right-click to display context-sensitive menu.
•      Press  to constrain dragging or drawing to straight line or multiples of 45º.
•      Press Caps Lock to use precise cross hair for brushes.
•      Press Enter to apply, or press Esc or Ctrl +  to cancel, an operation of a magnetic tool.



Quick Reference 

Selecting & moving
 Shift      
 Function

Repositions marquee while selecting Any marquee tool + spacebar + drag

Adds to or subtracts from a selection Any selection tool +  or Alt + drag 

Intersects a selection Any selection tool +  + Alt + drag 

Constrains marquee to square or 
circle 

 + drag

Draws marquee from center Alt + drag

 Ctrl (except when  or any pen tool 
is selected)

Switches from  to Alt + drag

Switches from  to Alt + click

Moves copy of a selection   + Alt + drag selection

Moves selection 1 pixel Any selection tool or  +   
 *

Moves layer 1 pixel Ctrl +     * 

Increases or decreases detection 
width

  + [ or ] 

Accepts cropping or exits cropping  + Enter or Esc

Makes protractor  + Alt + drag end point 

Snaps guide to ruler ticks  + drag guide

Changes guide orientation to 
horizontal or vertical

Alt + drag guide

*Hold down  to move 10 pixels.



Quick Reference 

Path editing
 Shift      
 Function

Selects multiple anchor points  +  + click

Selects entire path  + Alt + click

Duplicates a path  + Alt + Ctrl + drag 

Switches from any pen tool to Ctrl

Switches from  to  Alt

Switches between  and Alt

Switches from  to  when pointer is 
over anchor point or direction point

Alt + Ctrl

Switches from  to Alt

Closes path  + double-click

Closes path with straight-line 
segments

 + Alt + double-click

Deletes last point  + Backspace

Converts path to selection Any pen tool + Enter (on numeric 
keypad)

Switches from  to  Alt + drag

Switches from  to  Alt + click



Quick Reference 

Painting shortcuts
 Shift      
 Function

Any painting or editing tool + Alt 

 + 

Deletes   + Alt + click

Selects background color  + Alt + click

Sets opacity, pressure, or exposure for
painting mode or active layer

Any painting or editing tool + number 
keys(e.g., 0 = 100%, 1 = 10%, 4 then 
5 in quick succession = 45%)

Cycles through painting and layer 
blending modes

 +  

Fills selection/layer with foreground or 
background color

Alt + Backspace, or Ctrl + Backspace*

Fills from history Alt + Ctrl + Backspace*

Displays Fill dialog box  + Backspace

Turns Preserve Transparency option 
on/off

/

Connects points with a straight line Any painting tool +  + click

*Hold down  to fill with Preserve Transparency on.



Quick Reference 

Gradient editing
 Shift      
 Function

Creates new gradient Ctrl + N in Gradient Editor

Selects individual gradients or 
contiguous gradients 

Ctrl + click or  + click in Gradient 
Editor

Saves selected gradients as map 
settings

Ctrl + click Save in Gradient Editor



Quick Reference 

Viewing
 Shift      
 Function

Fits image on screen Double-click , or Ctrl + Ø (zero)

100% magnification Double-click , or Alt + Ctrl + Ø 
(zero)

Zoom in or out Ctrl +  or 

 or Ctrl + spacebar, or Alt + spacebar

Applies zoom percentage and keeps 
zoom percentage box active

 + Enter in Navigator palette

Zooms in on specified area of image Ctrl + drag over preview in Navigator 
palette

Scrolls image with hand tool Spacebar + drag, or drag view area 
box in Navigator palette

Scrolls up or down 1 screen Page Up or Page Down*

Scrolls up or down 10 units  + Page Up or Page Down*

Moves view to upper left corner or 
lower right corner

Home or End

Turns rubylith view of layer on/off \

*Hold down Ctrl to scroll left or right.



Quick Reference 

Type Tool dialog box
 Shift      
 Function

Moves type in image Drag type when Type Tool dialog box 
is displayed

Aligns left, center, or right  +  + Ctrl + L, C , or R

Aligns top, center, or bottom  +  + Ctrl + L, C, or R

Selects 1 character to the left/right or 
1 line below/above

 +    

Selects all characters Ctrl + A

Selects characters from insertion point
to mouse click point

 + click

Moves 1 character left/right, 1 line 
down/up, or 1 word left/right

  ,  , or Ctrl +  

Decreases/increases type size of 
selected text 2 points/pixels

 + Ctrl + < >

Decreases/increases type size of 
selected text 10 points/pixels

 + Alt + Ctrl + < >

Decreases/increases leading 2 
points/pixels

Alt +  *

Decreases/increases baseline shift 2 
points/pixels

 + Alt +  *

Decreases/increases kerning/tracking 
20/1000 ems

Alt +  

Decreases/increases kerning/tracking 
100/1000 ems

Alt + Ctrl +  

*Hold down Alt to decrease/increase leading or baseline shift 10 points/pixels.



Quick Reference 

Blending modes* (part 1)
 Shift      
 Function

Normal  + Alt + N

Threshold (bitmap mode)  + Alt + L

Dissolve  + Alt + I

Behind  + Alt + Q

Clear  + Alt + R

Multiply  + Alt + M

Screen  + Alt + S

Overlay  + Alt + O

Soft Light  + Alt + F

Hard Light  + Alt + H

Color Dodge  + Alt + D

Color Burn  + Alt + B

Darken  + Alt + K

*Sets painting blending modes (if the active tool supports this) or sets layer blending modes.



Quick Reference 

Blending modes* (part 2)
 Shift      
 Function

Lighten  + Alt + G

Difference  + Alt + E

Exclusion  + Alt + X

Hue  + Alt + U

Saturation  + Alt + T

Color  + Alt + C

Luminosity  + Alt + Y

Desaturate  +  + Alt + J

Saturate  +  + Alt + A

Shadows   +  + Alt + W

Midtones   +  + Alt + V

Highlights   +  + Alt + Z

 

*Sets painting blending modes (if the active tool supports this) or sets layer blending modes.



Quick Reference 

3D Transform dialog box
 Shift      
 Function

Selection tool V

Cube tool M

Sphere tool N

Cylinder tool C

Trackball R

Pan camera tool E



Quick Reference 

Hue/Saturation dialog box
 Shift      
 Function

Moves range to new location  + click in image

Subtracts from range  + Alt + click in image

Adds to range  +  + click in image

Rotates color spectrum Ctrl + click ramp



Quick Reference 

Curves dialog box
 Shift      
 Function

Adds new point on curve of selected 
channel

Ctrl + click in image

Adds new point on all curves except 
composite curves

 + Ctrl + click

Moves selected points    

Moves selected points in increments 
of 10

 +    

Selects multiple control points  + click

Moves forward through control points Ctrl + Tab

Moves backward through control 
points

 + Ctrl + Tab

Adds new point Click grid

Deletes point Ctrl + click point

Deselects all points on selected 
channel

Ctrl + D

Makes curves grid finer or coarser Alt + click grid



Quick Reference 

Other shortcuts
 Shift      
 Function

Creates new file with default settings Alt + Ctrl + N

Displays dialog box for the previous 
filter

Alt + Ctrl + F

Resets dialog box to last settings used Alt + click Reset

Displays last-viewed Preferences 
dialog box

Alt + Ctrl + K

Loads last color adjustment settings 
used

Alt + choose Image > Adjust (Levels, 
Curves, Color Balance, etc.) 

Increases/decreases selected value in
dialog box by 1 unit (except in filters)

 *

Erases to history  + Alt + drag

Activates button in alert box First letter of button label

Switches between  and  Alt

Switches between  and  Alt

*Hold down  to increase/decrease value by 10 units.



Quick Reference 

Common palette shortcuts
 Shift      
 Function

A. Ctrl + click thumbnail loads as selection.  + Ctrl + click thumbnail adds to current selection. Alt + Ctrl
+ click thumbnail subtracts from current selection. 

 + Alt + Ctrl + click intersects with current selection.    
B. Creates new layer, channel, path, or snapshot; Alt + click sets options.
C. Deletes selected layer, channel, path, or state; Alt + click deletes without confirmation.

Other common palette shortcuts

• Tab shows/hides all palettes.

•  + Tab shows/hides all palettes except the Toolbox.



Quick Reference 

Layers palette
 Shift      
 Function

A. Double-click adjustment layer opens Color Adjustment dialog box.
B. Shows/hides layer; Alt + click shows this layer only/shows all layers.
C. Click between layer and layer mask thumbnails links them.
D. Links layers.
E. Indicates active paint layer (brush icon if layer image is active, mask icon if layer mask is active).
F. Adds new layer mask; Alt + click adds inverted mask.
G. Ctrl + click adds new adjustment layer.

H. Alt + click line between layers creates clipping group.

I. Double-click changes layer or layer mask options;  + click turns layer mask on/off; Alt + click 
switches between layer mask view/composite image; 

 + Alt + click turns rubylith on/off.
J. Type layer; Double-click edits type layer.
K. Layer effect icon; Double-click edits the last-edited layer effect; Alt + double-click clears the most 
recent layer effect.

Layers menu shortcuts

• Alt + Merge Down copies current layer to layer below.

• Alt + Merge Visible merges visible layers to active layer.

• Alt + Merge Linked merges linked layers to active layer.

Other layer shortcuts

• F7 shows/hides palette.

• Alt + [ ] descends/ascends through layers.

• Alt + Ctrl + [ ] moves active layer down/up.

•  + Alt + [ ] activates bottom/top layer.
• Alt toggles layer effects.
• Drag effect in image when Layer Effects dialog box is displayed moves effect in image.



Quick Reference 

Channels palette
 Shift      
 Function

A. Shows/hides channels; Click top icon shows/hides composite channel.
B. Loads channel as a selection. 
C. Saves current selection as a new channel; Alt + click sets options.
D. Ctrl + click creates a new spot channel.
E.  + click color channel selects/deselects in multiple color-channel selection.

Other channel shortcuts

•  + click alpha channel switches between composite color channel and alpha channel.
• Double-click alpha channel changes channel name and options.
• ~ displays composite.



Quick Reference 

Actions palette
 Shift      
 Function

A. Turns set on/off.
B. Turns action on/off.
C. Turns command on/off; Alt + click turns current command on and all others off.
D. Turns breakout point on/off; Alt + click turns on current breakout point and turns off all other breakout 
points in an action.
E. Stops action.
F. Records action.
G. Plays action; Ctrl + click plays a command.
H. Creates new set.
I. Creates new action and begins recording; Alt + click creates and begins recording new actions without 
confirmation.

J. Double-click changes action options; Ctrl + double-click plays entire action; Alt + click 
collapses/expands all components of an action.

K. Turns on all breakout points in an action.

L. Double-click records commands again (double-click set or action displays Options dialog box).

Other action shortcuts

• F9 shows/hides palette.

•  + click selects multiple items of the same kind.



Quick Reference 

History palette
 Shift      
 Function

A. Sets source for history brush.
B. Snapshot.
C. States of the image, from first to most recent;  + Ctrl + Z steps forward; Alt + Ctrl + Z steps 
backward; Double-click on snapshot displays Rename Snapshot dialog box; Alt + click duplicates all 
states except the current state.
D. Drag slider moves selection between snapshots and states.
E. Creates new document from current state or snapshot.
• Alt + Clear History (in History menu) clears history permanently.



Quick Reference 

Paths palette
 Shift      
 Function

A. Path name;  + Ctrl + click adds path to selection; 
 + Alt + Ctrl + click retains intersection of path; Alt + Ctrl + click removes path from selection; 
 + Ctrl + H hides path.

B. Fills path with current foreground color; Alt + click sets options.
C. Strokes path with current stroke tool; Alt + click sets options.
D. Loads path as selections; Alt + click sets options.
E. Makes selection a work path; Alt + click sets options.



Quick Reference 

Brushes palette
 Shift      
 Function

• F5 shows/hides palette.

• Click in empty area of palette creates new brush. 

• Ctrl + click brush deletes brush.

• [ or ] cycles through brushes.

•  + [ selects first brush.
•  + ] selects last brush.
• Double-click brush edits current settings.



Quick Reference 

Swatches palette
 Shift      
 Function

• Click empty swatch creates new swatch.

•  + Alt + click inserts new swatch.
• Ctrl + click swatch deletes swatch.
• Alt + click swatch selects background color.
•  + click swatch replaces color.



Quick Reference 

Color palette
 Shift      
 Function

• F6 shows/hides palette.

• Alt + click color in color bar selects background color.

• Ctrl + click color bar displays Color Bardialog box.

•  + click color bar cycles through color choices.



Quick Reference 

Info palette
 Shift      
 Function

• F8 shows/hides palette.

• Click eyedropper icon changes color readout modes.

• Click cross-hair icon changes measurement units.



Quick Reference 

Transform of selections, selection borders, and paths
 Shift      
 Function

• Alt transforms from center or reflects.
•  constrains.
• Ctrl distorts.
• Return or Enter applies.
• Ctrl +  or Esc cancels.
• Alt + Ctrl + T free transforms with duplicate data.
•  + Alt + Ctrl + T transforms again with duplicate data.



Looking at the Work Area

See also: 

Using the toolbox 

Using the status bar 

Using palettes 

Using context menus 

Using Adobe online services 

Viewing images 

Using plug-in modules 

Setting preferences 



Looking at the Work Area 

Using the toolbox

The tools in the toolbox let you select, paint, edit, and view images. Other controls choose foreground 
and background colors, create quick masks, and change the screen display mode. Most tools have 
associated Brushes and Options palettes, which let you define the tools’ painting and editing effects. 
(See Using the Options palette.)

For information on the foreground and background color controls, see Choosing the foreground and 
background colors; on Quick Mask mode control, see Using Quick Mask mode.

To display the toolbox:

Choose Window > Show Tools.

To move the toolbox:

Drag the toolbox by its title bar.

See also: 

Selecting tools 

Using the tool pointers 



Using the toolbox 

Selecting tools

You select a tool by clicking its icon in the toolbox. A small triangle to the right of a tool icon indicates a
pull-out menu of hidden tools.

To select a tool:

Do one of the following:
•      To select a visible tool, click its icon.
•      To select a hidden tool, position the pointer on the visible tool, and drag to highlight the tool you 
want.

 Use these shortcuts to select tools: 
• To select a tool quickly, press its shortcut key on the keyboard. 
• To cycle through a set of hidden tools, press Alt (Windows) or Option (Mac OS) and click the visible tool; 
or hold down Shift and press the visible tool’s shortcut key.

To display the active tool name:

Position the pointer over the triangle in the bottom border of the program window (Windows) or image 
window (Mac OS), hold down the mouse button, and choose Current Tool from the menu.

The name of the currently selected tool appears in the lower left of the window.



Using the toolbox 

Using the tool pointers

When you select most tools, the mouse pointer matches the tool’s icon. This is the default standard 
tool pointer. The marquee, line, and gradient pointers appear by default as crosshairs. 

Each default pointer has a different hot spot, where an effect or action begins. You can switch to 
precise pointers, which appear for most tools as cross hairs centered around the hot spot. For the 
magnetic lasso and magnetic pen tools, precise pointers appear as circles representing the lasso or 
pen width. With the painting tools, you can also display the pointer as a brush shape of a certain size.

To set the tool pointer appearance:

1    Choose File > Preferences > Display & Cursors.

2    Select the tool pointer appearance:
•      Click Standard under Painting Cursors, Other Cursors, or both to display pointers as tool icons.
•      Click Precise under Painting Cursors, Other Cursors, or both to display pointers for most tools as 
crosshairs. 
•      Click Brush Size under Painting Cursors to display the painting tool pointers as brush shapes 
representing the size of the current brush. Brush Size pointers may not display for very large brushes.

3    Click OK.

With very small brushes, the brush shape is surrounded by four dots for finer accuracy.

A. Standard    B. Precise    C. Brush Size 

The Painting Cursors options control the pointers for the eraser, pencil, airbrush, paintbrush, rubber 
stamp, pattern stamp, smudge, blur, sharpen, dodge, burn, and sponge tools. 

The Other Cursors options control the pointers for the marquee, lasso, polygon lasso, magic wand, 
crop, eyedropper, pen, gradient, line, paint bucket, magnetic lasso, magnetic pen, measure, and color 
sampler tools.

 To change the appearance of some tool pointers, press Caps Lock. Press Caps Lock again to return 
to your original setting. The pointers change in these ways: 
• Standard to precise 
• Precise to brush size 
• Brush size to precise



Looking at the Work Area 

Using the status bar

The status bar at the bottom of the program window displays useful information—such as the current 
magnification and file size of the active image, and brief instructions for using the active tool.

To show or hide the status bar (Windows only):

Choose Window > Show Status Bar or Window > Hide Status Bar.



Looking at the Work Area 

Using palettes

Palettes help you monitor and modify images. You can display or hide them as you work. By default, 
they appear in stacked groups.

To show or hide a palette:

Choose the appropriate Window > Show or Window > Hide command. 

Show displays the selected palette at the front of its group; Hide conceals the entire group.

See also: 

Changing the palette display 

Setting the positions of palettes and dialog boxes 

Using the Options palette 

Using pop-up sliders 

Using the Info palette 



Using palettes 

Changing the palette display

You can reorganize your work space using the following techniques:
•      To hide or display all open palettes and the toolbox, Press Tab. To hide or display the palettes only,
press Shift+Tab.
•      To make a palette appear at the front of its group, click the palette’s tab.
•      To move an entire palette group, drag its title bar.
•      To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette outside of an 
existing group creates a new group. 
•      To move a palette to another group, drag the palette’s tab to that group.
•      To display a palette menu, position the pointer on the triangle in the upper right corner of the 
palette, and hold down the mouse button. 
•      To change the height of a palette (except the Color, Options, or Info palette), drag its lower right 
corner. To return the palette to default size, click the minimize/maximize box (Windows) or the resize 
box (Mac OS) in the right of the title bar. (A second click collapses the palette group.)
•      To collapse a group to palette titles only, Alt-click the minimize/maximize box (Windows) or Option-
click the resize box (Mac OS). Or double-click a palette’s tab. You can still access the menu of a 
collapsed palette.



Using palettes 

Setting the positions of palettes and dialog boxes

The positions of all open palettes and moveable dialog boxes are saved by default when you exit the 
program. Alternatively, you can always start with default palette positions or restore default positions at
any time.

To reset palettes to the default positions:

1    Choose File > Preferences > General.

2    Click Reset Palette Locations to Defaults.

To start always with the preset palette and dialog box positions: 

1    Choose File > Preferences > General.

2    Deselect Save Palette Locations. The change takes effect the next time you start Adobe 
Photoshop.



Using palettes 

Using the Options palette

Most tools have an Options palette. Depending on the tool selected, the palette’s appearance and 
available choices change.

Some settings in the Options palette are common to several tools (such as painting modes and 
opacity), some specific to one tool (such as the Auto Erase setting for the pencil tool). 

To display the Options palette:

Do one of the following:
•      Choose Window > Show Options. 
•      Double-click a tool in the toolbox (except the zoom or hand tool). 
•      Click a tool or press its keyboard shortcut, and press Enter (Windows) or Return (Mac OS).

Paintbrush Options palette

To return to a tool’s default settings:

Do one of the following:
•      To return a tool to its default settings, double-click the tool in the toolbox, and choose Reset Tool 
from the Options palette menu. 
•      To return all the tools to their default settings, choose Reset All Tools from the Options palette 
menu. 



Using palettes 

Using pop-up sliders

A number of palettes and dialog boxes contain settings that use pop-up sliders (for example, the 
Opacity option in the Layers palette).

To use a pop-up slider:

Do one of the following:
•      Position the pointer over the triangle next to the setting, hold down the mouse, and drag the slider 
or angle radius to the desired value.

•      Click the triangle next to the setting to open the pop-up slider box, and drag the slider or angle 
radius to the desired value. Click outside the slider box or press Enter (Windows) or Return (Mac OS) 
to close the slider box. (To cancel changes, press Esc.)

 Use the following shortcuts when the pop-up slider box is open: 
• To increase or decrease values in 1% increments, press the Up or Down arrow key. 
• To increase or decrease values in 10% increments, hold down Shift and press the Up or Down arrow 
key.



Using palettes 

Using the Info palette

The Info palette displays information about the color values beneath the pointer and, depending on the
tool in use, other useful measurements. You can also display color values of specific target points in 
your image using color samplers (see Previewing color values) and use the measure tool to measure 
distances and angles (see Using the measure tool.) 

See also: 

To display the Info palette 

To change the Info palette options 



Using the Info palette 

To display the Info palette:

Choose Window > Show Info.

The Info palette displays the following specific information: 
•      When displaying CMYK values, the Info palette displays an exclamation point if the color beneath 
the pointer or color sampler is out of the printable CMYK color gamut. (See Identifying out-of-gamut 
colors.).

Out-of-gamut color
•      When you use the marquee tool, the Info palette displays the x and y coordinates of your starting 
position and the width (W) and height (H) of the marquee as you drag. 
•      When you use the crop tool or zoom tool, the Info palette displays the width (W) and height (H) of 
the marquee as you drag. The palette also shows the angle of rotation of the crop marquee.
•      When you use the line tool, pen tool, or gradient tool or when you move a selection, the Info 
palette displays the x and y coordinates of your starting position, the change in X (DX), the change in 
Y (DY), the angle (A), and the distance (D) as you drag. 
•      When you use a two-dimensional transformation command, the Info palette displays the 
percentage change in width (W) and height (H), the angle of rotation (A), and the angle of horizontal 
skew (H) or vertical skew (V).
•      When you use any color adjustment dialog box (for example, Curves), the Info palette displays the 
before and after color values of the pixels beneath the pointer and beneath color samplers.

See also: 

To change the Info palette options 



Using the Info palette 

To change the Info palette options:

1    Choose Palette Options from the Info palette menu.

2    For First Color Readout, choose one of the following display options: 
•      Actual Color to display values in the current color mode of the image.
•      Total Ink to display the total percentage of all CMYK ink at the pointer’s current location, based on 
the values set in the CMYK Setup dialog box.
•      Opacity to display the opacity of the current layer. This option does not apply to the background.
•      Any other option to display the color values in that color mode. (See Color modes and models.)

3    For Second Color Readout, choose a display option listed in step 2.

4    For Ruler Units, choose a unit of measurement.

5    Click OK.

 To change measurement units, click the cross-hair icon in the Info palette for a menu of options. To 
change color readout modes, click the eyedropper icon.

See also: 

To display the Info palette 



Looking at the Work Area 

Using context menus

In addition to the menus at the top of your screen, context-sensitive menus display commands 
relevant to the active tool, selection, or palette.

To display context menus:

1    Position the pointer over the image or over an item in a palette list (for example, a thumbnail in the 
Layers palette).

2    Click with the right mouse button (Windows) or press Control and hold down the mouse button 
(Mac OS).

To get context-sensitive help (Windows only):

Do one of the following:
•      Press Shift + F1 (a question mark appears next to the pointer), and choose a command or click in 
a palette to display the appropriate help topic. 
•      With a dialog box open, press F1 to display the help topic for that dialog box.



Looking at the Work Area 

Using Adobe online services

If you have an Internet connection and a Web browser installed on your system, you can access the 
Adobe Systems Home Page on the World Wide Web (at http://www.adobe.com) for information on 
services, products, and tips pertaining to Photoshop.

To use Adobe Online:

1    Do one of the following:
•      Choose File > Adobe Online.
•      Click the icon at the top of the toolbox.

2    Click a topic to open the Adobe Home Page.



Looking at the Work Area 

Viewing images

The hand tool, the zoom tools, the Zoom commands, and the Navigator palette let you view different 
areas of an image at different magnifications. You can open additional windows to display several 
views at once (such as different magnifications) of an image. 

A list of open windows appears in the Window menu. Available memory may limit the number of 
windows per image. 

See also: 

Changing viewing options 

Using the Navigator palette 

Magnifying and reducing the view 



Viewing images 

Changing viewing options

To change the viewing mode of image windows:

Click a window control in the toolbox:

A. Standard screen mode    B. Full screen mode with menu bar    C. Full screen mode
•      The left window control to display the default window with a menu bar at the top and scroll bars on 
the sides. 
•      The center window control to display a full-screen window with a menu bar but no title bar or scroll 
bars. 
•      The right window control to display a full-screen window with no title bar, menu bar, or scroll bars. 

The hand tool or the Navigator palette can be used for scrolling.

See also: 

To open multiple views of the same image 

To arrange multiple windows (Windows only) 

To close windows 

To view another part of an image 



Changing viewing options 

To open multiple views of the same image:

Choose View > New View. 

See also: 

To arrange multiple windows (Windows only) 

To close windows 

To view another part of an image 



Changing viewing options 

To arrange multiple windows (Windows only):

Do one of the following:
•      Choose Window > Cascade to display windows stacked and cascading from the top left to the 
bottom right of the screen.
•      Choose Window > Tile to display windows edge to edge.

See also: 

To open multiple views of the same image 

To close windows 

To view another part of an image 



Changing viewing options 

To close windows:

Choose a command:
•      Choose File > Close to close the active window.
•      Choose Window > Close All (Windows only) to close all windows.

See also: 

To open multiple views of the same image 

To arrange multiple windows (Windows only) 

To view another part of an image 



Changing viewing options 

To view another part of an image:

Do one of the following:
•      Use the window scroll bars.
•      Select the hand tool, and drag in the image to move its view.

Drag the hand tool to move the view.

 To use the hand tool while another tool is selected, hold down the spacebar as you drag in the image.

See also: 

To open multiple views of the same image 

To arrange multiple windows (Windows only) 

To close windows 



Viewing images 

Using the Navigator palette

With a thumbnail, the Navigator palette lets you quickly change the view of an image. 

See also: 

To display the Navigator palette 

To move the view of an image using the Navigator palette 

To change the color of the Navigator palette view box 



Using the Navigator palette 

To display the Navigator palette:

Choose Window > Show Navigator.

See also: 

To move the view of an image using the Navigator palette 

To change the color of the Navigator palette view box 



Using the Navigator palette 

To move the view of an image using the Navigator palette:

Do one of the following:
•      Drag the view box, which represents the boundaries of the image window.
•      Click in the thumbnail of the image. The new view includes the area you click. 

See also: 

To display the Navigator palette 

To change the color of the Navigator palette view box 



Using the Navigator palette 

To change the color of the Navigator palette view box:

1    Choose Palette Options from the Navigator palette menu.

2    Choose a color:
•      To use a preset color, choose an option for Color.
•      To specify a different color, click the color box, and choose a color as described in Using the 
Adobe Photoshop Color Picker.

3    Click OK.

 Try these viewing shortcuts: 
• Press Page Up/Page Down to scroll the view up/down by one screen. 
• Press Shift+Page Up/Shift+Page Down to scroll up or down by 10 pixels, or to move to the previous or 
next frame in a Filmstrip file.

See also: 

To display the Navigator palette 

To move the view of an image using the Navigator palette 



Viewing images 

Magnifying and reducing the view

You can magnify or reduce your view using various methods. The window’s title bar displays the zoom
percentage at all times. 

Note: The 100% view of an image displays an image based on the monitor resolution and the image 
resolution, not on the actual image dimensions. (See “Pixel dimensions and monitor resolution” on 
About image size and resolution.)

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To zoom in:

Do one of the following:
•      Select the zoom tool, and click the area you want to magnify. Each click magnifies the image to the
next preset percentage, centering the display around the point you click. At maximum magnification, 
the center of the zoom tool appears empty.
•      Choose View > Zoom In to magnify to the next preset percentage.

See also: 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To zoom out:

Do one of the following:
•      Select the zoom tool. Hold down Alt (Windows) or Option (Mac OS) to activate the zoom-out tool, 
and click the area of the image you want to reduce. Each click reduces the view to the previous preset
percentage.
•      Choose View > Zoom Out to reduce to the previous preset percentage.

 Use these zoom shortcuts: 
• To activate the zoom-in tool, press Ctrl+spacebar (Windows) or Command+spacebar (Mac OS). 
• To activate the zoom-out tool, press Alt+spacebar/Option+spacebar. 
• To zoom in, press Ctrl+(=)/Command+(=). 
• To zoom out, press Ctrl+(-)/Command+(-).

See also: 

To zoom in 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To magnify by dragging:

1    Select the zoom tool.

2    Drag over the part of the image you want to magnify.

Drag the zoom tool to magnify the view.

The area inside the zoom marquee appears at the highest possible magnification. 

See also: 

To zoom in 

To zoom out 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To magnify or reduce to a specified percentage:

Enter a percentage value in the zoom percentage box at the lower left of the program window 
(Windows) or image window (Mac OS), and press Enter (Windows) or Return (Mac OS). 

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To display an image at 100%:

Do one of the following:
•      Double-click the zoom tool.
•      Choose View > Actual Pixels.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To change the view to fit the screen 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To change the view to fit the screen:

Do one of the following:
•      Double-click the hand tool. 
•      Choose View > Fit on Screen.

These options scale both the view and the window size to match the monitor size.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To constrain the window size 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To constrain the window size:

In the Zoom Tool Options palette, deselect Resize Windows To Fit. Doing this maintains a constant 
window size regardless of the image’s magnification and can be helpful when using smaller monitors 
or working with tiled views.

View in Navigator palette, and 210% view of image

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To magnify or reduce the view using the Navigator palette 



Magnifying and reducing the view 

To magnify or reduce the view using the Navigator palette:

Do one of the following:

•      Click the zoom in ( ) or zoom out (
) button at the bottom of the Navigator palette.

•      Drag the zoom slider at the bottom of the palette.
•      Enter the percentage of magnification or reduction you want, and press Enter (Windows) or Return 
(Mac OS).
•      Hold down Ctrl (Windows) or Command (Mac OS), and drag over the area of the Navigator palette’s 
thumbnail that you want to magnify.

 To zoom to the specified percentage and keep the zoom percentage box highlighted, hold down Shift 
while pressing Enter/Return.

See also: 

To zoom in 

To zoom out 

To magnify by dragging 

To magnify or reduce to a specified percentage 

To display an image at 100% 

To change the view to fit the screen 

To constrain the window size 



Looking at the Work Area 

Using plug-in modules

Plug-in modules are software programs developed by Adobe Systems, and by other software 
developers in conjunction with Adobe Systems, to add features to Adobe Photoshop. A number of 
importing, exporting, automation, and special effects plug-ins come with your program—automatically 
installed in the Plug-Ins folder. If you want to use a plug-in that is installed in another folder, you must 
change the preference settings so Photoshop uses the other plug-ins location.

Once installed, plug-in modules appear as options in the Import, Export, or Automate menus; as file 
formats in the Open, Save As, and Save a Copy dialog boxes; or as filters in the Filter menus.

Note: If many plug-in modules are installed, Photoshop may not be able to list all the plug-ins in their 
appropriate menus. Newly installed plug-ins will appear in the Filter > Other submenu.

To install an Adobe Systems plug-in module:

If an installer is provided, use it to install the plug-in module. Otherwise, drag a copy of the module to 
the Plug-Ins folder inside the Adobe Photoshop folder. 

Follow any installation instructions that come with third-party plug-ins.

To set plug-ins preferences:

1    Choose File > Preferences > Plug-Ins & Scratch Disk. 

2    Click Choose, and select a folder or directory from the list. (Be sure not to select a location inside 
the Plug-Ins folder.) To display the contents of a folder, double-click the folder (Windows) or click Open
(Mac OS).

Important: If you change the plug-ins location, the usual Photoshop plug-ins, filters, and scanners will 
be unavailable until you change back to the Plug-Ins location inside the application folder.

3    When you have highlighted the new plug-ins folder, click OK (Windows) or Select (Mac OS).

4    Restart Adobe Photoshop.

 On the Macintosh, to select the plug-ins location immediately upon starting Adobe Photoshop, press 
Command+Option as you launch the program.



Looking at the Work Area 

Setting preferences 

Numerous program settings are stored in preferences files, located in the Adobe Photoshop Settings 
folder inside the application folder. The settings stored in these files include general display options, 
separation setup information, calibration options, display options, tool options, ruler units, and options 
for exporting information from the Clipboard. Most of these options are set in dialog boxes that can be 
opened through the Preferences submenus in the File menu. Preference settings are saved each time
you exit Adobe Photoshop.

To open a preferences dialog box:

1    Choose the desired preference dialog box from the File > Preferences submenu.

2    Switch to a different preference dialog box:
•      Choose an option from the menu at the top of the dialog box.
•      Click Next to display the next preference dialog box in the menu list; click Prev to display the 
previous preference dialog box.

To restore all preferences to their default settings:

Open the Adobe Photoshop Settings folder inside the Photoshop folder, and rename or delete the 
Adobe Photoshop 5.0 Prefs file and the Color Settings file.

New default preferences files will be created the next time you start Photoshop.

Note: You should not rename or delete the Actions Palette file, unless you believe that your actions 
have been damaged.



Getting Images into Photoshop

See also: 

About bitmap images and vector graphics 

About image size and resolution 

Changing image size and resolution 

Scanning images 

Creating new images 

Opening and importing images 

Viewing copyright and file information 

Cropping an image 

Increasing the size of the work canvas 



Getting Images into Photoshop 

About bitmap images and vector graphics

Computer graphics fall into two main categories—bitmap images and vector graphics. Understanding 
the difference between the two will help as you create and edit digital images.

See also: 

Bitmap images 

Vector graphics 



About bitmap images and vector graphics 

Bitmap images

Photoshop and other paint and image-editing programs generate bitmap images, also called raster 
images. Bitmap images use a grid (the bitmap or raster) of small squares known as pixels to represent
images. Each pixel is assigned a specific location and color value. For example, a bicycle tire in a 
bitmap image is made up of a mosaic of pixels in that location. When working with bitmap images, you
edit pixels rather than objects or shapes. 

A bitmap image is resolution-dependent—that is, it contains a fixed number of pixels to represent its 
image data. As a result, a bitmap image can lose detail and appear jagged if viewed at a high 
magnification on-screen or printed at too low a resolution. Bitmap images are the best choice for 
representing subtle gradations of shades and color—for example, in photographs or painted images. 



About bitmap images and vector graphics 

Vector graphics

Drawing programs such as Adobe Illustrator® create vector graphics, made of lines and curves 
defined by mathematical objects called vectors. Vectors describe graphics according to their geometric
characteristics. For example, a bicycle tire in a vector graphic is made up of a mathematical definition 
of a circle drawn with a certain radius, set at a specific location, and filled with a specific color. You can
move, resize, or change the color of the tire without losing the quality of the graphic. 

A vector graphic is resolution-independent—that is, it can be scaled to any size and printed on any 
output device at any resolution without losing its detail or clarity. As a result, vector graphics are the 
best choice for type (especially small type) and bold graphics that must retain crisp lines when scaled 
to various sizes—for example, logos.

Because computer monitors represent images by displaying them on a grid, both vector and bitmap 
images are displayed as pixels on-screen.



Getting Images into Photoshop 

About image size and resolution

To produce high-quality images using Photoshop, it is important to understand how the pixel data of 
bitmap images is measured and displayed.    

See also: 

Pixel dimensions 

On-screen display size 

Image resolution 

Monitor resolution 

Printer resolution 

Screen frequency 

File size 



About image size and resolution 

Pixel dimensions 

The number of pixels along the height and width of a bitmap image. The display size of an image on-
screen is determined by the pixel dimensions of the image plus the size and setting of the monitor. 
The file size of an image is proportional to its pixel dimensions.

A typical 13-inch monitor displays 640 pixels horizontally and 480 vertically. An image with pixel 
dimensions of 640 by 480 would fill this small screen. On a larger monitor with a 640 by 480 setting, 
the same image (with pixel dimensions of 640 by 480) would still fill the screen, but each pixel would 
appear larger. Changing the setting of this larger monitor to 1152 pixels by 870 pixels would display 
the image at a smaller size, occupying only part of the screen.

When preparing an image for online display (for example, a Web page that will be viewed on a variety 
of monitors), pixel dimensions become especially important. Because your image may be viewed on a 
13-inch monitor, you’ll probably want to limit the size of your image to a maximum of 640 pixels by 480
pixels.



About image size and resolution 

On-screen display size

How large an image appears on-screen depends on a combination of factors––the pixel dimensions of
the image, the monitor size, and the monitor resolution setting. The examples below show a 620 x 400
pixel image displayed with various monitor sizes and monitor resolutions.



About image size and resolution 

Image resolution

The number of pixels displayed per unit of printed length in an image, usually measured in pixels per 
inch (ppi). An image with a high resolution contains more, and therefore smaller, pixels than an image 
of the same printed dimensions with a low resolution. For example, a 1-inch-by-1-inch image with a 
resolution of 72 ppi contains a total of 5184 pixels (72 pixels wide x 72 pixels high = 5184). The same 
1-inch-by-1-inch image with a resolution of 300 ppi would contain a total of 90,000 pixels. 

72-ppi and 300-ppi images; inset zoom 200% 

Because they use more pixels to represent each unit of area, higher-resolution images usually 
reproduce more detail and subtler color transitions than lower-resolution images when printed. 
However, increasing the resolution of an image scanned or created at a lower resolution only spreads 
the original pixel information across a greater number of pixels and rarely improves image quality. 

To determine the image resolution to use, consider the medium of final distribution for the image. If 
you’re producing an image for online display, the image resolution only needs to match the typical 
monitor resolution (72 or 96 ppi). However, using too low a resolution for a printed image results in 
pixelation— output with large, coarse-looking pixels. Using too high a resolution (pixels smaller than 
what the output device can produce) increases the file size and slows the printing of the image; 
furthermore, the device will be unable to print the image at the high resolution. (See Screen frequency 
for guidelines on choosing an image resolution for a printed image.) 



About image size and resolution 

Monitor resolution

The number of pixels or dots displayed per unit of length on the monitor, usually measured in dots per 
inch (dpi). Monitor resolution depends on the size of the monitor plus its pixel setting. The typical 
resolution of a PC monitor is about 96 dpi, of a Mac OS monitor 72 dpi. Understanding monitor 
resolution helps explain why the display size of an image on-screen often differs from its printed size.

In Photoshop, image pixels are translated directly into monitor pixels. This means that when the image
resolution is higher than the monitor resolution, the image appears larger on-screen than its specified 
print dimensions. For example, when you display a 1-inch-by-1-inch, 144-ppi image on a 72-dpi 
monitor, it appears in a 2-inch-by-2-inch area on-screen. Because the monitor can display only 72 
pixels per inch, it needs 2 inches to display the 144 pixels that make up one edge of the image. 



About image size and resolution 

Printer resolution

The number of ink dots per inch (dpi) produced by an imagesetter or laser printer. For best results, use
an image resolution that is proportional to, but not the same as, printer resolution. Most laser printers 
have output resolutions of 300 dpi to 600 dpi and produce good results with images from 72 ppi to 150
ppi.

High-end imagesetters can print at 1200 dpi or higher and produce good results with images from 200 
ppi to 300 ppi.



About image size and resolution 

Screen frequency

The number of printer dots or halftone cells per inch used to print grayscale images or color 
separations. Also known as screen ruling or line screen, screen frequency is measured in lines per 
inch (lpi)—or lines of cells per inch in a halftone screen.

The relationship between image resolution and screen frequency determines the quality of detail in the
printed image. To produce a halftone image of the highest quality, you generally use an image 
resolution that is from 1.5 to at most 2 times the screen frequency. But with some images and output 
devices, a lower resolution can produce good results.

Note: Some imagesetters and 600-dpi laser printers use screening technologies other than halftoning.
If you are printing an image on a nonhalftone printer, consult your service provider or your printer 
documentation for the recommended image resolutions.



About image size and resolution 

File size

The digital size of an image, measured in kilobytes (K), megabytes (MB), or gigabytes (GB). File size 
is proportional to the pixel dimensions of the image. Images with more pixels may produce more detail
at a given printed size, but they require more disk space to store and may be slower to edit and print. 
For instance, a 1-inch-by-1-inch 200-ppi image contains four times as many pixels as a 1-inch-by-1-
inch 100-ppi image and so has four times the file size. Image resolution thus becomes a compromise 
between image quality (capturing all the data you need) and file size. 

Photoshop supports a maximum file size of 2 GB and maximum pixel dimensions of 30,000 by 30,000 
pixels per image. This restriction places limits on the print size and resolution available to an image. 
For example, an image 100 by 100 inches can have a resolution of at most 300 ppi (30,000 pixels / 
100 inches = 300 ppi). 



Getting Images into Photoshop 

Changing image size and resolution

Once you have scanned or imported an image into Photoshop, you may want to adjust its size or 
resolution. The Image Size command lets you adjust the pixel dimensions, print dimensions, and 
resolution of an image.
 For assistance with resizing and resampling images, choose Help > Resize Image. This interactive 

wizard helps you scale your images for printed or online display.

See also: 

Resolution, file size, and output 

Displaying file and print information 

About resampling 

Changing the pixel dimensions of an image 

Changing the print dimensions and resolution of an image 

Determining a recommended resolution for an image 

Choosing an interpolation method 



Changing image size and resolution 

Resolution, file size, and output

The file size of an image refers to the total amount of pixel information in the image. For example, a 1-
inch-by-2-inch high-resolution image has more pixels, and thus a larger file size, than a 1-inch-by-2-
inch low-resolution image. In print, a high-resolution image has more detail than the same image at 
low resolution. On-screen, a high-resolution image appears larger (see Image resolution). The 
enlarged on-screen display does not affect the dimensions of the printed image.

1 in. x 2 in. @ 72 ppi; file size 323K. 100% view on-screen

1 in. x 2 in. @ 300 ppi; file size 5.47MB. 100% view on-screen



Changing image size and resolution 

Displaying file and print information

Information about the current file size and resolution of an image is displayed at the lower left of the 
image window. Before you change the size of an image, you also may want to preview how the image 
will appear when printed.

See also: 

To display the file size 

To display dimensions, channel information, and resolution information 

To preview a page 

To view the print size on-screen 



Displaying file and print information 

To display the file size:

Position the pointer over the triangle in the bottom border of the program window (Windows) or image 
window (Mac OS), hold down the mouse button, and choose Document Sizes from the menu.

The file size appears at the lower left of the window. The first value indicates the size if saved as a 
flattened file with no layer data, the second value the size if saved with all layers and channels. For 
more information on how layers affect file size, see Managing layered images. 

See also: 

To display dimensions, channel information, and resolution information 

To preview a page 

To view the print size on-screen 



Displaying file and print information 

To display dimensions, channel information, and resolution information: 

Press Alt (Windows) or Option (Mac OS), position the pointer over the box in the lower left of the 
window, and hold down the mouse button.

The box displays the width and height of the image (both in pixels and in the unit of measurement 
currently selected for the rulers), the number of channels, and the image resolution.

See also: 

To display the file size 

To preview a page 

To view the print size on-screen 



Displaying file and print information 

To preview a page: 

Position the pointer over the box where the file size is displayed, and hold down the mouse button.

The dimensions of the page shown in the page preview box correspond to the page size specified with
the Page Setup command (see General printing options). Other options selected appear as gray 
boxes. 

Previewing a page    A. Label    B. Registration marks    C. Crop marks    D. Calibration bar    E. Caption

See also: 

To display the file size 

To display dimensions, channel information, and resolution information 

To view the print size on-screen 



Displaying file and print information 

To view the print size on-screen:

Choose View > Print Size.

The magnification of the image is adjusted to display its approximate printed size, as specified in the 
Print Size section of the Image Size dialog box. (See Changing the print dimensions and resolution of 
an image).

See also: 

To display the file size 

To display dimensions, channel information, and resolution information 

To preview a page 



Changing image size and resolution 

About resampling

Resampling refers to changing the pixel dimensions (and therefore file size) of an image. When you 
downsample (or decrease the number of pixels), information is deleted from the image. When you 
resample up (or increase the number of pixels), new pixel information is added based on color values 
of existing pixels. You specify an approximation or interpolation method to determine how pixels are 
added or deleted. (See Choosing an interpolation method).

A. Resampled down    B. Original    C. Resampled up

Keep in mind that resampling can result in poorer image quality. For example, when you resample an 
image to a higher resolution, the pixels interpolated from the new image data can make the image 
appear blurry or out of focus.

You can avoid the need for resampling by scanning in or creating the image at a high enough 
resolution. If you want to preview the effects of changing pixel dimensions on-screen or print proofs at 
different resolutions, resample a duplicate of your original file. (See Duplicating images.)
 Applying the Unsharp Mask filter to a resampled image can help refocus the image’s details. For 

instructions, see Step 6: Sharpen the image.

A. Original    B. Resampled down    C. Unsharp Mask applied



Changing image size and resolution 

Changing the pixel dimensions of an image

When preparing images for online distribution (on a Web site, for example), it’s useful to specify image
size in terms of the pixel dimensions. Keep in mind that changing pixel dimensions affects not only the
size of an image on-screen but also its image quality and its printed characteristics—either its printed 
dimensions or its image resolution. (See About image size and resolution; About resampling.) 

To change the pixel dimensions of an image:

1    Choose Image > Image Size.

2    Make sure that Resample Image is selected, and choose an interpolation method, as described in 
Choosing an interpolation method.

3    To maintain the current proportions of pixel width to pixel height, select Constrain Proportions. This 
option automatically updates the width as you change the height, and vice versa.

4    Under Pixel Dimensions, enter values for Width and Height. To enter values as percentages of the 
current dimensions, choose Percent as the unit of measurement.

The new file size for the image appears at the top of the Image Size dialog box with the old file size in 
parentheses.

5    Click OK to change the pixel dimensions and resample the image.
 For best results in producing a smaller image, resample down and apply the Unsharp Mask filter. To 

produce a larger image, rescan the image at a higher resolution.



Changing image size and resolution 

Changing the print dimensions and resolution of an image

When preparing images for print, it’s useful to specify image size in terms of the printed dimensions 
and the image resolution. These two measurements determine the total pixel count and therefore the 
file size of the image. (See About image size and resolution.)

If you turn on resampling for the image, you can change print dimensions and resolution 
independently. If you turn resampling off, you can change either the dimensions or the resolution—
Photoshop adjusts the other value automatically to preserve the total pixel count. For the highest print 
quality, it’s generally best to change the dimensions and resolution first without resampling. Then 
resample only as necessary.

Note: If your image resolution is more than 2.5 times the screen ruling, an alert message appears 
when you try to print the image. This means that the image resolution is higher than necessary for the 
printer . Save a copy of the file, and then lower the resolution. 

To change the print dimensions and resolution of an image:

1    Choose Image > Image Size.

2    Change the print dimensions or image resolution or both:
•      To change only the print dimensions or only the resolution and adjust the total number of pixels in 
the image proportionately, make sure that Resample Image is selected. Then choose an interpolation 
method, as described in Choosing an interpolation method.
•      To change the print dimensions and resolution without changing the total number of pixels in the 
image, deselect Resample Image.

3    To maintain the current proportions of image width to image height, select Constrain Proportions. 
This option automatically updates the width as you change the height, and vice versa.

4    Under Print Size, enter new values for the height and width. If desired, choose a new unit of 
measurement. Note that for Width, the Columns option uses the width and gutter sizes specified in the
Units & Rulers preferences.

5    For Resolution, enter a new value. If desired, choose a new unit of measurement.

6    Click OK.
 To return to the original values displayed in the Image Size dialog box, hold down Alt (Windows) or 

Option (Mac OS), and click Reset. 



Changing image size and resolution 

Determining a recommended resolution for an image

If you plan to print your image using a halftone screen, the range of suitable image resolutions 
depends on the screen frequency of your output device. You can have Photoshop determine a 
recommended resolution for your image based on your device’s screen frequency. (See Screen 
frequency.)

To determine a suggested resolution for an image:

1    Choose Image > Image Size.

2    Click Auto. 

3    For Screen, enter the screen frequency for the output device. If desired, choose a new unit of 
measurement. Note that the screen value is used only to calculate the image resolution, not to set the 
screen for printing.

Important: To specify the halftone screen ruling for printing, you must use the Halftone Screens dialog
box, accessible through the Page Setup dialog box. 

4    For Quality, select an option:
•      Draft to produce a resolution the same as the screen frequency (no lower than 72 pixels per inch).
•      Good to produce a resolution 1.5 times the screen frequency.
•      Best to produce a resolution 2 times the screen frequency.

5    Click OK.



Changing image size and resolution 

Choosing an interpolation method 

When an image is resampled, Adobe Photoshop uses an interpolation method to assign color values 
to any new pixels based on the color values of existing pixels in the image. The more sophisticated the
method, the more quality and detail from the original image are preserved. 

The General Preferences dialog box lets you specify a default interpolation method to use whenever 
images are resampled with the Image Size or transformation commands. The Image Size command 
also lets you specify an interpolation method other than the default. 

To specify the default interpolation method: 

1    Choose File > Preferences > General.

2    For Interpolation, choose an option:
•      Nearest Neighbor for the fastest, but least precise, method. This method can result in jagged 
effects, which become apparent when distorting or scaling an image or performing multiple 
manipulations on a selection. 
•      Bilinear for a medium-quality method.
•      Bicubic for the slowest, but most precise, method, resulting in the smoothest tonal gradations.



Getting Images into Photoshop 

Scanning images

Before you scan an image, make sure that the software necessary for your scanner has been 
installed. To ensure a high-quality scan, you should predetermine the scanning resolution and dynamic
range your image requires. These preparatory steps can also prevent unwanted colors casts from 
being introduced by your scan.

Scanner drivers are provided and supported by the manufacturers of the scanners, not Adobe 
Systems. If you have problems with scanning, make sure that you are using the latest version of the 
appropriate scanner driver.

See also: 

Importing scanned images 

Importing an image using the TWAIN interface 

Scanning using the resolution setting 

Scanning using the file size setting 

Optimizing the dynamic range of the scan 

Eliminating unwanted color casts 



Scanning images 

Importing scanned images

You can import scanned images directly from any scanner that has an Adobe Photoshop-compatible 
plug-in module or supports the TWAIN interface. To import the scan, choose the scanner name from 
the File > Import submenu. (See your scanner documentation for instructions on installing the scanner
plug-in; see Using plug-in modules for general plug-in information.) 

If your scanner does not have an Adobe Photoshop-compatible scanner driver, use the manufacturer’s
software to scan your images, and save the images as TIFF, BMP, or PICT files. Then open the files in
Adobe Photoshop.



Scanning images 

Importing an image using the TWAIN interface 

TWAIN is a cross-platform interface for acquiring images captured by certain scanners, digital 
cameras, and frame grabbers. The manufacturer of the TWAIN device must provide a Source 
Manager and TWAIN Data source for your device to work with Photoshop. 

Adobe Photoshop supports the current TWAIN_32 standard for scanning. Photoshop does not support
TWAIN software used with Windows 3.1. Contact your scanner manufacturer for information on the 
availability of TWAIN_32 source modules.

To import an image using the TWAIN interface:

1    If you’re using the TWAIN device for the first time with Adobe Photoshop, choose File >Import > 
Select TWAIN_32 Source. Then select the device you’re using. You do not need to repeat this step for 
subsequent uses of the TWAIN module.

If more than one TWAIN device is installed in your system and you want to switch devices, use the 
Select Source command. 

2    To import the image, choose TWAIN_32 (Windows) or TWAIN Acquire (Mac OS) from the File > 
Import submenu.



Scanning images 

Scanning using the resolution setting

You can determine the settings for your scan using the original and final image dimensions and the 
screen frequency of your output device to calculate a scan resolution to enter in the scanner settings. 
This scan resolution translates into image resolution when you open the scan in Photoshop. 

The quality of final output depends not only on the scan resolution but also on the resolution of your 
output device and the size of the original image compared with the final image. (See About image size
and resolution.)

To estimate scan resolution:

1    Multiply the screen frequency by 2 (the typical ratio of image resolution to screen frequency 
needed to produce a high-quality image).

2    Multiply the result in step 1 by the ratio of final image dimensions to original dimensions to 
determine an estimated scan resolution.

For example, suppose you are scanning a 2-inch-by-3-inch image and want to produce a final 6-inch-
by-9-inch image. You are using a screen frequency of 85 lpi.

First multiply 85 (the screen frequency) by 2 to get 170. Then multiply 170 by 3 (the ratio of final image
dimensions to original ones) to get a scan resolution of 510 ppi. 

Different color separation procedures might require different ratios of image resolution to screen 
frequency (see Screen frequency). It’s a good idea to check with your service provider or print shop 
before you scan the image.
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Scanning using the file size setting 

You can create a dummy file to predict the file size needed for the final output of your scan. 

To calculate the file size before scanning an image:

1    Open Adobe Photoshop, and choose File > New. 

2    Enter the width, height, and resolution for your final printed image. The resolution should be 1.5 to 
2 times the screen frequency you will use to print. Make sure that the mode you plan to scan in is 
selected. (See Color modes and models.) The New dialog box then displays the file size.

For example, suppose you want the final image to be 4 inches wide and 5 inches high. You plan to 
print it with a 150-line screen using a 2:1 ratio, so you set the resolution to 300. The resulting file size 
is 5.15 megabytes.

To produce the scan, enter the resulting file size in your scanner settings. Don’t worry about resolution 
or image dimensions. After you have scanned the image and imported it into Photoshop, use the 
Image Size command to enter the correct width and height for the image.
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Optimizing the dynamic range of the scan

Keep in mind that the human eye can detect a wider tonal range than can be printed. If your scanner 
allows, set the black and white points before scanning a file to produce the best tonal range and 
capture the widest dynamic range. Then use Photoshop’s color correction tools to set the white and 
black points for the scanned image (see Step 3: Set the highlight and shadow values). 
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Eliminating unwanted color casts

If your scanned image contains an unwanted color cast, you can perform a simple test to determine 
whether the cast was introduced by your scanner. If it was, you can use the same test file to create a 
color-cast correction for all images scanned with the scanner. 

To identify and correct a color cast introduced by a scanner:

1    Make sure that your monitor has been calibrated. (See Calibrating your monitor.)

2    Open a new Photoshop file, and use the linear gradient tool ( ) to create a blend from pure black
to pure white.

3    Choose Image > Adjust > Posterize, and posterize the blend using 11 levels.
4    Print the 11-step gray wedge on a black-and-white printer, and then scan it into Photoshop.

Note: You can also perform this test using an 18-percent neutral gray card or an 11-step gray wedge 
from a photography store.

5    Open the Info palette, and read the RGB values on-screen for each of the gray levels. Uneven R, 
G, and B values indicate a color cast. 

6    Use Levels or Curves to correct the color cast, and then save the dialog box settings. (For 
instructions, see Making Color and Tonal Adjustments)

7    Open the scanned image you want to correct, reopen the dialog box you used to correct the cast in
step 6, and load the saved settings.
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Creating new images 

The New command lets you create a blank, untitled Photoshop image. You can also use this 
command to create a new image with the exact same pixel dimensions as an image or selection that 
has been copied to the Clipboard.

To create a new image:

1    Do one of the following:
•      To base the image dimensions and resolution on the Clipboard contents, choose File > New.
•      To base the image size on the default dimensions and resolution or the last entered settings, hold 
down Alt (Windows) or Option (Mac OS) as you choose File > New.
•      To base the image size on an open window, choose File > New. With the New dialog box open, 
choose the image whose size you want to match from the Window menu. 

2    Type a name for the image and if desired, set the width, height, resolution, and mode. (See Color 
modes and models.)

3    For Contents, select an option:
•      White to fill the background with white, the default background color.
•      Background Color to fill the image with the current background color.
•      Transparent to create an image containing a single layer with no color values. 

Note: Because images created with the transparent option contain a single layer instead of a 
background, they must be saved in Photoshop format. Photoshop is the only format that supports 
layers. (See Saving files.)
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Opening and importing images

In Adobe Photoshop, you can open and import images in various file formats and have multiple 
images open at one time. If a file format does not appear in the Open dialog box or in the File > Import
submenu, install the format’s plug-in module (see Using plug-in modules). For more information on a 
specific file format, see About file formats. 

To import an image, choose the import module from the File > Import submenu. The options for some 
import modules are discussed later in this section.

See also: 

Opening files 

Importing Adobe Illustrator, PDF, and EPS files 

Turning off anti-aliasing for imported objects 

Opening Photo CD files 

Opening Raw files 

Importing an anti-aliased PICT file (Macintosh only) 

Importing PICT Resources (Macintosh only) 
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Opening files

To open a file in Windows:

1    Choose File > Open.

2    Specify a file format:
•      In Windows, for Files of Type, choose All Formats to display all the files in the selected directory. 
Choose an individual format to display only files saved in that format.
•      In Mac OS, select Show All Files to display all files in the selected folder. To locate files in other 
folders, click Find and type the filename.

3    In Mac OS, select Show Thumbnail to preview files before opening them (if a preview has been 
saved with the image). This option requires the Apple QuickTime extension.

4    Select the file.

5    Click Open. In some cases, a dialog box appears, letting you set the open options. The formats 
requiring an open dialog box are described in the following sections.

In some cases (such as when first opening a file that was saved in an older version of Photoshop), a 
status bar appears indicating the file is being converted to a specified color space. If the Profile 
Mismatch dialog box appears, specify whether to convert the file’s color profile (see Managing ICC 
profiles in files).

To specify the file format in which to open a file:

Do one of the following:
•      In Windows, choose File > Open As, select the desired format, and click Open.
•      In Mac OS, choose File > Open, and select Show All Files. For Format, choose the desired file 
format, and click Open.

Note: If the file does not open, then the chosen format may not match the file’s true format, or the file 
may be damaged.
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Importing Adobe Illustrator, PDF, and EPS files

You can import files created in Adobe Illustrator® and PDF and EPS files containing vector art using 
these commands:
•      The Open command to open an Illustrator, PDF, or EPS file as a new Photoshop image.
•      The Place command to place an Illustrator, PDF, or EPS file as a new layer in an existing 
Photoshop image. 
•      The Paste commands to paste copied Illustrator artwork into a Photoshop image either as pixels or
as a path. (See Using drag and drop to copy between applications.) 

When an Illustrator, PDF, or EPS image is opened or placed in Photoshop, it is rasterized—the 
mathematically defined lines and curves of the vector image are converted into the pixels or bits of a 
bitmap image. For more on vector and bitmap images, see About bitmap images and vector graphics.
 To convert a multiple-page PDF file to multiple images in Photoshop format, choose File > Automate > 

Multi-Page PDF to PSD.

To open an Adobe Illustrator, PDF, or EPS file as a new Adobe Photoshop image:

1    Choose File > Open. 

2    Select the file you want to open, and click Open. If the file does not appear, for Files of Type, 
choose All Formats (Windows) or select Show All Files (Mac OS).

3    If you are opening a PDF file that contains multiple pages, select the page you want to open, and 
click OK. 

4    Indicate the desired dimensions, resolution, and mode. To maintain the same height-to-width ratio, 
select Constrain Proportions.

5    Select Anti-aliased to minimize the jagged appearance of the artwork’s edges as it is rasterized. 

6    Click OK.

To place Adobe Illustrator, PDF, or EPS artwork into an Adobe Photoshop image:

1    Open the Adobe Photoshop image in which you want to place the artwork.

2    Choose File > Place, select the file you want to place, and click Open.

3    If you are placing a PDF file that contains multiple pages, select the page you want to place, and 
click OK. 

The placed artwork appears as a new layer inside a bounding box at the center of the Adobe 
Photoshop image. The artwork maintains its original aspect ratio.

4    Adjust the placed artwork:
•      To move, position the pointer inside the bounding box, and drag. 
•      To scale, drag one of the handles at the corners or sides of the bounding box. Hold down Shift as 
you drag to constrain the proportions. 
•      To rotate, position the pointer outside the bounding box (the pointer turns into a curved arrow), and
drag. To adjust the point around which the marquee is rotated, drag the circle at the center of the 
bounding box.
•      To skew, hold down Ctrl (Windows) or Command (Mac OS) and drag a side handle of the 
bounding box.

5    To confirm the placement of the artwork, press Enter (Windows) or Return (Mac OS). To cancel the
placement, press Esc.
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Turning off anti-aliasing for imported objects.

The Anti-alias PostScript® option removes jagged edges from a pasted or placed selection by making 
a subtle transition between the edges of the selection and its surrounding pixels. Turning off this option
helps maintain the hard edges of line art as it is rasterized. 

To turn off the Anti-alias Postscript option:

1    Choose File > Preferences > General.

2    Deselect Anti-alias PostScript. Clearing this option can decrease the time it takes to import the file.
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Opening Photo CD files 

You can open Kodak® Photo CD™ files, including high-resolution files from Pro Photo CD discs, 
directly in Photoshop. The Kodak Precision Color Management System (KPCMS) lets you control the 
color mode and display of Photo CD images by specifying profiles for the source film and the 
destination output device. The KPCMS is automatically installed on your system when you install 
Photoshop. 

Note: You cannot save files in the Photo CD format from Photoshop.

To open a Photo CD file:

1    Choose File > Open.

2    Select the file you want to open, and click Open. If the file does not appear, for Files of Type, 
choose All Formats (Windows) or select Show All Files (Mac OS).

3    Choose a resolution for the image.

4    Select Landscape to open portrait images in landscape orientation.

5    Click Source. Choose a device and a profile description, and click OK.

If you are unsure of the source profile, click Image Info and note the number next to Product Type of 
Original. Then click Source and choose the profile that displays the same number for Input Device 
Settings.

6    Click Destination, choose a profile for the output device, and click OK. 

In addition to the RGB and Lab color mode profiles, you can install profiles for specialized output 
needs. 

7    To display scanner information about the image, click Image Info.

8    Click OK to open the image.
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Opening Raw files

The Raw format is designed to accommodate images saved in undocumented formats, such as those 
created by scientific applications. Compressed files, such as PICT, and GIF, cannot be opened using 
this format. See Raw for more information on Raw format options.

To open a file using the Raw format:

1    Choose File > Open As (Windows) or File > Open (Mac OS).

2    Choose Raw from the file format list, and click Open.

3    For Width and Height, enter values for the dimensions of the file.

4    To reverse the order of the width and height, click Swap.

5    Enter the number of channels.

6    Select Interleaved if the file was saved with an interlaced data option.

7    Select a color depth and, if necessary, a byte order.

8    For Header, enter a value.

9    If you are missing the dimensions or header value, you can have Photoshop estimate the 
parameters. Either enter the correct height and width values to estimate the header size, or enter the 
correct header size to estimate the height and width, and then click Guess.

10    To have Photoshop retain the header when you save the file, select Retain When Saving.

11    Click OK.
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Importing an anti-aliased PICT file (Macintosh only)

Choose File > Import > Anti-aliased PICT to import object-oriented PICT files (such as those created 
with MacDraw® and Canvas) as smooth-edged, or anti-aliased, images. Because the entire PICT file 
must be held in memory for this module to operate, you may not be able to use the module with large 
PICT files. 

The Anti-aliased PICT dialog box indicates the current file size and dimensions. To change the image 
dimensions, enter new values for Width and Height. The file size is then updated. To maintain image 
proportions, select Constrain Proportions. You can choose to open the Anti-aliased PICT file in either 
Grayscale or RGB mode.

You can also use the Open command to open a PICT file without applying anti-aliasing to its contents.
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Importing PICT Resources (Macintosh only)

The PICT Resource module lets you read PICT resources from a file—for example, from another 
application. To open a PICT resource, choose File > Import > PICT Resource.

To preview a resource, click Preview. Click the arrow buttons to step forward and backward through 
the resources. Note that the number displayed for Resource refers to the resource’s position in 
ascending order in the resource fork and not to the resource’s identification number.

Note: You can also open a file in the PICT Resource file format by choosing File > Open and, for 
Format, choosing PICT Resource. However, the Open command automatically opens the first 
resource in the file and does not display any other PICT resources in the file.
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Viewing copyright and file information

Once you have opened a file, you can view copyright and authorship information that has been added 
to the file. This information includes standard file information (see Adding file information) and 
Digimarc watermarks. 

Photoshop automatically scans opened images for watermarks using the Digimarc Detect Watermark 
plug-in. If a watermark is detected, Photoshop displays a copyright symbol in the image window’s title 
bar and updates the Copyright & URL section of the File Info dialog box.

To view file information:

Choose File > File Info. For section, choose the attribute you want to view.

To read a Digimarc watermark:

1    Choose Filter > Digimarc > Read Watermark. If the filter finds a watermark, a dialog box displays 
the Creator ID, copyright year (if present), and image attributes.

2    Click OK, or for more information choose from the following:
•      If you have a Web browser installed, click Web Lookup to get more information about the owner of 
the image. This option launches the browser and displays the Digimarc Web site, where contact 
details appear for the given Creator ID.
•      Call the phone number listed in the Watermark Information dialog box to get information faxed 
back to you.
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Cropping an image

Photoshop provides two ways to crop an image:
•      The Image > Crop command discards the area outside of a rectangular selection and keeps the 
same resolution as the original. 
•      The crop tool ( ) lets you crop an image by dragging over the area you want to keep. The 
advantage of using the crop tool is that you can rotate and resample the area as you crop. See About 
resampling for more information on resampling.

To crop an image using the Crop command: 

1    Use the rectangle marquee tool to select the part of the image you want to keep. Make sure that 
the Feather option is set to 0 pixels.

2    Choose Image > Crop.

See also: 

To use the crop tool 

To specify the size and resolution of the cropped area 
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To use the crop tool:

1    Select the crop tool ( ). 
2    Drag over the part of the image you want to keep.

When you release the mouse button, the crop marquee appears as a bounding box with handles at 
the corners and sides. 

3    Adjust the crop marquee:
•      To move the marquee to another position, position the pointer inside the bounding box and drag. 
•      To scale the marquee, drag a handle. To constrain the proportions, hold down Shift as you drag a 
corner handle.
•      To rotate the marquee, position the pointer outside the bounding box (the pointer turns into a 
curved arrow), and drag. To adjust the point around which the marquee is rotated, drag the circle at 
the center of the bounding box.

Drag handle to scale; drag outside bounding box to rotate.

4    To crop the image, press Enter (Windows) or Return (Mac OS). To cancel the cropping operation, 
press Esc. 

Cropped area

Note: You can’t rotate the crop tool marquee for an image in Bitmap mode.
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To specify the size and resolution of the cropped area:

1    Double-click the crop tool ( ) to display its Options palette.
2    Select Fixed Target Size.
3    To begin with the size and resolution values of the current image, click Front Image.
4    Choose the units of measurement you want from the menus. The Columns option measures width in 
terms of the columns specified in the Rulers & Units preferences.
5    Enter values for the size and resolution you want for the cropped area. 
The Fixed Target Size option constrains the file size of the image. If you specify size but not resolution, 
the resolution changes automatically to compensate for the size change. If you specify resolution but not 
size, the size changes automatically to compensate for the resolution change. 

6    Drag over the area you want to keep with the crop tool, and then press Enter (Windows) or Return 
(Mac OS). 
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Increasing the size of the work canvas

The Canvas Size command lets you add or remove work space around an existing image. You can 
crop an image by decreasing the canvas area. Added canvas appears in the same color or 
transparency as the background.

To use the Canvas Size command: 

1    Choose Image > Canvas Size.

2    Choose the units of measurement you want. The Columns option measures width in terms of the 
columns specified in the Rulers & Units preferences.

3    Enter the dimensions in the Width and Height boxes. A new file size appears.

4    For Anchor, click a square to indicate where to position the existing image on the new canvas. 

5    Click OK.

Original canvas, and canvas added to top of image
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See also: 

Color modes and models 

Color gamuts 

Color channels 

Measuring color values in the Info palette 

Adjusting the monitor display 

Converting between bit depths 

Converting images from one mode to another 

Converting between Grayscale mode and Bitmap mode 

Converting to indexed color 
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Color modes and models

A color mode in Photoshop determines the color model used to display and print Photoshop 
documents. Photoshop bases its color modes on established models for describing and reproducing 
color. Common models include HSB (for hue, saturation, brightness); RGB (for red, green, blue); 
CMYK (for cyan, magenta, yellow, black); and CIE L*a*b*. Photoshop also includes modes for 
specialized color output such as indexed color and duotones.

See also: 

Color Modes 

HSB model 

RGB model 

RGB mode 

CMYK model 

CMYK mode 

L*a*b model 

Lab mode 

Specialized color modes 
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Color Modes

In addition to determining the number of colors that can be displayed in an image, color modes affect 
the number of channels and the file size of an image.
Bitmap mode 
Indexed color mode 
Grayscale mode 
RGB color mode 
Duotone mode 
CMYK color mode 
Multichannel mode 
Lab color mode 
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HSB model

Based on the human perception of color, the HSB model describes three fundamental characteristics 
of color:
•      Hue is the color reflected from or transmitted through an object. It is measured as a location on the
standard color wheel, expressed as a degree between 0 and 360. In common use, hue is identified by 
the name of the color such as red, orange, or green. 
•      Saturation, sometimes called chroma, is the strength or purity of the color. Saturation represents 
the amount of gray in proportion to the hue, measured as a percentage from 0% (gray) to 100% (fully 
saturated). On the standard color wheel, saturation increases from the center to the edge.
•      Brightness is the relative lightness or darkness of the color, usually measured as a percentage 
from 0% (black) to 100% (white).

Although you can use the HSB model in Photoshop to define a color in the Color palette or Color 
Picker dialog box, there is no HSB mode available for creating and editing images.

A. Saturation    B. Hue    C. Brightness    D. All hues
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RGB model

A large percentage of the visible spectrum can be represented by mixing red, green, and blue (RGB) 
colored light in various proportions and intensities. Where the colors overlap, they create cyan, 
magenta, and yellow.

Because the RGB colors combine to create white, they are also called additive colors. Adding all 
colors together creates white—that is, all light is reflected back to the eye. Additive colors are used for 
lighting, video, and monitors. Your monitor, for example, creates color by emitting light through red, 
green, and blue phosphors.

 
Additive colors (RGB)
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RGB mode

Photoshop’s RGB mode uses the RGB model, assigning an intensity value to each pixel ranging from 
0 (black) to 255 (white) for each of the RGB components in a color image. For example, a bright red 
color might have an R value of 246, a G value of 20, and a B value of 50. When the values of all three 
components are equal, the result is a shade of gray. When the value of all components is 255, the 
result is pure white; when the value is 0, pure black. 

RGB images use three colors to reproduce up to 16.7 million colors on-screen. RGB images are three-
channel images, so they contain 24 (8 x 3) bits per pixel. RGB is the default mode for new Photoshop 
images. Computer monitors always display colors using the RGB model. This means that when 
working in color modes other than RGB, such as CMYK, Photoshop temporarily converts data into 
RGB data for display on-screen. 
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CMYK model

The CMYK model is based on the light-absorbing quality of ink printed on paper. As white light strikes 
translucent inks, part of the spectrum is absorbed and part is reflected back to your eyes. 

In theory, pure cyan (C), magenta (M), and yellow (Y) pigments should combine to absorb all color and
produce black. For this reason these colors are called subtractive colors. Because all printing inks 
contain some impurities, these three inks actually produce a muddy brown and must be combined with
black (K) ink to produce a true black. (K is used instead of B to avoid confusion with blue.) Combining 
these inks to reproduce color is called four-color process printing.

The subtractive (CMY) and additive (RGB) colors are complementary colors. Each pair of subtractive 
colors creates an additive color, and vice versa.

 
Subtractive colors (CMYK)
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CMYK mode

In Photoshop’s CMYK mode, each pixel is assigned a percentage value for each of the process inks. 
The lightest (highlight) colors are assigned small percentages of process ink colors, the darker 
(shadow) colors higher percentages. For example, a bright red might contain 2% cyan, 93% magenta, 
90% yellow, and 0% black. In CMYK images, pure white is generated when all four components have 
values of 0%.

Use the CMYK mode when preparing an image to be printed using process colors. Converting an 
RGB image into CMYK creates a color separation. If you start with an RGB image, it’s best to edit first 
and then convert to CMYK. In RGB mode, you can use the CMYK Preview command to simulate the 
effects of the change without actually changing image data (see Previewing CMYK colors). You can 
also use CMYK mode to work directly with CMYK images scanned or imported from high-end 
systems.
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L*a*b model

The L*a*b color model is based on the model proposed by the Commission Internationale d’Eclairage 
(CIE) in 1931 as an international standard for color measurement. In 1976, this model was refined and
named CIE L*a*b.

L*a*b color is designed to be device independent; creating consistent color whatever the device (such 
as monitor, printer, computer, or scanner) used to create or output the image.

L*a*b color consists of a luminance or lightness component (L) and two chromatic components: the a 
component (from green to red) and the b component (from blue to yellow).

A. Luminance =100 (white)    B. Green to red component    C. Blue to yellow component    D. Luminance = 0 
(black) to red component 
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Lab mode

In Photoshop’s Lab mode (the asterisks are dropped from the name), the lightness component (L) can
range from 0 to 100. The a component (green-red axis) and the b component (blue-yellow axis) can 
range from +120 to –120.

You can use Lab mode to work with Photo CD images, edit the luminance and the color values in an 
image independently, move images between systems, and print to PostScript® Level 2 and Level 3 
printers. To print Lab images to other color PostScript devices, convert to CMYK first. 

Lab color is the internal color model Photoshop uses when converting from one color mode to another.
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Specialized color modes

Photoshop also provides specialized color modes.

Bitmap mode

Uses one of two color values (black or white) to represent the pixels in an image. Images in Bitmap 
mode are called bitmapped, or 1-bit, images because they have a bit depth of 1. (See About bit 
depth.)

Grayscale mode

Uses up to 256 shades of gray. Every pixel of a grayscale image has a brightness value ranging from 
0 (black) to 255 (white). Grayscale values can also be measured as percentages of black ink coverage
(0% is equal to white, 100% to black). Images produced using black-and-white or grayscale scanners 
typically are displayed in Grayscale mode. You can convert both Bitmap-mode and color images to 
grayscale. 

To convert a color image to a high-quality black-and-white image, Photoshop discards all color 
information in the original image. The gray levels (shades) of the converted pixels represent the 
luminosity of the original pixels.
 You can mix information from the color channels to create a custom grayscale channel by using the 

Channel Mixer command.

When converting from grayscale to RGB, the color values for a pixel are based on its previous gray 
value. A grayscale image can also be converted to a CMYK image (for creating process-color 
quadtones without converting to Duotone mode) or to a Lab color image.

Duotone mode

Creates duotone (two-color), tritone (three-color), and quadtone (four-color) grayscale images using 
two to four colored inks. (See Using monotones, duotones, tritones, and quadtones.)

Indexed color mode

Uses at most 256 colors. When converting to indexed color, Photoshop builds a color lookup table 
(CLUT), which stores and indexes the colors in the image. If a color in the original image does not 
appear in the table, the program chooses the closest one or simulates the color using available colors.

By limiting the palette of colors, indexed color can reduce file size while maintaining visual quality—for 
example, for a multimedia animation application or a Web page. Limited editing is available in this 
mode. For extensive editing you should convert temporarily to RGB mode. (See Converting to indexed
color.)

Multichannel mode

Uses 256 levels of gray in each multiple channel. Multichannel images are useful for specialized 
printing—for example, converting a duotone for printing in Scitex CT format.

These guidelines apply to converting images to Multichannel mode:
•      You can convert any image composed of more than one channel to a multichannel image. The 
original channels are converted to spot color channels.
•      When converting a color image to multichannel, the new grayscale information is based on the 
color values of the pixels in each channel. 
•      Converting a CMYK image to multichannel creates cyan, magenta, yellow, and black spot 
channels.
•      Converting an RGB image to multichannel creates cyan, magenta, and yellow spot channels.



•      Deleting a channel from an RGB, a CMYK, or a Lab image automatically converts the image to 
multichannel mode. See Color channels for more information on channels. 

Note: You cannot print a color composite from Multichannel mode. Also, most export file formats do 
not support multichannel mode images. However, you can export the file in Photoshop DCS 2.0 
format.
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Color gamuts

A gamut is the range of colors that a color system can display or print. The spectrum of colors seen by
the human eye is wider than the gamut available in any color model. 

Among the color models used in Photoshop, L*a*b has the largest gamut, encompassing all colors in 
the RGB and CMYK gamuts. Typically, the RGB gamut contains the subset of these colors that can be
viewed on a computer or television monitor (which emits red, green, and blue light). Therefore, some 
colors, such as pure cyan or pure yellow, can’t be displayed accurately on a monitor.

Note: The Wide Gamut RGB mode extends this color range beyond what can be previewed on a 
monitor, creating a larger RGB color range in which to work. For information on editing images in this 
mode, see Entering RGB setup information.

The CMYK gamut is smaller, consisting only of colors that can be printed using process-color inks. 
When colors that cannot be printed are displayed on-screen, they are referred to as out-of-gamut 
colors—that is, outside the CMYK gamut. (See Identifying out-of-gamut colors.)

A. Lab color gamut    B. RGB color gamut    C. CMYK color gamut 
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Color channels

Every Adobe Photoshop image has one or more channels, each storing information about color 
elements in the image. The number of default color channels in an image depends on its color mode. 
For example, a CMYK image has at least four channels, one each for cyan, magenta, yellow and 
black information. Think of a channel as analogous to a plate in the printing process, with a separate 
plate applying each layer of color. 

In addition to these default color channels, extra channels, called alpha channels, can be added to an 
image for storing and editing selections as masks; and spot color channels can be added, to add spot 
color plates for printing. (See Using Channels and Masks.)

An image can have up to 24 channels. By default, Bitmap-mode, grayscale, duotone, and indexed-
color images have one channel; RGB and Lab images have three; and CMYK images have four. You 
can add channels to all image types except Bitmap-mode images. 



Choosing a Color Mode 

Measuring color values in the Info palette

Depending on how your Info palette is set up, you can select any tool, position the pointer over any 
part of an image, and determine the color value under the pointer. You can customize the Info palette 
and color samplers to express color values using the HSB, RGB, CMYK, Lab, or Grayscale modes 
without changing the mode of the image itself. For more information on measuring color with the Info 
palette and color samplers, see Previewing color values and the procedure To change the Info palette 
options.



Choosing a Color Mode 

Adjusting the monitor display

Although the RGB color model used by computer monitors is capable of displaying much of the visible 
spectrum, the video system sending data to a given monitor often limits how many colors can be 
displayed at once. By understanding how color data is measured in digital files and on-screen, you 
can better adjust Photoshop’s preferences to offset the limitations of your video system.

This understanding also will help you choose a file format for your images. For more information, see 
Saving and Exporting Images.

See also: 

About bit depth 

Color display options for 8-bit color displays 



Adjusting the monitor display 

About bit depth

Bit depth—also called pixel depth or color depth—measures how much color information is in the 
image to display or print pixels. Greater bit depth (more bits of information per pixel) means more 
available colors and more accurate color representation in the digital image. For example, a pixel with 
a bit depth of 1 has two possible values: black and white. A pixel with a bit depth of 8 has 28, or 256, 
possible values. And a pixel with a bit depth of 24 has 224, or roughly 16 million, possible values. 
Common values for bit depth range from 1 to 64 bits per pixel.

Photoshop supports up to 16 bits per pixel for each channel in an image. A 24-bit RGB image, for 
example, would have 8 bits per pixel for each of the red, green, and blue channels.

A. 1-bit (Bitmap)    B. 8-bit (grayscale)    C. 8-bit (indexed color)    D. 24-bit (RGB)



Adjusting the monitor display 

Color display options for 8-bit color displays

Each image mode in Adobe Photoshop uses a color lookup table, or color palette, to store the colors 
used in the image. When you’re working with a display system that supports 8-bit color (or fewer 
colors), the monitor displays only 256 different colors at a time. For example, a 24-bit RGB image can 
display 16.7 million colors in any image at a time. However, if the monitor can display only 256 of the 
16.7 million colors, Adobe Photoshop uses a technique called dithering to mix pixels of available 
colors and thus simulate colors not currently available.

By default, Adobe Photoshop uses pattern dithering, which can result in a distinctive pattern of darker 
or lighter areas in the image. In contrast, diffusion dithering eliminates this distinctive patterning by 
using the surrounding pixels in the mix of pixel color. But diffusion dithering can cause visual 
inconsistencies when only part of a screen is redrawn as you scroll, edit, or paint. Keep in mind that 
dithering effects only appear on-screen, not in print. 

To select a color display option:

1    Choose File > Preferences > Display & Cursors.

2    Choose one or both of these display options:
•      System Palette to use the system’s standard 256-color palette.
•      Diffusion Dither to minimize dither patterns produced by dithering.
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Converting between bit depths

In most cases, RGB, grayscale, and CMYK images contain 8 bits of data per color channel. With three
channels in an RGB image, this translates to a 24-bit RGB bit depth (8 bits x 3 channels), an 8-bit 
grayscale bit depth (8 bits x 1 channel), and a 32-bit CMYK bit depth (8 bits x 4 channels). Photoshop 
can also read and import 48-bit RGB, 64-bit CMYK, and 16-bit grayscale images (each with 16 bits of 
data per color channel). 

Note: A16-bit-per-channel image provides finer distinctions in color, but its file size is much larger than
an 8-bit-per-channel image.

Photoshop supports these tools and commands in 16-bit-per-channel images: the marquee, lasso, 
crop, measure, zoom, hand, pen, eyedropper, color sampler, and rubber stamp tools; and the 
Duplicate, Feather, Modify, Levels, Auto Levels, Curves, Histogram, Hue/Saturation, 
Brightness/Contrast, Color Balance, Equalize, Invert, Channel Mixer, Image Size, Transform Selection,
and Rotate Canvas commands. To take full advantage of Photoshop’s features, you can convert a 16-
bit-per-channel image to an 8-bit-channel image. 

To convert from 8 bits per channel to 16 bits per channel:

1    Flatten the image you want to convert, as explained in Flattening all layers.

2    Choose Image > Mode > 16 Bits/Channel.

To convert from 16 bits per channel to 8 bits per channel:

Choose Image > Mode > 8 Bits/Channel.
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Converting images from one mode to another

The transition between converting an image from one mode to another permanently changes color 
values in the image. For example, when you convert an RGB image to CMYK mode, RGB color 
values outside the CMYK gamut are adjusted to fall within the CMYK gamut. Consequently, 

before converting images, it’s best to do the following:
•      Do as much editing as possible in the image’s original mode (usually RGB from most scanners, or 
CMYK from traditional drum scanners or if imported from Adobe Illustrator or from a Scitex system). 
•      Save a backup copy before converting. Be sure to save a copy of your image that includes all 
layers in order to edit the original version of the image after the conversion.
•      Flatten the file before converting it. The interaction of colors between layer blending modes will 
change when the mode changes.

For information on converting to CMYK, see Converting to CMYK, About calibration, and Adjusting the
separation type and black generation. For converting open images to a different color space, see 
Converting the color space of open images.

To convert an image to another mode:

Choose Image > Mode and the mode you want from the submenu. Modes not available for the active 
image appear dimmed in the menu. 

The following mode conversions flatten the file: 
•      RGB to Indexed color or Multichannel mode.
•      CMYK to Multichannel mode. 
•      Lab to Multichannel, Bitmap, or Grayscale mode.
•      Grayscale to Bitmap, Indexed, or Multichannel mode.
•      Duotone to Bitmap, Indexed, or Multichannel mode.
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Converting between Grayscale mode and Bitmap mode

Converting an image to Bitmap mode reduces the image to two colors, greatly simplifying the color 
information in the image and reducing its file size. To convert an image to Bitmap mode, you must first 
convert it to Grayscale mode. This removes the hue and saturation information from the pixels and 
leaves just the brightness values. However, because few editing options are available for Bitmap-
mode images, it’s usually best to edit the image in Grayscale mode and then convert it. 

Keep in mind that a Bitmap-mode image edited in Grayscale mode may not look the same when 
converted back to Bitmap mode. For example, a pixel that is black in Bitmap mode and then edited in 
Grayscale mode may be converted to a shade of gray. If the pixel is light enough, it will be white when 
converted back to Bitmap mode.

See also: 

To convert an image to Bitmap mode 

To convert a Bitmap-mode image to grayscale 

Specifying a halftone screen for a Bitmap-mode image 

Additional bitmap conversion options 



Converting between Grayscale mode and Bitmap mode 

To convert an image to Bitmap mode:

1    Do one of the following:
•      If the image is in color, choose Image > Mode > Grayscale. Then choose Image > Mode > Bitmap.
•      If the image is grayscale, choose Image > Mode > Bitmap.

2    For Output, enter a value for the output resolution of the Bitmap-mode image, and choose a unit of 
measurement. By default, the current image resolution appears as both the input and the output 
resolutions.

3    Select a bitmap conversion method, and click OK. If you choose Halftone Screen, see the following
section. For other conversion methods, see Additional bitmap conversion options.



Converting between Grayscale mode and Bitmap mode 

To convert a Bitmap-mode image to grayscale:

1    Choose Image > Mode > Grayscale.

2    Enter a value between 1 and 16 for the size ratio.

The size ratio is the factor for scaling down the image. For example, to reduce a grayscale image by 
50%, enter 2 for the size ratio. If you enter a number greater than 1, the program averages multiple 
pixels in the Bitmap-mode image to produce a single pixel in the grayscale image. This process lets 
you generate multiple shades of gray from an image scanned on a 1-bit scanner. 



Converting between Grayscale mode and Bitmap mode 

Specifying a halftone screen for a Bitmap-mode image

The Halftone Screen option in the Bitmap dialog box lets you convert a grayscale image to simulated 
halftone dots.

Important: The halftone screen becomes part of the image. If you print the image on a halftone 
printer, it will print with the halftone screen you choose here plus that of the printer. On some printers, 
the result probably will be a moiré pattern in the image.

To specify the halftone screen for a Bitmap-mode image: 

1    Choose Image > Mode > Bitmap.

2    Click Halftone Screen; then click OK.

3    For Frequency, enter a value for the screen frequency, and choose a unit of measurement. Values 
can range from 1 to 999 for lines per inch and from 0.400 to 400 for lines per centimeter. You can 
enter decimal values. 

The screen frequency specifies the ruling of the halftone screen in lines per inch (lpi). The frequency 
depends on the paper stock and type of press used for printing. Newspapers commonly use an 85-line
screen. Magazines use higher resolution screens, such as 133 lpi and 150 lpi. Check with your print 
shop for correct screen frequencies.

4    Enter a value for the screen angle in degrees from –180 to +180. 

The screen angle refers to the orientation of the screen. Continuous-tone and black-and-white halftone
screens commonly use a 45 angle. 

5    For Shape, choose the dot shape you want.

6    Click OK.

You can save and reuse halftone screen settings by using the Save and Load buttons in the Halftone 
Screen dialog box.



Converting between Grayscale mode and Bitmap mode 

Additional bitmap conversion options

Like the Halftone Screen option, the other bitmap conversion options determine the quality of the 
Bitmap-mode image. 

See also: 

50% Threshold 

Pattern Dither 

Diffusion Dither 

Custom Pattern 



Additional bitmap conversion options 

50% Threshold

Converts pixels with gray values above the middle gray level (128) to white and below to black. The 
result is a very high-contrast, black-and-white representation of the image.

See also: 

Pattern Dither 

Diffusion Dither 

Custom Pattern 



Additional bitmap conversion options 

Pattern Dither

Converts an image by organizing the gray levels into geometric configurations of black-and-white dots.

See also: 

50% Threshold 

Diffusion Dither 

Custom Pattern 



Additional bitmap conversion options 

Diffusion Dither

Converts an image by using an error-diffusion process, starting at the pixel in the upper left corner of 
the image. If the pixel’s value is above middle gray (128), the pixel is changed to white—if below, to 
black. Because the original pixel is rarely pure white or pure black, error is inevitably introduced. This 
error is transferred to surrounding pixels and diffused throughout the image, resulting in a grainy, 
filmlike texture. This option is useful for viewing images on a black-and-white screen.

Original grayscale image, and 50% Threshold conversion method

Pattern Dither conversion method, and Diffusion Dither conversion method

See also: 

50% Threshold 

Pattern Dither 

Custom Pattern 



Additional bitmap conversion options 

Custom Pattern

Simulates the effect of printing a grayscale image through a custom halftone screen. This method lets 
you apply a screen texture, such as a wood grain, to an image. To use this option, you must first 
define a pattern (see Filling and stroking selections and layers).

You can create a pattern representing the texture you want and then screen the grayscale image to 
apply the texture. To cover the entire image, the pattern must be as large as the image. Otherwise, the
pattern will be tiled. For example, if you apply a 1-inch-by-1-inch pattern to a 4-inch-by-4-inch image, 
the pattern appears as 16 squares. Adobe Photoshop comes with several self-tiling patterns that can 
be used as halftone screen patterns (see the procedure To use a pattern from the PostScript Patterns 
folder).

Because the Custom Pattern option simulates dark and light colors by making the halftone pattern 
thicker and thinner, it makes sense to choose a pattern that lends itself to thickness variations, 
typically one with a variety of gray shades. 
 To prepare a black-and-white pattern for conversion, you can first convert the image to grayscale and 

then apply the Blur More filter several times. This blurring technique creates thick lines tapering from dark 
gray to white. 

See also: 

50% Threshold 

Pattern Dither 

Diffusion Dither 
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Converting to indexed color

Converting to indexed color deletes all but 256 colors from the image—the standard number of colors 
supported by many multimedia animation applications and Web pages. Converting an RGB image to 
indexed color lets you edit the image’s color table or export it to an application supporting only 8-bit 
color. The conversion also reduces the file size by deleting color information from the image.

See also: 

To convert an RGB image to an indexed-color image 

Specifying a palette 

Specifying the bit depth 

Specifying dithering options 

Specifying color matching options 

Manipulating the color table 

Choosing a color-table option 

Saving and loading a color table 



Converting to indexed color 

To convert an RGB image to an indexed-color image:

1    Choose Image > Mode > Indexed Color.

Note: The image must be flattened first, or you will lose layers.

2    Select Preview to display a preview of the changes.

3    Select a palette, color depth (bit depth), and dither method as described in the following sections.

4    Click OK.



Converting to indexed color 

Specifying a palette 

Eight palette types are available for converting an image to indexed color.

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Web 

Uniform 

Adaptive 

Custom 

Previous 



Specifying a palette 

Exact

Creates a palette using the exact colors appearing in the RGB image—an option available only if the 
image uses 256 or fewer colors. Because the image’s palette contains all colors in the image, there is 
no dithering. 

See also: 

System (Windows) 

System (Macintosh) 

Web 

Uniform 

Adaptive 

Custom 

Previous 



Specifying a palette 

System (Windows)

Uses the Windows system’s default 8-bit palette, which is based on a uniform sampling of RGB colors.

See also: 

Exact 

System (Macintosh) 

Web 

Uniform 

Adaptive 

Custom 

Previous 



Specifying a palette 

System (Macintosh)

Uses the Macintosh system’s default 8-bit palette, which is based on a uniform sampling of RGB 
colors. 

See also: 

Exact 

System (Windows) 

Web 

Uniform 

Adaptive 

Custom 

Previous 



Specifying a palette 

Web

Uses the palette most often used by Web browsers to display 8-bit images. This palette is a subset of 
the Windows and Macintosh systems’ palettes.

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Uniform 

Adaptive 

Custom 

Previous 



Specifying a palette 

Uniform

Creates a palette by uniformly sampling colors from the spectrum. For example, if you choose an 8-bit 
color depth, Photoshop takes 6 evenly spaced color levels each of red, green, and blue and calculates
the combinations of these colors to produce a uniform palette of 216 colors (6 x 6 x 6 = 216). A lower 
bit depth creates a uniform palette composed of fewer colors. The total number of colors displayed in 
the image corresponds to the cube nearest the chosen bit depth (8, 27, 64, 125, or 216).

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Web 

Adaptive 

Custom 

Previous 



Specifying a palette 

Adaptive

Creates a palette by sampling the colors from the spectrum appearing most commonly in the image. 
For example, an RGB image with only the colors green and blue produces a palette made primarily of 
greens and blues. Most images concentrate colors in particular areas of the spectrum. 

To control a palette more precisely, first select a part of the image containing the colors you want to 
emphasize. Photoshop weights the conversion toward these colors.

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Web 

Uniform 

Custom 

Previous 



Specifying a palette 

Custom

Creates a custom palette using the Color Table dialog box. Either edit the color table and save it for 
later use or click Load to load a previously created color table. (See Specifying color matching 
options.) 

This option also displays the current adaptive palette, which is useful for previewing the colors most 
often used in the image.

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Web 

Uniform 

Adaptive 

Previous 



Specifying a palette 

Previous

Uses the custom palette from the previous conversion, making it easy to convert several images with 
the same custom palette.

A. Web palette    B. Adaptive palette    C. Custom palette

See also: 

Exact 

System (Windows) 

System (Macintosh) 

Web 

Uniform 

Adaptive 

Custom 
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Specifying the bit depth

Using the Uniform or Adaptive palette, you can specify the bit depth of an indexed-color image—the 
number of bits of color information per pixel. Bit depth, also known as color depth, determines the 
number of colors used to display (or print) an image. For example, if you choose 4 bits per pixel, the 
image is composed of 16 colors; 6 bits per pixel, 64 colors; 8 bits per pixel, 256 colors. (The number of
colors used is displayed in the Colors text box.) In addition, you can specify the exact number of colors
to be displayed (up to 256) by choosing Other for Color Depth and entering a value for Colors. 

The options in the Indexed Color dialog box control only how the indexed color table is created. Adobe
Photoshop still treats the image as an 8-bit, 256-color image.
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Specifying dithering options

Unless you’re using the Exact color table option, the color table may not contain all the colors used in 
the image. To simulate colors not in the color table, you can dither the colors. Dithering mixes the 
pixels of the available colors to simulate the missing colors. You can choose from three dithering 
options:

None

Does not dither colors but instead uses the color closest to the missing color. This tends to result in 
sharp transitions between shades of color in the image, creating a posterized effect.

Diffusion

Uses an error-diffusion method that produces a less structured dither than the Pattern option.

Pattern

Uses a halftone-like square pattern to simulate any colors not in the color table. This option is 
available only when you’re using the Mac OS System palette, the Web palette, or the Uniform (216 
colors) palette.
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Specifying color matching options

You can choose from three options to match colors in the original image when dithering:

Best

Finds the best possible match for each pixel. Although this option takes longer to process, it can 
provide a better image. This option is only available if you choose None or Diffusion for the dithering 
option.

Faster

Takes less time than Best, but may not find the best color match for each pixel. This option is only 
available if you choose None or Diffusion for the dithering option.

Preserve Exact Colors

Prevents colors that are already in the chosen palette from being dithered. This is useful for preserving
fine lines and text for Web images. This option is only available if you choose Diffusion for the 
dithering option.
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Manipulating the color table 

You can change one or more colors in the color table of an indexed-color image, edit colors to produce
special effects, model the colors after a predefined color table, and save a color table for reuse with 
other indexed-color images. 

Another type of image with fewer than 256 colors is a pseudocolor image—a grayscale image 
displaying variations in gray levels with color rather than shades of gray, and often used in scientific 
and medical applications. The color table-editing features are particularly useful with pseudocolor 
images, but can also produce special effects with indexed-color images having a limited number of 
colors.

Note: Simply to change colors in an image, choose Image > Adjust, and use the color correction 
commands in the submenus. (See Making Color and Tonal Adjustments for a description of these 
commands.)

To edit colors in the color table:

1    Open the indexed-color image.

2    Choose Image > Mode > Color Table.

3    Click or drag in the table to choose the color or range of colors you want to change. 

4    Choose the color you want, as explained in Using the Adobe Photoshop Color Picker, and click 
OK. 

If you are changing a range of colors, Photoshop creates a gradient in the color table between the 
starting and ending colors. The first color you choose in the Color Picker is the beginning color for the 
range. When you click OK, the Color Picker reappears so that you can choose the last color in the 
range.

The colors you selected in the Color Picker are placed in the range you selected in the Color Table 
dialog box.

5    Click OK in the Color Table dialog box to apply the new colors to the indexed-color image.
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Choosing a color-table option

Your indexed color table can be modeled after predefined color tables, which you select from the Table
menu in the Color Table dialog box. 

Custom

Creates a palette you specify.

Black Body

Displays a palette based on the different colors a blackbody radiator emits as it is heated—from black 
to red, orange, yellow, and white. 

Grayscale

Displays a palette based on 256 levels of gray—from black to white. 

Spectrum

Displays a palette based on the colors produced as white light passes through a prism— from violet, 
blue, and green to yellow, orange, and red. 

Windows System

Displays the standard Windows 256-color system palette. 

Macintosh System

Displays the standard Mac OS 256-color system palette.
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Saving and loading a color table 

You use the Save and Load buttons in the Color Table dialog box to save your indexed color tables for 
use with other Adobe Photoshop images. Once you load a color table into an image, the colors in the 
image change to reflect the color positions they reference in the new color table. 

Note: You can also load saved color tables into the Swatches palette. See the procedure To save and 
use custom swatch sets.
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See also: 
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About workflow 
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Choosing a color management module 
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Calibrating your monitor 

Entering RGB setup information 

Entering CMYK setup information 
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Converting to CMYK 

Managing ICC profiles in files 

Converting the color space of open images 



Reproducing Color Accurately 

About calibration

Whether preparing artwork for print or online use, you should begin by calibrating your monitor. This 
will ensure the closest possible match between your colors on-screen and those produced by a printer,
a video display, or a different computer monitor, and also between your colors in Adobe Photoshop 
and in other software programs. If your monitor isn’t calibrated, the resulting colors may not even be 
close to what you originally saw on it.

Most problems associated with accurately reproducing colors from a software program stem from 
reconciling the differences between the total set of colors, or gamut, produced by the red, green, and 
blue phosphors of a computer monitor and the gamut produced by the cyan, magenta, yellow, and 
black inks of a printer. In addition, colors can vary dramatically between different monitors, printers, 
and software. The color space for a device is defined by the gamut it can represent.

Every image file you create needs to reside in a specific color space. For example, a CMYK file 
created for one printer may have slightly different color characteristics than one created for another 
printer. Photoshop requires you to specify what color space you want to use for all of your RGB, 
CMYK, and Grayscale files.

This workflow provides an overview of how to reproduce colors accurately:

1    Calibrate your monitor as described in Calibrating your monitor.

The Adobe Gamma utility calibrates your monitor and defines the RGB color space that your monitor 
can display. You must calibrate your monitor before you can display colors accurately on it. Once you 
have calibrated your monitor, Photoshop will compensate for differences between the color space in 
which your image resides and the color space in which your monitor displays images.

2    In most cases you should not have to adjust RGB Setup information, especially if you have left the 
dialog box at its default settings. However, if you want to change the RGB color space in which 
Photoshop edits RGB images, enter RGB Setup information as described in Entering RGB setup 
information.

The RGB Setup dialog box defines the RGB color space to use for editing RGB images. It also 
determines whether images are converted to your monitor’s RGB space when displaying them.

3    If you plan to create or edit CMYK files, either for print, for color separations, or for exporting to 
another application, enter CMYK setup information as described in Entering CMYK setup information.

The CMYK Setup dialog box defines which CMYK color space to use for editing and printing CMYK 
images.

Even if you plan to print your files, you may not need to do this step. Most low-end inkjet printers and 
some other output devices accept RGB data directly, and don’t require that you define a CMYK color 
space. If you are unsure whether your printer is an RGB printer, see the documentation that came with
your printer or contact the printer’s manufacturer.

4    If you plan to work on grayscale images, enter Grayscale Setup information as described in 
Applying dot gain settings to grayscale images.

The Grayscale Setup dialog box defines whether grayscale images behave as RGB images or black 
ink.

5    If you want to control how Photoshop opens and saves ICC profiles (color space definitions) in 
files, enter Profile Setup information as described in Managing ICC profiles in files.

The Profiles Setup dialog box specifies whether ICC profiles are saved with files, and lets you specify 
how to handle files that don’t match the working color spaces defined for Photoshop (as described in 
the RGB Setup and CMYK Setup dialog boxes).

This step is optional, particularly if you left the Profile Setup dialog box at its default settings.



6    To fine-tune the CMYK settings you made in step 3, print a pre-separated CMYK proof as 
described in Printing a color proof. Then adjust the CMYK Setup settings to match the proof as 
described in Calibrating the screen image to the proof.

Note: If you defined your CMYK color space using ICC profiles, your ability to fine-tune the settings 
will be limited.
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About workflow

Once you’ve calibrated your system and defined your working color spaces, the normal workflow is 
that any file that is opened or acquired is compared against those defined color spaces. If it doesn’t 
match, the file is converted to the defined color space. When you save an image, the profile of the 
working color space is saved with the file so that the file can be handled correctly with Photoshop and 
other applications.

Calibration is the process of adjusting your monitor and Photoshop’s color conversion settings to 
compensate for factors that affect how colors in the image appear on-screen and in print. Calibration 
helps you do the following:
•      Display printed colors accurately on the screen. With a well-calibrated system, the color 
corrections you make to the image are an accurate reflection of what will come out of the printer.
•      Display RGB colors accurately on the screen.
•      Display CMYK colors accurately on the screen.



Reproducing Color Accurately 

About ICC profiles

One of the methods Photoshop can use to manage color is based on the use of ICC profiles. An ICC 
profile is a color space description. The ICC profile format was defined by the International Color 
Consortium (ICC) as a cross-application standard. ICC profiles help you reproduce colors accurately 
across different platforms, devices, and ICC-compliant applications (such as Adobe Illustrator and 
Adobe PageMaker®).

Adobe Photoshop uses a Color Management Module (CMM) to interpret the ICC profiles that describe
the RGB and CMYK color spaces you are using in your system. You can select from existing ICC 
profiles or create your own. These profiles can then become part of your image files. The CMM 
interprets the ICC profiles to automatically manage color issues among different color models as well 
as color issues between your monitor, other monitors, and the final print image. Although you do not 
have to use ICC profiles, it can greatly simplify managing color.

Important: To ensure that color management works correctly on your system, change the color 
management settings every time you change printing devices.



Reproducing Color Accurately 

Choosing a color management module

To work with ICC profiles in Adobe Photoshop, you can choose which CMM to use for converting 
images. These are typical CMMs:
•      The Photoshop built-in CMM. In most cases, this CMM will give you the best results. If you have 
trouble matching colors between applications, you can try setting Photoshop’s CMM to match the 
other application’s.
•      The Kodak Digital Science Color Management System®, which is installed on your system when 
you install the Kodak Photo CD Acquire plug-in that comes with Photoshop.
•      The CMM specified by the operating system, such as Apple ColorSync 2.1.2 or later, and Microsoft
ICM 2.0.
•      Any other CMM on your system.



Reproducing Color Accurately 

About the RGB, Grayscale, and CMYK Setup dialog boxes

The RGB Setup, Grayscale Setup, and CMYK Setup dialog boxes let you define the native color 
space for editing RGB, Grayscale, and CMYK images. The settings in these dialog boxes are used for 
the following:
•      To convert images between standard color modes (such as from RGB to CMYK).
•      When opening an RGB, Grayscale, or CMYK file, to compare the file’s color space to the color 
space defined in the appropriate Setup dialog box. If the two color spaces are not the same, you can 
convert the file. (See Managing ICC profiles in files.)
•      When viewing a file on-screen, to convert the file to the monitor’s color space. This only affects the
display, not the file—Photoshop assumes that the file’s true color space is the one defined in the 
appropriate Setup dialog box.

Note: If you have disabled the Display Using Monitor Compensation option in the RGB Setup dialog 
box, files may not be displayed accurately in the monitor’s color space. (See Entering RGB setup 
information.)

Changes to the Setup dialog boxes do not affect the pixel values of open images. However, the on-
screen appearance may change, because Photoshop then displays the image assuming a different 
native color space.

For example, suppose your file was created in the sRGB color space and you use the RGB Setup 
dialog box to change the color space to ColorMatch RGB. Photoshop will treat your file as a 
ColorMatch RGB file when it displays it online, even though it is not changing the actual pixel values in
the file.
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Calibrating your monitor

The Adobe Gamma utility lets you calibrate the contrast and brightness, gamma (midtones), color 
balance, and white point of monitors. This helps you eliminate any color cast in your monitor display, 
make your monitor grays as neutral as possible, and standardize your display of images on different 
monitors (whatever the combinations of monitor and video card). The utility then saves these settings 
as an ICC profile for your monitor.

The following guidelines can help you in calibrating your monitor:
•      You can use a third-party calibration utility and an ICM 2.0- or ColorSync-compatible ICC profile 
generator instead of the Adobe Gamma utility. See the utility’s documentation for details.
•      You don’t need to recalibrate your monitor if you have already done so with an ICC-aware 
calibration tool and you have not changed your monitor settings.
•      Gamma settings saved by the Monitor Setup Utility (Windows) or the Gamma control panel (Mac 
OS) in Photoshop 4.0 and earlier are not supported.
•      You only need to set calibration and save it as an ICC profile once on your system, for all 
applications, unless you change any of the factors affecting calibration. For example, if you change the
room lighting or readjust the monitor brightness and contrast controls, you must recalibrate the 
system. If you haven’t done so already, after calibrating the monitor consider taping down your 
monitor’s brightness and contrast controls and your room’s lighting controls.

To calibrate a monitor:

1    Make sure your monitor has been turned on for at least a half hour, to stabilize the monitor display.

2    Set the room lighting at the level you plan to maintain.

3    Turn off any desktop patterns and change the background color on your monitor to a light gray. 
This prevents the background color from interfering with your color perception and helps you adjust 
the display to a neutral gray. (For more on how to do this, refer to the manual for your operating 
system.)

4    Start the Adobe Gamma utility located in the Photoshop/Calibrate folder (Windows) or 
Photoshop/Goodies/Calibration folder (Mac OS).

5    Select which version of the utility you want:
•      Step by Step and click OK for a version of the utility that will guide you through each step of the 
process. If you choose this option, follow the instructions described in the utility.
•      Control Panel and click OK for a version of the utility that is contained in a single dialog box. If you 
choose this option, follow the instructions in the rest of this section.

6    If desired, choose Load and select the monitor ICC profile that most closely matches your monitor. 
Use this as a starting point from which to calibrate your monitor.

Note: In Windows, the folder Windows/System/Color is displayed by default, and contains .icm files in 
8.3 format. Select a file to display the type of monitor ICC profile at the bottom of the Open Monitor 
Profile dialog box.

7    Turn up the contrast and brightness controls on your monitor to their maximum settings. Leave the 
contrast control at maximum.

8    For Brightness and Contrast, adjust the brightness control on your monitor to make the alternating 
gray squares in the top bar as dark as possible (but not black), while keeping the bottom bar a bright 
white.

9    For Phosphors, choose a monitor type. If the correct type is not listed, choose Custom, and enter 
the red, green, and blue chromaticity coordinates as specified by the monitor manufacturer. This 
option accounts for the different red, green, and blue phosphors used by monitors to display color.



10    For Gamma, choose one of the following options to establish your current gamma settings:
•      View Single Gamma Only to adjust the gamma based on a single combined grayscale reading. 
Drag the slider under the gamma preview until the center box fades into the patterned frame.
•      Deselect View Single Gamma Only to adjust the gamma based on Red, Blue, and Green reading. 
Drag the slider under each box, until the center box matches the patterned frame.

The gamma setting of your monitor defines how bright the midtones are.

11    For Desired, choose the target gamma you want. For example, the default target gamma in 
Windows is 2.2 and in Mac OS is 1.8. 

Note: This option is not available on Windows systems that cannot control the monitor.

12    For Hardware, choose the white point of your monitor as described by your monitor’s 
manufacturer. This setting determines whether you are using a warm or cool white. To measure the 
hardware white point, choose Measure and follow the instruction on-screen.

13    For Adjusted, if you know the color temperature at which the finished image will be viewed, 
choose it here. Otherwise, choose Same As Hardware. Only choose a different setting to work at a 
different white point than your monitor’s factory-specified hardware setting.

Note: This option is not available on Windows systems that cannot control the monitor.

14    Click the close button on the window.

15    Save the settings.

To calibrate multiple monitors:

1    Drag the Adobe Gamma control panel onto the secondary monitor.

2    Repeat the calibration steps for that monitor.

3    Deselect Use As Default Monitor Profile in the Adobe Gamma control panel unless you want the 
secondary monitor’s profile to be used as the default monitor profile for all of your monitors.
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Entering RGB setup information

The RGB Setup dialog box lets you describe the RGB color space in which to edit RGB images. This 
space is usually different from the monitor’s RGB definition (listed in the bottom part of the RGB Setup
dialog box), so that you can create RGB images without being restricted by a particular monitor’s 
limitations.

The default settings are generally the most appropriate. You should change them if you need to 
specify a different RGB space.

Note: RGB Setup is not the same as Monitor Setup in Photoshop 4.0. To set up your monitor, use the 
Adobe Gamma utility as described in Calibrating your monitor.

To enter RGB setup information:

1    Choose File > Color Settings > RGB Setup. 

2    Select Preview to display a preview of your changes.

3    For RGB, choose one of the following:
•      sRGB for the standard RGB color space. This color space is endorsed by a wide variety of 
hardware and software manufacturers and is becoming the default color space for many scanners, 
low-end printers, and software applications.
•      Apple RGB for the RGB color space used by earlier versions of Adobe Photoshop as well as a 
variety of other desktop publishing applications. Apple RGB is a good choice for online images that will
be displayed on Mac OS systems.
•      CIE RGB for the RGB color space defined by the Commission Internationale d’Eclairage. This 
option provides a fairly large color gamut, but does not handle cyan very well.
•      ColorMatch RGB for the RGB color space defined by Radius that matches the native color space 
of their Pressview monitors.
•      NTSC (1953) for the video color space defined by the National Television Standards Committee 
(NTSC). This is the original color television standard. It has been mostly superseded by the more 
recent SMPTE-C standard.
•      PAL/SECAM for the current color television standard for Europe and other parts of the world that 
use PAL or SECAM-based television.
•      SMPTE-240M for the RGB color space for high-definition television production (as opposed to 
broadcast). It has a larger color gamut than the spaces based on HDTV phosphors. This option can be
a good choice if you need a wider color gamut than many of the other color spaces—sRGB in 
particular—without going to the extreme of using Wide-Gamut RGB.
•      SMPTE-C for the current color television standard in the United States and other parts of the world
that use NTSC-based television.
•      Wide-Gamut RGB for a very wide-gamut RGB space defined using pure spectral-color primaries. 
This space’s gamut includes almost all visible colors and is wider than what the typical monitor can 
display accurately. However, many colors specified in the gamut cannot be reproduced on RGB 
monitors or on press.
•      Custom to create a custom RGB profile. This option may be useful if you know the description of 
the RGB space for your scanner and you want to set Photoshop’s RGB color space to be the same. 
(For details see the instructions “To create a custom RGB profile” later in this section.)

4    Select Display Using Monitor Compensation to display images using the monitor’s RGB color 
space. This does not affect the color information in images, only the way images look on the screen, 
and provides a more accurate display. Leaving this option deselected displays images directly to the 
monitor, with no compensation, and can make screen updates faster but less accurate.

5    Click OK.



To create a custom RGB profile:

1    Enter the Gamma value you want to use.

2    For White Point, choose a setting.

3    For Primaries, choose a set of red, green, and blue phosphor or primary types. This option is 
based on the different red, green, and blue phosphors or primaries used by monitors to display color. If
the correct type is not listed, choose Custom, and enter the red, green, and blue chromaticity 
coordinates.

Note: Because you are defining the color space in which to edit images, the primaries do not have to 
match your monitor.

To save and load the settings for different RGB color spaces:

Select Save or Load in the RGB Setup dialog box. Saving the setting saves it as an ICC profile.

Note: Only RGB profiles that exactly match Photoshop’s RGB model can be loaded. They must be 
matrix-based, and use a single, pure-gamma tone response curve. Most RGB profiles are not 
supported as a working RGB space.
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Entering CMYK setup information

The CMYK Setup dialog box lets you define the CMYK color space using ICC profiles, color 
separation tables, or by specifying the properties of the inks and paper stock used to reproduce your 
color plates.

As with the RGB Setup dialog box, Photoshop uses information in the CMYK Setup dialog box when 
converting color values between modes. If you change the CMYK Setup settings after you have 
converted an image to CMYK mode, only the display is affected. You must revert to the original RGB 
image (by choosing File > Revert) and then reconvert the image for the changes to affect the 
separation data. See Converting to CMYK for more information on how the printing inks settings affect
mode conversions.

If you are using an RGB-based printer (such as most low-end inkjet printers, some thermal printers, 
and some high-end proofing devices, such as Fujix Pictography), you don’t need to enter CMYK setup
information. Such printers use RGB information, not CMYK information, to print the file. If you are 
unsure whether your printer is an RGB printer, see the documentation that came with your printer or 
contact the printer’s manufacturer. All options for managing color in RGB-based output devices are in 
the Print dialog box. For more information, see Converting the color space of images while printing.

To specify the CMYK settings: 

Do one of the following:
•      To use an ICC profile to define the CMYK color space for your printer, see Using ICC profiles to 
define the CMYK color space.
•      To specify the ink and separation options yourself, see Using the Built-in option to define the 
CMYK color space.
•      To create or use third-party, Photoshop-compatible color separation tables, see Using color 
separation tables.
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Using ICC profiles to define the CMYK color space

The CMYK Setup dialog box lets you specify the CMYK color space based on the ICC profile of the 
printer you select. The CMM then maps the colors in the image to the profiled printer’s color gamut, or 
range of printable colors.You can choose the method (called rendering intent) that is used to translate 
the colors to the printed gamut.

To use ICC printer profiles to define the CMYK color space:

1    Choose File > Color Settings > CMYK Setup.

2    For CMYK Model, select ICC.

3    Select Preview to display a preview of your changes. A flashing bar under the option indicates a 
preview is being created.

4    For Profile, choose the printer profile you want to use. If the printer you use is not listed in the 
Profile menu, contact your printer manufacturer for the appropriate printer profile or create one using 
third-party printer profiling software.

5    For Engine, choose the CMM you want to use. Built-in refers to Photoshop’s built-in CMM.

Note: This option is not the same as choosing Built-in for CMYK Model.

6    For Intent, choose one of the following:
•      Perceptual (Images) to maintain the relative color values among the original pixels as they are 
mapped to the printer gamut. This method preserves the relationship between colors, although the 
color values themselves may change.
•      Saturation (Graphics) to maintain the relative saturation values of the original pixels. Out-of-gamut 
colors are converted to colors that have the same saturation but fall just inside the gamut.
•      Relative Colorimetric to leave colors that fall inside the gamut unchanged. This method usually 
converts out-of-gamut colors to colors that have the same lightness but fall just inside the gamut.
•      Absolute Colorimetric to disable white point matching when converting colors. This option is not 
generally recommended.

7    If desired, choose Black Point Compensation to map the darkest neutral color of the source’s color 
space to the darkest neutral color of the destination’s color space rather than to black when converting
colors.

8    Click OK.
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Using the Built-in option to define the CMYK color space

The Built-in option in the CMYK Setup dialog box lets you specify the ink and separation options. 
Photoshop then enters a default value for the dot gain (the change in the halftone dot size caused by 
absorption on the output device). After you print a proof or talk to your print shop, you might need to 
return to the CMYK Setup dialog box to adjust for dot gain, ink characteristics, and color casts. (See 
About dot gain.)

See also: 

To specify the CMYK settings using the Built-in option 



Using the Built-in option to define the CMYK color space 

To specify the CMYK settings using the Built-in option:

1    Choose File > Color Settings > CMYK Setup.

2    Select Preview to display a preview of your changes. A flashing bar under the option indicates a 
preview is being created.

3    For CMYK Model, choose Built-in.

4    For Ink Colors, select an ink type.

The default color values used in the color separation calculations are designed to produce quality 
separations using SWOP (Specifications for Web Offset Publication) inks on coated paper. These inks 
differ slightly from those used in Europe. Similarly, the color and ink absorption qualities of the paper 
stock affect the final printed result. You can think of this information as telling 

Photoshop what printed cyan, magenta, yellow, and black look like given a certain set of inks and 
paper stock under your lighting conditions.

Note: In most cases, printing ink characteristics do not vary greatly from printer to printer within the 
same printer type. For example, one Tektronix Phaser II printer prints ink hues very similar to another 
one. But the amount of dot gain can vary significantly. Thus, for a different printer of the same type, 
you may have to change the dot gain setting in the CMYK Setup dialog box but not the printing ink 
colors. 

If you choose Custom for Ink Colors, the Ink Colors dialog box appears. (See Setting the 
characteristics of custom ink colors.)

5    Verify the dot gain percentage.

Do not adjust this value until you have run a proof (which includes a calibration bar) and have 
measured the density values on the proof with a reflective densitometer. Change this value if your print
shop has provided a different value for estimated dot gain. See Calibrating the screen image to the 
proof and Specifying dot gain for more information on dot gain.

6    Click OK.

For information on choosing separation options, see Adjusting separation options.

To save and load settings:

Use the Save and Load buttons in the CMYK Setup dialog box to save these settings as an ICC 
profile. The profile can then be used again by Photoshop and other ICC-aware applications.
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Adjusting separation options

Along with the other options when you choose Built-in as the CMYK model in the CMYK Setup dialog 
box, the separation options control how the CMYK plates are generated. The separation options 
determine the method used for black generation and undercolor removal and specify the total ink limit 
for the press.

When converting RGB values to CMYK, Photoshop uses information in the RGB Setup and CMYK 
Setup dialog boxes. The settings in these dialog boxes help ensure the closest match possible 
between the colors on-screen and in the final output. The CMYK Setup dialog box settings determine 
the precise CMYK values chosen for a given RGB color. Once an image is in CMYK mode, Photoshop
converts the CMYK color values internally to display them on an RGB monitor. (See Converting to 
CMYK.)

See also: 

About separation types and black generation 

Adjusting the separation type and black generation 

Choosing the separation type 

Choosing the degree of black generation 

Choosing the ink limits 

Using undercolor addition 
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About separation types and black generation

To make color separations, the three additive colors (red, green, and blue) are translated into their 
subtractive counterparts (cyan, magenta, and yellow). In theory, equal parts of cyan, magenta, and 
yellow combine to subtract all light reflected from the paper and create black. Due to impurities 
present in all printing inks, however, a mix of these colors instead yields a muddy brown. To 
compensate for this deficiency in the color separation process, printers remove some cyan, magenta, 
and yellow in areas where the three colors exist in equal amounts, and they add black ink. 

A given color can be translated from RGB mode to CMYK mode in an endless number of ways. But 
prepress operators typically use one of two ways to generate black in print: undercolor removal (UCR) 
or gray component replacement (GCR):
•      With UCR, black ink is used to replace cyan, magenta, and yellow ink in neutral areas only (that is,
areas with equal amounts of cyan, magenta, and yellow). This results in less ink and greater depth in 
shadows. Because it uses less ink, UCR is generally used for newsprint and uncoated stock.
•      With GCR, black ink is used to replace portions of cyan, magenta, and yellow ink in colored areas 
as well as in neutral areas. GCR separations tend to reproduce dark, saturated colors somewhat 
better than UCR separations do and maintain gray balance better on press.

Choose the type of separation based on your paper stock and the requirements of your print shop.
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Adjusting the separation type and black generation

In most cases, the Photoshop color separation defaults produce excellent results. But when 
necessary, you can modify the black generation method, set new ink limits, and change the separation
type. If you have already converted the image to CMYK mode, you must reconvert the image after 
adjusting the separation options.

Note: The separation options don’t affect output from non-PostScript color printers (such as HP 
DeskJet, Canon® Bubblejet™, and Epson® Stylus®Color ), because they generate their own black 
values.

To adjust the separation type and black generation:

Choose File > Color Settings > CMYK Setup.

For Color Model, choose Built-in.

The Separation Options area in the CMYK Setup dialog box displays a graph based on current 
settings showing how the neutral colors in the image will separate. In the graph, sometimes called a 
gray ramp, neutral colors have equal parts of cyan, magenta, and yellow. The horizontal axis 
represents the neutral color value, from 0% (white) to 100% (black). The vertical axis represents the 
amount of each ink that will be generated for the given value. In most cases, the cyan curve extends 
beyond the magenta and yellow curves, because a small extra amount of cyan is required to produce 
a true neutral. 
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Choosing the separation type 

By default, Photoshop uses the GCR type of color separation. Select UCR if you want to use 
undercolor removal. Check with your print shop to find out which to use.
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Choosing the degree of black generation 

For GCR separations, you choose the degree of black generation, set ink limits, and indicate 
undercolor addition. 

Note: ICC profiles specify the degree of black generation.

A. No black generation (Composite image, CMY, K)    B. Medium black generation (Composite image, CMY, K)    
C. Maximum black generation (Composite image, CMY, K)

You can choose from several Black Generation settings in the Separation Setup dialog box: 
•      None generates the color separation using no black plate.
•      The Light and Heavy settings decrease and increase the effect of the Medium setting (the default).
In most cases, Medium produces the best results. 
•      Maximum maps the gray value directly to the black generation value. This option is useful for 
images with a large amount of solid black against a light background, such as screen shots from a 
computer.
•      Custom lets you adjust the black generation curve manually. 

To use the Custom option:

1    For Black Generation, select an option (Light, Medium, Heavy, or Maximum) that is closest to the 
type of black generation you want. This gives you a black generation curve to use as a starting point.

2    For Black Generation, select Custom.

3    Position the pointer on the curve, and drag to adjust the black curve. The curves for cyan, 
magenta, and yellow are adjusted automatically relative to the new black curve and the total ink 
densities.
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Choosing the ink limits

For both GCR and UCR separations, the black generation uses the ink limit settings you enter in the 
Separation Options area. The total ink limit is the maximum ink density your press can support. By 
default, the Black Ink Limit is 100%; the Total Ink Limit is 300%. Check with your print shop to see if 
you should adjust these values. 

Note: In the Gray Ramp graph, these limits determine the cutoff points for the CMYK curves.
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Using undercolor addition

Use the UCA (undercolor addition) Amount text box in the Separation Options area to compensate for 
the loss of ink density in neutral shadow areas. This additional ink produces rich, dark shadows in 
areas that might appear flat if printed with only black ink. UCA can also prevent posterization in subtle 
detail in the shadows. This option is available only for GCR separations.

Increasing the UCA Amount increases the amount of CMY added to shadow areas. Values can range 
from 0 to 100%. Check with your print shop for the preferred value. If you are unsure of this value, 
leave it at 0%.
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Printing a color proof

After calibrating your monitor and entering settings for CMYK Setup, you should print a CMYK image, 
called a proof, on the printer you are calibrating to. The document you use to generate the proof 
should contain color samples of all the CMYK color combinations and must be created or imported 
directly in CMYK mode.

You can produce a proof by printing the Testpict.jpg (Windows) or Olé No Moire (Mac OS) CMYK 
image included with the Adobe Photoshop software, or you can create your own CMYK image. Do not 
print an RGB image that has been converted to CMYK in Photoshop. Instead use an image that has 
been saved in CMYK format without an embedded ICC profile and whose CMYK values have been 
assigned directly in CMYK mode.

Important: Before opening an existing test file, open the Profile Setup dialog box. In the Profile 
Mismatch Handling area, for CMYK, choose Ignore. This will prevent the file from being converted to a
different CMYK color space, and possibly changing the results of the test. Reset this dialog box when 
you are done printing the file.

A. Black overprint color bar    B. Label    C. Registration marks    D. Progressive color bar    E. Crop mark    F. 
Gradient tint bar    G. Star target 

To create your own CMYK proof document:

1    Create a new Photoshop document in CMYK mode.

2    Create a set of swatches that includes the following:
•      Four swatches, each containing 100% of the CMYK colors (100% cyan, 100% magenta, 100% 
yellow, and 100% black).
•      Four combination swatches (100% each of magenta and yellow, 100% each of cyan and yellow, 
100% each of cyan and magenta, and 100% each of cyan, magenta, and yellow).
•      A set of swatches that make up a four-color black, such as 60% cyan, 50% magenta, 50% yellow, 
and 100% black.

3    To include a calibration bar in the image, choose File > Page Setup, and select the Calibration Bars
option. Then click OK.



4    Print the document on a color printer you are calibrating to.
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Calibrating the screen image to the proof

If you are not using ICC profiles, after examining the color proof you may need to adjust some 
calibration settings to make the image on-screen exactly match the proof. In particular, you may need 
to adjust settings in the CMYK Setup dialog box to compensate for dot gain, custom ink 
characteristics, and color casts. 

If you are using ICC profiles and the on-screen image doesn’t match the printed proof closely enough, 
you can do the following:
•      Check that the printer is not miscalibrated. It may not match the dot gain specified in its ICC 
profile. Adobe Systems strongly recommends that you calibrate the imagesetter using the 
manufacturer’s calibration software or a third-party imagesetter calibration device, such as Precision 
Color by Kodak. If you are using a service bureau, verify that the imagesetter is not off by more than 1 
percentage point. 
•      Get a more accurate ICC profile from the printer’s manufacturer.
•      Create an ICC printer profile using hardware designed for this task. (See the documentation that 
came with the ICC profile creation hardware.)
•      Adjust the dot gain using transfer functions. (See Compensating for dot gain in film using transfer 
functions.)
•      Instead of using ICC profiles, define your CMYK space using the Built-in option in the CMYK Setup
dialog box. (See Entering CMYK setup information.)

See also: 

About dot gain 

Specifying dot gain 

Applying dot gain settings to grayscale images 

Compensating for dot gain in film using transfer functions 

Setting the characteristics of custom ink colors 
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About dot gain

Dot gain or loss can occur when the specified printer’s halftone dots change as the ink spreads and is 
absorbed by paper. Photoshop calculates dot gain as the amount by which the expected dot increases
or decreases. For example, a 50% halftone screen may be read with a densitometer at an actual 
density on the printed page of 55%. In this case, the dot gain would be 5%. Dot gain can also result 
when a miscalibrated imagesetter is used during the imaging process.

The dot gain estimate in the CMYK Setup dialog box represents dot gain for a specified paper stock 
for the midtones (the 50% pixels). Photoshop uses this value to create a dot gain curve that adjusts for
dot gain throughout the image. 

Note: If you will be printing separations, consult your printer service bureau for recommended printer 
dot gain settings.

The default dot gain estimate reflects the expected dot gain between film and final output. (The dot 
gain between the color proof and the final output is typically between 2% and 5%.)

Proof (no dot gain), and printed image (with dot gain)

Decreasing the dot gain makes the image on-screen appear lighter, because the dots are smaller. 
Increasing the dot gain makes the image appear darker, because the dots are larger. Changes don’t 
affect actual data in the image until Photoshop uses the setting to adjust the CMYK percentages to 
compensate for dot gain during the conversion process. 
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Specifying dot gain

The CMYK Setup dialog box gives you two ways to specify a printer’s dot gain: by defining a single 
dot gain value at the 50% level or by setting up to 13 values along the grayscale to create a 
customized dot gain curve for one or more CMYK plates.

If the proof has a significant color cast along its gray range, then the printer probably has different dot 
gain values for each ink. In this case, specify the dot gain using curves.

To specify the dot gain at the standard 50% mark:

1    Include a calibration bar with your proof by choosing File > Page Setup and selecting the 
Calibration Bars option.

2    Using a reflective densitometer, take a reading at the 50% mark of the printed calibration bar.

Note: If you don’t have a densitometer, adjust the Dot Gain value until the image on-screen looks like 
the proof, and then add that value to your printer’s estimate of the expected dot gain between proof 
and final output.

3    Choose File > Color Settings > CMYK Setup.

4    For CMYK Model, choose Built-in.

5    Choose Standard from the Dot Gain menu and enter the total amount of dot gain from step 2 in the
Dot Gain text box. For example, if the value in step 2 was 54%, you would enter 4 in the text box, 
because the dot gain is 4%.

To specify the dot gain using curves:

1    Include a calibration bar with your proof by choosing File > Page Setup and selecting the 
Calibration Bars option.

2    Using a reflective densitometer, take a reading at one or more marks of the printed calibration bar.

Note: If you don’t have a densitometer, adjust the Dot Gain value until the image on-screen looks like 
the proof.

3    Choose File > Color Settings > CMYK Setup.

4    For Color Model, choose Built-in.

5    Choose Curves from the Dot Gain menu.

6    Select the plates for which you want to set dot gain curves: Cyan, Magenta, Yellow, Black, or All.

7    Do one of the following:
•      Calculate the required adjustment, and enter the values (as percentages) in the Dot Gain Curves 
dialog box.

For example, if you have specified a 30% dot, and your printer prints it at 36%, you have a 6% dot 
gain in your midtones. To compensate for this gain, enter 36% in the 30% text box of the Dot Gain 
Curves dialog box.
•      Click to add an adjustment point in the dot gain curve, and drag the point to change its value. The 
value then appears in the appropriate text box.
•      Click OK.
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Applying dot gain settings to grayscale images

If your grayscale images will be viewed only on-screen, you don’t need to compensate for dot gain. 
However, if you will print your images, you should apply the same dot gain values you used for CMYK 
output.

To specify Grayscale Setup settings:

1    Choose File > Color Settings > Grayscale Setup.

2    Select Preview to display a preview of your changes.

3    Select a grayscale behavior option:
•      RGB to work without any compensation for dot gain.
•      Black Ink to use the dot gain settings specified in the CMYK Setup dialog box. This option is 
equivalent to choosing the Use Dot Gain for Grayscale Images option in Photoshop 4.0.

4    Click OK.
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Compensating for dot gain in film using transfer functions

When using ICC profiles, you cannot adjust the dot gain with the CMYK Setup dialog box. However, 
you may be able to compensate for dot gain from a miscalibrated imagesetter by using the transfer 
functions.

Transfer functions enable you to compensate for dot gain between the image and film. For example, 
the Transfer function makes 50% dots in the image print as 50% dots on film. Similarly to dot gain 
curves, the transfer functions let you specify up to 13 values along the grayscale to create a 
customized transfer function.

The following guidelines can help you in using transfer functions:
•      Check that the printer is not miscalibrated. (See Calibrating the screen image to the proof.)
•      Do not use transfer functions to compensate for dot gain from film to press. Instead, use the dot 
gain curves in the CMYK Setup dialog box. (Dot gain curves affect the CMYK to RGB conversions and
on-screen display, but transfer functions apply only to printing—they don’t affect the image color data. 
(See Specifying dot gain.)

Important: Remember, use the transfer functions only for dot gain problems that cannot be fixed any 
other way.

To adjust the transfer function values: 

1    Use a transmissive densitometer to record the density values at the appropriate steps in your 
image on film.

2    Choose File > Page Setup.

3    Click the Transfer button.

4    Calculate the required adjustment, and type the values (as percentages) in the Transfer Functions 
dialog box. 

For example, if you specified a 50% dot, and your imagesetter prints it at 58%, an 8% dot gain occurs 
in the midtones. To compensate for this gain, enter 42% (50% – 8%) in the 50% text box of the 
Transfer Functions dialog box. The imagesetter then prints the 50% dot you want.

When entering transfer function values, keep in mind the density range of your imagesetter. On a 
given imagesetter, a very small highlight dot may be too small to hold ink. Beyond a certain density 
level, the shadow dots may fill as solid black, removing all detail in shadow areas. 

Note: To preserve transfer functions in an exported EPS file, select Override Printer’s Default 
Functions in the Transfer Functions dialog box and then export the file with Include Transfer Functions 
selected in the EPS Format dialog box. (See Saving files in Photoshop EPS or DCS format.)

To save the current transfer function settings as the default:

Hold down Alt (Windows) or Option (Mac OS) to change the Save button to —> Defaults, and click the



button. 

To load different transfer function settings:

Hold down Alt (Windows) or Option (Mac OS) to change the Load button to <— Defaults, and click the 
button.
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Setting the characteristics of custom ink colors

In most cases, the Ink Colors options in the CMYK Setup dialog box accurately describe various 
printing inks. In some situations, however, you may want to adjust the ink colors further by using a 
color proof. For example, you may be using ink sets not listed for Ink Colors. When you change these 
settings, you change the profile of the inks Photoshop uses during the color separation.

To adjust for custom ink colors:

1    Choose File > Color Settings > CMYK Setup.

2    For Color Model, choose Built-in.

3    For Ink Colors, select Custom.

The Ink Colors dialog box displays the various combinations of CMYK and the CIE coordinates 
measured for each. CIE coordinates are an international color definition standard supported by 
PostScript Level 2.

By default, the Ink Colors dialog box defines colors as Y (lightness), x, and y values. The default ink 
sets are calibrated for viewing conditions of 5000K (when viewed under D50 lighting), 2° field of view.

Note: Colors appear slightly different based on how much of the eye’s field of view they cover. The 
CIE has defined two standard ways of measuring color coordinates, one based on colors filling 10° of 
the eye’s field of view, and one based on colors filling 2° of the field of view. Photoshop uses the 2° 
field of view standard.

4    If desired, choose L*a*b* Coordinates to enter the color box coordinates as Lab values rather than 
Yxy values. Use this option if your colorimeter only has Lab readouts.

5    Using your printed CMYK proof, take a reading of the color values using a spectrophotometer or a 
colorimeter, and then enter those values in the Ink Colors dialog box. 

Alternatively, you can click the color box of the ink color you want to adjust and then adjust the color 
on-screen until it matches the patch on the color proof. 

6    If desired, choose Estimate Overprints to automatically estimate the overprint colors (MY, CY, CM, 
and CMY) using the CMYK and white values you entered. This is useful if you don’t have a proof.

7    Click OK.
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Converting to CMYK

To print a color separation, you convert an RGB, indexed-color, or Lab image to a CMYK image. 
(PostScript Level 2 color printers can interpret and print Lab images.) The conversion splits the RGB 
or Lab colors into the four colors commonly used for printing color separations: cyan, magenta, yellow,
and black.

Note the following when converting an image to CMYK:
•      Be sure to save a copy of your RGB or indexed color image in case you want to reconvert the 
image.
•      Avoid multiple conversions between RGB and CMYK mode, because each conversion requires 
color values be recalculated and rounded, resulting in less accurate color.
•      When converting color values from one mode to another, Photoshop uses the Lab color mode, 
which provides a system for defining color values in all modes. Using Lab ensures that colors are not 
visibly altered during conversion—other than the necessary remapping of colors to confine them to a 
reduced gamut. (See Color gamuts; L*a*b model.)

For example, when converting an RGB image to CMYK, Photoshop first converts the RGB color 
values to Lab mode using the information in the RGB Setup dialog box. Once the image is in CMYK 
mode, Photoshop converts the CMYK values back to RGB to display the image on an RGB monitor. 
•      The conversion from CMYK to RGB for screen display does not affect the actual data in the file. 
The conversion is performed on a copy of the data.

See also: 

Preparing for CMYK conversion 

Using color separation tables 
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Preparing for CMYK conversion

Photoshop lets you preview CMYK colors prior to making the conversion. You can also use the Gamut
Warning command in the View menu to check for and correct any out-of-gamut colors. (See 
Previewing CMYK colors and Identifying out-of-gamut colors.)
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Using color separation tables

The Tables option lets you do the following:
•      Save the CMYK setup from the built-in model as an ICC profile for use by other programs.
•      Load Photoshop 4.0 format separation tables.

To save the CMYK settings as an ICC profile:

1    Choose File > Color Settings > CMYK Setup.

2    Enter the settings you want. (See Entering CMYK setup information and Adjusting separation 
options.)

3    For CMYK Model, choose Tables.

4    Click Save. Select a location, and then name and save the new separation table. Then click OK.

To load a Photoshop 4.0 format separation table:

1    Choose File > Color Settings > CMYK Setup.

2    For CMYK Model, choose Tables.

3    Select Preview to display a preview of your changes.

4    Click Load.

5    Select the table you want to use, and click Open.

The name of the table appears in the CMYK Setup dialog box.

6    Click OK to use the table in CMYK conversions. The table settings will be used the next time you 
convert an image to CMYK.

Loading a separation table overrides any options in the CMYK Setup dialog boxes. To use the dialog 
box settings again, you must choose File > Color Settings > CMYK Setup, and select Built-in or ICC.
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Managing ICC profiles in files

To manage color effectively across systems and applications, it is important to embed (or tag) ICC 
profiles into files. The ICC profiles then indicate the correct color space for the file. When another ICC-
aware application opens a properly tagged image file, that application knows what if any color 
conversions are required.

The Profile Setup dialog box lets you specify how Photoshop uses ICC profiles when opening and 
saving files. This controls what color spaces are assumed when you exchange files between 
applications and devices.

The default settings for Profile Setup are designed to properly tag files in other applications and to 
correctly convert files from Photoshop 4.0 and earlier, which may have been created using a different 
color space than in Photoshop 5. As a result, entering Profile Setup information is optional, particularly
if you left the Profile Setup dialog box at its default settings.

Note: When opening files, you may see a status bar indicating that Photoshop is performing this 
conversion. This conversion generally happens the first time you open a file that is tagged with a 
different ICC profile.

The following information can help you in specifying Profile Setup options:
•      Embedding profiles increases the file size.
•      Embedding profiles provides color consistency when a file is opened in another application or on 
another system.
•      The Embed Profiles option affects how files are saved.
•      Assumed Profiles and Profile Mismatch handling options affect how files are opened.
•      File formats that support embedding include EPS, JPEG, PCT, PDF (only for RGB and Grayscale 
images), PSD, and TIFF.
•      Some applications require you to choose which profile to associate with a file when opening the 
file. To create an ICC profile for your RGB or CMYK settings, see the instructions about loading 
settings in Entering RGB setup information and Using color separation tables.

To specify how Photoshop should interact with ICC profiles:

1    Choose File > Color Settings > Profile Setup.

2    For Embed Profiles, select the types of files into which you want to embed ICC profiles: RGB, 
CMYK, Grayscale, Lab, or none at all. ICC profiles will then be embedded when you save those types 
of files.

Note: Deselecting the Embed Profiles option marks the file as intentionally untagged, which disables 
the assumed profile feature when the file is reopened. This will prevent the file from being converted 
each time you open it.

3    In the Assumed Profiles area, choose which ICC profiles to use to define the RGB, CMYK, and 
Grayscale color spaces to convert from when opening files that don’t contain an ICC profile.

For example, if an RGB image was previously saved in Photoshop 4.0 in Mac OS, choosing Monitor 
RGB here would open the image using the same RGB color space it used before. (This occurs 
because earlier versions of Photoshop edited images within your monitor’s color space.)

Note: This feature is disabled for images saved from Photoshop 4.0.

Choosing Ask When Opening displays a dialog box when opening a file that doesn’t have an 
embedded profile.

4    In the Profile Mismatch Handling area, choose whether to convert files being opened for which the 
embedded or assumed ICC profile does not match the profiles specified in the appropriate RGB 



Setup, Grayscale Setup, and CMYK Setup dialog boxes.

Choosing Ask When Opening displays a dialog box when opening a file whose embedded or assumed
profile doesn’t match the setting in the appropriate Setup dialog box.

Choosing Ignore ignores color information embedded in a file and opens the file with no color 
conversion.

Choosing Convert converts the image to the chosen color space as defined by the appropriate Setup 
dialog box.

Important: Adobe does not recommend automatically converting CMYK images to other color spaces,
because CMYK color space mismatches can cause color information (such as black generation, 
undercolor removal, and trapping) to be lost in the image. For CMYK, you should choose Ask When 
Opening, Convert to RGB Color, or Convert to Lab Color.

To open a file when the Profile Mismatch dialog box appears:

Do one of the following:
•      Click Don’t Convert to open the file without converting its color space.
•      Click cancel to close the file without converting its color space.
•      Apply the options described for the Profile to Profile command. (See Converting the color space of 
open images.) Then click Convert to convert the file’s color space.
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Converting the color space of open images

The Profile to Profile command lets you convert an open image from any color space to the color 
spaces defined in the RGB Setup, Grayscale Setup, and CMYK Setup dialog boxes. 

If you’ve changed one of the Setup dialog boxes, use this command to maintain accurate color on any 
open images. For example, if you’ve used the RGB Setup dialog box to change the RGB color space 
from sRGB to CIE RGB, you can select an open RGB image and use the Profile to Profile command 
to convert the image data from sRGB to CIE RGB.

The Profile to Profile command is also useful if you chose to ignore ICC profiles when opening files. 
You can then convert the open file to your native RGB space using this command.

Note: The Profile to Profile command can also convert an image to a color space that does not match 
the color settings in the RGB Setup or CMYK Setup dialog boxes. However, this is not usually 
recommended, because it can result in inaccurate on-screen displays and can embed the wrong 
profiles in saved files.

If you want to convert an image to an arbitrary color space, and you are aware of these issues, hold 
down the Alt (Windows) or Option (Macintosh) key when selecting Profile to Profile. The To option will 
then list all available ICC profiles.

To convert the color space of open images:

1    Select an open image.

2    Choose Image > Mode > Profile to Profile.

3    For From, choose the image’s color space.

4    For To, choose the color space to which you want to convert the image. Choosing RGB or CMYK 
will use the color space information defined in that RGB Setup or CMYK Setup dialog box.

5    For Engine, choose a CMM.

6    For Intent, choose a rendering intent. (SeeUsing ICC profiles to define the CMYK color space.)

7    If desired, choose Black Point Compensation to map the darkest neutral color of the images “From”
color space to the darkest neutral color of the images “To” color space rather than to black when 
converting colors.

8    Click OK.
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See also: 

Using the Adobe Photoshop color correction tools 

Comparing CMYK and RGB mode corrections 

Step 1: Calibrate your system 

Step 2: Check the scan quality and tonal range 

Step 3: Set the highlight and shadow values 

Step 4: Adjust the midtones and fine-tune the tonal correction 

Step 5: Adjust the color balance 

Step 6: Sharpen the image 

General-purpose color and tonal adjustment commands 

Special-purpose color adjustment commands 
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Using the Adobe Photoshop color correction tools

All Adobe Photoshop color correction tools work essentially the same way: by mapping existing ranges
of pixel values to new ranges of values. The difference between the tools is the amount of control you 
have.

For example, the Brightness/Contrast command makes the same adjustment to every pixel in the 
selection or image—if you increase the brightness value by 30, 30 is added to the brightness value of 
every pixel. On the other hand, two of the color adjustment tools are particularly useful because of the 
control and flexibility they provide. Levels allows you precise adjustments using three variables 
(highlights, shadows, and midtones). Curves replicates high-end color correction systems and lets you
isolate 16 ranges of pixel values between pure highlight and pure shadow.
 For finer control over color, convert your artwork to a 16-bit image as described in Converting between 

bit depths. When you finish making color adjustments, convert it back to an 8-bit image.

See also: 

Using color adjustment commands 

Previewing color adjustments 

Previewing color values 

Saving and loading color adjustment settings 
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Using color adjustment commands

You can use most color adjustment tools in three ways: applying them to one or more channels, to a 
regular layer, or to an adjustment layer. When you make color adjustments to a channel or a regular 
layer, you permanently alter the pixels on that layer.

With an adjustment layer, your color and tonal changes reside only within the adjustment layer and do 
not alter any pixels. The effect is as if you were viewing the visible layers through the adjustment layer 
above them. This lets you experiment with color and tonal adjustments without permanently altering 
pixels in the image. Adjustment layers are also the only way to affect multiple layers at once.

(See Using adjustment layers; Color channels; and Using Channels and Masks)

To open a color adjustment dialog box:

Do one of the following:
•      Choose Image > Adjust and choose the command you want from the submenu.
•      Hold down Ctrl (Windows) or Command (Mac OS), and click the New Layer button in the Layers 
palette. For type, choose the color adjustment command you want, and click OK.
•      Choose Layer > New > Adjustment Layer. For Type, choose the color adjustment command you 
want and click OK.
•      For an existing adjustment layer, double-click the adjustment layer name in the Layers palette.
 To cancel color changes without closing a color adjustment dialog box, hold down Alt (Windows) or 

Option (Mac OS) to change the Cancel button to the Reset button; click Reset. This action—like resetting 
an adjustment layer—resets the image to the default settings (except for the Posterize and Threshold 
commands). 
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Previewing color adjustments

When you make color changes to a selection, Photoshop usually displays the changes throughout the 
entire screen. This happens because the Preview option is selected and, by default, Photoshop does 
not use the video card’s color lookup table (VLUT) in response to your adjustments. Known as video 
table lookup, or color table animation, this process displays an immediate, but not always accurate, 
preview of changes. You can turn off color table animation to display an accurate preview of color 
adjustments to the selected area only.

The following guidelines apply when using color table animation:
•      The VLUT is off by default on Windows and is not available for most operations on Windows and 
Mac OS unless the monitor is set to 256 colors.
•      For color table animation to work in 24-bit mode with Windows, you must install a color table 
animation extension, supplied by your video card manufacturer, in the Plug-Ins directory. 
•      The color table animation feature can cause problems in Mac OS if you are using a 24-bit or 32-bit
video card for which certain color QuickDraw commands have not been properly implemented. If you 
have a problem, contact your video card manufacturer for ROM updates. You should also reset the 
video mode and turn off the Video LUT Animation option in the General Preferences dialog box. 

Image with Preview option off and on

To turn on previewing and deactivate color table animation:

Select the Preview option in any color correction dialog box. 

To turn off color table animation:

1    Choose File > Preferences > Display & Cursors.

2    Deselect Video LUT Animation, and click OK.

To reset the video mode in a Mac OS machine with a 24-bit or 32-bit video card, for previewing 
changes:

1    Choose Control Panels from the Apple menu, and double-click Monitors.

2    Click one of the other color display options (such as 256 Colors), and perform a preview to see the 
results.

3    Click your original color display option.

4    Close the Control Panel.

5    In Photoshop, choose File > Preferences > Display & Cursors, and deselect Video LUT Animation; 
then click OK.

You can still preview changes by clicking the Preview option, but clicking Preview will not turn the color
table animation off and on.
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Previewing color values

You can use the Color palette and the Info palette to preview the color values of pixels affected by 
color adjustments. 

When you work with a color adjustment dialog box, the Info palette displays two sets of color values 
for the pixels under the pointer. The value in the left column is the original pixel’s color value. The 
value in the right column is the color value after the adjustment is made.

You can view the color of a single area using the eyedropper tool, or you can use up to four color 
samplers to display color information for one or more locations in the image. These samplers are 
saved in the image, so you can refer to them repeatedly as you work, even if you close and reopen the
image.

Color samplers and Info palette

To view color samplers and color sampler information:

Select the eyedropper ( ) or color sampler (
) tool , or open a color adjustment dialog box.

To display or hide color sampler information in the Info palette:
•      Choose Show Color Samplers or Hide Color Samplers from the Info palette menu.

To place a color sampler:

Select the color sampler tool ( ), and click where you want to place it.

To set the area measured by the color sampler tool:

1    Select the color sampler tool ( ).
2    Choose Window > Show Options.
3    Choose what to sample:

•      Point Sample to read the value of a single pixel.
•      3 by 3 Average to read the average value of a 3-by-3 pixel area.
•      5 by 5 Average to read the average value of a 5-by-5 pixel area.

To delete a color sampler:

1    Select the color sampler tool ( ).
2    Delete the color sampler:



•      Drag the sampler out of the document window.
•      Hold down Alt (Windows) or Option (Mac OS), and click the sampler.

To move a color sampler:

1    Select the color sampler tool ( ).
2    Drag to the new location.

Note: The sampler does not move to the new location until you release the mouse button.

To change the color space in which a color sampler displays values:

1    Move the pointer onto the color sampler icon in the Info palette.

2    Hold down the mouse button and choose a color space from the menu.

To use the Info palette to preview color changes:

1    Choose Window > Show Info. (See To change the Info palette options for information on the Info 
palette display options.)

2    Place one or more color samplers if desired. As with the eyedropper tool, the color sampler reads a
1-by-1, 3-by-3, or 5-by-5 pixel area.

3    Open a color adjustment dialog box (See Using color adjustment commands).

4    Move the pointer over an area of the image you want to examine. The eyedropper reads the value 
of a single screen pixel, a 3-by-3 screen pixel area, or a 5-by-5 screen pixel area, depending on the 
Sample Size option chosen in the Eyedropper Options palette. (See Using the eyedropper tool.)

Note: Opening a color adjustment dialog box activates the eyedropper tool outside the dialog box. 
However, you still have access to the scroll controls and to the hand and zoom tools when using 
keyboard modifier keys.

5    Make any color adjustments, and before applying them, view the before and after color values in 
the Info palette.

To use the Color palette to preview color values: 

1    Choose Window > Show Color.

2    Select the eyedropper tool ( ).
3    Open a color adjustment dialog box (see Using color adjustment commands).
4    Click the pixel you want to preview in the image.
The color values of the pixel after the adjustment has been made are shown in the Color palette.
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Saving and loading color adjustment settings

The Save and Load buttons in the Levels, Curves, Selective Color, Replace Color, Hue/Saturation, 
and Variations dialog boxes let you save color corrections and apply them to other images.

To apply a color correction adjustment to another image: 

1    Click Save in the color correction dialog box you are using, and name and save the color correction
settings. 

2    Close the color correction dialog box, and open the image to which you want to apply the 
corrections. 

3    Reopen the color correction dialog box, and click Load. Locate and open the saved color correction
file.

4    Click OK to apply the corrections to the image.
 If you routinely apply the same color correction, consider recording and running the correction as an 

action.
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Comparing CMYK and RGB mode corrections

Even though you can perform all tonal and color corrections in either RGB or CMYK mode, you should
choose carefully.

Whenever possible avoid multiple conversions between modes, because color values are rounded 
and lost with each conversion. If an RGB image is to be used on-screen, you needn’t convert it to 
CMYK mode. Conversely, if a CMYK scan is to be separated and printed, you needn’t perform 
corrections in RGB mode.

But if you must convert your image from one mode to another anyway, it makes sense to perform most
of your tonal and color corrections in RGB mode and use CMYK mode for fine-tuning. Keep in mind 
the following advantages of working in RGB mode:
•      You save memory and improve performance.
•      You have more device independence, because RGB color spaces are not dependent on monitors 
or inks. Corrections made to the image are preserved regardless of the monitor, computer, or output 
device used. If any of these devices change, simply change the appropriate CMYK Setup options and 
then reconvert the RGB image to CMYK. 
•      With certain types of separations, you must work in RGB mode anyway. For example, if you 
separate an image using the Maximum Black Generation option in the CMYK Setup dialog box, it will 
be difficult, if not impossible, to make any corrections requiring a significant increase in the C, M, or Y 
components. To make these changes, you must reconvert the image to RGB, correct the color, and 
then reseparate the image—or you must reseparate the image with a lighter Black Generation option. 

See also: 

Previewing CMYK colors 

Identifying out-of-gamut colors 
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Previewing CMYK colors

When adjusting out-of-gamut colors or making color corrections in RGB mode, you can preview CMYK
colors in an RGB image.

To preview CMYK colors:

Choose View > Preview > CMYK, Cyan, Magenta, Yellow, Black, or CMY. (To return to the normal 
preview mode, reselect this option.)

CMYK equivalents for colors in the image are displayed using the current separation and calibration 
values in the CMYK Setup dialog boxes, but no permanent changes are made.
 Monitor CMYK colors as you edit in RGB mode by choosing View > New View to open a second 

window. Turn on CMYK Preview in one window and leave it off in the other. 
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Identifying out-of-gamut colors

The gamut is the range of colors that can be displayed or printed in a color system. A color that can be
displayed in RGB or HSB models may be out-of-gamut, and therefore unprintable, for your CMYK 
setting. (See Color gamuts.)

Photoshop automatically brings all colors into gamut when you convert an image to CMYK. But you 
might want to identify the out-of-gamut colors in an image or correct them manually before converting 
to CMYK. 

In RGB mode, you can identify out-of-gamut colors in the following ways:
•      In the Info palette, an exclamation point appears next to the CMYK values whenever you move the
pointer over an out-of-gamut color.
•      In both the Color Picker and the Color palette, an alert triangle appears and the closest CMYK 
equivalent is displayed whenever you select an out-of-gamut color. To select the CMYK equivalent, 
click the triangle or the color patch. 

Out-of-gamut color indicator

You can also quickly identify all out-of-gamut colors in an RGB image by using the Gamut Warning 
command. This command highlights all pixels that are out of gamut in the image.

To turn on and off the highlighting of out-of-gamut colors:

Choose View > Gamut Warning. 

To change the gamut warning color:

1    Choose File > Preferences > Transparency & Gamut.

2    Under Gamut Warning, click the color box to display the color picker; then choose a new warning 
color. 

3    Enter a value in the Opacity text box. Values can range from 0 to 100%. Use this setting to reveal 
more or less of the underlying image through the warning color. Then click OK. 

Original image, and preview of out-of-gamut colors 

Note: Because the gamut warning is generated using the current CMYK settings, be sure to fill in the 
CMYK Setup dialog box properly before following these out-of-gamut procedures. (See Calibrating the 



screen image to the proof and Adjusting separation options.)
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Step 1: Calibrate your system

The first, critical step before making a color or tonal adjustment to an image is to make sure that you 
have calibrated your system as described in Reproducing Color Accurately. Ohterwise, the image’s 
color on your screen can look vastly different from the same image when printed or when seen on 
another monitor.

If you are a color expert, you could print a full-color proof of each image whenever any element in your
environment changed (such as lighting) or whenever you adjusted the image’s color and tone. 
However, by calibrating you ensure that colors are reproduced more accurately on your system, 
saving you time and expense.
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Step 2: Check the scan quality and tonal range

It’s important to determine whether your image has sufficient detail to produce high-quality output. The
higher the number of pixels in an area, the greater the detail. Bad photographs or bad scans can be 
difficult if not impossible to correct. Too many color corrections can also result in loss of pixel values 
and too little detail. 
 If you save a copy or use adjustment layers, you can always revert to the original image. 

A histogram graphs the number of pixels at each brightness level in an image. It can show you 
whether an image contains enough detail to make a good correction. It also gives a quick picture of 
the tonal range of the image, or the image key type. A low-key image has detail concentrated in the 
shadows, a high-key one has detail concentrated in the highlights. An image with full tonal range has a
high number of pixels in all these areas. Identifying tonal range helps determine appropriate tonal 
corrections.

 A quick way to adjust an image that’s too dark is to move the white point to where the pixels begin, using the 
histogram in the Levels dialog box.

 To determine whether a scan captured enough detail for high-quality output, check the RGB pixel values of your 
highlight and shadow areas in the Info palette—generally, 240 and 10, respectively. The scan must also be free of 
large gaps within these ranges.

To check the histogram for an image: 

1    Open the image you want to examine, and choose Image > Histogram.

Note: To include pixel data from spot channels and alpha channels, hold Alt (Windows) or Option (Mac
OS) when you choose Image > Histogram. 

Histogram of gray levels in entire image

The x axis of the histogram represents the color values from darkest (0) at the far left to brightest (255)
at the far right; the y axis represents the total number of pixels with a given value. 

Note: If part of the image is selected, the histogram represents only the selected pixels. In addition, 
the histogram for an adjustment layer depends on the visibility of the layers beneath it.

The numerical values at the lower left of the Histogram dialog box display statistical information about 
the color values of the pixels:
•      Mean is the average brightness value. 
•      Standard deviation (Std Dev) represents how widely the values vary. 
•      Median shows the middle value in the range of color values. 
•      Pixels represents the total number of pixels used to calculate the histogram.
•      Cache Level shows the setting for the image cache. If the Use Cache for Histograms option is 
selected in the Memory & Image Cache Preferences dialog box, the histogram is based on a 
representative sampling of pixels in the image (based on the magnification), rather than on all of the 
pixels.

2    For RGB, CMYK, and indexed-color images, choose an option from the Channel menu. You can 



plot either the color values in the individual channels or the luminance of the composite channel (with 
the Luminosity option).

3    To view information about a specific point on the histogram, place the pointer there. To view 
information about a range of values, drag in the histogram to highlight the range.

The values at the lower right of the dialog box change to display the gray level (Level) of the point 
(from 0 to 255), the total number of pixels at that level (Count), and the percentage of pixels at or 
below that level (Percentile).

See also: 

Looking at the histogram 



Step 2: Check the scan quality and tonal range 

Looking at the histogram

The histogram shows how the pixels’ values are distributed in an image, and whether the image 
contains enough detail in the shadows (shown in the left part of the histogram), the midtones (shown 
in the middle), and the highlights (shown in the right) to produce a good correction.

Original with insufficient detail, and sufficient detail

Original, and corrected average-key image

Original, and corrected high-key image

Original, and corrected low-key image



Making Color and Tonal Adjustments 

Step 3: Set the highlight and shadow values

You begin professional tonal correction by assigning values to the extreme highlight and shadow 
pixels in the image, setting an overall tonal range that allows for the sharpest detail possible 
throughout the image. This process is known as setting the highlights and shadows or setting the 
white and black points. You can do this several ways.

See also: 

Determining highlight and shadow values 

Setting the highlights and shadows using target values 

Setting the highlights and shadows using the Levels sliders 

Setting the highlights and shadows automatically 



Step 3: Set the highlight and shadow values 

Determining highlight and shadow values

High-key and low-key images may benefit from slightly different target values than those suggested in 
Setting the highlights and shadows using target values:
•      With a low-key image, you might want to set the highlight to a lower value to avoid too much 
contrast.
•      With a high-key image, you might want to set the shadow to a higher value to maintain detail in the
highlights.

Experiment with shadow Brightness values between 4 and 20 and highlight Brightness values 
between 96 and 80.
 Use an adjustment layer for each color correction technique described in this section. Adjustment 

layers let you experiment with different color correction settings without permanently changing underlying 
pixel values. (See Using adjustment layers.)



Step 3: Set the highlight and shadow values 

Setting the highlights and shadows using target values

Professional color technicians typically set the highlights and shadows in the image by assigning their 
lightest and darkest CMYK ink values to the lightest and darkest areas of detail in the image.

It’s important to identify a truly representative highlight and shadow area. Otherwise the tonal range 
may be expanded unnecessarily to include extreme pixel values that don’t give the image detail. A 
highlight area must be a printable highlight, not specular white. Specular white has no detail, and so 
no ink is printed on the paper. For example, a spot of glare is specular white, not a printable highlight.

Selecting the specular highlight area and the representative highlight area

See also: 

To set the highlight and shadow using target values 

To use Threshold mode to identify the lightest and darkest areas in the image 



Setting the highlights and shadows using target values 

To set the highlight and shadow using target values:

1    Select and double-click the eyedropper tool ( ) to display its Options palette.
2    For Sample Size, choose 3 by 3 Average. 
The eyedropper displays the average value of each 3-by-3-screen-pixel area, ensuring a representative 
sample of an area rather than the value of a single screen-pixel.
3    Identify the highlight:

•      Open the Info palette, and move the pointer around the image to help identify the lightest neutral 
areas in the image. (See Previewing color values.) 
•      Use Threshold mode in the Levels dialog box to identify the highlight area in the image (see the 
procedure To use Threshold mode to identify the lightest and darkest areas in the image).
•      Open the Curves dialog box and drag the pointer in the image to identify the lightest and darkest 
areas. (See Using the Curves command.)

4    Open the Levels or Curves dialog box, as described in Using color adjustment commands.

5    Double-click the white eyedropper tool to display the color picker. In the color picker, enter the 
value that you want to assign to the highlight you identified in step 3, following these guidelines: 
•      In most situations when you are printing on white paper, you can achieve a good highlight in an 
average-key image using CMYK values of 5, 3, 3, and 0, respectively. 
•      The RGB equivalent is 244, 244, 244.
•      The grayscale equivalent is a 4% dot. 
•      You can reproduce these target values quickly by entering a value of 96% in the Brightness text 
box.

Important: If you have changed your monitor or separation setup values from their defaults, entering 
non-CMYK values will generate different values from those shown in this example. 

6    Click OK in the Color Picker dialog box when you’ve entered the values, and then click the highlight
area that you identified in step 3. If you accidentally click the wrong highlight, hold down Alt (Windows)
or Option (Mac OS), and click Reset in the dialog box.

The pixel values throughout the image are adjusted proportionately to the new highlight values. Any 
pixels lighter than the area you clicked become specular white. The Info palette shows the values both
before and after the color adjustment.

7    Use the Info palette to help identify a representative shadow area in the image. (Don’t click the 
area yet.) 

8    Double-click the black eyedropper tool in the Levels or Curves dialog box, and enter a target 
shadow value following these guidelines:
•      Typical when you’re printing on white paper. You can achieve a good shadow in an average-key 
image using CMYK values of 65, 53, 51, and 95. 
•      The RGB equivalent is 10, 10, 10.
•      The grayscale equivalent is a 96% dot.
•      You can reproduce these same values quickly by entering a value of 4 in the Brightness text box.

9    Click OK when you’ve entered the values. Then click the shadow area you identified in step 7. 



See also: 

To use Threshold mode to identify the lightest and darkest areas in the image 



Setting the highlights and shadows using target values 

To use Threshold mode to identify the lightest and darkest areas in the image:

1    Open the Levels dialog box (see Using color adjustment commands). Make sure that the Preview 
option is deselected.

The Levels dialog box displays a histogram of the image (unless it is an adjustment layer). (See Step 
2: Check the scan quality and tonal range.)

Note: On most systems running Windows, Threshold mode works only if the monitor is set to 256 
colors. The Video LUT Animation option in the General Preferences dialog box must be on for 
Threshold mode to work. (See Previewing color adjustments.)

2    Hold down Alt (Windows) or Option (Mac OS), and drag the white or black Input Levels triangle.

The image changes to Threshold mode, and a high-contrast preview image appears. The visible areas
of the image indicate the lightest parts of the image if you are dragging the white slider, and the 
darkest parts if you are dragging the black slider. If a color channel is selected in the Levels dialog 
box, the black area indicates where none of the given color component exists.

3    Slowly drag the slider to the center of the histogram to identify the light or dark areas in the image. 
Use these pixels for targeting the black point and white point in your image.

See also: 

To set the highlight and shadow using target values 



Step 3: Set the highlight and shadow values 

Setting the highlights and shadows using the Levels sliders

You can also set the highlights and shadows in an image by moving the Levels input sliders to the first
group of pixels on both ends of the histogram. Doing so maps these pixels—the darkest and lightest 
pixels in each channel—to black and white, increasing the tonal range of the image. The 
corresponding pixels in the other channels are adjusted proportionately to avoid altering the color 
balance.

Less exact than assigning target values or using the Curves dialog box, this method often gives good 
results, especially if you want to maintain a color cast in the highlights and shadows. (For more 
information, see Using the Curves command.)

In many images, eliminating the color cast is useful. But in other images, using the Levels sliders to 
set the highlights and shadows may produce better results precisely because it does not affect the 
color balance.

Contrast improved by setting highlights and shadows to neutral color values (color cast eliminated), and contrast 
improved by adjusting Levels sliders (color cast retained)

To set the highlights and shadows using the Levels sliders:

1    Open the Levels dialog box (see Using color adjustment commands).

The Levels dialog box displays a histogram of the image. (See Step 2: Check the scan quality and 
tonal range.)

2    If the image has more than one color channel, choose the channel (or channels) you want to adjust
from the Channel menu. (See Using the Channels palette.)

To edit a combination of color channels at the same time, Shift-select the channels in the Channels 
palette before choosing the Levels command. The Channel menu then displays the abbreviations for 
the target channels—for example, CM for cyan and magenta. The menu also contains the individual 
channels for the selected combination.

3    Drag the Input Levels sliders to the edge of the first group of pixels on either end of the histogram.

For example, suppose you want to increase the contrast in an image with pixels that currently cover a 
range of only 0–233. If you drag the Input Levels white triangle to 233, pixels with brightness values of 
233 and higher (in each channel of the image) are mapped to 255, pixels with lower brightness values 
are mapped to corresponding lighter values. This remapping lightens the image, increasing the 
contrast in highlight areas.

You can also enter values directly into the Input Levels text boxes.



Original

Resulting histogram

Suppose instead you want to decrease the contrast in the image. If you drag the Output Levels white 
triangle to 220, pixels with brightness values of 255 are remapped to 220, and pixels with lower 
brightness values are mapped to corresponding darker values. This darkens the image, decreasing 
the contrast in highlight areas.

You can also enter values directly into the Output Levels text boxes.

A. Decreases shadows    B. Decreases highlights

4    If your image also needs midtone corrections, you can set them now with the Levels dialog box. Do
this before applying the levels changes. (See Adjusting the midtones using the Levels sliders.)

5    Click OK.

6    To view the new histogram, reopen the Levels dialog box. The histogram has been stretched out to
accommodate the new white and black points, causing gaps in the histogram. 

These gaps do not indicate a perceptible problem in the image unless they are large or accompanied 
by a low pixel count.



Step 3: Set the highlight and shadow values 

Setting the highlights and shadows automatically

The Auto Levels command and Auto buttons in the Levels and Curves dialog boxes perform 
automatically the equivalent of the Levels slider adjustment: they define the lightest and darkest pixels 
in each channel as white and black and then redistribute the intermediate pixel values proportionately. 

By default, the Auto feature clips the white and black pixels by 0.5%—that is, it ignores the first 0.5% 
of either extreme when identifying the lightest and darkest pixels in the image. This clipping of color 
values ensures that white and black values are based on representative rather than extreme pixel 
values.

The Auto feature gives good results when an image with an average distribution of pixel values needs 
a simple contrast adjustment. However, adjusting the Levels or Curves controls manually is more 
precise. (See Setting the highlights and shadows using the Levels sliders, and Using the Curves 
command.)

To set the black and white points automatically:

1    Do one of the following:
•      Choose Image > Adjust > Auto Levels.
•      Open the Levels or Curves dialog box, as described in Using color adjustment commands, and 
then click Auto. 

To change the amount of white and black values clipped:

1    Hold down Alt (Windows) or Option (Mac OS), and click Options in the Levels or Curves dialog box.

2    In the Auto Range dialog box, enter the percentage of extreme highlight and shadow pixels to 
ignore, and click OK. A value between 0.5% and 1% is recommended.



Making Color and Tonal Adjustments 

Step 4: Adjust the midtones and fine-tune the tonal correction

Once you have set the highlights and shadows, you may want to fine-tune the contrast. This step is 
usually not necessary with average-key images. Setting the highlights and shadows typically 
redistributes the midtone pixel values appropriately. But when pixel values are concentrated on either 
end of the grayscale, the midtones often need adjustment.

You can use the gray eyedropper button in the Levels or Curves dialog box to eliminate color casts in 
the midtones. But for precise control over midtone adjustments, use the Levels midtone slider or 
Curves. (See Setting the highlights and shadows using target values for a description of how the 
eyedropper buttons work.)

See also: 

Adjusting the midtones using the Levels sliders 

Using the Curves command 



Step 4: Adjust the midtones and fine-tune the tonal correction 

Adjusting the midtones using the Levels sliders

The Levels sliders let you gradually adjust the brightness, contrast, and midtones in an image. By 
adjusting the midtones, you can change the brightness values of the middle range of gray tones 
without dramatically altering the shadows and highlights.

To use the Levels sliders:

1    Open the Levels dialog box (see Using color adjustment commands).

The Levels dialog box displays a histogram of the image. (See Step 2: Check the scan quality and 
tonal range.)

2    If you’re working in an image with more than one color channel, choose the channel (or channels) 
you want to adjust from the Channel menu. (See Using the Channels palette.) 

To edit a combination of color channels at the same time, Shift-select the channels in the Channels 
palette before choosing the Levels command. The Channel menu then displays the abbreviations for 
the target channels—for example, CM for cyan and magenta. The menu also contains the individual 
channels for the selected combination. 

3    Select Preview to see your changes as you drag the Levels sliders.

4    To adjust the midtones, use the gray slider directly under the histogram. Drag the slider to the right 
to darken the midtones, drag it to the left to lighten the midtones. You can also enter values directly in 
the Input Levels text boxes, using the center text boxes for midtones.

Adjusts gamma or gray levels

5    Click OK.



Step 4: Adjust the midtones and fine-tune the tonal correction 

Using the Curves command

Like Levels, Curves lets you adjust the tonal range of an image. However, instead of making the 
adjustments using just three variables (highlights, shadows, and midtones), you can adjust any point 
along the 0–255 scale while keeping up to 15 other values constant.

You can also use the Arbitrary Map option in the Curves dialog box to draw a tonal curve by dragging. 
This feature lets you create a variety of interesting tonal and color effects.

Using curves for tonal adjustments

Curves lets you make precise adjustments to one area of the tonal range while controlling the effect 
on the others. The first curve shown here is a common curve adjustment used to boost contrast in a 
CMYK scan: the S-curve. The midpoint of the curve is anchored, then the quartertones are decreased 
to lighten the highlights, and the three-quartertones are increased to darken the shadows. The inverse
of this curve could be used to correct an image with too much contrast. The final two curves 
demonstrate other typical tonal adjustments in CMYK mode.
Flat image 
Light image 
Dark image 

See also: 

To use the Curves dialog box 

To use the Arbitrary Map option in the Curves dialog box 



Using the Curves command 

To use the Curves dialog box:

1    Open the Curves dialog box (see Using color adjustment commands).

A. Highlights    B. Midtones    C. Shadows

The horizontal axis of the graph represents the original brightness values of the pixels (Input levels); 
the vertical axis represents the new brightness values (Output levels). In the default diagonal line, no 
pixels have been mapped to new values, so all pixels have identical Input and Output values.

Note: For RGB images, Curves displays brightness values from 0 to 255, with shadows (0) on the left.
For CMYK images, Curves displays percentages from 0 to 100, with highlights (0) on the left. To 
reverse the curve and change the display at any time, click the double arrow beneath the curve.

2    If the image has more than one color channel, choose the channel (or channels) you want to adjust
from the Channel menu.

To edit a combination of color channels at the same time, Shift-select the channels in the Channels 
palette before choosing the Curves command. The Channel menu then displays the abbreviations for 
the target channels—for example, CM for cyan and magenta. The menu also contains the individual 
channels for the selected combination. 

For more information on choosing channels, see Using the Channels palette.

3    To make the Curves grid finer, hold down Alt (Windows) or Option (Mac OS), and click the grid. 
Alt/Option-click again to make the grid larger.

4    Click the part of the curve you want to adjust.

A set of direction arrows marks the pixel’s position on the graph, and the Input and Output values 
appear at the bottom of the dialog box.



Clicking in the image displays the pixel values and location on the curve.
 Drag through the image to determine the lightest and darkest areas in the composite channel of an 

RGB, Lab, or grayscale image, or in individual channels of all images. This is particularly useful in 
Windows when the threshold function in Levels is unavailable.

5    Click any points on the curve that you want to remain fixed. For example, if you want to adjust the 
midtones while minimizing the effect on the highlights and shadows, click the quarter and three-
quarter points on the curve.

You can add up to 14 points to the curve, locking those values. To remove a fixed point, drag it off the 
graph; select it and press Delete; or Ctrl-click (Windows) or Command-click (Mac OS) it. You cannot 
delete the endpoints of the curve.

6    Adjust the curve:
•      Drag the curve until the image looks as you want it. 
•      Enter an Input and Output value for the selected point on the curve.

Click to fix a point on the curve. Click and drag to adjust.

The gamma of any curve is its slope, expressed as the ratio of the logs of the output to input values. 
For example, a gamma value of 1.0 equals an output-to-input ratio of 1:1. Moving the midpoint of the 
curve up (in an RGB readout) lowers the gamma value (that is, to less than 1.0); moving the midpoint 
down raises the gamma value. (This is the same as moving the gamma Levels slider to the right to 
lower the gamma level, left to raise it.)

The following shortcuts work with the Curves dialog box:
•      Ctrl-click (Windows) or Command-click (Mac OS) in the image to set a point on the curve for the 
selected color in the composite channel (but not in the component channels).
•      Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) in the image to set a point on the 
curve for the selected color in each color component channel (but not in the composite channel).
•      Arrow keys to move points on the curve.
•      Shift-click to select multiple points.
•      Ctrl+Tab (Windows) or Command+Tab to move forward through control points on the curve.



•      Shift+Ctrl+Tab (Windows) or Shift+Command+Tab to move backward through control points on the
curve.
•      Ctrl-click (Windows) or Command-click (Mac OS) in the grid to deselect all points on the curve.
•      Ctrl-D (Windows) or Command-D (Mac OS) in the grid to deselect all control points on the curve.

See also: 

To use the Arbitrary Map option in the Curves dialog box 



Using the Curves command 

To use the Arbitrary Map option in the Curves dialog box:

1    Click the pencil at the bottom of the Curves dialog box. 

2    Drag to draw the curve you want in the Curves graph area.

The pencil pointer appears when you move into the graph. To constrain the curve to a straight line, 
hold down Shift, and click to define the endpoints of the curve. For example, you can create an image 
negative by holding down Shift and clicking the upper left and then the lower right corner of the graph.

3    If desired, click Smooth to smooth the curve.

See also: 

To use the Curves dialog box 



Making Color and Tonal Adjustments 

Step 5: Adjust the color balance

With the tonal correction complete, you can accurately examine and diagnose any problems with color
in the image—a color cast, oversaturated or undersaturated colors. 

Once again, although you can use the Levels command, Curves offers the most precise control over 
pixel distribution within a channel. The commands Hue/Saturation, Replace Color, and Selective Color
offer additional control over specific color components and attributes. 

See also: 

Adjusting color balance 

Using the Color Balance command 

Using the Hue/Saturation command 

Using the Replace Color command 

Using the Selective Color command 



Step 5: Adjust the color balance 

Adjusting color balance

Every color adjustment affects the overall color balance in your image. You have numerous ways to 
achieve similar effects, so determining which adjustment is appropriate depends on the image and on 
the desired effect.

It helps to keep a diagram of the color wheel on hand if you’re new to adjusting color components. You
can use the color wheel to predict how a change in one color component affects other colors and also 
how changes translate between RGB and CMYK color models. For example, you can decrease the 
amount of any color in an image by increasing the amount of its opposite on the color wheel—and vice
versa. Similarly, you can increase and decrease a color by adjusting the two adjacent colors on the 
wheel, or even by adjusting the two colors adjacent to its opposite. 

A. Green    B. Yellow    C. Red    D. Magenta    E. Blue    F. Cyan

For example, in a CMYK image you can decrease magenta either by decreasing the amount of 
magenta or its proportion (by adding cyan and yellow). You can even combine these two corrections, 
minimizing their effect on overall lightness. In an RGB image, you can decrease magenta by removing
red and blue or by adding green. All of these adjustments result in an overall color balance containing 
less magenta.



Step 5: Adjust the color balance 

Using the Color Balance command

The Color Balance command lets you change the mixture of colors in a color image. Like the 
Brightness/Contrast command, this tool provides generalized color correction. For precise control over
individual color components, use Levels, Curves, or one of the specialized color correction tools: 
Hue/Saturation, Replace Color, or Selective Color.

Note: You can also change the mixture of colors with the Channel Mixer command. (See Mixing 
channels.)

To adjust the levels of a particular color in an image: 

1    Open the Color Balance dialog box, as described in Using color adjustment commands. 

Note: You must be viewing the composite channel to use the Color Balance command. (See Using the 
Channels palette.)

2    Choose Shadows, Midtones, or Highlights to select the tonal range on which you want to focus the 
changes. 

3    With RGB images, select Preserve Luminosity to prevent changing the luminosity values in the 
image while changing the color. This option maintains the tonal balance in the image.

4    Drag a triangle toward a color you want to increase in the image; drag a triangle away from a color 
you want to decrease in the image.

The values above the color bars show the color changes for the red, green, and blue channels. (For 
Lab images, the values are for the a and b channels.) Values can range from –100 to +100.

Original image with greenish cast, and magenta/green level adjusted in midtones



Step 5: Adjust the color balance 

Using the Hue/Saturation command

The Hue/Saturation command lets you adjust the hue, saturation, and lightness of individual color 
components in an image. Like the Color Balance command, this command relies on the color wheel. 
Adjusting the hue, or color, represents a move around the color wheel. Adjusting the saturation, or 
purity of the color, represents a move across its radius. 

You can also use the Colorize option to add color to a grayscale image converted to RGB, or to an 
RGB image—for example, to make it look like a duotone image by reducing its color values to one 
hue.

A. Saturation    B. Hue    C. Brightness    D. All hues

See also: 

To adjust an image using Hue/Saturation 

To modify the range of an adjustment slider 

To colorize a grayscale image or create a monotone effect 



Using the Hue/Saturation command 

To adjust an image using Hue/Saturation: 

1    Open the Hue/Saturation dialog box, as described in Using color adjustment commands. 

A. Adjusts fall off without affecting range    B. Adjusts range without affecting fall off    C. Moves entire slider    D. 
Adjusts range of color component

Two color bars are displayed in the dialog box. These bars represent the colors in their order on the 
color wheel.

The upper color bar shows the color before the adjustment; the lower bar shows how the adjustment 
affects all of the hues at full saturation. 

2    Choose which colors to adjust:
•      Choose Master from the Edit menu in the dialog box to adjust all colors at once. 
•      Choose one of the other preset color ranges listed for the color you want to adjust. An adjustment 
slider appears between the color bars, which you can use to edit any range of hues. (For information 
on how to modify the slider’s range, see the instructions later in this section.)

3    For Hue, enter a value or drag the slider until the colors appear as you want.

The values displayed in the text box reflect the number of degrees of rotation around the wheel from 
the pixel’s original color. A positive value indicates clockwise rotation, a negative value 
counterclockwise rotation. Values can range from -180 to +180.

4    For Saturation, enter a value or drag the slider to the right to increase the saturation, left to 
decrease it. The color shifts away from or toward the center of the wheel, relative to the beginning 
color values of the selected pixels. Values can range from -100 to +100.

Original image, and Saturation: –40

5    For Lightness, enter a value or drag the slider to the right to increase the lightness, left to decrease
it. Values can range from –100 to +100.



See also: 

To modify the range of an adjustment slider 

To colorize a grayscale image or create a monotone effect 



Using the Hue/Saturation command 

To modify the range of an adjustment slider:

1    Choose an individual color from the Edit menu in the dialog box:

2    Do any of the following to the adjustment slider:
•      Drag the dark gray, center part to move the entire adjustment slider, selecting a different color 
area.
•      Drag one of the vertical white bars next to the dark gray, center part to adjust the range of the color
component. Increasing the range decreases the fall off, and vice versa.
•      Drag one of the lighter gray bars to adjust the range without affecting the amount of fall off.
•      Drag one of the white triangles to adjust the amount of fall off, without affecting the range.
•      Ctrl-drag (Windows) or Command-drag (Mac OS) to drag the color bar, so that a different color is 
in the center of the bar.

If you modify the adjustment slider so that it falls into a different color range, the name changes to 
reflect this. For example, if you choose Yellow and alter its range so that it falls in the red part of the 
color bar, the name changes to Red 2. You can convert up to six of the individual color ranges to 
varieties of the same color range (for example, Red through Red 6).

Note: By default, the range of color selected when you choose a color component is 30° wide, with 
30° of fall off on either side. Setting the fall off too low can produce dithering in the image.

3    To edit the range by choosing colors from the image, select the eyedropper tool ( ) in the dialog 
box and click in the image. Use the eyedropper + tool to add to the range; use the eyedropper - tool to
subtract from the range. (While the eyedropper tool is selected, you can also press Shift to add to the 
range or Alt (Windows) or Option (Mac OS) to subtract.)

Original image, and with cyan hue adjusted

See also: 

To adjust an image using Hue/Saturation 

To colorize a grayscale image or create a monotone effect 



Using the Hue/Saturation command 

To colorize a grayscale image or create a monotone effect: 

1    If you are colorizing a grayscale image, choose Image > Mode > RGB to convert the image to 
RGB.

2    Open the Hue/Saturation dialog box, as described in Using color adjustment commands.

3    Select Colorize. The image is converted to the hue of the current foreground color. The lightness 
value of each pixel does not change.

4    Use the Hue slider to select a new color if desired. 

5    Use the Saturation and Lightness sliders to adjust the saturation and lightness of the pixels. Then 
click OK. 

Original image, and colorized (Hue: 108, Saturation: 22)

See also: 

To adjust an image using Hue/Saturation 

To modify the range of an adjustment slider 



Step 5: Adjust the color balance 

Using the Replace Color command

The Replace Color command lets you create a mask based on specific colors in the image to adjust 
hue, saturation, and lightness values. The mask is temporary and does not create a selection. 

Original image, and with colors replaced

To adjust and replace a color:

1    Choose Image > Adjust > Replace Color.

2    Choose from the following options:
•      Selection to display the mask in the preview box. Masked areas are black and unmasked areas 
are white. Partially masked areas (areas covered with a semitransparent mask) appear as varying 
levels of gray according to their opacity. For more information, see About masks.
•      Image to display the image in the preview box. This option is useful when you are working with a 
magnified image or have limited screen space.

3    Click in the image or in the preview box to select areas for the mask. Shift-click or use the 
Eyedropper + button to add areas; Alt-click (Windows), Option-click (Mac OS), or use the Eyedropper -
button to remove areas.

Color changed to mask

4    Adjust the tolerance of the mask by using the slider or by entering a Fuzziness value. This option 
controls the degree to which related colors are included in the selection.

5    Drag the hue, saturation, and lightness sliders (or enter values in the text boxes) to change the 
color of the selected areas. 

6    Click OK to replace the color.



Step 5: Adjust the color balance 

Using the Selective Color command

Like the other color correction tools, the Selective Color command lets you correct imbalances and 
adjust colors. Selective color correction is a technique used by high-end scanners and separation 
programs to increase and decrease the amount of the process colors in each of the additive and 
subtractive primary color components in an image. 

Selective color correction is based on a table that shows the amount of each process ink used to 
create each primary color. By increasing and decreasing the amount of a process ink in relation to the 
other process inks, you can modify the amount of a process color in any primary color selectively—
without affecting any other primary colors. For example, you can use selective color correction to 
dramatically decrease the cyan in the green component of an image while leaving the cyan in the blue 
component unaltered.

Note: You must be viewing the composite channel to use the Selective Color command. (See Using 
the Channels palette.)

To use the Selective Color command:

1    Open the Selective Color dialog box, as described in Using color adjustment commands.

2    Choose the color you want to adjust from the Colors menu at the top of the dialog box. Color sets 
consist of the primary additive and subtractive colors plus whites, neutrals, and blacks.

3    For Method, select an option:
•      Relative to change the existing amount of cyan, magenta, yellow, or black by its percentage of the 
total. For example, if you start with a pixel that is 50% magenta and add 10%, 5% is added to the 
magenta (10% of 50% = 5%) for a total of 55% magenta. (This option cannot adjust pure specular 
white, which contains no color components.) 
•      Absolute to adjust the color in absolute values. For example, if you start with a pixel that is 50% 
magenta and add 10%, the magenta ink is set to a total of 60%. 

Note: The adjustment is based on how close a color is to one of the indicated correction points. For 
example, a pixel that contains 50% magenta is not at any exact correction point, and so will get a mix 
of corrections. 

4    Drag the sliders to increase or decrease the components in the selected color.
 Use the Info palette to show before and after color values.



Making Color and Tonal Adjustments 

Step 6: Sharpen the image

Unsharp masking, or USM, is a traditional film compositing technique used to sharpen edges in an 
image. The Unsharp Mask filter corrects blurring introduced during photographing, scanning, 
resampling, or printing. It is useful for images intended both for print and online.

Numbers represent Unsharp Mask amount, Radius, and Threshold.

The Unsharp Mask filter locates pixels that differ from surrounding pixels by the threshold you specify 
and increases the pixels’ contrast by the amount you specify. In addition, you specify the radius of the 
region to which each pixel is compared.

The effects of the Unsharp Mask filter are far more pronounced on-screen than in high-resolution 
output. If your final destination is print, experiment to determine what dialog box settings work best for 
your image.

To sharpen an image using the Unsharp Mask filter: 

1    Choose Filter > Sharpen > Unsharp Mask. 

2    Sharpen the image:
•      For Amount, drag the slider or enter a value to determine how much to increase the contrast of 
pixels. For high-resolution printed images, an amount between 150% and 200% is recommended. 
•      For Radius, drag the slider or enter a value to determine the number of pixels surrounding the 
edge pixels that affects the sharpening. For high-resolution images, a Radius between 1 and 2 is 
recommended.

A lower value sharpens only the edge pixels, whereas a higher value sharpens a wider band of pixels. 
This effect is much less noticeable in print than on-screen, because a 2-pixel radius represents a 
smaller area in a high-resolution printed image. 
•      For Threshold, drag the slider or enter a value to determine how different the sharpened pixels 
must be from the surrounding area before they are considered edge pixels and sharpened by the filter.



To avoid introducing noise (in images with fleshtones, for example), experiment with Threshold values 
between 2 and 20. The default Threshold value (0) sharpens all pixels in the image.
 If applying the Unsharp Mask filter makes already bright colors appear overly saturated, convert the 

image to Lab mode and apply the filter to the L channel only. This technique sharpens the image without 
affecting the color components.



Making Color and Tonal Adjustments 

General-purpose color and tonal adjustment commands

The Variations and Brightness/Contrast commands change colors or brightness values in an image 
but are not as precise or flexible as the high-end color adjustment commands described in the 
previous sections. They provide a simple way to make fast overall adjustment to an image.

See also: 

Using the Variations command 

Using the Brightness/Contrast command 



General-purpose color and tonal adjustment commands 

Using the Variations command

The Variations command lets you visually adjust the color balance, contrast, and saturation of an 
image or selection. This command is most useful for average-key images that don’t require precise 
color adjustments. It does not work on indexed-color images.

To use the Variations command:

1    Open the Variations dialog box, as described in Using color adjustment commands.

Note: If the Variations command does not appear in the Adjust submenu, the Variations plug-in 
module may not have been installed. (See Using plug-in modules.)

The two thumbnails at the top of the dialog box show the original selection (Original) and the selection 
with its currently selected adjustments (Current Pick). When you first open the dialog box, these two 
images are the same. As you make adjustments, the Current Pick image changes to reflect your 
choices.

2    Select any of these adjustments:
•      Show Clipping to display a neon preview of areas in the image that will be clipped by the 
adjustment—that is, converted to pure white or pure black. Clipping does not occur when you adjust 
midtones. 

Note: Clipping is not the same as out-of-gamut colors.
•      Shadows, Midtones, or Highlights to indicate whether you want to adjust the dark, middle, or light 
areas.
•      Saturation to change the degree of hue in the image. With the Show Clipping option selected, the 
image may show clipping after an adjustment. This means you have exceeded maximum saturation 
for the color.
•      The Fine/Coarse slider to determine the amount of each adjustment. Moving the slider one tick 
mark doubles the adjustment amount. 

3    Adjust the color and brightness:
•      To add a color to the image, click the appropriate color thumbnail. 
•      To subtract a color, click its opposite on the color wheel (see Adjusting color balance). For 
example, to subtract cyan, click red.

4    Click the thumbnails on the right of the dialog box to adjust the brightness in the image. 

Each time you click a thumbnail, all thumbnails change. The center thumbnail always reflects the 
current choices. 



General-purpose color and tonal adjustment commands 

Using the Brightness/Contrast command

Using the Brightness/Contrast command is the easiest way to make simple adjustments to the tonal 
range of the image. Unlike Curves and Levels, this command adjusts all pixel values in the image at 
once—highlights, shadows, and midtones. In addition, the Brightness/Contrast command does not 
work with individual channels and is not recommended for high-end output. 

To use the Brightness/Contrast dialog box: 

1    Open the Brightness/Contrast dialog box, as described in Using color adjustment commands. 

2    Drag the sliders to adjust the brightness and contrast.

Dragging to the left decreases the level and to the right increases it. The number at the right of each 
slider value displays the brightness or contrast value. Values can range from –100 to +100. 

3    When you’ve finished making adjustments, click OK.



Making Color and Tonal Adjustments 

Special-purpose color adjustment commands

The Invert, Equalize, Threshold, Posterize, and Desaturate commands also change colors or 
brightness values in an image but are typically used for enhancing color and producing special effects,
rather than for correcting color. 

Note: You can also make color adjustments with the Channel Mixer command. (See Mixing channels.)

See also: 

Using the Invert command 

Using the Equalize command 

Using the Threshold command 

Using the Posterize command 

Using the Desaturate command 



Special-purpose color adjustment commands 

Using the Invert command 

The Invert command inverts an image. You might use this command to make a positive black-and-
white image negative or to make a positive from a scanned black-and-white negative. 

Note: Because color film contains an orange mask in its base, the Invert command cannot make 
negatives and positives from scanned color film.

When you invert an image, the brightness value of each pixel in the channels is converted to the 
inverse value on the 256-step color-values scale. For example, a pixel in a positive image with a value
of 255 is changed to 0, and a pixel with a value of 5 to 250.

To invert an image:

Choose Image > Adjust > Invert.

Original image, and Invert command applied



Special-purpose color adjustment commands 

Using the Equalize command

The Equalize command redistributes the brightness values of the pixels in an image so that they more 
evenly represent the entire range of brightness levels. When you choose this command, Photoshop 
finds the brightest and darkest values in the image so that the darkest value represents black (or as 
close to it as possible) and the brightest value represents white. Photoshop then attempts to equalize 
the brightness—that is, to distribute the intermediate pixel values evenly throughout the grayscale. 

You might use this command when a scanned image appears darker than the original and you want to
balance the values to produce a lighter image. Using the Equalize command together with the 
Histogram command lets you see before-and-after brightness comparisons.

To equalize the brightness values of pixels: 

1    Choose Image > Adjust > Equalize. 

2    If you selected an area of the image, in the Equalize dialog box select what to equalize:.
•      Equalize Selected Area Only to distribute evenly only the selection’s pixels.
•      Equalize Entire Image Based on Selected Area to distribute evenly all image pixels based on 
those in the selection. 

3    Click OK to equalize the image or the selection.

Original image, and Equalize command applied



Special-purpose color adjustment commands 

Using the Threshold command

Use the Threshold command to convert grayscale or color images to high-contrast, black-and-white 
images. This command lets you specify a certain level as a threshold. All pixels lighter than the 
threshold are converted to white and all pixels darker to black.

To use the Threshold command: 

1    Open the Threshold dialog box, as described in Using color adjustment commands.

The Threshold dialog box displays a histogram of the luminance levels of the pixels in the current 
selection.

2    Drag the slider below the histogram until the threshold level you want appears at the top of the 
dialog box. As you drag, the image changes to reflect the new threshold setting.

Original image, and Threshold command applied: 170



Special-purpose color adjustment commands 

Using the Posterize command

The Posterize command lets you specify the number of tonal levels (or brightness values) for each 
channel in an image and then maps pixels to the closest matching level. For example, choosing two 
tonal levels in an RGB image gives six colors, two for red, two for green, and two for blue.

This command is useful for creating special effects, such as large, flat areas in a photograph. Its 
effects are most evident when you reduce the number of gray levels in a grayscale image. But it also 
produces interesting effects in color images.
 If you want a specific number of colors in your image, convert the image to grayscale and specify the 

number of levels you want. Then convert the image back to the previous color mode, and replace the 
various gray tones with the colors you want.

To specify the number of levels in an image:

1    Open the Posterize dialog box, as described in Using color adjustment commands. 

2    Enter the number of levels you want, and click OK.

Original image, and Posterize command applied: 2 levels of color



Special-purpose color adjustment commands 

Using the Desaturate command 

The Desaturate command removes all color values from a color image, converting it to a grayscale 
image in the same color mode.

To desaturate an image:

Choose Image > Adjust > Desaturate.



Selecting

See also: 

Making selections 

Adjusting selections 

Softening the edges of a selection 

Creating and using paths 

Drawing freehand paths 

Drawing with the pen tool 

Adjusting path segments 

Moving and copying paths 

Filling and stroking paths 

Converting between paths and selection borders 



Selecting 

Making selections

You make selections by clicking and dragging with the marquee, lasso, polygon lasso, or magnetic 
lasso tool, or by targeting color areas with the magic wand tool or the Color Range command. The 
choices associated with a selection tool appear in its Options palette. Making a new selection replaces
the existing one.

Key selected

To select all pixels on a layer within the canvas boundaries:

1    Select the layer in the Layers palette, as explained in Using the Layers palette.

2    Choose Select > All. 

To deselect selections:

Do one of the following:
•      Choose Select > Deselect. 
•      If you are using the rectangular marquee, elliptical marquee, or lasso tool, click anywhere in the 
image outside the selected area.

To reselect the most recent selection:

Choose Select > Reselect.

Photoshop reloads the last selection you deselected in the active image. 

See also: 

Using the marquee tools 

Using the lasso, polygon lasso, and magnetic lasso tools 

Using the magic wand tool 

Using the Color Range command 



Making selections 

Using the marquee tools

The marquee tools let you select rectangular or elliptical areas. By default, the selection border is 
dragged from its corner.

Rectangular and elliptical selections 

To use the marquee tools:

1    Select and double-click one of the following marquee tools to display its Options palette:
•      Rectangular marquee ( ) to make a rectangular selection. 

•      Elliptical marquee ( ) to make an elliptical selection.
•      Single row ( ) or single column (
) marquee to define the border as a 1-pixel-wide row or column. 

2    In the Marquee Options palette, specify feathering and anti-aliasing settings. (You cannot select 
anti-aliasing for the rectangular marquee tool.) (See Softening the edges of a selection.)

3    For the rectangular or elliptical marquee, choose an option for Style in the Marquee Options 
palette:
•      Normal to determine marquee proportions by dragging. 
•      Constrained Aspect Ratio to set a height-to-width ratio. Enter the values (including decimal values)
for the aspect ratio. For example, to draw a marquee twice as wide as it is high, enter 2 for the width 
and 1 for the height. 
•      Fixed Size to specify set values for the marquee’s height and width. Enter pixel values in whole 
numbers. Keep in mind that the number of pixels needed to create a 1-inch selection depends on the 
resolution of the image. (See About image size and resolution.)

4    To make a selection, do one of the following:
•      With the rectangular or elliptical marquee, drag over the area you want to select. Hold down Shift 
as you drag to constrain the marquee to a square or circle. To drag a marquee from its center, hold 
down Alt (Windows) or Option (Mac OS) after you begin dragging.

Dragging from corner and from center
•      With the Single Row or Single Column marquee, click near the area you want to select, and then 
drag the marquee to the exact location. If no marquee is visible, increase the magnification of your 
image view.
 To reposition a rectangular or elliptical marquee, first drag to create the border, keeping the mouse 



button depressed; then hold down the spacebar, and continue to drag. If you have finished drawing the 
border, click inside the selection; then drag it where you want.



Making selections 

Using the lasso, polygon lasso, and magnetic lasso tools

The lasso and polygon lasso tools let you draw both straight-edged and freehand segments of a 
selection border. With the magnetic lasso tool, the border snaps to the edges of defined areas in the 
image. The magnetic lasso tool is especially useful for quickly selecting objects with complex edges 
set against high-contrast backgrounds.

To use the lasso tool:

1    Select and double-click the lasso tool ( ) to display its Options palette, and select options as 
described in the procedure To set options for the lasso, polygon lasso, and magnetic lasso tools.

2    Drag to draw a freehand selection border. 

Freehand selection with lasso tool

3    To draw a straight-edged selection border, hold down Alt (Windows) or Option (Mac OS), and click 
where segments should begin and end. You can switch between drawing freehand and straight-edged 
segments. 

4    To erase recently drawn segments, hold down Delete until you’ve erased the desired segment.

5    To close the selection border, release the mouse without holding down Alt/Option.

See also: 

To use the polygon lasso tool 

To use the magnetic lasso tool 

To set options for the lasso, polygon lasso, and magnetic lasso tools 



Using the lasso, polygon lasso, and magnetic lasso tools 

To use the polygon lasso tool:

1    Select and double-click the polygon lasso tool ( ) to display its Options palette, and select options
as described in the procedure To set options for the lasso, polygon lasso, and magnetic lasso tools. 

2    Click in the image to set the starting point.
3    To draw a straight segment, position the pointer where you want the first straight segment to end, and 
click. Continue clicking to set endpoints for subsequent segments.

Click to add straight segments.

4    To draw a freehand segment, hold down Alt (Windows) or Option (Mac OS), and drag. When 
finished, release Alt/Option and the mouse button.

5    To erase recently drawn straight segments, press Delete. To erase freehand segments, hold down 
Delete.

6    Continue to click and Alt/Option-drag to finish selecting. 

7    Close the selection border:
•      Position the lasso tool pointer over the starting point (a closed circle appears next to the pointer) 
and click.
•      If the pointer is not over the starting point, double-click the lasso tool pointer, or Ctrl-click 
(Windows) or Command-click (Mac OS).

See also: 

To use the magnetic lasso tool 

To set options for the lasso, polygon lasso, and magnetic lasso tools 



Using the lasso, polygon lasso, and magnetic lasso tools 

To use the magnetic lasso tool:

1    Select and double-click the magnetic lasso tool ( ) to display its Options palette, and select 
options as described in the procedure To set options for the lasso, polygon lasso, and magnetic lasso 
tools. 

2    Click in the image to set the first fastening point.
Fastening points anchor the selection border in place.
3    To draw a freehand segment, move the pointer along the edge you want to trace. (You can also drag 
with the mouse button depressed.) 
The most recent segment of the selection border remains active. As you move the pointer, the active 
segment snaps to the strongest edge in the image. Periodically, the magnetic lasso tool adds fastening 
points to the selection border to anchor previous segments.
4    If the border doesn’t snap to the desired edge, click once to add a fastening point manually. Continue 
to trace the edge and add fastening points as needed.

Fastening points anchor selection border to edges.

5    To switch temporarily to the other lasso tools, do one of the following:
•      To activate the lasso tool, hold down Alt (Windows) or Option (Mac OS) and drag with the mouse 
button depressed.
•      To activate the polygon lasso tool, hold down Alt/Option and click.

6    To erase recently drawn segments and fastening points, press Delete. 

7    Close the selection border:
•      To close the border with a freehand magnetic segment, double-click, or press Enter (Windows) or 
Return (Mac OS).
•      To close the border with a a straight segment, hold down Alt (Windows) or Option (Mac OS), and 
double-click.

See also: 

To use the polygon lasso tool 

To set options for the lasso, polygon lasso, and magnetic lasso tools 



Using the lasso, polygon lasso, and magnetic lasso tools 

To set options for the lasso, polygon lasso, and magnetic lasso tools:

1    If needed, double-click the tool to open its Options palette.

2    Specify feather and anti-aliasing options, as described in Softening the edges of a selection.

3    For the magnetic lasso tool, set any of these options:
•      To specify a detection width, enter a pixel value between 1 and 40 for Lasso Width. The magnetic 
lasso only detects edges within the specified distance from the pointer.
•      To specify the rate at which the lasso sets fastening points, enter a value between 0 and 100 for 
Frequency. A higher value anchors the selection border in place more quickly. 
•      To specify the lasso’s sensitivity to edges in the image, enter a value between 1% and 100% for 
Edge Contrast. A higher value detects only edges that contrast sharply with their surroundings; a lower
value detects lower-contrast edges.

On an image with well-defined edges, you can use a greater lasso width and higher edge contrast and
trace the border roughly. On an image with softer edges, try a smaller width and lower edge contrast 
setting, and trace the border more precisely.

Use smaller width, higher value for edge contrast value for most precise border. Use wider width, smaller value 
for edge strength for rough path.
•      If you are working with a stylus tablet, select or deselect the Stylus: Pressure option. When the 
option is selected, an increase in stylus pressure will cause the lasso width to narrow.
 While creating a selection, you can press [ to decrease the magnetic lasso width by 1 pixel; press ] to 

increase the lasso width by 1 pixel.

See also: 

To use the polygon lasso tool 

To use the magnetic lasso tool 



Making selections 

Using the magic wand tool

The magic wand tool ( ) lets you select a consistently colored area (for example, a red flower) 
without having to trace its outline. You specify the color range, or tolerance, for the magic wand tool’s 
selection.

Note: You cannot use the magic wand tool on an image in Bitmap mode.

To use the magic wand tool:

1    Double-click the magic wand tool to display its Options palette.

2    For Tolerance, enter a value in pixels, ranging from 0 to 255. Enter a low value to select colors very
similar to the pixel you click or a higher value to select a broader range of colors. 

High tolerance detects shadow; lower tolerance detects only the key

3    To define a smooth edge, select Anti-aliased. (See Softening the edges of a selection.)

4    To select colors using data from all the visible layers, select Use All Layers. Otherwise, the magic 
wand tool selects colors from the active layer only. 

5    In the image, click the color you want to select. 

All adjacent pixels within the tolerance range are selected.



Making selections 

Using the Color Range command

The Color Range command selects a specified color or color subset within an existing selection or an 
entire image. If you want to replace a selection, be sure to deselect everything before applying this 
command. 

To refine an existing selection, use the Color Range command repeatedly to select a subset of colors. 
For example, to select the green areas in a cyan selection, select Cyans in the Color Range dialog 
box, and click OK. Then reopen the Color Range dialog box, and select Greens. (The results are 
subtle because the technique selects parts of colors within a color mix.) 

See also: 

To select a color range using sampled colors 

To select a range using preset colors 

To save and load color range settings 



Using the Color Range command 

To select a color range using sampled colors:

1    Choose Select > Color Range. 

2    For Select, choose Sampled Colors.

3    Select one of the following options listed below the preview box:
•      Selection to preview only the selection as you build it.
•      Image to preview the entire image. For example, you might want to sample from a part of the 
image that isn’t on-screen.
 To toggle between the Image and Selection previews in the Color Range dialog box, press Ctrl 

(Windows) or Command (Mac OS). 

4    Position the pointer over the image or preview area, and click to sample the colors you want 
included. 

Sampling color

5    Adjust the range of colors by using the Fuzziness slider or entering a value. To decrease the range 
of colors selected, decrease the value. The Fuzziness option partially selects pixels by controlling the 
degree to which related colors are included in the selection (similar to the Tolerance option for the 
magic wand and paint bucket options). 

Increasing Fuzziness expands selection

6    Adjust the selection:
•      To add colors, select the plus eyedropper from the Color Range dialog box and click in the preview
area or image.
•      To remove colors, select the minus eyedropper, and click in the preview area or image.
 To activate the plus eyedropper temporarily, hold down Shift. Hold down Alt (Windows) or Option (Mac 



OS) to activate the minus eyedropper.

7    To preview the selection in the image window, choose an option for Selection Preview:
•      None to display no preview in the image window.
•      Grayscale to display the selection as it would appear in a grayscale channel. 
•      Black Matte to display the selection in color against a black background. 
•      White Matte to display the selection in color against a white background.
•      Quick Mask to display the selection using the current quick mask settings. (See Using Quick Mask 
mode.)

8    To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and click Reset.

9    Click OK to make the selection.

See also: 

To select a range using preset colors 

To save and load color range settings 



Using the Color Range command 

To select a range using preset colors:

1    Choose Select > Color Range. 

2    For Select, choose a color or tonal range. The Out-of-Gamut option works only on RGB and Lab 
images. (An out-of-gamut color is an RGB or Lab color that cannot be printed using process color 
printing. See Color gamuts.)

3    Click Selection to display the selected areas in the preview area. 

Blue areas displayed in selection preview

4    To preview the selection in the image window, choose an option for Selection Preview. See step 7 
of To select a color range using sampled colors.

5    To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and click Reset.

6    Click OK to make the selection.

Note: If a message appears stating “No pixels are more than 50% selected,” the selection border will 
not be visible. You may have selected a color, such as red, when the image didn’t contain the fully 
saturated color.

See also: 

To select a color range using sampled colors 

To save and load color range settings 



Using the Color Range command 

To save and load color range settings: 

Use the Save and Load buttons in the Color Range dialog box to save and reuse settings.

See also: 

To select a color range using sampled colors 

To select a range using preset colors 



Selecting 

Adjusting selections

You can adjust and refine your selections using the selection tools or a variety of commands in the 
Select menu. 

In addition, you can apply geometric transformations to change the shape of a selection border. (See 
Transforming objects in two dimensions.)

See also: 

Moving, hiding, or inverting a selection 

Adjusting selections manually 

Adjusting selections numerically 



Adjusting selections 

Moving, hiding, or inverting a selection

See also: 

To move just the selection border 

To hide or show a selection border 

To select the unselected parts of an image 



Moving, hiding, or inverting a selection 

To move just the selection border: 

1    Using any selection tool, position the pointer inside the selection border.

2    Drag the selection border to enclose a different area of the image. You can drag a selection border 
beyond the canvas boundaries. When you drag it back, the original border reappears intact. You can 
also drag the selection border to another image window.

Original selection border, and selection border moved
 Use the following methods to control selection movement: 

• To constrain the direction to a multiple of 45, begin dragging, and then hold down Shift as you continue 
to drag. 
• To move the selection in 1-pixel increments, use the keyboard arrow keys. 
• To move the selection in 10-pixel increments, hold down Shift, and press an arrow key.

See also: 

To hide or show a selection border 

To select the unselected parts of an image 



Moving, hiding, or inverting a selection 

To hide or show a selection border:

Choose View > Hide Edges or Show Edges.

This option affects the current selection only. The selection border reappears when you make another 
selection.

See also: 

To move just the selection border 

To select the unselected parts of an image 



Moving, hiding, or inverting a selection 

To select the unselected parts of an image:

Choose Select > Inverse. 

You might use this option to select an object placed against a solid-colored background. For example, 
you could first select the background using the magic wand tool and then invert the selection. 

See also: 

To move just the selection border 

To hide or show a selection border 



Adjusting selections 

Adjusting selections manually

You can use the selection tools to add to or subtract from existing selections. 

Before manually adding to or subtracting from a selection, set the feather and anti-aliased values in 
the Options palette to the same settings used for the original selection. (See Softening the edges of a 
selection.)

To add to, subtract from, or intersect a selection:

1    Make a selection. 

2    Using any selection tool, modify the selection:
•      To add to the selection or select an additional area in the image, hold down Shift (a plus sign 
appears next to the pointer), and select the area or areas you want to add.
•      To subtract an area from a selection, hold down Alt (Windows) or Option (Mac OS) (a minus sign 
appears next to the pointer), and select the area or areas you want to subtract. 
•      To intersect selections, press Alt+Shift (Windows) or Option+Shift (Mac OS) (a cross appears next 
to the pointer), and select an area that intersects the original selection. Photoshop retains only that 
portion of the original selection falling within the newly selected area. 

Flower and frame selections intersected



Adjusting selections 

Adjusting selections numerically

You can use the following Select commands to increase or decrease the pixels in an existing 
selection:
•      Modify to expand or contract a selection by a specified number of pixels.
•      Grow and Similar to expand a selection to include areas similar in color. 
•      Smooth to clean up any stray pixels left inside or outside a color-based selection.

See also: 

To expand or contract a selection border 

To frame an existing selection with a selection 

To extend a selection based on color 

To smooth a selection 



Adjusting selections numerically 

To expand or contract a selection border:

1    Choose Select > Modify > Expand or Contract. 

2    For Expand By or Contract By, enter a pixel value between 1 and 16, and click OK.

The border is increased or decreased by the specified number of pixels. Any portion of the selection 
border running along the image’s edge is unaffected.

See also: 

To frame an existing selection with a selection 

To extend a selection based on color 

To smooth a selection 



Adjusting selections numerically 

To frame an existing selection with a selection:

1    Use a selection tool to make a selection.

2    Choose Select > Modify > Border. 

3    Enter a value between 1 and 64 pixels for the width of the border, and click OK. 

The new selection frames the border of the original selected area.

Original selection, and with Border command: 5 pixels

The Border command always creates an anti-aliased selection (see Softening the edges of a 
selection). To paint a hard-edged border around a selection, use the Stroke command (see Filling and 
stroking selections and layers).

See also: 

To expand or contract a selection border 

To extend a selection based on color 

To smooth a selection 



Adjusting selections numerically 

To extend a selection based on color:

Do one of the following:
•      Choose Select > Grow to include adjacent pixels falling within the tolerance range specified in the 
Magic Wand Options palette. 

Original selection, and with Grow command applied
•      Choose Select > Similar to include pixels throughout the image, not just adjacent ones, falling 
within the tolerance range. 

Original selection, and with Similar command applied

To increase the selection in increments, choose either command more than once.

Note: You cannot use the Grow and Similar commands on images that are in Bitmap mode.

See also: 

To expand or contract a selection border 

To frame an existing selection with a selection 

To smooth a selection 



Adjusting selections numerically 

To smooth a selection:

1    Choose Select > Modify > Smooth. 

2    For Sample Radius, enter a pixel value between 1 and 16, and click OK. 

Adobe Photoshop checks around each selected pixel to find any unselected pixels falling within the 
specified range. For example, if you enter 16 for the sample radius, the program uses each pixel as 
the center of a 33-by-33-pixel area (16 pixels in the horizontal and vertical directions). If most pixels in 
the range are selected, any unselected pixels are added to the selection. If most pixels are 
unselected, any selected pixels are removed from the selection.

Note: The relationship between physical distance and pixel distance depends on the resolution of the 
image. For example, 5 pixels is a longer distance in a 72-ppi image than in a 300-ppi image. (See 
About image size and resolution.)

See also: 

To expand or contract a selection border 

To frame an existing selection with a selection 

To extend a selection based on color 



Selecting 

Softening the edges of a selection

Photoshop offers two ways to smooth the hard edges of a selection.

See also: 

Anti-aliasing 

Feathering 

To use anti-aliasing 

To define a feathered edge for a selection tool 

To define a feathered edge for an existing selection 



Softening the edges of a selection 

Anti-aliasing 

Smooths the jagged edges of a selection by softening the color transition between edge pixels and 
background pixels. Since only the edge pixels change, no detail is lost. Anti-aliasing is useful when 
cutting, copying, and pasting selections to create composite images. 

Anti-aliasing is available for the lasso, polygon lasso, magnetic lasso, elliptical marquee, and magic 
wand tools. (Double-click the tool to display its Options palette.) You must specify this option before 
using these tools. Once a selection is made, you cannot add anti-aliasing. 

For an illustration of anti-aliasing, see Specifying anti-aliasing.



Softening the edges of a selection 

Feathering 

Blurs edges by building a transition boundary between the selection and its surrounding pixels. This 
blurring can cause some loss of detail at the edge of the selection.

You can define feathering for the marquee, lasso, polygon lasso, or magnetic lasso tool as you use the
tool, or you can add feathering to an existing selection. Feathering effects become apparent when you
move, cut, or copy the selection.



Softening the edges of a selection 

To use anti-aliasing:

1    Double-click the marquee, lasso, polygon lasso, or magnetic lasso tool to display its Options 
palette.

2    Select Anti-aliased in the Options palette for the selected tool. 



Softening the edges of a selection 

To define a feathered edge for a selection tool:

1    Double-click the marquee, lasso, polygon lasso, or magnetic lasso tool to display its Options 
palette.

2    Enter a Feather value in the Options palette. This value defines the width of the feathered edge 
and can range from 1 to 250 pixels.



Softening the edges of a selection 

To define a feathered edge for an existing selection:

1    Choose Select > Feather.

2    Enter a value for the Feather Radius, and click OK.

Note: A small selection made with a large feather radius may be so faint its edges are invisible and 
thus not selectable. If a message appears stating “No pixels are more than 50% selected,” either 
decrease the feather radius or increase the selection’s size.

A. Original selection    B. Feather: 0    C. Feather: 10    D. Feather: 30



Selecting 

Creating and using paths

Paths provide an effective way to draw precise selection borders. A path is any line or shape you draw
using the pen, magnetic pen, or freeform pen tool. Unlike the bitmap shapes drawn by the pencil or 
other painting tools, paths are vector objects that contain no pixels. As a result, paths remain separate 
from the bitmap image and do not print, with the exception of clipping paths. (See About bitmap 
images and vector graphics.)

Once you have created a path, you can save it in the Paths palette, convert it to a selection border, or 
fill or stroke the path outline with color. In addition, you can convert a selection to a path. Because they
take up less disk space than pixel-based data, paths can be used for long-term storage of simple 
masks. Paths can also be used to clip sections of your image for export to an illustration or page-
layout application (see Using clipping paths).

Pen tool used as selection tool, and as drawing tool

See also: 

Using the Paths palette 

Creating, saving, and deleting paths 

Creating multiple subpaths 



Creating and using paths 

Using the Paths palette

The Paths palette lists the name of each saved path and a thumbnail of its contents. Decreasing the 
size of thumbnails or turning them off lets you view more paths at one time in the palette and can 
improve performance. To view a path, you must first select the path name in the Paths palette.

To display the Paths palette:

Choose Windows > Show Paths.

A. Selected path    B. Fill Path    C. Stroke Path    D. Make Selection    E. Make Work Path    F. New Path

To select or deselect a path:

Do one of the following:
•      To select a path, click the path name in the Paths palette. Only one path can be selected at a time.
•      To deselect a path, click in the blank area of the Paths palette, or choose Turn Off Path from the 
Paths palette menu.

To change the size of a path thumbnail:

1    Choose Palette Options from the Paths palette menu.

2    Select a size, or select None to turn off the display of thumbnails. 

To change a path’s stacking order:

1    Select the path in the Paths palette.

2    Drag the path up or down in the Paths palette. When the solid line appears in the desired location, 
release the mouse button.

To show or hide a path:

Select the path name in the Paths palette and choose View > Show Path or View > Hide Path to 
toggle the command.
 To toggle between hiding and showing a path, Shift-click the path name in the Paths palette. 



Creating and using paths 

Creating, saving, and deleting paths

Paths can be created in two ways:
•      You can select a pen tool and begin drawing. If no path name is selected, the new path appears as
a temporary work path in the Paths palette. You must save the work path to avoid losing its contents. If
you deselect the work path without saving and then start drawing again, a new work path will replace 
the first one. 
•      You can create a new path in the Paths palette and then begin drawing. The path contents are 
saved automatically. 

Paths saved with an image appear when you open it again. In Windows, the Photoshop, JPEG, DCS, 
EPS, PDF, and TIFF formats support paths. In Mac OS, all available file formats (except GIF89a 
Export) support paths.

See also: 

To save a work path 

To create a new path 

To rename a saved path 

To delete a path 



Creating, saving, and deleting paths 

To save a work path:

Do one of the following:
•      To save without renaming, drag the Work Path name to the New Path button ( ) at the bottom of 
the Paths palette.

•      To save and rename, Choose Save Path from the Paths palette menu, enter a new path name, and 
click OK.

See also: 

To create a new path 

To rename a saved path 

To delete a path 



Creating, saving, and deleting paths 

To create a new path:

Do one of the following:
•      To create a path without naming it, click the New Path button at the bottom of the palette.
•      To create and name a path, make sure no work path is selected. Choose New Path from the Paths
palette menu, or Alt-click (Windows) or Option-click (Mac OS) the New Path button ( ) at the bottom 
of the palette. Enter a name for the path in the New Path dialog box, and click OK.

See also: 

To save a work path 

To rename a saved path 

To delete a path 



Creating, saving, and deleting paths 

To rename a saved path:

1    Double-click the path’s name in the Paths palette. 

2    Enter a new name in the Rename Path dialog box, and click OK.

See also: 

To save a work path 

To create a new path 

To delete a path 



Creating, saving, and deleting paths 

To delete a path:

1    Select the path name in the Paths palette.

2    Do one of the following:
•      Drag the path to the Trash button at the bottom of the Paths palette.
•      Click the Trash button at the bottom of the Paths palette, and click Yes. 
•      Choose Delete Path from the Paths palette menu.
 To delete a path automatically, Alt-click (Windows) or Option-click (Mac OS) the Trash button at the 

bottom of the Paths palette.

See also: 

To save a work path 

To create a new path 

To rename a saved path 



Creating and using paths 

Creating multiple subpaths

Each time you draw a connected series of straight or curved segments, you create a subpath. You can
create several subpaths and save them as a single path in the Paths palette. To create additional 
subpaths, close or end the current subpath, and begin drawing again to create a new, disconnected 
segment. 

Original path, and subpath added



Selecting 

Drawing freehand paths

The freeform pen tool and the magnetic pen tool let you draw paths as if you were drawing with a 
pencil on paper. As you draw with the freeform pen tool, anchor points are automatically set down. You
do not determine where they are positioned, although you can adjust them once the path is complete. 
(See About anchor points, direction lines, and direction points, for more information.)

The magnetic pen tool lets you draw a path that snaps to the edges of defined areas in your image. 
You can define the range and sensitivity of the snapping behavior, as well as the complexity of the 
resulting path. The magnetic pen and magnetic lasso tools share many of the same options.

See also: 

To use the freeform pen tool 

To use the magnetic pen tool 



Drawing freehand paths 

To use the freeform pen tool:

1    Select and double-click the freeform pen tool to display its Options palette.

2    For Curve Fit, enter a value between 0.5 and 10.0. 

This option controls how sensitive the final path is to the movement of your mouse or stylus. A higher 
Curve Fit value results in a simpler path with fewer anchor points.

3    Drag the pointer in the image. 

As you drag, a path trails behind the pointer. When you release the mouse, a work path is created.

4    To continue the existing freehand path, position the freeform pen pointer on an endpoint of the 
path, and drag.

Path continued with freeform pen tool

5    To complete the path, release the mouse. To create a closed path, drag over the initial point of the 
path (a circle appears next to the pointer when it is aligned) and release the mouse.

See About anchor points, direction lines, and direction points for more on closed and open paths.



Drawing freehand paths 

To use the magnetic pen tool:

1    Select and double-click the magnetic pen tool ( ) to display its Options palette.
2    Specify tool options as described in the following procedure.
3    Click in the image to set the first fastening point.
4    To draw a freehand segment, move the pointer along the edge you want to trace. (You can also drag 
with the mouse button depressed.) 
The most recent segment of the border remains active. As you move the pointer, the active segment 
snaps to the strongest edge in the image, connecting the pointer to the last fastening point. Periodically, 
the magnetic pen tool adds fastening points to the border to anchor previous sections.
5    If the border doesn’t snap to the desired edge, click once to add a fastening point manually, to keep 
the border from moving. Continue to trace the edge and add fastening points as needed.

Click to add fastening point, and continue tracing.

6    To turn off magnetic properties temporarily, do one of the following:
•      Hold down Alt (Windows) or Option (Mac OS), and drag with the mouse button depressed to draw 
a freehand path.
•      Hold down Alt/Option and click to draw straight segments.

7    Complete the path:
•      Press Enter (Windows) or Return (Mac OS) to end an open path.
•      Double-click to close the path with a magnetic segment.
•      Hold down Alt (Windows) or Option (Mac OS) and double-click to close the path with a straight 
segment.

See About anchor points, direction lines, and direction points for more on closed and open paths.

To specify magnetic pen tool options:

1    If needed, double-click the magnetic pen tool to display its Options palette.

2    For Curve Fit, enter a value between 0.5 and 10.0. 

This option controls how sensitive the final path is to the movement of your mouse or stylus. A higher 
Curve Fit value results in a simpler path with fewer anchor points.

Curve fit tolerance 0.5 and 10.0

3    To specify a detection width, enter a pixel value between 1 and 40 for Pen Width. The magnetic 



pen only detects edges within the specified distance from the pointer.
 While creating a path, press [ to decrease the magnetic pen width by 1 pixel; press ] to increase the 

pen width by 1 pixel.

4    Specify Frequency, Edge Contrast, and Stylus: Pressure options, as described in the procedure To 
set options for the lasso, polygon lasso, and magnetic lasso tools.



Selecting 

Drawing with the pen tool

The pen tool ( ) lets you create straight lines and smooth flowing curves with greater precision than 
possible with the freeform pen or magnetic pen tool. For most users, the pen tool provides the best 
control and greatest accuracy for drawing.

Before you use the pen tool, it is important to understand how paths are constructed.

See also: 

About anchor points, direction lines, and direction points 

Drawing straight line paths 

Drawing curved paths 

Tips for drawing curves 



Drawing with the pen tool 

About anchor points, direction lines, and direction points

A path consists of one or more straight or curved segments. Anchor points mark the endpoints of the 
path segments. On curved segments, each selected anchor point displays one or two direction lines, 
ending in direction points. The positions of direction lines and points determine the size and shape of a
curved segment. Moving these elements reshapes the curves in a path.

A. Curved segment    B. Direction point    C. Anchor point    D. Direction line

A path can be closed, with no beginning or end (for example, a circle), or open, with distinct endpoints 
(for example, a wavy line). 

Closed and open paths    A. Selected line segment    B. Unselected anchor point    C. Selected anchor point    D. 
Selected endpoint

Smooth curves are connected by anchor points called smooth points. Sharply curved paths are 
connected by corner points. 

Smooth point and corner point

When you move a direction line on a smooth point, the curved segments on both sides of the point 
adjust simultaneously. In comparison, when you move a direction line on a corner point, only the curve
on the same side of the point as the direction line is adjusted. 



Adjusting smooth point and corner point

To preview path segments as you draw:

1    Double-click the pen tool to display its Options palette.

2    Select Rubber Band.

As you move the pointer in the image, Photoshop displays the proposed segment. The segment 
doesn’t become permanent until you press the mouse button.



Drawing with the pen tool 

Drawing straight line paths

The simplest path you can draw with the pen tool is a straight line, made by clicking to create anchor 
points. 

To draw straight line paths: 

1    Select the pen tool ( ). 
2    Position the pen pointer where you want the straight line to begin, and click to define the first anchor 
point. The anchor point remains selected (solid) until you define the next point.

Click to add straight segments.

3    Click again where you want the first segment of the straight line path to end. Hold down Shift as 
you click to constrain the angle of the segment to a multiple of 45.

4    Continue clicking to set anchor points for additional straight segments.

The last anchor point is always a solid square, indicating it is selected. Previously defined anchor 
points become hollow squares as you add further anchor points.

5    Complete the path:
•      To end an open path, click the pen tool in the toolbox. Or hold down the Ctrl key (Windows) or 
Command key (Mac OS), and then click anywhere away from the path.
•      To close a path, position the pen pointer over the first anchor point. A small loop appears next to 
the pen tip when it is positioned correctly. Click to close the path.



Drawing with the pen tool 

Drawing curved paths

You create curves by dragging the pen tool in the direction you want the curve to go.

To draw a curved path: 

1    Select the pen tool.

2    Position the pointer where you want the curve to begin. Hold down the mouse button. The first 
anchor point appears, and the pointer changes to an arrowhead.

3    Drag in the direction you want the curve segment to be drawn. As you drag, the pointer leads one 
of two direction points. Hold down the Shift key to constrain the tool to multiples of 45. 

The length and slope of the direction line determine the shape of the curve segment. You can adjust 
one or both sides of the direction line later.

Drag in direction of curve to set first anchor point. Drag in the opposite direction to complete the curve segment.

4    Position the pointer where you want the curve segment to end, press the mouse button, and drag 
in the opposite direction to complete the segment. 

5    Do one of the following:
•      To draw the next segment of a smooth curve, position the pointer where you want the next 
segment to end, and drag away from the curve.

Drag away from curve to create the next segment.
•      To change the direction of the curve sharply, release the mouse button, press Alt (Windows) or 
Option (Mac OS), and then drag the direction point in the direction of the curve. Release Alt/Option 
and the mouse button, reposition the pointer where you want the segment to end, and drag in the 
opposite direction to complete the curve segment.



Press Alt/Option, and drag direction point toward the curve. Release the key, and drag in opposite direction.

6    Complete the path:
•      To end an open path, click the pen tool in the toolbox. Or hold down the Ctrl key (Windows) or 
Command key (Mac OS), and then click anywhere away from the path.
•      To close the path, position the pointer over the first anchor point. A small loop appears next to the 
pointer when it is positioned correctly. Click or drag to close the path.



Drawing with the pen tool 

Tips for drawing curves

Keep these guidelines in mind when drawing curves:
•      Always drag the first direction point in the direction of the bump of the curve, and drag the second 
direction point in the opposite direction to create a single curve. Dragging both direction points in the 
same direction creates an “S” curve.

Drag in opposite direction to create a smooth curve. Drag in same direction to create an “S” curve. 
•      When drawing a series of smooth curves, draw one curve at a time, placing anchor points at the 
beginning and end of each curve, not at the tip of the curve. Use as few anchor points as possible, 
placing them as far apart as possible.

A. Less efficient    B. More efficient



Selecting 

Adjusting path segments

The path tools, in the path pull-out menu, let you change the shapes of a path. 

See also: 

Selecting path segments 

Moving, reshaping, and erasing segments 

Adding, deleting, and converting anchor points 



Adjusting path segments 

Selecting path segments

To modify the shape of a path, you must first select the path name in the Paths palette to display the 
path. Then you use the direct-selection tool to select the path or a segment of the path.

Selecting a path or path segment displays all of the anchor points on the selected portion, including 
any direction lines and direction points if the selected segment is curved. Direction points appear as 
filled circles, selected anchor points as filled squares, unselected anchor points as hollow squares.

To select a path or path segment: 

1    Select the direct-selection tool ( ). 
2    Do the following:

•      To select an entire path or subpath, hold down Alt (Windows) or Option (Mac OS), and click the 
path. If the path consists of several subpaths, only the subpath directly under the pointer is selected. 

Alt/Option-click to select entire path.
•      To select a segment, drag a marquee enclosing the anchor points at the ends of the segment.

Marquee-drag to select segments.

3    To add selections, hold down Shift while selecting additional paths or segments.
 To activate the direct-selection tool when any other tool is selected, position the pointer over an anchor

point, and press Ctrl (Windows) or Command (Mac OS).

Subpath selected by Alt/Option-clicking, and second subpath selected by holding down Shift and Alt/Option-
clicking.



Adjusting path segments 

Moving, reshaping, and erasing segments

You also use the direct-selection tool to move and reshape one or more segments on a path. You can 
also erase part or all of a path.

See also: 

To adjust a straight segment 

To move a curved segment 

To reshape a curved segment 

To erase a path segment 



Moving, reshaping, and erasing segments 

To adjust a straight segment:

1    Select the direct-selection tool ( ), and select the segment you want to adjust. To adjust the angle 
or length of the segment, select an anchor point.

2    Drag the selected segment to its new position.

Click to select straight segment. Then drag to adjust.

See also: 

To move a curved segment 

To reshape a curved segment 

To erase a path segment 



Moving, reshaping, and erasing segments 

To move a curved segment:

1    Select the direct-selection tool ( ), and select the points or segments you want to move. Be sure 
to select both the points anchoring the segment.

2    Drag the selected anchor points or segments to new positions. Hold down Shift as you drag to 
constrain the movement to multiples of 45°.

Select points anchoring curve. Then drag to move curve.

See also: 

To adjust a straight segment 

To reshape a curved segment 

To erase a path segment 



Moving, reshaping, and erasing segments 

To reshape a curved segment:

1    Select the direct-selection tool ( ), and select the curved segment you want to adjust. Direction 
lines appear for that segment.

2    Adjust the curve:
•      To adjust the position of the segment, drag the segment.

Click to select curve segment. Then drag to adjust.
•      To adjust the shape of the segment on either side of a selected anchor point, drag the anchor 
point, or drag the direction point. Hold down Shift as you drag to constrain the movement to multiples 
of 45°.

Drag the anchor point, or drag the direction point to reshape.

See also: 

To adjust a straight segment 

To move a curved segment 

To erase a path segment 



Moving, reshaping, and erasing segments 

To erase a path segment:

1    Select the direct-selection tool ( ), and select the curved segment you want to adjust. Direction 
lines appear for that segment.

2    Press Backspace (Windows) or Delete (Mac OS) to erase the selected segment. Pressing 
Backspace/Delete again erases the rest of the subpath.

See also: 

To adjust a straight segment 

To move a curved segment 

To reshape a curved segment 



Adjusting path segments 

Adding, deleting, and converting anchor points

The add-anchor-point and delete-anchor-point tools let you add and delete anchor points from a path. 
The convert-direction-point tool lets you convert a smooth curve to a sharp curve or to a straight 
segment, and vice versa. 

See also: 

To add an anchor point 

To delete an anchor point 

To convert between a smooth point and a corner point 



Adding, deleting, and converting anchor points 

To add an anchor point:

1    Select the add-anchor-point tool ( ), and position the pointer on the path where you want the 
anchor point added (a plus sign appears next to the pointer).

2    Do one of the following:
•      Click to add an anchor point without changing the shape of the segment. 
•      To add an anchor point and change the shape of the segment, drag to define direction lines for the
anchor point.

See also: 

To delete an anchor point 

To convert between a smooth point and a corner point 



Adding, deleting, and converting anchor points 

To delete an anchor point:

1    Select the delete-anchor-point tool ( ), and position the pointer on the anchor point you want 
deleted (a minus sign appears next to the pointer).

2    Delete the anchor point:
•      Click the anchor point to delete it and reshape the path to fit the remaining anchor points.
•      Drag the anchor point to delete it and change the shape of the segment.

See also: 

To add an anchor point 

To convert between a smooth point and a corner point 



Adding, deleting, and converting anchor points 

To convert between a smooth point and a corner point:

1    Select the convert-anchor-point tool ( ), and position the pointer over the anchor point you want 
changed. 
 To activate the convert-anchor-point tool while the direct-selection tool is selected, position the pointer 

over an anchor point and press Ctrl+Alt (Windows) or Command+Option (Mac OS).

2    Convert the point:
•      To convert a smooth point to a corner point without direction lines, click the smooth anchor point. 
•      To convert a smooth point to a corner point with direction lines, make sure the direction lines are 
visible. Then drag a direction point to break the pair of direction lines.

Drag direction point to break direction lines.
•      To convert a corner point to a smooth point, drag away from the corner point to make direction 
lines appear.

Click to create a corner point. Drag to create a smooth point.

See also: 

To add an anchor point 

To delete an anchor point 



Selecting 

Moving and copying paths

You can reposition a path anywhere within an image. You can copy paths within an image or between 
two Photoshop images. You can also use the Copy and Paste commands to duplicate paths, between 
a Photoshop image and an image in another application, such as Adobe Illustrator, Adobe 
Streamline™, or Adobe Dimensions®. 

See also: 

To move a path 

To copy a path 

To copy paths between two Adobe Photoshop files 



Moving and copying paths 

To move a path:

1    Select the path name in the Paths palette, and use the direct-selection tool ( ) to select the path 
in the image. 

2    Drag the path to its new location.
If you move any part of a path beyond the canvas boundaries, the hidden part of the path is still available.

Note: If you drag a path so that the move pointer is over another open image, the path will be copied 
to that image.



Moving and copying paths 

To copy a path:

Do any of the following:
•      To copy a path as you move it, select the path name in the Paths palette, and use the direct-
selection tool ( ) to select the path in the image. Hold down Alt (Windows) or Option (Mac OS) as 
you drag the path. 

•      To copy a path without renaming, drag the path in the Paths palette to the New Path button ( ) at the 
bottom of the palette.
•      To copy and rename a path, Alt-drag (Windows) or Option-drag (Mac OS) the path in the Paths palette
to the New Path button ( ) at the bottom of the palette. Or select the path to copy, and choose Duplicate 
Path from the Paths palette menu. Enter a new name for the path, and click OK.



Moving and copying paths 

To copy paths between two Adobe Photoshop files:

1    Open both images. 

2    Use the direct-selection tool to select the path in the source image you want to copy.

3    Copy the path:
•      Drag the path from the source image to the destination image. The path is copied to the active 
path in the Paths palette.
•      Drag the path from the source image’s Paths palette into the destination image. The path is copied
to the active path in the Paths palette. 
•      In the source image, choose Edit > Copy to copy the path, and in the destination image choose 
Edit > Paste. 



Selecting 

Filling and stroking paths

You can add color values to a path by filling or stroking the path. 
•      Fill Path lets you fill a path with a specified color, a state of the image, or a pattern. 
•      Stroke Path lets you paint a path border. 

If a subpath is selected, these commands become the Fill Subpath and Stroke Subpath commands. 

Important: When you fill or stroke a path, the color values appear on the active layer. Make sure that 
the desired layer is active before beginning.

See also: 

To fill a path using the current Fill Path settings 

To fill a path and specify options 

To stroke a path using the current Stroke Path settings 

To stroke a path and specify options 



Filling and stroking paths 

To fill a path using the current Fill Path settings:

Click the Fill Path button ( ) at the bottom of the Paths palette. 



Filling and stroking paths 

To fill a path and specify options:

1    Select the path in the Paths palette.

2    Fill the path:
•      Alt-click (Windows) or Option-click (Mac OS) the Fill Path button at the bottom of the Paths palette.
•      Choose Fill Path from the Paths palette menu. 

3    For Use, choose the contents for the fill (see Filling and stroking selections and layers).

4    Specify an opacity for the fill. To make the fill more transparent, use a low percentage. A setting of 
100% makes the fill opaque.

5    Choose a blending mode for the fill, as explained in Selecting a blending mode. 

The Mode list includes a Clear mode that lets you erase to transparency. You must be working in a 
layer to use this option. 

6    Select Preserve Transparency to limit the fill to layer areas that contain pixels. (See Preserving a 
layer’s transparency.)

7    Select a Rendering option:
•      Feather Radius to define how far inside and outside the selection border the feather edge extends.
Enter a value in pixels.
•      Anti-aliased to create a finer transition between the pixels in the selection and the surrounding 
pixels by partially filling the edge pixels of the selection. 

(See Softening the edges of a selection for more on these options.)

8    Click OK to fill the path.

Path created, and filled 



Filling and stroking paths 

To stroke a path using the current Stroke Path settings:

Click the Stroke Path button ( ) at the bottom of the Paths palette. Each click of the Stroke Path 
button builds up the thickness of the stroke.



Filling and stroking paths 

To stroke a path and specify options:

1    Select the path in the Paths palette. 

2    Select the painting or editing tool you want to use to stroke the path. Set the tool options in the 
Options palette, and specify a brush in the Brushes palette. You must specify the tool’s settings before
opening the Stroke Path dialog box. (See Editing and Retouching and Painting for information on 
specific tool settings.)

3    Stroke the path:

•      Alt-click (Windows) or Option-click (Mac OS) the Stroke Path button ( ) at the bottom of the 
Paths palette.

•      Choose Stroke Path from the Paths palette menu. 

4    If you did not select a tool in step 2, choose a tool from the Stroke Path dialog box. 

5    Click OK to stroke the path. 

Paths selected, and stroked



Selecting 

Converting between paths and selection borders

Because of their smooth outlines, paths can be converted into precise selection borders. You also can 
convert selection borders into paths, using the direct-selection tool for fine-tuning. 

See also: 

Defining paths as selection borders 

Converting selection borders into paths 



Converting between paths and selection borders 

Defining paths as selection borders

You can define any closed path as a selection border. A closed path that overlaps a selected area can 
be added to, subtracted from, or combined with the current selection. 

To convert a path to a selection border using the current Make Selection settings:

Click the Make Selection button ( ) at the bottom of the Paths palette.

To convert a path to a selection border and specify settings:

1    To combine the path with a selection, first make the selection using a selection tool.

2    In the Paths palette, select the name of the path to define as a selection. 

3    Make the selection:

•      Alt-click (Windows) or Option-click (Mac OS) the Make Selection button ( ) at the bottom of the
Paths palette.

•      Choose Make Selection from the Paths palette menu. 

4    Select a Rendering option:
•      Feather Radius to define how far inside and outside the selection border the feather edge extends.
Enter a value in pixels. 
•      Anti-aliased to create a finer transition between the pixels in the selection and the surrounding 
pixels. Make sure the Feather Radius is set to 0. 

See Softening the edges of a selection for more on these options.

5    Select a selection option:
•      New Selection to select only the area defined by the path.
•      Add to Selection to add the area defined by the path to the original selection. 
•      Subtract from Selection to remove the area defined by the path from the original selection. 
•      Intersect with Selection to select the area common to both the path and the original selection. If 
the path and selection do not overlap, nothing is selected. 

To convert a path to a selection border using shortcuts:

Do any of the following: 
•      To define a path as a selection using the current settings in the Make Selection dialog box, Ctrl-
click (Windows) or Command-click (Mac OS) the path thumbnail in the Paths palette. 
•      To add the path to the current selection, press Ctrl+Shift/Command+Shift and click the path 
thumbnail. 
•      To subtract the path from the current selection, press Ctrl+Alt/Command+Option and click the path
thumbnail. 
•      To select the intersection of the path and the current selection, press 
Ctrl+Shift+Alt/Command+Shift+Option and click the path thumbnail.



Converting between paths and selection borders 

Converting selection borders into paths

Any selection made with a selection tool can be defined as a path. You can convert a selection into a 
path using the Make Work Path command or the Make Work Path button.

The Make Work Path command eliminates any feathering applied to the selection. It can also alter the 
shape of the selection, depending on the complexity of the path and the tolerance value you choose in
the Make Work Path dialog box.

To convert a selection to a path:

Click the Make Work Path ( ) button at the bottom of the Paths palette.

To convert a selection to a path and specify tolerance:

1    Make the selection.

2    Convert the selection to a path:

•      Alt-click (Windows) or Option-click (Mac OS) the Make Work Path ( ) button at the bottom of 
the Paths palette. 

•      Choose Make Work Path from the Paths palette menu. 

3    Enter a Tolerance value.

Tolerance values can range from 0.5 to 10 pixels and determine how sensitive the Make Work Path 
command is to slight changes in the selection shape. The higher the tolerance value, the fewer the 
anchor points used to draw the path and the smoother the path. If you experience difficulties printing 
the image, use a higher tolerance value (see Printing clipping paths).

Path tolerance: 2 pixels and 10 pixels

4    Click OK. The converted selection appears as a work path at the bottom of the Paths palette.
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See also: 

Monitoring operations 

Correcting mistakes 

Reverting to any state of the image 

Duplicating images 

Using rulers, the measure tool, guides, and grids 

Moving, copying, and pasting selections 

Deleting a selection 

Removing fringe pixels from a selection 

Transforming objects in two dimensions 

Transforming objects in three dimensions 

Using the rubber stamp tool and pattern stamp tool 

Using other retouching tools 



Editing and Retouching 

Monitoring operations

You can’t continue working while a progress bar is displayed, indicating an operation is in process. But
you can usually interrupt the process or have the program beep when it’s done. 

To interrupt operations:

Hold down Esc until the operation in progress has stopped or press Command+(.) (Mac OS only).

To set the beep:

1    Choose File > Preferences > General.

2    Select Beep When Done, and click OK.



Editing and Retouching 

Correcting mistakes

Most operations can be undone if you make a mistake. Alternatively, you can restore all or part of an 
image to its last saved version. But available memory may limit your ability to use these options.

For information on how to restore your image to how it looked during any point in the current work 
session, see Reverting to any state of the image.

To undo the last performed operation only:

Choose Edit > Undo. 

If an operation can’t be undone, the command is dimmed and changes to Can’t Undo.

To free memory used by the Undo command, the History palette, the Clipboard, or the Pattern 
buffer:

Choose Edit > Purge, and choose the item type or buffer you want to clear. If already empty, the item 
type or buffer is dimmed. 

Important: The Purge command permanently clears from memory the operation stored by the 
command or buffer, and cannot be undone. For example, choosing Edit > Purge > Histories deletes all
history states from the History palette. Use the Purge command when information held in memory is 
so large, Photoshop cannot perform the next operation.

To reverse all changes made to the image since it was last saved:

Choose File > Revert, and click Revert.

To restore part of an image to its previously saved version:

Do one of the following:

•      Use the history brush tool ( ) to paint with the selected state or snapshot on the History palette. 
(See Painting with a state or snapshot of the image.)

•      Use the eraser tool ( ) with the Erase to History option selected. (See Using the eraser tool.)
•      Select the area you want to restore and choose Edit > Fill. For Use, choose History, and click OK. 
(See Filling and stroking selections and layers.)

Note: To restore the image with a snapshot of the initial state of the document, make sure that the 
Automatically Create First Snapshot option is on.



Editing and Retouching 

Reverting to any state of the image

The History palette lets you jump to any recent state of the image created during the current working 
session. Each time you apply a change to an image, the new state of that image is added to the 
palette.

For example, if you select, paint, and rotate part of an image, each of those states is listed separately 
in the palette. You can then select any of these states, and the image will revert to how it looked when 
that change was first applied. You can then work from that state.

The following guidelines can help you with the History palette:
•      Program-wide changes, such as changes to palettes, color settings, actions, and preferences, are 
not changes to a particular image and so are not added to the History palette.
•      By default, the History palette lists the previous 20 states. Older states are automatically deleted to
free more memory for Photoshop. To keep a particular state throughout your work session, make a 
snapshot of the state. 

For more information on making snapshots, see Making a snapshot of the image.
•      Once you close and reopen the document, all states and snapshots from the last working session 
are cleared from the palette.
•      By default, a snapshot of the initial state of the document is displayed at the top of the palette. 
•      States are added from the top down. That is, the oldest state is at the top of the list, the most 
recent one at the bottom.
•      Each state is listed with the name of the tool or command used to change the image.
•      By default, selecting a state dims those below. This way you can easily see which changes will be 
discarded if you continue working from the selected state. (See To specify history options.)
•      By default, selecting a state and then changing the image eliminates all states that come after.
•      If you select a state and then change the image, eliminating the states that came after, you can 
use the Undo command to undo the last change and restore the eliminated states. (See Correcting 
mistakes.)
•      By default, deleting a state deletes that state and those that came after it. If you choose the Allow 
Non-Linear History option, deleting a state deletes just that state.

A. Sets the source for the history brush    B. Thumbnail of a snapshot    C. History state    D. History state slider    
E. Create new document from current state button    F. Create new snapshot button    G. Trash button

See also: 

Using the History palette 

Making a snapshot of the image 



Painting with a state or snapshot of the image 



Reverting to any state of the image 

Using the History palette

To display the History palette:

Choose Window > Show History.

See also: 

To revert to a previous state of the image 

To delete one or more states of the image 

To create a new document based on the selected state or snapshot of the image 

To replace another document with a selected state 

To specify history options 



Using the History palette 

To revert to a previous state of the image:

Do any of the following:
•      Click the name of the state.
•      Drag the slider at the left of the state up or down to a different state.
•      Choose Step Forward or Step Backward from the pop-up menu to move to the next or previous 
state.
•      Press Shift+Ctrl+Z (Windows) or Shift+Command+Z (Mac OS) to move to the next state.
•      Press Alt+Ctrl+Z (Windows) or Option+Command+Z (Mac OS) to move to the previous state.

See also: 

To delete one or more states of the image 

To create a new document based on the selected state or snapshot of the image 

To replace another document with a selected state 

To specify history options 



Using the History palette 

To delete one or more states of the image:

Do one of the following:
•      Click the name of the state, and choose Delete from the pop-up menu on the palette to delete that 
change and those that came after it.
•      Drag the state to the Trash button ( ) to delete that change and those that came after it.

•      Choose Clear History from the pop-up menu to delete the list of states from the History palette, 
without changing the image.
•      Hold down Alt (Windows) or Option (Mac OS) and choose Clear History from the pop-up menu to 
purge the list of states from the History palette without changing the image. If you get a message 
indicating Photoshop is low on memory, purging states is useful, since the command deletes the states 
from the Undo buffer, and frees up memory. This action cannot be undone.

•      Choose Edit > Purge > Histories to purge the list of states from the History palette for all open 
documents. This action cannot be undone.

See also: 

To revert to a previous state of the image 

To create a new document based on the selected state or snapshot of the image 

To replace another document with a selected state 

To specify history options 



Using the History palette 

To create a new document based on the selected state or snapshot of the 
image:

Do one of the following:
•      Drag a state or snapshot onto the New Document button ( ).

•      Select a state or snapshot and click the New Document button ( ).
•      Select a state or snapshot and choose New Document from the pop-up menu on the palette.

The history list for the newly created document will be empty.
 To save one or more snapshots or image states for use in a later editing session, create a new file for 

each state you’ll save, and save each in a separate file. When you reopen your original file, also open the 
other saved files. You can drag each file’s initial snapshot to the original image and thus access the 
snapshots again from the original image’s History palette.

See also: 

To revert to a previous state of the image 

To delete one or more states of the image 

To replace another document with a selected state 

To specify history options 
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To replace another document with a selected state:

Drag the state onto the other document.

See also: 

To revert to a previous state of the image 

To delete one or more states of the image 

To create a new document based on the selected state or snapshot of the image 

To specify history options 



Using the History palette 

To specify history options:

1    Choose History Options from the History palette pop-up menu.

2    Select history options:
•      For Maximum History Items, enter the maximum number of states that can be listed on the History 
palette.

Note: This number is limited by the size of the image, the type of changes you make to it, and the 
amount of memory available to Photoshop.
•      Select Automatically Create First Snapshot to automatically create a snapshot of the initial state of 
the image when the document is opened.
•      Select Allow Non-linear History to make changes to a selected state without deleting the states 
that come after. Normally, when you select a state and change the image, all states that come after 
the selected one are deleted. This enables the History palette to display a list of the editing steps in 
the order you made them. By recording states in a non-linear way you can select a state, make a 
change to the image, and delete just that state. The change will be inserted into the list of states, 
without deleting the states after it. This gives greater flexibility, but is less clearly organized.

3    Click OK.

See also: 

To revert to a previous state of the image 

To delete one or more states of the image 

To create a new document based on the selected state or snapshot of the image 

To replace another document with a selected state 



Reverting to any state of the image 

Making a snapshot of the image

The Snapshot command lets you make a temporary copy (or snapshot) of any state of the image. The 
new snapshot is added to the list of snapshots at the top of the History palette. Selecting the snapshot 
lets you work from that version of the image. 

Important: Snapshots are not saved with the image—closing an image removes all snapshots. Also, 
unless you select the Allow Non-linear History option, selecting a snapshot and changing the image 
deletes all of the states currently listed in the History palette.

Snapshots let you do the following:
•      Switch repeatedly between several states. By taking a temporary snapshot of a state, you can 
keep that state for the entire work session, even if the original state is deleted from the list of states in 
the History palette.
•      Give a unique name to states, to make them easier to identify.
•      Experiment more freely. For example, you may want to compare two different techniques for 
achieving a similar effect. You can take a snapshot before and after trying the first technique. You can 
then select the first snapshot, try the second technique on it, and then compare snapshots of each 
technique.
•      Take a snapshot before creating or applying an action. Then you can recover your work more 
easily if you decide later you don’t like the action. Each step in an action is added to the list of states 
on the History palette. An action with many steps could scroll the current states off the palette, so that 
you could not return to any of them. Using the Undo command undoes only one step and state. By 
making a snapshot first, you can select and redisplay the pre-action image.

See also: 

To create a snapshot 

To select a snapshot 

To delete a snapshot 



Making a snapshot of the image 

To create a snapshot:

1    Select a state.

2    Click the New Snapshot button ( ) on the History palette, or choose New Snapshot from the 
History palette pop-up menu.

3    Enter the name of the Snapshot in the Name text box.
4    For From, select the snapshot contents:

•      Full Document to make a snapshot of all layers in the image at that state.
•      Merged Layers to make a snapshot that merges all layers in the image at that state.
•      Current Layer to make a snapshot of only the currently selected layer at that state.

5    Click OK.

See also: 

To select a snapshot 

To delete a snapshot 



Making a snapshot of the image 

To select a snapshot:

Do any of the following:
•      Click the name of the snapshot.
•      Drag the slider at the left of the snapshot up or down to a different snapshot.

See also: 

To create a snapshot 

To delete a snapshot 



Making a snapshot of the image 

To delete a snapshot:

Do one of the following:
•      Select the snapshot, and choose Delete from the pop-up menu on the palette.
•      Select the snapshot, and click the Trash button ( ).

•      Drag the snapshot to the Trash button ( ).

See also: 

To create a snapshot 

To select a snapshot 



Reverting to any state of the image 

Painting with a state or snapshot of the image

The history brush tool lets you paint a copy of one state or snapshot of an image into the current 
image window. This tool makes a copy, or sample, of the image and then paints with it.

For example, you might make a snapshot of a change you made with a painting tool or filter. After 
undoing the change to the image, you could use the history brush tool to apply the change selectively 
to areas of the image. Unless you select a merged snapshot, the history brush tool paints from a layer 
in the selected state to the same layer in another state.

The history brush tool works similarly to the rubber stamp tool, but on any state or snapshot of the 
image, not just the current one. (See Using the rubber stamp tool and pattern stamp tool.)

To paint with a state or snapshot of an image:

1    Double-click the history brush tool ( ) to display its Options palette.
2    Specify the opacity and blending mode as explained in Using the Options palette for painting and 
editing tools.
3    Choose a brush size, as explained in Using the Brushes palette.
4    If desired, select Impressionist to paint with an “impressionistic” copy of the source state or snapshot. 
This option drags and smears the pixels as you paint.

Original image, and with Impressionist option

5    In the History palette, click the left column of the state or snapshot to use as the source for the 
history brush tool.

6    Drag to paint with the history brush tool.



Editing and Retouching 

Duplicating images

You can copy an entire image (including all layers, layer masks, and channels) into available memory 
without saving to disk by using the Duplicate command or by dragging and dropping. 

To copy an image using the Duplicate command:

1    Open the image you want to copy.

2    Choose Image > Duplicate.

3    Enter a name for the copied image.

4    To duplicate the image without layers, select Merged Layers Only.

5    Click OK.
 To duplicate an image and automatically append the name “copy” to it, hold down Alt (Windows) or 

Option (Mac OS) as you choose Image > Duplicate.
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Using rulers, the measure tool, guides, and grids

Rulers, the measure tool, guides, and grids help you position images or elements precisely across the 
width or length of an image.

Note: You can also align and distribute parts of an image by using the Layers palette. (See Moving and 
aligning layer contents.)

See also: 

Using rulers 

Using the measure tool 

Using guides and the grid 



Using rulers, the measure tool, guides, and grids 

Using rulers

When visible, rulers appear along the top and left side of the active window. Markers in the ruler 
display the pointer’s position when you move it. Changing the ruler origin (the 0, 0 mark on the top and
left rulers) lets you measure from a specific point on the image.The ruler origin also determines the 
grid’s point of origin.

See also: 

To display or hide rulers 

To change the rulers’ zero origin 

To change the rulers’ settings 



Using rulers 

To display or hide rulers:

Choose View > Show Rulers or Hide Rulers.

See also: 

To change the rulers’ zero origin 

To change the rulers’ settings 



Using rulers 

To change the rulers’ zero origin:

1    To snap the ruler origin to guidelines or gridlines, choose View > Snap to Guides or View > Snap to
Grid.

2    Position the pointer over the intersection of the rulers in the upper left corner of the window, and 
drag diagonally down onto the image. To make the ruler origin snap to the ruler ticks, hold down Shift 
as you drag. A set of cross hairs appears while you drag, marking the new origin on the rulers.

Note: To reset the ruler origin to its default value, double-click the upper left corner of the rulers.

Dragging to create new ruler origin and result

See also: 

To display or hide rulers 

To change the rulers’ settings 



Using rulers 

To change the rulers’ settings:

1    Do one of the following:
•      Double-click a ruler. 
•      Choose File > Preferences > Units & Rulers.

2    For Units, choose a unit of measurement.

Note: Changing the units on the Info palette changes the units on the rulers to match them.

3    For Width and Gutter, enter values for the column size. You also can change the units.

Some layout programs use the column width setting to specify the display of an image across 
columns. The Image Size and Canvas Size commands also use this setting. (See Changing the print 
dimensions and resolution of an image and Increasing the size of the work canvas.)

4    For Point/Pica Size, choose from the following options:
•      PostScript (72 points per inch) if you are printing to a PostScript device.
•      Traditional to use printer’s 72.27 points per inch.

5    Click OK.

See also: 

To display or hide rulers 

To change the rulers’ zero origin 
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Using the measure tool

The measure tool calculates the distance between any two points in the work area. When you 
measure from one point to another, a non-printing line is drawn and the Info palette shows the 
following information:
•      The starting location (X and Y).
•      The horizontal (W) and vertical (H) distances traveled from the x and y axes.
•      The total distance traveled (D).
•      The angle measured relative to the axis (A).
•      Optionally, set a second measuring line to create a protractor. This lets you measure angles 
separated from the x and y axes, and view two distances traveled (D1 and D2).

All measurements except the angle are calculated in the unit of measure currently set in the Units & 
Rulers preference dialog box. For information on setting the unit of measure, see Using rulers. For 
information on applying the values made by the measure tool to the Numeric Transform dialog box, 
see Transforming numerically.

See also: 

To display an existing measuring line 

To measure between two points 

To edit a measuring line or protractor 



Using the measure tool 

To display an existing measuring line:

Select the measure tool ( ).

See also: 

To measure between two points 

To edit a measuring line or protractor 



Using the measure tool 

To measure between two points:

1    Select the measure tool ( ).
2    Drag from the starting point to the ending point. Hold down the Shift key to constrain the tool to 
multiples of 45°.
3    To create a protractor from an existing measuring line, Alt-drag (Windows) or Option-drag (Mac OS) at 
an angle from one end of the measuring line. Hold down the Shift key to constrain the tool to multiples of 
45°.

See also: 

To display an existing measuring line 

To edit a measuring line or protractor 



Using the measure tool 

To edit a measuring line or protractor:

1    Select the measure tool ( ).
2    Do one of the following:

•      To resize the line, drag one end of an existing measuring line. 
•      To move the line, place the pointer on the line away from either endpoint and drag the line.
•      To remove the line, place the pointer on the line away from either endpoint and drag the line out of 
the image.

See also: 

To display an existing measuring line 

To measure between two points 
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Using guides and the grid

Guides appear as lines that float over the entire image and do not print. You can move, remove, or 
lock a guide to avoid accidentally moving it. The grid appears by default as nonprinting lines but can 
also be displayed as dots. The grid is useful for laying out elements symmetrically.

Guides and grids behave in similar ways:
•      Selections, selection borders, and tools snap to a guide or the grid when dragged within 8 screen 
(not image) pixels. Guides also snap to the grid when moved. You can turn this feature on and off. 
•      Guide spacing, along with guide and grid visibility and snapping, is specific to an image.
•      Grid spacing, along with guide and grid color and style, is the same for all images. 

See also: 

To show or hide guides or the grid 

To place a guide 

To move a guide 

To lock all guides 

To remove guides from the image 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To show or hide guides or the grid:

Choose View > Show/Hide Guides or Show/Hide Grid.

See also: 

To place a guide 

To move a guide 

To lock all guides 

To remove guides from the image 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To place a guide:

1    If the rulers are not visible, choose View > Show Rulers.

Note: For the most accurate readings, view the image at 100% magnification or use the Info palette.

2    Create a guide:
•      Drag from the horizontal ruler to create a horizontal guide.

Dragging to create a horizontal guide
•      Hold Alt (Windows) or Option (Mac OS) and drag from the vertical ruler to create a horizontal 
guide.
•      Drag from the vertical ruler to create a vertical guide.
•      Hold Alt (Windows) or Option (Mac OS) and drag from the horizontal ruler to create a vertical 
guide.

The pointer changes to a double-headed arrow when you drag a guide.

See also: 

To show or hide guides or the grid 

To move a guide 

To lock all guides 

To remove guides from the image 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To move a guide:

1    Select the move tool ( ).
2    Position the pointer over the guide (the pointer turns into a double-headed arrow).
3    Move the guide:

•      Drag the guide to move it. 
•      Change the guide from horizontal to vertical, or vice versa, by holding down Alt (Windows) or 
Option (Mac OS) as you click or drag the guide.
•      Align the guide with the ruler ticks by holding down Shift as you drag the guide. The guide will snap
to the grid if the grid is visible and View > Snap to Grid is selected.

See also: 

To show or hide guides or the grid 

To place a guide 

To lock all guides 

To remove guides from the image 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To lock all guides:

Choose View > Lock Guides.

See also: 

To show or hide guides or the grid 

To place a guide 

To move a guide 

To remove guides from the image 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To remove guides from the image:

Do one of the following:
•      To remove a single guide, drag the guide outside the image window.
•      To remove all guides, choose View > Clear Guides.

See also: 

To show or hide guides or the grid 

To place a guide 

To move a guide 

To lock all guides 

To turn snapping to guides or the grid on or off 

To set guide and grid preferences 



Using guides and the grid 

To turn snapping to guides or the grid on or off:

Choose View > Snap to Guides or Snap to Grid, respectively.

Grids turned on

See also: 

To show or hide guides or the grid 

To place a guide 

To move a guide 

To lock all guides 

To remove guides from the image 

To set guide and grid preferences 



Using guides and the grid 

To set guide and grid preferences:

1    Choose File > Preferences > Guides & Grid.

2    For Color, choose a color for guides or the grid, or both. If you choose Custom, click the color box, 
choose a color, as described in Using the Color palette, and click OK.

3    For Style, choose a display option for guides or the grid, or both. 

4    For Gridline Every, enter a value for the grid spacing. For Subdivisions, enter a value to subdivide 
the grid. 

If desired, change the units for this option. The Percent option creates a grid that divides the image up 
into even sections. For example, choosing 25 for the Percent option creates an evenly divided 4 by 4 
grid.

5    Click OK.

See also: 

To show or hide guides or the grid 

To place a guide 

To move a guide 

To lock all guides 

To remove guides from the image 

To turn snapping to guides or the grid on or off 
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Moving, copying, and pasting selections

You can move or copy selections and layers within or between Photoshop images—and also between 
images in Photoshop and other applications.

See also: 

Moving selections and layers within an image 

Copying selections or layers 

Using drag and drop to copy between applications 

Using the Clipboard to copy between applications 



Moving, copying, and pasting selections 

Moving selections and layers within an image

The move tool lets you drag a selection or layer to a new location in the image. With the Info palette 
open, you can track the exact distance of the move.

To specify move tool options:

1    Double-click the move tool ( ) to display its Options palette.
2    In the Move Options palette, select any of the following:

•      Pixel Doubling to speed the preview of the move tool’s effect by temporarily doubling the size of 
the pixels (halving the resolution) in the preview. This option has no effect on the pixels in the file, it 
simply provides faster previews with the tool.
•      Auto Select Layer to select the topmost layer that has pixels under the move tool, rather than the 
selected layer.

To move a selection or layer:

1    Select the move tool ( ). 
To activate the move tool when another tool is selected, hold down Ctrl (Windows) or Command (Mac 
OS). (This technique does not work with the pen tool ( ), direct-selection tool (

), hand tool (
), magnifying glass tool (
), or anchor-point tools (

) (
) (
).)

2    Do one of the following:
•      Move the pointer inside the selection border, and drag the selection to a new position. If you have 
selected multiple areas, all move as you drag.

Original selection, and selection moved with move tool
•      Select the layer you want to move. Then drag the layer to a new position.



Moving, copying, and pasting selections 

Copying selections or layers

You can use the move tool to copy selections as you drag them within or between Photoshop images. 
Or you can copy and move selections using the Copy, Copy Merged, Cut, and Paste commands. 
Dragging with the move tool saves memory because the Clipboard is not used as it is with the Copy, 
Copy Merged, Cut, and Paste commands. 

Keep in mind that when a selection or layer is pasted between images with different resolutions, the 
pasted data retains its pixel dimensions. This can make the pasted portion appear out of proportion to 
the new image. Use the Image Size command to make the source and destination images the same 
resolution before copying and pasting. 

Photoshop includes two copy and two paste commands:
•      The Copy command copies the selected area on the active layer.
•      The Copy Merged command makes a merged copy of all the visible layers in the selected area.
•      The Paste command pastes a cut or copied selection into another part of the image or into another
image as a new layer. 
•      The Paste Into command pastes a cut or copied selection inside another selection in the same 
image or different image. The source selection is pasted onto a new layer, and the destination 
selection border is converted into a layer mask. (See Using layer masks.)

See also: 

To copy a selection 

To copy a selection while dragging 

To create multiple copies of a selection within an image 

To paste one selection into another 



Copying selections or layers 

To copy a selection:

1    Select the area you want to copy.

2    Choose Edit > Copy or Edit Copy Merged.

See also: 

To copy a selection while dragging 

To create multiple copies of a selection within an image 

To paste one selection into another 



Copying selections or layers 

To copy a selection while dragging: 

1    Select the move tool ( ) or hold down Ctrl (Windows) or Command (Mac OS) to activate the move
tool. 

2    Hold down Alt (Windows) or Option (Mac OS), and drag the selection you want to copy and move. 
When copying between images, drag the selection from the active image window into the destination 
image window. If nothing is selected, the entire active layer is copied. As you drag the selection over 
another image window, a border highlights the window if you can drop the selection into it.

See also: 

To copy a selection 

To create multiple copies of a selection within an image 

To paste one selection into another 



Copying selections or layers 

To create multiple copies of a selection within an image: 

1    Select the move tool ( ) or hold down Ctrl (Windows) or Command (Mac OS) to activate the move
tool.

2    Copy the selection:
•      To copy the selection and offset the duplicate by 1 pixel, hold down Alt (Windows) or Option (Mac 
OS), and press an arrow key.
•      To copy the selection and offset the duplicate by 10 pixels, press Alt+Shift/Option+Shift, and press 
an arrow key.
•      Hold down Alt/Option and drag the selection.

As long as you hold down Alt/Option, each press of an arrow key creates a copy of the selection and 
offsets it by the specified distance from the last duplicate. 

Selection dragged to new image, and result 

See also: 

To copy a selection 

To copy a selection while dragging 

To paste one selection into another 



Copying selections or layers 

To paste one selection into another: 

1    Cut or copy the part of the image you want to paste. 

2    Select the part of the image into which you want to paste the selection. The source selection and 
the destination selection can be in the same image or in two different Photoshop images.

Source selection, and destination selection

3    Choose Edit > Paste Into. The contents of the source selection appear masked by the destination 
selection. 

In the Layers palette, the layer thumbnail for the source selection appears next to the layer mask 
thumbnail for the destination selection. The layer and layer mask are unlinked—that is, you can move 
each one independently.

Source selection pasted into destination selection

For more information on editing layer masks, see Applying and discarding layer masks.

4    Select the move tool ( ), or hold down the Ctrl (Windows) or Command (Mac OS) key to activate 
the move tool. Then drag the source contents until the part you want appears through the mask.

5    To reveal more or less of the image underlying the layer, click the layer mask thumbnail in the Layers 
palette, select a painting tool, and edit the mask:

•      To hide more of the image underlying the layer, paint the mask with black.
•      To reveal more of the image underlying the layer, paint the mask with white.
•      To partially reveal the image underlying the layer, paint the mask with gray.

6    If you are satisfied with your results, you can choose Layer > Merge Down to merge the new layer 
and layer mask with the underlying layer and make the changes permanent.

See also: 

To copy a selection 

To copy a selection while dragging 



To create multiple copies of a selection within an image 



Moving, copying, and pasting selections 

Using drag and drop to copy between applications

The drag-and-drop feature lets you copy and move artwork between Photoshop and other 
applications.

In Windows, the application must be OLE-compliant. To duplicate an entire Photoshop image by 
dragging and dropping, use the move tool to drag the image. To copy an OLE object that contains .psd
data, use the OLE Clipboard. (See your Windows documentation.) Dragging vector artwork from 
Adobe Illustrator or from other applications that use the Illustrator Clipboard converts the artwork to a 
bitmap image (also called raster format). To copy the artwork as a path in Adobe Photoshop, hold 
down Ctrl as you drag.

In Mac OS, the application must support Macintosh Drag Manager.



Moving, copying, and pasting selections 

Using the Clipboard to copy between applications

You can often use the Edit > Cut or Copy commands to copy selections between Photoshop and other
applications. The cut or copied selection remains on the Clipboard until you cut or copy another 
selection. By default, the contents of the Clipboard are usually converted to a bitmap image (also 
called raster format), or rasterized. 

This automatic conversion lets you paste the Clipboard’s contents into another application. But 
because it can be time-consuming, you may want to disable it if you don’t plan to paste the Clipboard 
contents into another application. You can still paste selections between Photoshop images.

Note: If you are using the system, not the Adobe Clipboard, this technique resizes your image based 
on an image size of 96 dpi for Windows, and 72 dpi for the Mac OS.

See also: 

To change the Export Clipboard preference 

To paste PostScript artwork from another application to Photoshop 



Using the Clipboard to copy between applications 

To change the Export Clipboard preference:

1    Choose File > Preferences > General. 

2    Select Export Clipboard to save any Photoshop contents on the Clipboard when quitting 
Photoshop. Leaving this option unselected deletes any Photoshop contents on the Clipboard when 
quitting the program.

3    Click OK.

See also: 

To paste PostScript artwork from another application to Photoshop 



Using the Clipboard to copy between applications 

To paste PostScript artwork from another application to Photoshop:

1    In the supporting application, select your artwork, and choose Edit > Copy. Applications which 
produce PostScript artwork include Adobe Illustrator (version 5.0 and later), Adobe Dimensions, and 
Adobe Streamline. (See Photoshop EPS.)

2    In Adobe Photoshop, make active the image into which you’ll paste the selection.

3    Choose Edit > Paste.

4    In the dialog box that appears, choose from the following options: 
•      Paste as Pixels to have the artwork rasterized as it is pasted. Rasterizing converts mathematically 
defined vector artwork to the pixels displayed in Adobe Photoshop. 
•      Paste as Paths to paste the copy as a path in the Paths palette.

5    If you chose Paste as Pixels in the previous step, do one of the following:
•      Keep Anti-aliasing selected to make a smooth transition between the edges of the selection and 
the surrounding pixels. (See Softening the edges of a selection.)
•      Deselect Anti-aliasing if you want the selection to have a crisp edge. 

Note: If anti-aliasing causes ghosting, you can also use the Matting commands. (See Removing fringe 
pixels from a selection.)

6    Click OK.

See also: 

To change the Export Clipboard preference 



Editing and Retouching 

Deleting a selection

To delete a selection, choose Edit > Clear or press Delete. To cut a selection to the Clipboard, choose 
Edit > Cut. Deleting a selection on a background or on a layer with the Preserve Transparency option 
selected replaces the original location with the background color. Deleting a selection on a layer with 
the Preserve Transparency option deselected replaces the original area with the layer transparency.



Editing and Retouching 

Removing fringe pixels from a selection

When you move or paste an anti-aliased selection, some of the pixels surrounding the selection 
border are included with the selection. This can result in a fringe or halo around the edges of the 
pasted selection. These three Matting commands let you edit these unwanted edge pixels: 
•      Defringe replaces the color of any fringe pixels with the colors of nearby pixels containing pure 
colors (those without background color). For example, if you select a yellow object on a blue 
background and then move the selection, some of the blue background is selected and moved with 
the object. Defringe replaces the blue pixels with yellow ones.
•      Remove Black Matte and Remove White Matte are useful when you want to paste a selection anti-
aliased against a white or black background onto a different background. For example, anti-aliased 
black text on a white background has gray pixels at the edges, which are visible against a colored 
background.
 You can also remove fringe areas by using the sliders in the Layer Options dialog box to remove, or 

make transparent, areas from the layer. In this case, you would make the black or white areas 
transparent.

See also: 

To decrease a fringe on a selection 

To remove a matte from a selection 



Removing fringe pixels from a selection 

To decrease a fringe on a selection: 

1    Choose Layer > Matting > Defringe.

2    Enter a value in the Width text box for the distance to search for replacement pixels, and then click 
OK. In most cases, a distance of 1 or 2 pixels is enough.

Original selection, and selection defringed: 2 pixels



Removing fringe pixels from a selection 

To remove a matte from a selection:

Choose Layer > Matting > Remove Black Matte or Remove White Matte.



Editing and Retouching 

Transforming objects in two dimensions

You can scale, rotate, skew, distort, and apply perspective to selected parts of an image, entire layers,
paths, and selection borders. You can also rotate and flip part or all of a layer, an entire image, path, or
selection border. 

Original path and scaled path

Original selection and scaled selection border

Use the following guidelines when applying transformations:
•      You can transform a linked layer. The transformation affects all the layers in the linking group. 
•      You cannot apply transformations to the background as a layer, or on 16-bit-per-channel images. 
You can, however, transform selections on the background.
•      You can apply transformations to an alpha channel by first selecting it in the Channels palette. 
(See Using alpha channels.)
•      You can apply transformations to a layer mask by first selecting its thumbnail in the Layers palette.
(See Using layer masks.)
•      Pixels are added or deleted during transformations. To calculate the color values of these pixels, 
Adobe Photoshop uses the interpolation method selected in the General Preferences dialog box. This 
option directly affects the speed and quality of the transformation. Bicubic interpolation, the default, is 
slowest but yields the best results. (See Choosing an interpolation method.)

See also: 

To specify what to transform 

Rotating and flipping an entire image 

Applying a specific transformation 

Freely transforming and previewing effects 

Transforming numerically 





Transforming objects in two dimensions 

To specify what to transform:

Do one of the following:
•      To transform part of a layer, select the layer, and then select part of the image on that layer. (See 
Using the Layers palette and Selecting.)
•      To transform an entire layer, make the layer active, and make sure that nothing is selected. (See 
Using the Layers palette.)
•      To transform a path, choose a path tool or select part or all of the path. If you select one or more 
points on a path, only those path segments connected to the points are transformed. (See Selecting 
path segments.)
•      To transform a selection border, make or load a selection. (See Selecting.)

To move the center point for the transformation:

Drag the center point. The center point can be outside the part of the image, the path, or the selection 
you want to transform.



Transforming objects in two dimensions 

Rotating and flipping an entire image

The Rotate Canvas commands let you rotate or flip the entire image. It does not work on individual 
layers or parts of layers, paths, or selection borders.

Original image, and with canvas rotated

To rotate or flip an entire image:

Choose Image > Rotate Canvas and, from the submenu, choose one of the following commands:
•      180° to rotate the image by a half-turn.
•      90° CW to rotate the image clockwise by a quarter-turn.
•      90° CCW to rotate the image counterclockwise by a quarter-turn.
•      Arbitrary to rotate the image by the angle you specify. If you choose this option, enter an angle 
between -359.99 and 359.99 in the angle text box, then select CW or CWW to rotate clockwise or 
counterclockwise. Click OK.
•      Flip Horizontal to flip the image horizontally, along the vertical axis.
•      Flip Vertical to flip the image vertically, along the horizontal axis.



Transforming objects in two dimensions 

Applying a specific transformation

The commands under the Transform submenu let you apply specific transformations to a selection, 
layer, path, or selection border. Photoshop previews the effect and surrounds the selected area with a 
bounding border that lets you manipulate the selection, layer, or path.

Original image, and with green leaf layer rotated

You can apply several commands in succession before applying the cumulative transformation. For 
example, you can choose Scale, drag a handle to scale, and then choose Distort, drag a handle to 
distort, and press Enter (Windows) or Return (Mac OS) to apply both transformations. For information 
about making a layer active, see Using the Layers palette. 

See also: 

To scale, rotate, skew, distort, or apply perspective 

To flip or rotate 

To repeat a transformation 

To duplicate an item when transforming it 



Applying a specific transformation 

To scale, rotate, skew, distort, or apply perspective:

1    Do one of the following:
•      To transform part or all of a layer, select it. Then choose Edit > Transform > Scale, Rotate, Skew, 
Distort, or Perspective.
•      To transform part or all of a path, select it. Then choose Edit > Transform Points or Transform Path
> Scale, Rotate, Skew, Distort, or Perspective.

Note: Distort and Perspective are only available when transforming entire paths.
•      To transform a selection border, make or load one. Choose Select > Transform Selection. Then 
choose Edit > Transform > Scale, Rotate, Skew, Distort, or Perspective.
 To scale or skew around the center point, press Alt (Windows) or Option (Mac OS) when choosing the 

Scale or Skew command.

2    Drag the handles to achieve the desired effect.

3    To apply additional transformations, repeat steps 1 and 2.

4    Press Enter (Windows) or Return (Mac OS) to apply the cumulative transformation. Press Esc to 
cancel the transformation.

See also: 

To flip or rotate 

To repeat a transformation 

To duplicate an item when transforming it 



Applying a specific transformation 

To flip or rotate:

1    Do one of the following:
•      To flip or rotate part or all of a layer, select it.
•      To flip or rotate part or all of a path, select it. 
•      To transform a selection border, make or load one. Then choose Select > Transform Selection.

2    Choose Edit > Transform, Transform Points, or Transform Path and, from the submenu, choose 
one of the following commands:
•      Rotate 180° to rotate by a half-turn.
•      Rotate 90° CW to rotate clockwise by a quarter-turn.
•      Rotate 90° CCW to rotate counterclockwise by a quarter-turn.
•      Flip Horizontal to flip horizontally, along the vertical axis.
•      Flip Vertical to flip vertically, along the horizontal axis.

Original selection, and with selection on green leaf layer flipped

See also: 

To scale, rotate, skew, distort, or apply perspective 

To repeat a transformation 

To duplicate an item when transforming it 



Applying a specific transformation 

To repeat a transformation:

Choose Edit > Transform > Again, Transform Points > Again, or Transform Path > Again.

See also: 

To scale, rotate, skew, distort, or apply perspective 

To flip or rotate 

To duplicate an item when transforming it 



Applying a specific transformation 

To duplicate an item when transforming it:

Press Ctrl+Alt+T (Windows) or Command+Option+T (Mac OS), or hold down Alt/Option when 
selecting the Transform command.

See also: 

To scale, rotate, skew, distort, or apply perspective 

To flip or rotate 

To repeat a transformation 



Transforming objects in two dimensions 

Freely transforming and previewing effects

The Free Transform command lets you use the Scale, Rotate, Skew, Distort, and Perspective 
commands without having to select them from the menu. To access the various transformation modes,
you use different shortcut keys as you drag the handles of the transform bounding box.

To freely transform:

1    Specify what to transform:
•      To transform part or all of the layer, select it. Then choose Edit > Free Transform. 
•      To transform part or all of the path, select it. Then choose Edit > Free Transform Points or Free 
Transform Path. 
•      To transform a selection border, create or load one. Then choose Select > Transform Selection.

2    Transform as follows:
•      To move, position the pointer inside the bounding border (it turns into a black arrowhead), and 
drag.
•      To scale, drag a handle. Press Shift as you drag a corner handle to scale proportionately. When 
positioned over a handle, the pointer turns into a double arrow.

Drag handle to scale, and result
•      To rotate, move the pointer outside of the bounding border (it turns into a curved, two-sided arrow),
and then drag. Press Shift to constrain the rotation to 15° increments. 

Rotate
•      To distort freely, press Control (Windows) or Command (Mac OS), and drag a handle.

Distort freely



•      To distort relative to the center point of the bounding border, press Alt (Windows) or Option (Mac 
OS), and drag a handle.

Distort symmetrically
•      To skew, press Control+Shift (Windows) or Command+Shift (Mac OS), and drag a side handle. 
When positioned over a side handle, the pointer turns into a white arrowhead with a small double 
arrow.

Skew
•      To apply perspective, press Control+Alt+Shift (Windows) or Command+Option +Shift (Mac OS), 
and drag a corner handle. When positioned over a corner handle, the pointer turns into a gray 
arrowhead.

Apply perspective

To undo the last handle adjustment, choose Edit > Undo.

3    Press Enter (Windows) or Return (Mac OS) to apply the transformation. To cancel the 
transformation, press Esc.



Transforming objects in two dimensions 

Transforming numerically

The Numeric command lets you scale, rotate, skew, or move part of the image, a layer, path, or 
selection border precisely, by entering specific numeric values for the transformation.

To transform a layer or path numerically:

1    Specify what to transform:
•      To transform part or all of an image on a layer, select it. Then choose Edit > Transform > Numeric.
•      To transform part or all of a path, select it. Then choose Edit > Transform Points > Numeric or 
Transform Path > Numeric.
•      To transform a selection border, make or load one. Choose Select > Transform Selection. Then 
choose Edit > Transform > Numeric.

2    Deselect any transformation option in the dialog box to turn it off.

3    Transform as follows:
•      To move, select Position. Choose the unit of measurement from the menus; then enter a horizontal
distance in the X text box and a vertical distance in the Y text box. To move relative to the existing 
image, layer, or path, select Relative. Otherwise, the movement is relative to the top left corner of the 
image.
•      To resize, select Scale. Choose the unit of measurement from the menus; then enter values for the
Width and Height. Select Constrain Proportions to scale proportionally.
•      To skew, select Skew. Then enter values for the Horizontal and Vertical angles of slant.
•      To rotate, select Rotate. Then enter a value for Angle or drag the radius inside the circle to the 
desired angle of rotation.

4    Click OK.



Editing and Retouching 

Transforming objects in three dimensions

The 3D Transform filter lets you manipulate a flat, two-dimensional image as if it were a solid, 3-D 
object. Take, for example, a perspective photograph of a cereal box. You specify the corners of the 
box using a wire frame, and can then manipulate the box as if it were a 3-dimensional object. You can 
reposition the box, turn or rotate it, shrink or enlarge it, and change its field of view.

In addition to boxes, you can manipulate spheres and cylinders using wire frames based on those 
shapes. Cylinders can include anything from simple objects, such as a can of soup, to shapes whose 
sides are lathed, such as a bottle or a lamp.

You can create and manipulate any grouping of cubes, spheres, and cylinders in the same image. For 
example, you can create and rotate a box, two balls, and a bottle together in the same image.

Wire frames around cubes, spheres, and cylinders

See also: 

To transform an object in three dimensions 

To delete a wire frame 

To manipulate the object in three dimensions 

To magnify or shrink the preview image 

To move the view of the preview image 

To specify rendering options 



Transforming objects in three dimensions 

To transform an object in three dimensions:

1    Choose Filters > Render > 3D Transform.

2    Select one of these tools in the dialog box:

•      Cube ( ) to map the image (such as a file cabinet) to a cubic surface.
•      Sphere ( ) to map the image (such as a globe or ball) to a spherical surface.
•      Cylinder ( ) to map the image (such as a can or bottle) to a cylindrical surface.

3    Drag to create a cubic, cylindrical, or spherical wire frame over the image.

4    Move or reshape the wire frame as described in this section. The anchor points should line up with 
the corners of the box, or the top and bottom of the sphere or cylinder you want to manipulate.

5    Manipulate the object in three dimensions as described in this section.

6    Click OK.

To move or reshape the wire frame:

1    Select the selection tool ( ) or direct-selection tool (
) in the dialog box.

2    Do either of the following:
•      Drag an edge of the wire frame to move the entire frame.
•      With the direct-selection tool, drag an anchor point on the wire frame to move that anchor point.

Note: The wire frame turns red if you try to make a wire frame that would be impossible to re-create in
three dimensions.

Dragging to reshape wire frame over box

3    If you are creating a complex cylinder, do any of the following:
•      To add an anchor point to a cylinder, select the add-anchor-point tool ( ) in the dialog box, and 
click the right side of the wire frame. For example, you can add an anchor point to more closely fit the 
cylindrical wire frame to a picture of a bottle.

Original, and with smooth point added
•      To change an added anchor point from a smooth anchor point to a corner anchor point and vice 
versa, select the convert-anchor-point tool ( ) and click the point. A smooth anchor point creates a 



gentle curve when you adjust it, a corner anchor point creates a sharp corner.
•      To delete an added anchor point, select the delete-anchor-point-tool ( ) and click the point.

4    For Field of View, enter a value between 1 and 130 or drag the slider to the left to increase the 
apparent field of view, right to decrease it.This can make the wire frame fit the image better. If you 
know the field of view angle used to photograph the image, you can enter it here.

Field of view 76, and field of view 36



Transforming objects in three dimensions 

To delete a wire frame:

1    Select the selection tool ( ) in the dialog box.
2    Select the wire frame and press Delete.



Transforming objects in three dimensions 

To manipulate the object in three dimensions:

Do any of the following:
•      To move the object, click the pan camera tool in the dialog box and drag the object.
•      To rotate the object in any direction, click the trackball tool, and drag the object.
•      For Dolly Camera, enter a value between 0 and 100 or drag the slider to the left to magnify the 
transformed object, right to shrink it. This has the same effect as if you were dollying, or moving, the 
camera further from or closer to the image.
•      For Field of View, enter a value between 1 and 130 or drag the slider to the left to increase the 
apparent field of view, right to decrease it.



Transforming objects in three dimensions 

To magnify or shrink the preview image:

1    Select the zoom tool ( ) in the dialog box.
2    Click the image to Zoom in, or Alt-click (Windows) or Option-click (Mac OS) to zoom out.



Transforming objects in three dimensions 

To move the view of the preview image:

Select the hand tool ( ) in the dialog box, and drag the hand to drag the preview image. This only 
works if you are zoomed in on the image.



Transforming objects in three dimensions 

To specify rendering options:

1    Click Options.

2    Do any of the following:
•      For Resolution, choose the quality of the rendered image. The setting has little effect on the image
quality of cubes, but will produce smoother curved surfaces in cylinders and spheres.
•      For Anti-aliasing, choose the level of anti-aliasing to apply to the rendered image.
•      Select Display Background to include the portions of the original image outside of the wire frame in
the preview and with the rendered image. Turn this option off to separate the transformed object from 
the original background.

3    Click OK
 The 3D Transform dialog box previews only the active layer. As you manipulate an object in three 

dimensions, you can align it with the contents of the underlying layers. Duplicate the layer to align to, and 
place it directly under the layer to be transformed in the layer stacking order. Merge the layer to be 
transformed with the duplicated layer. With the Display Background option enabled in the 3D Transform 
dialog box, manipulate the object on the layer. When the layer is aligned, disable the Display Background 
option and click OK.
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Using the rubber stamp tool and pattern stamp tool 

The rubber stamp tool takes a sample of the image, which you can then apply over another image or 
part of the same image. Each stroke of the tool paints on more of the sampled image. Cross hairs 
mark the original sampling point. The pattern stamp tool lets you select part of an image and paint with
the selection as a pattern.

For information on restoring painted areas to their previous states, see Painting with a state or 
snapshot of the image. 

To use the rubber stamp tool and pattern stamp tool:

1    Double-click the rubber stamp tool ( ) or pattern stamp tool (
) to display its Options palette.

2    Do any of the following:
•      Specify the blending mode and opacity as explained in Using the Options palette for painting and 
editing tools.
•      Choose a brush size as explained in Using the Brushes palette
•      If you are using a pressure-sensitive drawing tablet, select Size to change the brush size with 
changes in stylus pressure, Opacity to change the opacity.

3    If you are using the rubber stamp tool, select Use All Layers to sample data from all visible layers. 
If left deselected, the tool samples only from the active layer.

4    Do one of the following:
•      With the rubber stamp tool, select Aligned to apply the entire sampled area once, regardless of 
how many times you stop and resume painting. This option is useful when you want to use different 
sized brushes to paint an image. You can also use the Aligned option to duplicate two halves of a 
single image and place them at different locations. 
•      With the rubber stamp tool, deselect Aligned to apply the sampled area from the initial sampling 
point each time you stop and resume painting. Because the rubber stamp tool samples the entire 
image, this option is useful for applying multiple copies of the same part of an image to different 
images. 
•      With the pattern stamp tool, select Aligned to repeat the pattern as contiguous, uniform tiles, even 
when you stop and resume painting in different parts of the image.
•      With the pattern stamp tool, deselect Aligned to center the pattern on the pointer each time you 
stop and resume painting. 

5    Set the sampling point or pattern:
•      For the rubber stamp tool, position the pointer on the part of any open image you want to sample, 
and Alt-click (Windows) or Option-click (Mac OS). This sample point is the location from which the 
image is duplicated as you paint. 

Sampling point, and with cross hairs marking the part of the original being applied
•      For the pattern stamp tool, use the rectangle marquee tool ( ) on any open image to select an 



area to use as a pattern. Then choose Edit > Define Pattern. Reselect the pattern stamp tool.

Area defined for pattern, and painted

Note: If you are sampling or using a pattern from one image and applying to another, both images 
must be in the same color mode.

6    Drag to paint with the tool.
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Using other retouching tools

You can also retouch images using the smudge, focus, and toning tools. 

Note: The smudge, focus, and toning tools can’t be used with Bitmap or Indexed color mode images.

The tools work in the following ways:
•      The smudge tool simulates the actions of dragging a finger through wet paint. The tool picks up 
color where the stroke begins and pushes it in the direction you drag. 

Original image, and smudging an image
•      The focus tools consist of the blur tool and the sharpen tool. The blur tool softens hard edges or 
areas in an image to reduce detail. The sharpen tool focuses soft edges to increase clarity or focus. 
For other ways to adjust image sharpness, see Step 6: Sharpen the image, or Improving performance 
with filters.

Blurring an image, and sharpening an image
•      The toning tools consist of the dodge tool and the burn tool. Used to lighten or darken areas of the 
image, the dodge and burn tools are based on a traditional photographer’s technique for regulating 
exposure on specific areas of a print. Photographers hold back light to lighten an area on the print 
(dodging) or increase the exposure to darken areas on a print (burning). 

Burning an image, and dodging an image
•      The sponge tool subtly changes the color saturation of an area. In Grayscale mode, the sponge 
tool increases or decreases contrast by moving gray levels away from or toward the middle gray.



Original image, and increasing saturation of an image

To use the smudge tool:

1    Double-click the smudge tool ( ) to display its Options palette.
2    Specify the blending mode and pressure as described in Using the Options palette for painting and 
editing tools.
3    If you are using a pressure-sensitive drawing tablet, choose Size or Pressure as described in 
Specifying stylus pressure options.
4    Select a brush size as described in Using the Brushes palette.
5    Select Finger Painting to smudge using the foreground color at the beginning of each stroke. If you 
leave this option deselected, the smudge tool uses the color under the pointer at the beginning of each 
stroke.
6    Select Use All Layers to smudge using color data from all visible layers. If deselected, the smudge tool
uses colors only from the active layer.

7    Drag in the image to smudge color.
 Press Alt (Windows) or Option (Mac OS) as you drag with the smudge tool to use the Finger Painting 

option.

To use the blur or sharpen tool:

1    Double-click the blur tool ( ) or sharpen tool (
) to display its Options palette. 

2    Specify the blending mode and pressure as described in Using the Options palette for painting and 
editing tools.
3    If you are using a pressure-sensitive drawing tablet, choose Size or Pressure as described in 
Specifying stylus pressure options.
4    Select a brush size as described in Using the Brushes palette.
5    To blur or sharpen using data from all visible layers, select Use All Layers. If deselected, the blur or 
sharpen tool uses data only from the active layer.
6    Drag over the part of the image you want to blur or sharpen.

To use the dodge, burn, or sponge tool:

1    Double-click the dodge tool ( ), burn tool (
), or sponge tool (
) to display its Options palette. 

2    For the dodge tool or burn tool, select what to change in the image:
•      Midtones to change only the middle range of grays in the image.
•      Shadows to change the dark portions of the image.
•      Highlights to change only the light pixels. 

3    For the sponge tool, select how to change the color:
•      Saturate to intensify the color’s saturation.
•      Desaturate to dilute the color’s saturation.

4    Specify the exposure for the dodge tool and burn tool, or the pressure for the sponge tool, as 
described in Specifying the opacity, pressure, or exposure.



5    Select a brush size as described in Using the Brushes palette.

6    Drag over the part of the image you want to modify.



Painting

See also: 

Using the painting tools 

Using the line tool 

Erasing 

Using the Brushes palette 

Using the Options palette for painting and editing tools 

Using the paint bucket tool 

Using the gradient tools 

Filling and stroking selections and layers 

Choosing the foreground and background colors 

Using the Adobe Photoshop Color Picker 

Using other color pickers 



Painting 

Using the painting tools

When using the painting tools, consider the painting effects you want: 

•      The paintbrush tool ( ) creates soft strokes of color. 
•      The airbrush tool ( ) applies gradual tones (including sprays of color) to an image, simulating 
traditional airbrush techniques. The edges of the stroke are more diffused than those created with the 
paintbrush tool. The pressure setting for the airbrush tool controls how quickly the spray of paint is 
applied. If you hold down the mouse button without dragging, you can build up color.
•      The pencil tool ( ) creates hard-edged freehand lines and is most useful for bitmapped images. See 
Using the Auto Erase option .

To save time when working with painting tools, make sure that the Options palette and the 
Brushes/Color/Swatches palette group are displayed. 
 To draw a straight line with any painting tool, click a starting point in the image. Then hold down Shift, 

and click an endpoint.

To use the paintbrush, airbrush, or pencil tool:

1    Specify a foreground color as described in Choosing the foreground and background colors.

2    Select and double-click the paintbrush, airbrush, or pencil tool to display its Options palette. 

3    Specify the blending mode, opacity, paint fade-out rate, and stylus options as described in Using 
the Options palette for painting and editing tools.

4    Select a brush size as described in Using the Brushes palette. 

5    For the paintbrush tool, select Wet Edges to paint with a watercolor effect. With this option 
selected, the paint builds up along the edges of the brush stroke. 

6    Drag in the image to paint.

Painting with Wet Edges off, and on



Painting 

Using the line tool

The line tool ( ) draws straight lines on an image. 

To use the line tool: 

1    Specify a foreground color as described in Choosing the foreground and background colors.

2    Select and double-click the line tool to display its Options palette. 

3    Specify the blending mode and opacity as explained in Using the Options palette for painting and 
editing tools. 

4    For Weight, enter the line width.

5    Select Anti-aliased to create soft-edged lines. 

6    To include arrowheads, select Start, End, or both to specify where you want arrowheads.

7    To edit the appearance of arrowheads, click Shape and do the following:
•      For the width of the arrowhead, enter a value from 10% to 1000% of the line width. 
•      For the length of the arrowhead, enter a value from 10% to 5000% of the line width. 
•      For the concavity of the arrowhead, enter a value from –50% to +50%. The concavity value 
defines the amount of curvature on the widest part of the arrowhead, where the arrowhead meets the 
line.

Arrowheads created with different values

8    Drag in the image. To constrain the line angle to a multiple of 45°, hold down Shift as you drag. 



Painting 

Erasing

The eraser tool and the Auto Erase option for the pencil tool let you replace colors in an image either 
with the background color or with transparency.

See also: 

Using the eraser tool 

Using the Auto Erase option 



Erasing 

Using the eraser tool

The eraser tool changes pixels in the image as you drag through them. If you’re working in the 
background, or in any other layer with Preserve Transparency on, the pixels change to the background
color (see Choosing the foreground and background colors). Otherwise, transparency replaces the 
color. You can also use the eraser to return the affected area to a state selected in the History palette.

Erasing pixels from layer exposes underlying layer.

To use the eraser tool:

1    Double-click the eraser tool to display its Options palette. 

2    Choose the tool type you want to use as an eraser—paintbrush, airbrush, pencil, or block. 
 To cycle through the eraser tool types, Alt-click (Windows) or Option-click (Mac OS) the eraser tool, or hold down 

Shift and press E on the keyboard.

3    Specify the opacity, fade-out rate, and stylus options as explained in Using the Options palette for 
painting and editing tools. 

4    Select a brush size as described in Using the Brushes palette. 

Note: When using the paintbrush option, select Wet Edges to erase with a watercolor effect. This 
option causes the erased effect to build up along the edges of the brush stroke. 

5    To erase to a saved state or snapshot of the image, select Erase to History (see Painting with a 
state or snapshot of the image).
 To use the eraser tool in Erase to History mode, hold down Alt (Windows) or Option (Mac OS) as you 

drag in the image.

6    Drag through the area you want to erase.



Erasing 

Using the Auto Erase option

The Auto Erase option for the pencil tool ( ) lets you paint the background color over areas containing
the foreground color.

To use the Auto Erase option:

1    Specify foreground and background colors as described in Choosing the foreground and 
background colors.

2    Select and double-click the pencil tool to display its Options palette.

3    Select Auto Erase.

4    Drag over the image. 

If you begin dragging over the foreground color, the area is erased to the background color. If you 
begin dragging from an area that doesn’t contain the foreground color, the area is painted with the 
foreground color. 



Painting 

Using the Brushes palette

The brush sizes and shapes available for painting and editing appear in the Brushes palette. You can 
add new brushes or delete ones you don’t need. You also can use part of an image to create a custom
brush shape. Brush settings are retained for each of the painting tools (airbrush, paintbrush, eraser, 
pencil) and editing tools (history brush, rubber stamp, smudge, focus, toning). 

To display the Brushes palette:

Choose Window > Show Brushes.

See also: 

Choosing, creating, or deleting a brush 

Setting brush options 

Saving, loading, and replacing brushes 



Using the Brushes palette 

Choosing, creating, or deleting a brush

See also: 

To choose a brush setting for a painting or editing tool 

To create a brush 

To delete a brush 

To create a custom brush shape 



Choosing, creating, or deleting a brush 

To choose a brush setting for a painting or editing tool:

1    Select the tool you want to use.

2    In the Brushes palette, click the brush you want to use. When a brush is too large to fit on the 
palette, it appears as a smaller brush with a number indicating the actual diameter in pixels.

See also: 

To create a brush 

To delete a brush 

To create a custom brush shape 



Choosing, creating, or deleting a brush 

To create a brush:

1    Do one of the following:
•      Click in the empty area outside the brush squares in the Brushes palette.
•      Choose New Brush from the Brushes palette menu.

The preview box in the lower right corner of the New Brush dialog box shows the current brush tip. 
The box in the lower left corner shows the current brush angle and roundness. As you enter new 
options, the brushes in these boxes update. 

2    Set the brush options as described inSetting brush options.

3    Click OK. New brushes are added at the bottom of the palette. 

See also: 

To choose a brush setting for a painting or editing tool 

To delete a brush 

To create a custom brush shape 



Choosing, creating, or deleting a brush 

To delete a brush:

Do one of the following:
•      Press Ctrl (Windows) or Command (Mac OS), and click the brush you want to delete.
•      Click the brush in the Brushes palette, and choose Delete Brush from the palette menu.

See also: 

To choose a brush setting for a painting or editing tool 

To create a brush 

To create a custom brush shape 



Choosing, creating, or deleting a brush 

To create a custom brush shape: 

1    Select part of an image to use as a custom brush. The brush shape can be up to 1000 pixels by 
1000 pixels in size. To be most effective, the shape should appear on a solid white background. If you 
want to define brushes with soft edges, select brush shapes composed of pixels with gray values. 
(Colored brush shapes appear as gray values.)

2    Choose Define Brush from the Brushes palette menu. 

3    Double-click the newly created brush in the Brushes palette to open the Brush Options dialog box.

4    Specify Spacing as described in the next section.

5    To make the brush placement more accurate, make sure that Anti-aliased is selected. Then click 
OK.

See Softening the edges of a selection for information on anti-aliasing. 

Note: The Anti-aliased option is not available for large brushes.

Pear painted with custom brush shown in inset

See also: 

To choose a brush setting for a painting or editing tool 

To create a brush 

To delete a brush 



Using the Brushes palette 

Setting brush options

You can define a number of options for the default brushes and any brushes you create. For custom 
brushes, only the spacing and anti-aliased options can be changed.

To set brush options:

1    Do one of the following:
•      Double-click the brush you want to edit. 
•      In the Brushes palette, select the brush you want to edit, and choose Brush Options from the 
palette menu.

2    Set the options for Diameter, Hardness, Spacing, Angle, and Roundness. Then click OK. 

Diameter
Controls the size of the brush. Enter a value in pixels or drag the slider.

Brush strokes with different diameter values

Hardness
Controls the size of the brush’s hard center. Type a number, or use the slider to enter a value that is a 
percentage of the brush diameter.

Brush strokes with different hardness values

Spacing
Controls the distance between the brush marks in a stroke. To change the spacing, type a number, or 
use the slider to enter a value that is a percentage of the brush diameter. To paint strokes without 
defined spacing, deselect this option.



Increasing the spacing makes the brush skip.

Angle
Specifies the angle by which an elliptical brush’s long axis is offset from horizontal. Type a value in 
degrees, or drag the horizontal axis in the left preview box.

Angled brushes create a chiseled stroke.

Roundness
Specifies the ratio between the brush’s short and long axes. Enter a percentage value, or drag the 
points in the left preview box. A value of 100% indicates a circular brush, a value of 0% indicates a 
linear brush, and intermediate values indicate elliptical brushes.

Adjusting roundness affects shape of brush tip.



Using the Brushes palette 

Saving, loading, and replacing brushes

The Brushes palette can hold as many brushes as you want. Creating sets of brushes can help you 
group related or special brushes and manage palette size. The Adobe Photoshop program folder 
includes files containing various brush sets.

To save and use custom brush sets:

Choose one of the following commands from the Brushes palette menu:
•      Reset Brushes to return to the default brushes. You can either replace the current brush set or 
append the default brushes to the current set.
•      Load Brushes to add brushes stored in a file to the current palette. 
•      Replace Brushes to replace the current brush set with brushes stored in a file.
•      Save Brushes to save a brush set in a file (and in Windows, append an .abr extension to the 
filename). 

Exiting Photoshop saves the current Brushes palette in the Preferences file.



Painting 

Using the Options palette for painting and editing tools

You specify options for a painting or editing tool by using the Options palette for that tool. See Editing 
and Retouching for information on the editing tools.

See also: 

Specifying the opacity, pressure, or exposure 

Specifying the paint fade-out rate 

Specifying stylus pressure options 

Selecting a blending mode 



Using the Options palette for painting and editing tools 

Specifying the opacity, pressure, or exposure

The Options palette lets you specify the opacity, pressure, or exposure for these painting and editing 
tools: 
•      You can adjust the opacity used by the gradient fill, pencil, paintbrush, rubber stamp, pattern 
stamp, and history brush tools. 
•      You can adjust the pressure of action applied by the airbrush, smudge, blur, sharpen, and sponge 
tools. 
•      You can adjust the amount of exposure used by the dodge and burn tools. 

To specify opacity, pressure, or exposure:

In the tool’s Options palette, enter a value for Opacity, Pressure, or Exposure, or drag the slider.

Opacity, pressure, or exposure can range from 1% to 100%. For transparent paint or a weak effect, 
specify a low percentage value; for more opaque paint or a strong effect, specify a high value. 

Painting with various opacity settings



Using the Options palette for painting and editing tools 

Specifying the paint fade-out rate 

You can specify the rate at which the pencil, paintbrush, airbrush, and eraser fade out from their 
beginning strokes, simulating actual brush strokes. 

To set a fade-out rate:

1    In the tool’s Options palette, for Fade, enter a value for the number of steps of the fade.

Each step is equal to one mark of the brush tip. The value can range from 1 to 9999. For example, 
entering 10 steps produces a fade in 10 increments. 

2    For the pencil, paintbrush, or airbrush tool, specify how the stroke fades:
•      Transparent to fade the stroke from the foreground color to transparency.
•      Background to fade the stroke from the foreground color to the background color. 

Fade-out showing setting of 40, 60, and 80 steps



Using the Options palette for painting and editing tools 

Specifying stylus pressure options

Adobe Photoshop is compatible with most pressure-sensitive digitizing tablets such as the Wacom 
tablets. With Control Panel software for your tablet installed, you can specify the type of effect that 
results when you vary stylus pressure. These stylus pressure options affect the magnetic lasso, 
magnetic pen, pencil, paintbrush, airbrush, eraser, rubber stamp, pattern stamp, history brush, 
smudge, blur, sharpen, dodge, burn, and sponge tools.

To set the effect of different stylus pressures:

Double-click the desired tool to display its Options palette, and select one of the following options:
•      Size to have increased pressure create a bigger brush stroke.
•      Opacity/Pressure/Exposure to have increased pressure make the paint more opaque or more 
intense.
•      Color if you want light pressure to paint with the background color, making a transition to the 
foreground color as the pressure increases.

Note: If the highest pressure of your stylus does not reach 100%, contact your tablet vendor. This 
problem is caused by the driver software, not Photoshop. 



Using the Options palette for painting and editing tools 

Selecting a blending mode

The blending mode specified in the Options palette controls how pixels in the image are affected by a 
painting or editing tool. It’s helpful to think in terms of the following colors when visualizing a blending 
mode’s effect: 
•      The base color is the original color in the image. 
•      The blend color is the color being applied with the painting or editing tool.
•      The result color is the color resulting from the blend. 
Normal 
Dissolve 
Multiply 
Screen 
Soft Light 
Hard Light 
Color Dodge 
Color Burn 
Darken 
Lighten 
Difference 
Saturation 
Color 
Luminosity 

Normal
Edits or paints each pixel to make it the result color. This is the default mode. (Normal mode is called 
Threshold when you’re working with a bitmapped or indexed-color image.)

Dissolve
Edits or paints each pixel to make it the result color. However, the result color is a random 
replacement of the pixels with the base color or the blend color, depending on the opacity at any pixel 
location. This mode works best with the paintbrush or airbrush tool and a large brush.

Behind
Edits or paints only on the transparent part of a layer. This mode works only in layers with Preserve 
Transparency off and is analogous to painting on the back of transparent areas in a sheet of acetate.

Clear
Edits or paints each pixel and makes it transparent. This mode is available for the line tool ( ), the 
paint bucket tool (

), the Fill command, and the Stroke command. You must be in a layer with Preserve Transparency off 
to use this mode. 

Multiply
Looks at the color information in each channel and multiplies the base color by the blend color. The 
result color is always a darker color. Multiplying any color with black produces black. Multiplying any 
color with white leaves the color unchanged. When you’re painting with a color other than black or 
white, successive strokes with a painting tool produce progressively darker colors. The effect is similar
to drawing on the image with multiple magic markers. 



Screen
Looks at each channel’s color information and multiplies the inverse of the blend and base colors. The
result color is always a lighter color. Screening with black leaves the color unchanged. Screening with 
white produces white. The effect is similar to projecting multiple photographic slides on top of each 
other. 

Overlay
Multiplies or screens the colors, depending on the base color. Patterns or colors overlay the existing 
pixels while preserving the highlights and shadows of the base color. The base color is not replaced 
but is mixed with the blend color to reflect the lightness or darkness of the original color. 

Soft Light
Darkens or lightens the colors, depending on the blend color. The effect is similar to shining a diffused 
spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were dodged. If 
the blend color is darker than 50% gray, the image is darkened, as if it were burned in. Painting with 
pure black or white produces a distinctly darker or lighter area but does not result in pure black or 
white. 

Hard Light
Multiplies or screens the colors, depending on the blend color. The effect is similar to shining a harsh 
spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were screened. 
This is useful for adding highlights to an image. If the blend color is darker than 50% gray, the image is
darkened, as if it were multiplied. This is useful for adding shadows to an image. Painting with pure 
black or white results in pure black or white.

Color Dodge
Looks at the color information in each channel and brightens the base color to reflect the blend color. 
Blending with black produces no change.

Color Burn
Looks at the color information in each channel and darkens the base color to reflect the blend color. 
Blending with white produces no change.

Darken
Looks at the color information in each channel and selects the base or blend color—whichever is 
darker—as the result color. Pixels lighter than the blend color are replaced, and pixels darker than the 
blend color do not change. 

Lighten
Looks at the color information in each channel and selects the base or blend color—whichever is 
lighter—as the result color. Pixels darker than the blend color are replaced, and pixels lighter than the 
blend color do not change. 

Difference
Looks at the color information in each channel and subtracts either the blend color from the base color
or the base color from the blend color, depending on which has the greater brightness value. Blending 
with white inverts the base color values; blending with black produces no change.

Exclusion
Creates an effect similar to but lower in contrast than the Difference mode. Blending with white inverts 
the base color values. Blending with black produces no change.

Hue



Creates a result color with the luminance and saturation of the base color and the hue of the blend 
color. 

Saturation
Creates a result color with the luminance and hue of the base color and the saturation of the blend 
color. Painting with this mode in an area with no (0) saturation (gray) causes no change. 

Color
Creates a result color with the luminance of the base color and the hue and saturation of the blend 
color. This preserves the gray levels in the image and is useful for coloring monochrome images and 
for tinting color images.

Luminosity
Creates a result color with the hue and saturation of the base color and the luminance of the blend 
color. This mode creates an inverse effect from that of the Color mode.



Painting 

Using the paint bucket tool

The paint bucket tool ( ) fills adjacent pixels that are similar in color value to the pixels you click. 

Note: The paint bucket tool cannot be used with images in Bitmap mode. 

To use the paint bucket tool: 

1    Specify a foreground color as described in Choosing the foreground and background colors.

2    Select and double-click the paint bucket tool to display its Options palette.

3    Specify the opacity and blending mode as described in Using the Options palette for painting and 
editing tools.

4    Enter the tolerance for the fill.

The tolerance defines how similar in color a pixel must be to be filled. Values can range from 0 to 255. 
A low tolerance fills pixels within a range of color values very similar to the pixel you click. A high 
tolerance fills pixels within a broader range.

5    To smooth the edges of the filled selection, select Anti-aliased. See Softening the edges of a 
selection.

6    To fill the selection with the foreground color or with a pattern, choose an option for Contents. See 
Filling and stroking selections and layers.

7    To fill pixels based on the merged color data from all visible layers, select Use All Layers. See 
Sampling from all layers.

8    Click the part of the image you want to fill. All adjacent pixels within the specified tolerance are 
filled with the foreground color or pattern.

If you’re working on a layer and don’t want to fill transparent areas, make sure that Preserve 
Transparency is selected in the Layers palette. See Preserving a layer’s transparency.



Painting 

Using the gradient tools

The gradient tools create a gradual blend between multiple colors. You can choose from existing 
gradient fills or create your own. You draw a gradient by dragging in the image from a starting point 
(where the mouse is pressed) to an ending point (where the mouse is released). The starting and 
ending points affect the gradient appearance according to the gradient tool used.

See also: 

Using a gradient tool 

Creating and editing gradient fills 

Editing the gradient transparency 

Loading, saving, and deleting gradients 



Using the gradient tools 

Using a gradient tool

The gradient pull-out menu in the toolbox includes these tools:

Linear gradient

( ) Shades from the starting point to the ending point in a straight line.

Radial gradient

( ) Shades from the starting point to the ending point in a circular pattern.

Angular gradient

( ) Shades in a counterclockwise sweep around the starting point. 

Reflected gradient

( ) Shades using symmetric linear gradients on either side of the starting point.

Diamond gradient

( ) Shades from the starting point outward in a diamond pattern. The ending point defines one 
corner of the diamond.

Angle gradient tool, and diamond gradient tool

Note: The gradient tools cannot be used with images in Bitmap or indexed-color mode.

To apply a gradient fill: 

1    To fill only part of the image, select the desired area. Otherwise, the gradient fill is applied to the 
entire active layer. 

2    Select and double-click the linear gradient, radial gradient, angular gradient, reflected gradient, or 
diamond gradient tool to display its Options palette.

3    Specify the opacity and blending mode as explained in Using the Options palette for painting and 
editing tools.

4    To use a transparency mask for the gradient fill, select Transparency. (See Editing the gradient 
transparency.)

5    To create a smoother blend with less banding, select Dither.

6    To reverse the order of colors in the gradient fill, select Reverse.

7    Select a gradient fill from the list.

8    Position the pointer in the image where you want to set the starting point of the gradient, and drag 
to define the ending point. To constrain the line angle to a multiple of 45°, hold down Shift as you drag.

For an explanation of how the starting and ending points affect gradient appearance, see the 
descriptions before this procedure.





Using the gradient tools 

Creating and editing gradient fills

The Gradient Editor dialog box lets you define a new gradient or modify an existing one. You can also 
add intermediate colors to a gradient, creating a blend between more than two colors.

A. Starting color stop    B. Color selection box    C. Preview    bar    D. Foreground and background selection boxes 
E. Color swatch    F. Midpoint    G. Gradient bar    H. Ending color stop

See also: 

To create or edit a gradient 

To add intermediate colors to a gradient 



Creating and editing gradient fills 

To create or edit a gradient:

1    Double-click a gradient tool to display its Options palette. 

2    Click Edit.

3    Make sure that Color is selected for Adjust, and do one of the following:
•      To create a new gradient, click New. Enter a name for the gradient, and click OK.
•      To base your gradient on an existing one, select it in the list, and click Duplicate. To name the 
copied gradient, hold down Alt (Windows) or Option (Mac OS) as you click Duplicate. 
•      To edit an existing gradient, select it in the list.

4    To define the starting color of the gradient, click the left color stop under the gradient bar. The 
triangle above the stop turns black, indicating that the starting color is being edited.

5    To choose a color, do one of the following:
•      Double-click the color stop, or click the color swatch below the gradient bar. Choose a color as 
described in Using the Adobe Photoshop Color Picker, and click OK. 
•      Click the foreground selection box to use the current foreground color.
•      Click the background selection box to use the current background color.
•      Position the pointer over the gradient bar (the pointer turns into the eyedropper), and click to 
sample a color.

6    To define the ending color, click the right color stop under the gradient bar. Then choose a color as 
described in the previous step.

7    To adjust the location of the starting point or ending point, do one of the following:
•      Drag the corresponding color stop left or right to the location you want. 
•      Click the corresponding color stop, and enter a value for Location. A value of 0% places the point 
at the far left end of the gradient bar, a value of 100% at the far right end.

8    To adjust the location of the midpoint (where the gradient displays an even mix of the starting and 
ending colors), drag the diamond above the gradient bar to the left or right, or click the diamond and 
enter a value for Location.

Gradients with different midpoint locations

9    Click OK to add the new gradient fill to the list or to update the edited gradient fill. 

See also: 

To add intermediate colors to a gradient 



Creating and editing gradient fills 

To add intermediate colors to a gradient:

In the Gradient Editor dialog box, click below the gradient bar to define another color stop. Specify the 
color and adjust the location and midpoint for the intermediate point as you would for a starting or 
ending point. To remove an intermediate color, drag the color stop down and off the gradient bar.

Adding a color

Deleting a color

See also: 

To create or edit a gradient 



Using the gradient tools 

Editing the gradient transparency

Each gradient fill contains a transparency mask that controls the opacity of the fill at different locations 
on the gradient. For example, you can set the starting color to 100% opacity and have the fill gradually
blend into an ending color with 50% opacity. By default, the transparency mask is set to 100%. Turn 
off the mask by deselecting Transparency in the Gradient Options palette.

To edit the gradient transparency mask:

1    Double-click a gradient tool to display its Options palette, and click Edit.

2    Select the gradient whose transparency mask you want to edit.

3    For Adjust, select Transparency.

4    To adjust the starting opacity, click the left transparency stop under the transparency gradient bar.

5    For Opacity, enter a value. 

In the gradient bar, white represents an opacity of 0%, black an opacity of 100%, and gray an opacity 
between 0 and 100%. The bar at the bottom of the Gradient Editor dialog box lets you preview the 
effects of the mask on the gradient fill.

6    To adjust the opacity of the endpoint, click the right transparency stop under the transparency 
gradient bar. Then set the opacity as explained in the previous step. 

7    To adjust the location of the starting or ending opacity, do one of the following:
•      Drag the corresponding transparency stop to the left or right.
•      Select the corresponding transparency stop, and enter a value for Location. 

8    To adjust the location of the midpoint opacity (the point midway between the starting and ending 
opacities), do one of the following:
•      Drag the diamond above the transparency gradient bar to the left or right.
•      Select the diamond and enter a value for Location.

9    To add an intermediate opacity to the mask, click under the transparency gradient bar to define a 
new transparency stop. You can then adjust and move this opacity as you would for a starting or 
ending opacity. To remove an intermediate opacity, drag its transparency stop down and off the 
gradient bar.

10    Click OK.



Using the gradient tools 

Loading, saving, and deleting gradients

By saving and loading sets of gradients, you can customize the gradient list that appears in the 
Gradient Tool Options palette and the Gradient Editor dialog box. 

To customize the gradient list:

Do one of the following:
•      To delete a gradient, select the gradient in the Gradient Editor dialog box, and click Remove.
•      To append gradients that have been stored in a file to the current list, click Load in the Gradient 
Editor dialog box.
•      To save gradients in a separate file for later use, select the desired gradients in the Gradient Editor
dialog box (Shift-click to select multiple gradients). Then click Save.
•      To return to the default gradient list, choose Reset Tool from the menu on the Gradient Tool 
Options palette. You can either replace the current list or append the default gradients to the current 
list.



Painting 

Filling and stroking selections and layers

Photoshop provides a variety of ways to fill a selection or a layer with colors, images, or patterns. You 
can also paint a border around a selection or a layer using the Stroke command. 

To increase the contrast between your image and the surrounding work canvas, you can fill the canvas
with a specified color. 

See also: 

To fill a selection or layer using shortcuts 

To fill the work canvas 

To fill a selection or a layer 

To fill a selection with a pattern 

To use a pattern from the PostScript Patterns folder 

To stroke a selection or layer 



Filling and stroking selections and layers 

To fill a selection or layer using shortcuts: 

1    Specify a foreground or background color as described in Choosing the foreground and 
background colors.

2    Select the area or layer you want to fill.

3    Apply the fill:
•      To fill with the foreground color, press Alt+Backspace (Windows) or Option+Delete (Mac OS).
•      To apply a foreground color fill only to the areas that contain pixels, press Alt+Shift+Backspace 
(Windows) or Option+Shift+Delete (Mac OS). This operation preserves the transparency of the layer.
•      To fill with the background color, press Ctrl+Backspace (Windows) or Command+Delete (Mac OS).
•      To apply a background color fill only to the areas that contain pixels, press Ctrl+Shift+Backspace 
(Windows) or Command+Shift+Delete (Mac OS).



Filling and stroking selections and layers 

To fill the work canvas:

1    Set the foreground color you want to use for the canvas. (See Choosing the foreground and 
background colors.)

2    Select and double-click the paint bucket tool to display its Options palette.

3    For Contents, choose Foreground.

4    Hold down Shift and click in the work canvas area surrounding the image.



Filling and stroking selections and layers 

To fill a selection or a layer: 

1    Specify a foreground or background color as described in Choosing the foreground and 
background colors.

2    Select the area you want to fill. To fill an entire layer, select the layer in the Layers palette.

3    Choose Edit > Fill to fill the selection or layer. 
 To display the Fill dialog box, press Shift+Backspace (Windows) or Shift+Delete (Mac OS). 

4    For Use, choose an option:
•      Foreground Color, Background Color, Black, 50% Gray, or White to fill the selection with the 
specified color.
•      Pattern to fill the selection with a pattern. Filling with patterns is discussed in the following 
procedures.
•      History to restore the selected area to a state or snapshot of the image (see Painting with a state 
or snapshot of the image).

Note: If you fill a CMYK image using the Black option, Photoshop fills all the channels with 100% 
black. This may result in more ink than is allowable by the printer. For best results when filling a CMYK
image, use the Foreground option with the foreground color set to an appropriate black.

5    Specify an opacity and blending mode, as explained in Using the Options palette for painting and 
editing tools.

6    If you’re working in a layer and want to fill only areas containing pixels, select Preserve 
Transparency. (See Preserving a layer’s transparency.) 

7    Click OK to fill the selection.



Filling and stroking selections and layers 

To fill a selection with a pattern: 

1    Make a rectangular selection around the part of the image you want to use as the pattern.

2    Choose Edit > Define Pattern. 

3    Select the part of the image you want to fill.

4    Choose Edit > Fill.

5    For Use, choose Pattern and click OK. 

The pattern you defined is repeated as tiles within the selection. Each new pattern replaces the 
current pattern. If you want to reuse patterns, save a file of swatches for defining patterns. You can 
also use the pattern stamp tool to paint with a pattern (see Using the rubber stamp tool and pattern 
stamp tool).

Defining a pattern, and filling image with pattern



Filling and stroking selections and layers 

To use a pattern from the PostScript Patterns folder:

1    Choose File > Open. Each file in the PostScript Patterns folder, which comes with your program, 
contains a single pattern in the Adobe Illustrator format. You can scale and render these patterns at 
any resolution.

2    Select the pattern file you want to use, and click Open. 

3    Select any rasterizing options. (SeeImporting Adobe Illustrator, PDF, and EPS files for these 
options.)

4    Click OK.

5    Make a rectangular selection around the pattern, or choose Select > All.

6    Choose Edit > Define Pattern. The pattern is defined as an Adobe Photoshop pattern.

7    Open an image, and select the part you want to fill.

8    Choose Edit > Fill.

9    For Use, select Pattern, and click OK.



Filling and stroking selections and layers 

To stroke a selection or layer:

1    Specify a foreground color as described in Choosing the foreground and background colors.

2    Select the area or layer you want to stroke. 

3    Choose Edit > Stroke. 

4    Specify the width of the hard-edged border. Values can range from 1 to 16 pixels. 

5    For Location, specify whether to place the border inside, outside, or directly over the selection or 
layer boundaries.

6    Specify an opacity and a blending mode as explained in Using the Options palette for painting and 
editing tools. 

7    If you’re working in a layer and want to stroke only areas containing pixels, select the Preserve 
Transparency option. (See Preserving a layer’s transparency.) 

8    Click OK to stroke the selection or layer.



Painting 

Choosing the foreground and background colors

Adobe Photoshop uses the foreground color to paint, fill, and stroke selections and the background 
color to make gradient fills and fill in the erased areas of an image. You can designate a new 
foreground or background color using the eyedropper tool, the Color palette, the Swatches palette, or 
the Photoshop Color Picker.

See also: 

Changing foreground and background colors 

Using the eyedropper tool 

Using the Color palette 

Using the Swatches palette 



Choosing the foreground and background colors 

Changing foreground and background colors

The current foreground color appears in the top color selection box in the toolbox, the background 
color in the lower box. The default foreground color is black, and the default background is white. (If 
you are viewing an alpha channel, the default foreground is white, and the background is black.)

A. Foreground color    B. Default Colors    C. Switch Colors    D. Background color

The Info palette, the Color palette, and the Color Picker let you display color values using a number of 
color models. (See Color modes and models.)

To reverse the foreground and background colors:

Click the Switch Colors icon in the toolbox. 

To return to the default foreground and background colors:

Click the Default Colors icon in the toolbox.

To change the foreground or background color:

1    Do one of the following:
•      To change the foreground color, click the top color selection box in the toolbox.
•      To change the background color, click the lower color selection box in the toolbox.

2    Choose a color, as explained in Using the Adobe Photoshop Color Picker, and click OK.
 To switch between the foreground and background colors, press X on the keyboard.



Choosing the foreground and background colors 

Using the eyedropper tool

With the eyedropper tool ( ), you sample color from an image to designate a new foreground or 
background color. You can sample from the active image or from another image. (When you’re using 
the eyedropper, you can click in a background window without making it the active window.)

You can also specify the area sampled by the eyedropper tool. For example, you can set the eyedropper 
to sample the color values of a 3-by-3-pixel area under the pointer. Modifying the sample size of the 
eyedropper affects the color readouts displayed in the Info palette. 

See also: 

To select the foreground or background color using the eyedropper 

To change the sample size of the eyedropper 



Using the eyedropper tool 

To select the foreground or background color using the eyedropper:

1    Click the eyedropper tool ( ).
2    Select a color:

•      To select a new foreground color from an image, click the color you want.
•        To select a new background color from an image, Alt-click (Windows) or Option-click (Mac OS) 
the color you want.

As you drag the eyedropper tool, the foreground color selection box changes dynamically. Alt-drag 
(Windows) or Option-drag (Mac OS) to activate the background color selection box. Release the 
mouse button to pick the new color.
 To use the eyedropper tool temporarily while using any painting tool, hold down Alt (Windows) or 

Option (Mac OS). 

See also: 

To change the sample size of the eyedropper 



Using the eyedropper tool 

To change the sample size of the eyedropper:

1    Double-click the eyedropper tool to display the Eyedropper Options palette.

2    Choose an option from the Sample Size menu: 
•      Point Sample to read the precise value of the pixel you click.
•      3 by 3 Average or 5 by 5 Average to read the average value of the specified number of pixels 
within the area you click.

See also: 

To select the foreground or background color using the eyedropper 



Choosing the foreground and background colors 

Using the Color palette 

The Color palette displays the color values for the current foreground and background colors. Using 
the sliders in the Color palette, you can edit the foreground and background colors according to 
several different color models. You can also choose a background or foreground color from the 
spectrum of colors displayed in the color bar.

A. Foreground color    B. Background color    C. Slider    D. Color bar    E. Color palette menu

To display the Color palette:

Choose Window > Show Color.

See also: 

To edit the foreground or background color using the Color palette 

To sample colors from the color bar 

To change the display of the color bar 



Using the Color palette 

To edit the foreground or background color using the Color palette: 

1    From the Color palette menu, choose the color model you want to use for color readout values. 
See Color modes and models for a discussion of these models.

2    To edit the foreground or background color, make sure that its color selection box is active or 
outlined. To make the foreground or background color selection box active, click the box. 

3    To specify a new color:
•      Drag the color sliders.

By default, the slider colors change as you drag. If you want to turn off this preview feature to improve 
performance, choose File > Preferences > General, and deselect Dynamic Color Sliders.
•      Enter values next to the color sliders. 
•      Click the color selection box, choose a color as described in Using the Adobe Photoshop Color 
Picker, and click OK. 

Note: An exclamation point inside a triangle in the Color palette indicates an out-of-gamut color, that 
is, a color that cannot be printed using CMYK inks. The closest CMYK equivalent appears next to the 
triangle. Click the alert triangle to use the CMYK equivalent. (See Identifying out-of-gamut colors.)

See also: 

To sample colors from the color bar 

To change the display of the color bar 



Using the Color palette 

To sample colors from the color bar:

1    To edit the foreground or background color, make sure that its color selection box is active (outlined
in black). To make the foreground or background color selection box active, click the box. 

2    Position the pointer over the color bar (the pointer turns into the eyedropper), and click to sample a 
color.

See also: 

To edit the foreground or background color using the Color palette 

To change the display of the color bar 



Using the Color palette 

To change the display of the color bar:

1    Choose Color Bar from the Color palette menu. 

2    For Style, choose a model, and then click OK. The Current Colors style displays a transition from 
the current foreground color to the current background color. 
 To change the display style of the color bar quickly, Shift-click in the color bar until you see the style 

you want.

See also: 

To edit the foreground or background color using the Color palette 

To sample colors from the color bar 



Choosing the foreground and background colors 

Using the Swatches palette

You can choose a foreground or background color from the Swatches palette, or you can add or 
delete colors to create a custom swatch set. You can also save a set of swatches and reload them for 
use in another image. Although you can add colors to the Swatches palette, you should manage its 
size and organization.

See also: 

To display the Swatches palette 

To choose a color 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To display the Swatches palette:

Choose Window > Show Swatches.

See also: 

To choose a color 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To choose a color:

Do one of the following:
•      To choose a foreground color, click a color in the Swatches palette. 
•      To choose a background color, Alt-click (Windows) or Option-click (Mac OS) a color in the 
Swatches palette.

See also: 

To display the Swatches palette 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To add a color to the Swatches palette: 

1    Use the eyedropper tool, the Color palette, or the Color Picker to select the color you want to add. 

2    Position the pointer over an empty space in the bottom row of the Swatches palette (the pointer 
turns into the paint bucket tool), and click to add the color.

See also: 

To display the Swatches palette 

To choose a color 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To replace or insert a color in the Swatches palette:

1    Use the eyedropper tool ( ), the Color palette, or the Color Picker to select the color you want to 
add. 

2    Add a swatch:
•      To replace an existing swatch, hold down Shift, position the pointer over a swatch (the pointer 
turns into a paint bucket), and click the swatch. 
•      To insert a new swatch, press Shift+Alt (Windows) or Shift+Option (Mac OS), and click a swatch.

See also: 

To display the Swatches palette 

To choose a color 

To add a color to the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To delete a color from the Swatches palette:

Hold down Ctrl (Windows) or Command (Mac OS), position the pointer over a swatch (the pointer 
turns into scissors), and click.

See also: 

To display the Swatches palette 

To choose a color 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To return to the default Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To return to the default Swatches palette:

1    Choose Reset Swatches from the Swatches palette menu.

2    Return to the default palette:
•      Click OK to replace the current swatches with the default set.
•      Click Append to attach the default swatches to the end of the current set.

See also: 

To display the Swatches palette 

To choose a color 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To save and use custom swatch sets 



Using the Swatches palette 

To save and use custom swatch sets:

Choose a command from the Swatches palette menu:
•      Reset Swatches to use the default set of swatches. You can either replace the current swatch set 
or append the default swatches to the current set.
•      Load Swatches to append the swatches stored in a file to the current set of swatches. Files 
containing different swatch sets are included in the Adobe Photoshop program folder.
•      Replace Swatches to replace the current swatch set with the swatches stored in a file.
•      Save Swatches to save the current swatches in a file. 

Exiting the program saves the current Swatches palette in the Adobe Photoshop preferences file.

See also: 

To display the Swatches palette 

To choose a color 

To add a color to the Swatches palette 

To replace or insert a color in the Swatches palette 

To delete a color from the Swatches palette 

To return to the default Swatches palette 



Painting 

Using the Adobe Photoshop Color Picker 

You can use the Adobe Photoshop Color Picker to select the foreground or background color by 
choosing from a color spectrum or by defining colors numerically. In addition, you can select colors 
based on the HSB, RGB, Lab, and CMYK color models and choose from several custom color 
systems (see Color modes and models). By default, the program uses the Adobe Photoshop Color 
Picker.

To display the Adobe Photoshop Color Picker:

Do one of the following:
•      Click the foreground or background color selection box in the toolbox.
•      Click the active color selection box in the Color palette. 

See also: 

Specifying a color using the color field and color slider 

Specifying a color using numeric values 

Recognizing nonprintable colors 

Choosing custom colors 

Choosing a custom color system 



Using the Adobe Photoshop Color Picker 

Specifying a color using the color field and color slider

With the HSB, RGB, and Lab color modes, you can use the color field and the color slider in the Color 
Picker dialog box to select a color. The color slider displays the range of color levels available for the 
selected color component (for example, R, G, or B). The color field displays the range for the 
remaining two components—one on the horizontal axis, one on the vertical.

For example, if the current color is black and you click the red component (R) using the RGB color 
model, the color slider displays the range of color for red (0 is at the bottom of the slider and 255 is at 
the top). The color field displays the values for blue along its horizontal axis, for green along its vertical
axis. 

To choose a color:

1    Click a component next to the HSB, RGB, or Lab values.

2    Select a color:
•      Drag the white triangles along the slider.
•      Click inside the color slider.
•      Click inside the color field. 

When you click in the color field, a circular marker indicates the color’s position in the field. 

As you adjust the color using the color field and color slider, the numerical values change to reflect the
new color. The color rectangle to the right of the color slider displays the new color in the top section of
the rectangle. The original color appears at the bottom of the rectangle.



Using the Adobe Photoshop Color Picker 

Specifying a color using numeric values

In the Adobe Photoshop Color Picker, you can select a color in any of the four color models by 
specifying numeric values for each color component. 

To specify colors using numeric values:

Do one of the following:
•      In CMYK color mode (this is the mode PostScript printers use), specify each component value as 
a percentage of cyan, magenta, yellow, and black. 
•      In RGB color mode (this is the mode your monitor uses), specify component values from 0 to 255 
(0 is black, and 255 is the pure color). 
•      In HSB color mode, specify saturation and brightness as percentages; specify hue as an angle, 
from 0° to 360°, that corresponds to a location on the color wheel. (See Color modes and models for 
information on the color wheel.)
•      In Lab mode, enter a lightness value (L) from 0 to 100, and a axis (green to magenta) and b axis 
(blue to yellow) values from –128 to +127. 



Using the Adobe Photoshop Color Picker 

Recognizing nonprintable colors

Some colors in the RGB, HSB, and Lab color models, such as neon colors, cannot be printed, 
because they have no equivalents in the CMYK model. When you select a nonprintable color, an alert 
triangle with an exclamation point appears in the Color Picker dialog box and in the Color palette. The 
closest CMYK equivalent is displayed below the triangle. (See Identifying out-of-gamut colors.)

Color Picker out-of-gamut display

Printable colors are determined by the printing values you enter for the selected ink set in the CMYK 
Setup dialog box.

To select the closest CMYK equivalent for a nonprintable color:

Click the alert triangle that appears in the Color Picker dialog box or the Color palette.



Using the Adobe Photoshop Color Picker 

Choosing custom colors

The Adobe Photoshop Color Picker lets you choose custom colors from the PANTONE® MATCHING 
SYSTEM®, the TRUMATCH® SWATCHING SYSTEM™, the FOCOLTONE® COLOUR SYSTEM, the 
TOYO Color Finder™ 1050 system, the ANPA-COLOR™ system, and the DIC Color Guide. 

To ensure that the final printed output is the color you want, consult your printer or service bureau and 
choose your custom color based on a printed color swatch. Manufacturers recommend that you get a 
new swatch book each year to compensate for fading inks and other damage. 

Important: Photoshop prints custom colors to CMYK, or process color, plates in every image mode 
except Duotone. To print true spot color plates, create spot color channels. (See Using spot channels.)

To choose a custom color:

1    Open the Adobe Photoshop Color Picker, and click Custom.

The Custom Colors dialog box displays the color closest to the color currently selected in the Adobe 
Photoshop Color Picker.

2    For Book, choose a color system described in the next section.

3    Locate the color you want by entering the ink number or by dragging the triangles along the scroll 
bar.

4    Click the desired color patch in the list.

5    Click OK.



Using the Adobe Photoshop Color Picker 

Choosing a custom color system

The Photoshop Color Picker supports various color systems:

PANTONE®
Used for printing inks. Each PANTONE color has a specified CMYK equivalent. To select a PANTONE 
color, first determine the ink color you want, using either the PANTONE Color Formula Guide 747XR 
or an ink chart obtained from your printer. PANTONE books are available from printers and graphic 
arts supply stores.

You can select from PANTONE Coated, PANTONE Uncoated, PANTONE Process, and PANTONE 
ProSim custom colors. (Contact PANTONE, Inc. in Carlstadt, New Jersey, U.S.A.)

TRUMATCH
Provides predictable CMYK color matching with more than 2000 achievable, computer-generated 
colors. TRUMATCH colors cover the visible spectrum of the CMYK gamut in even steps. The 
TRUMATCHCOLORFINDER displays up to 40 tints and shades of each hue, each originally created in
four-color process and each reproducible in four colors on electronic imagesetters. In addition, four-
color grays using different hues are included. (Contact TRUMATCH Inc. in New York, New York, 
U.S.A.)

FOCOLTONE 
Consists of 763 CMYK colors. FOCOLTONE colors help avoid prepress trapping and registration 
problems by showing the overprints that make up the colors. 

A swatch book with specifications for process and spot colors, overprint charts, and a chip book for 
marking up layouts are available from FOCOLTONE. (Contact FOCOLTONE INTERNATIONAL, Ltd. in
Stafford, United Kingdom.)

TOYO Color Finder 1050
Consists of more than 1000 colors based on the most common printing inks used in Japan. The TOYO
Color Finder 1050 Book contains printed samples of Toyo colors and is available from printers and 
graphic arts supply stores. (Contact Toyo Ink Manufacturing Co., Ltd. in Tokyo, Japan.)

ANPA-COLOR
Commonly used for newspaper applications. The ANPA-COLOR ROP Newspaper Color Ink Book 
contains samples of the ANPA colors. (Contact the Newspaper Association of America in Reston, 
Virginia, U.S.A.) 

DIC Color Guide
Commonly used for printing projects in Japan. (Contact Dainippon Ink and Chemicals, Inc. in Tokyo, 
Japan.)



Painting 

Using other color pickers

In addition to the default Adobe Photoshop Color Picker, you can use the built-in color picker on your 
system or a plug-in color picker to select colors. Any plug-in color pickers you install appear under 
Color Picker in the General Preferences dialog box. For information on installing and using a plug-in 
color picker, see the documentation that came with the plug-in.

See also: 

To use the Windows Color Picker 

To use the Apple Color Picker 

To return to the Adobe Photoshop Color Picker after using another color picker 



Using other color pickers 

To use the Windows Color Picker: 

1    Choose File > Preferences > General. 

2    For Color Picker, choose Windows and click OK.

3    Click the foreground or background color selection box in the toolbox. 

The Windows Color Picker lets you select colors from an array of basic colors or define up to 16 
custom colors based on the HSB or the RGB color model, but it does not alert you to nonprintable 
colors.

4    To choose a color from the Basic Colors palette, click the color you want.

5    To specify a custom color, click Define Custom Colors to open the Custom Color Selector. This 
dialog box functions similarly to the Adobe Photoshop Color Picker. Specify a color by using the color 
field and color slider or by entering numerical values for each color component. 

The new color is displayed on the left side of the Color/Solid box. The right side of this box displays 
the solid color closest to the color you have specified. (You can choose the displayed solid color by 
double-clicking the right side of the box.)

6    When you are satisfied with the color, click Add to Custom Colors to add it to the Custom Colors 
palette.

7    To choose a custom color from the Windows Color Picker, click the color you want.

8    Click OK.

(See your Windows documentation.)



Using other color pickers 

To use the Apple Color Picker: 

1    Choose File > Preferences > General.

2    For Color Picker, choose Apple, and click OK.

3    Click the foreground or background color selection box in the toolbox. 

4    Select a color model from the list at the left of the dialog box.

The Apple Color Picker lets you select colors based on a number of different color models but does 
not alert you to nonprintable colors.

5    Drag the color sliders, click in the color wheel, click a crayon, or enter numeric values to specify a 
color.

6    Click OK.

The exact appearance of the Apple Color Picker varies between different system software versions. 
For more information, see your MacOS documentation.



Using other color pickers 

To return to the Adobe Photoshop Color Picker after using another color 
picker:

1    Choose File > Preferences > General.

2    For Color Picker, choose Photoshop and click OK.



Using Channels and Masks

See also: 

About channels and masks 

About channels and file size 

Using the Channels palette 

Saving and managing channels 

Adding spot colors 

About masks 

Using Quick Mask mode 

Using alpha channels 



Using Channels and Masks 

About channels and masks

In Adobe Photoshop, channels store an image’s color information. In addition, channels and masks 
store selections that let you manipulate and control specific parts of an image in sophisticated ways. 

Color information channels are created automatically when you open a new image. The image’s color 
mode (and not its number of layers) determines the number of color channels created. For example, 
an RGB image has three default channels: one for each of the red, green, and blue colors plus a 
composite channel used for editing the image.

Image (RGB), and channels in Channels palette

Alpha channels store selections as 8-bit grayscale images and are added to the color channels in an 
image. You use alpha channels to create and store masks, which let you manipulate, isolate, and 
protect specific parts of an image. An image can have up to 24 channels, including all color and alpha 
channels.

In addition, spot color channels can be added to an image to let you specify additional plates for 
printing with spot color inks.



Using Channels and Masks 

About channels and file size

The file size required for a channel depends on the pixel information in the channel. For example, if 
the image has no alpha channels, duplicating a color channel in an RGB image increases the file size 
by about one-third, in a CMYK image by about one-fourth. Each alpha channel and spot color channel 
also adds to the file size. 

Certain file formats compress channel information and can save space, including the TIFF and 
Photoshop formats (see Saving and managing channels). The size of a file, including alpha channels 
and layers, appears as the second (right) value in the lower left corner of the window when the 
Document Size command is chosen. (See About image size and resolution.)



Using Channels and Masks 

Using the Channels palette

The Channels palette lets you create and manage channels and monitor the effects of editing. The 
palette lists all channels in the image—a composite channel first (for RGB, CMYK, and Lab images), 
then individual color channels, spot color channels, and finally alpha channels. Appearing to the left of 
the channel name, a thumbnail of the channel’s contents automatically updates as you edit the 
channel.

See also: 

Viewing channels 

Duplicating channels 

Deleting channels 

Mixing channels 



Using the Channels palette 

Viewing channels

You can view any combination of individual channels. For example, view an alpha channel and the 
composite channel together to see how changes made in the alpha channel relate to the entire image.
By default, individual channels are displayed in grayscale.

See also: 

To display the Channels palette 

To select a channel 

To show or hide a channel 

To see individual channels in color 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To display the Channels palette:

1    Choose Windows > Show Channels.

A. Show/Hide    B. Load Selection    C. Save Selection    D. New Channel    E. Trash

2    Use the scroll bars or resize the palette to see additional channels.

See also: 

To select a channel 

To show or hide a channel 

To see individual channels in color 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To select a channel:

Click the channel name. Shift-click to select (or deselect) multiple channels. The names of all selected,
or active, channels are highlighted. Editing changes apply to the active channels.

When a channel is visible, an eye icon appears to its left. 

Alpha channel visible in image, and Channels palette

These guidelines apply to channels you display:
•      In RGB, CMYK, or Lab images, you can view the individual channels in color. (In Lab images, only
the a and b channels appear in color.)
•      If more than one channel is visible, the channels always appear in color.
•      In alpha channels, selected pixels appear as white (partially selected pixels are gray) by default.
•      If you display an alpha channel at the same time as color channels, the alpha channel appears as 
a transparent color overlay, analogous to a printer’s rubylith or a sheet of acetate. To change the color 
of this overlay or set other alpha channel options, see Creating and saving alpha channels .

See also: 

To display the Channels palette 

To show or hide a channel 

To see individual channels in color 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To show or hide a channel: 

Click in the eye column next to the channel to show or hide that channel. (Click the composite channel
to view all default channels. The composite channel is displayed whenever all the color channels are 
visible.)
To show or hide multiple channels, drag through the eye column in the Channels palette. 

See also: 

To display the Channels palette 

To select a channel 

To see individual channels in color 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To see individual channels in color:

1    Choose File > Preferences > Display & Cursors.

2    Select Color Channels in Color, and click OK.

See also: 

To display the Channels palette 

To select a channel 

To show or hide a channel 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To change the order of alpha channels:

Drag the channel up or down. When the heavy black line appears in the position you want, release the
mouse button.

Whatever the order of alpha channels, the color information channels always appear at the top.

Drag channel in palette, and release to set new position.

See also: 

To display the Channels palette 

To select a channel 

To show or hide a channel 

To see individual channels in color 

To hide or change the size of channel thumbnails to work more efficiently 

To edit a channel 



Viewing channels 

To hide or change the size of channel thumbnails to work more efficiently:

1    Choose Palette Options from the Channels palette menu.

2    Select a display option:
•      Click a thumbnail size. Smaller thumbnails reduce the space required by the Channels palette—
helpful when you’re working on smaller monitors.
•      Click None to turn off the display of thumbnails. 

3    Click OK.

See also: 

To display the Channels palette 

To select a channel 

To show or hide a channel 

To see individual channels in color 

To change the order of alpha channels 

To edit a channel 



Viewing channels 

To edit a channel:

Use a painting or editing tool to paint in the image. Paint with white to add to the channel; paint with 
black to remove from the channel; paint with a lower opacity or a color to add to the channel with lower
opacities. 

See also: 

To display the Channels palette 

To select a channel 

To show or hide a channel 

To see individual channels in color 

To change the order of alpha channels 

To hide or change the size of channel thumbnails to work more efficiently 



Using the Channels palette 

Duplicating channels

You can duplicate any channel within or between images. (You cannot duplicate a channel to a 
Bitmap-mode image, however.) For example, duplicate an image’s channels to make a backup before 
editing the channel. Or duplicate alpha channels to a new image also to create a library of selections 
that you can load into the current image one by one—thus keeping the file smaller. If duplicating 
between images, alpha channels must have identical pixel dimensions (see Creating new images).

See also: 

To duplicate a channel using the Duplicate command 

To duplicate a channel by dragging 



Duplicating channels 

To duplicate a channel using the Duplicate command:

1    In the Channels palette, select the channel to duplicate.

2    Choose Duplicate Channel from the Channels palette menu.

3    Type a name for the duplicate channel.

4    For Document, do one of the following:
•      Choose a destination. Only images with pixel dimensions the same as the current image are 
available. To duplicate the channel in the same file, select the channel’s current file. 
•      Choose New to copy the channel to a new image, creating a multichannel image containing a 
single channel. Type a name for the new image. 

5    To reverse the selected and masked areas in the duplicate channel, select Invert. 

6    Click OK.

See also: 

To duplicate a channel by dragging 



Duplicating channels 

To duplicate a channel by dragging:

1    In the Channels palette, select the channel you want to duplicate.

2    Duplicate the channel:
•      To duplicate a channel within an image, drag the channel into the image window or onto the New 
Channel button ( ) at the bottom of the palette.

•      To duplicate the channel into another image, make sure that the destination image is open. Then drag
the channel into the destination image window.

See also: 

To duplicate a channel using the Duplicate command 



Using the Channels palette 

Deleting channels

You may want to delete alpha channels you no longer need before saving an image. Complex alpha 
channels can substantially increase the disk space required for an image. 

To delete a channel with no confirmation:

1    Select the channel in the Channels palette.

2    Delete the channel:
•      Alt-click (Windows) or Option-click (Mac OS) the Trash button.
•      Drag the channel name in the palette to the Trash button.
•      Choose Delete Channel from the Channels palette menu.

To delete a channel with confirmation:

1    Select the channel in the Channels palette.

2    Click the Trash button at the bottom of the palette. Then click Yes.

When deleting a channel from a file with layers, regardless of the method you use, Photoshop prompts
you first to flatten the visible layers and discard hidden layers (if any) before deleting the channel. This
is necessary because removing a color channel converts the image to Multichannel mode, which does
not support layers.



Using the Channels palette 

Mixing channels

The Channel Mixer command lets you modify a color channel using a mix of the current color 
channels. With this command, you can do the following:
•      Make creative color adjustments not easily done with the other color adjustment tools.
•      Create high-quality grayscale images by choosing the percentage contribution from each color 
channel.
•      Create high-quality sepia-tone or other tinted images.
•      Convert images to and from some alternative color spaces, such as YCrCb.
•      Swap or duplicate channels.

Original image and with a creative color adjustment

To mix channels in an image:

1    In the Channels palette, select the composite channel.

2    Choose Image > Adjust > Channel Mixer.

3    For Output Channel, choose the channel in which to blend one or more existing (or source) 
channels.

4    Drag any source channel’s slider to the left to decrease the channel’s contribution to the output 
channel, to the right to increase it, or enter a value between –200% and +200% in the text box. Using 
a negative value inverts the source channel before adding it to the output channel. 

5    If desired, drag the slider or enter a value for the Constant option. This option adds a channel of 
varying opacity to the output channel: negative values act as a black channel, positive values act as a 
white channel.

6    If desired, select Monochrome to apply the same settings to all the output channels, creating a 
color image that contains only gray values. 

Selecting Monochrome is useful for images you plan to convert to grayscale. If you select and then 
deselect this option, you can modify the blend of each channel separately, creating a handtinted 
appearance.



Using Channels and Masks 

Saving and managing channels

As long as you save a file in a format supporting the image’s color mode, the color channels will be 
preserved. But alpha channels are automatically kept only when you save a file in the Adobe 
Photoshop, Adobe Photoshop 2.0 (Mac OS only), DCS 2.0, PICT, TIFF, or Raw formats. Saving in 
other formats may cause channel information to be discarded (see About file formats).

See also: 

Splitting channels into separate images 

Merging channels 



Saving and managing channels 

Splitting channels into separate images

Choosing the Split Channels command from the Channels palette menu splits the various channels in 
an image into separate images. The original file is closed and individual channels appear in separate 
grayscale image windows. The title bar shows the original name plus the channel abbreviation 
(Windows) or full name (Mac OS). Any changes since the last save are retained in the new images, 
lost in the original.

Splitting channels is useful when you want to retain the individual channel information in a file format 
that doesn’t preserve channels.

Note: Only flattened images can be split (see Flattening all layers). 



Saving and managing channels 

Merging channels

Multiple grayscale images can be combined into a single image. Some grayscale scanners let you 
scan a color image through a red filter, a green filter, and a blue filter to generate red, green, and blue 
images. Merging lets you combine the separate scans into a single, color image.

Note: You can also blend the data in one or more channels into an existing or new channel (see Mixing
channels).

Images must be in Grayscale mode, have the same pixel dimensions, and be open. (See Changing 
the pixel dimensions of an image.) The number of grayscale images you have open determines the 
color modes available when merging channels. For example, you can’t merge the split channels from 
an RGB image into a CMYK image, because CMYK requires four channels and RGB only three. 

Note: If you are working with DCS files that have accidentally lost their links (and so cannot be 
opened, placed, or printed), open the channel files, and merge them into a CMYK image. Then resave
the file as a DCS EPS file. 

To merge channels: 

1    Open the grayscale images containing the channels you want to merge.

2    Make one of the images active. 

3    Choose Merge Channels from the Channels palette menu.

4    For Mode, choose the color mode you want to create. If an image mode is unavailable, it is 
dimmed. The number of channels appropriate for the mode appears in the Channels text box. 

5    If necessary, enter a number in the Channels text box. 

If the number is incompatible with the selected mode, Multichannel mode is automatically selected. 
This creates a multichannel image with two or more channels.

6    Click OK.

7    For each channel, make sure that the image you want is open. If you change your mind about 
image type, click Mode to return to the Merge Channels dialog box. 

8    If merging into a multichannel image, click Next, and repeat step 7 to select the remaining 
channels. 

Note: All channels of a multichannel image are alpha channels.

9    When finished selecting channels, click OK. 

The selected channels are merged into a new image of the specified type, and the original images 
closed without any changes. The new image appears in an untitled window. 

Note: You cannot split and recombine (merge) an image with spot color channels. The spot color 
channel will be added as an alpha channel.



Using Channels and Masks 

Adding spot colors

Spot colors are special premixed inks used instead of, or in addition to, the process color (CMYK) 
inks. Each spot color requires its own plate on the press. (Because a varnish also requires a separate 
plate on press, it is considered a spot color, too.) For information on printing spot color plates, see 
Printing color separations.

Use the following methods to assign spot colors to an image:
•      To apply spot color as a tint throughout the image, convert the image to Duotone mode and apply 
the spot color to one of the duotone plates. You can use up to four spot colors, one per plate. (See 
Using monotones, duotones, tritones, and quadtones.)
•      To apply spot color to specific areas of the image, create spot channels. The following sections 
discuss spot channels.

See also: 

Using spot channels 

Adjusting overlapping spot colors 



Adding spot colors 

Using spot channels

Spot channels let you add and preview spot colors in an image.

The following guidelines can help you in using spot channels:
•      If you need spot color graphics that have crisp edges and knock out the underlying image, 
consider creating the additional artwork in a page-layout or illustration application.
•      You can create new spot channels or convert an existing alpha channel to a spot channel.
•      Like alpha channels, spot channels can be edited or deleted at any time. (For more information, 
see Using alpha channels.)
•      Spot colors can’t be applied to individual layers.
•      Spot colors are overprinted on top of the fully composited image.
•      If you print an image that includes spot color channels to a composite printer, the spot colors print 
out as extra pages.
•      You can merge spot channels with color channels, splitting the spot color into its color channel 
components. Merging spot channels lets you print a single-page proof of your spot color image on a 
desktop printer.
•      The names of the spot colors print on the separations.
•      Each spot channel is overprinted in the order in which it appears in the Channels palette.
•      You cannot move spot colors above a default channel in the Channels palette except in 
Multichannel mode.
To move spot color channels in the Channels palette so that they print before other plates, convert the 

image to Multichannel mode.

See also: 

To create a spot channel 

To convert an alpha channel to a spot channel 

To edit a spot channel 

To change spot channel options 

To merge spot channels 



Using spot channels 

To create a spot channel:

1    Choose Window > Show Channels to display the Channels palette.

2    To fill a selected area with a spot color, make or load a selection.

3    Do one of the following:
•      Ctrl-click (Windows) or Command-click (Mac OS) the New Channel button ( ) in the Channels 
palette.

•      Choose New Spot Channel from the Channels palette menu.

If you made a selection, that area is filled with the currently specified spot color.

4    Click the color box and choose a color, as described in Using the Adobe Photoshop Color Picker. 
By selecting a custom color, your print service can more easily provide the proper ink to reproduce the
image. (For more information, see Choosing custom colors.)

5    For Solidity, enter a value between 0% and 100%. 

This option lets you simulate on-screen the solidity of the printed spot color. A value of 100% simulates
an ink that completely covers the inks beneath (such as a metallic ink); 0% simulates a transparent ink
that completely reveals the inks beneath (such as a clear varnish). You can also use this option to see 
where an otherwise transparent spot color (such as a varnish) will appear.

Important: The Solidity option only affects the on-screen preview. It has no effect on the printed 
output.

Solidity 100% and solidity 50%

6    If desired, enter a name for the spot channel. If you chose a custom color in step 4, the channel 
automatically takes the name of that color.

Remember that it’s important to name spot colors so they’ll be recognized by other applications 
reading your file. Otherwise the file might not print correctly— or print at all.

7    Click OK.

See also: 

To convert an alpha channel to a spot channel 

To edit a spot channel 

To change spot channel options 

To merge spot channels 



Using spot channels 

To convert an alpha channel to a spot channel:

1    In the Channels palette, double-click the alpha channel.

2    If needed, rename the channel.

3    Select Spot Color.

4    Click the color box and choose a color, as described in Using the Adobe Photoshop Color Picker.

5    Click OK.

The areas of the channel containing grayscale values are converted to spot color.

6    If desired, choose Image > Adjust > Invert to apply the spot color to the selected area of the 
channel. 

See also: 

To create a spot channel 

To edit a spot channel 

To change spot channel options 

To merge spot channels 



Using spot channels 

To edit a spot channel:

1    Select the spot channel in the Channels palette.

2    Use a painting or editing tool to paint in the image. Paint with black to add more spot color at 100%
opacity; paint with gray to add spot color with lower opacity.

Unlike the Solidity option in the Spot Channel Options dialog box, the Opacity option in the painting or 
editing tool’s Options palette determines the actual density of ink used in the printed output.

See also: 

To create a spot channel 

To convert an alpha channel to a spot channel 

To change spot channel options 

To merge spot channels 



Using spot channels 

To change spot channel options:

1    Do one of the following:
•      Double-click the spot channel name in the Channels palette.
•      Select the spot channel in the Channels palette, and choose Channel Options from the palette 
menu.

2    Change the channel options as described in the previous procedure, and click OK.

See also: 

To create a spot channel 

To convert an alpha channel to a spot channel 

To edit a spot channel 

To merge spot channels 



Using spot channels 

To merge spot channels:

1    In the Channels palette, select the spot channel you want to merge.

2    Choose Merge Spot Channel from the palette menu.

The spot color is converted to and merged with the color channels. The spot channel is deleted from 
the palette.

Before

After

Merging spot channels flattens layered images. The merged composite reflects the preview spot color 
information, including the Solidity settings. For example, a spot channel with a solidity of 50% will 
produce different merged results from the same channel with a solidity of 100%.

In addition, the resulting merged spot channels usually won’t reproduce the same colors as the 
original spot channels, because CMYK inks can’t represent the range of colors available from spot 
color inks.

To export spot channels:

Save the file in DCS 2.0 format. For more information, see Saving files in Photoshop EPS or DCS 
format.

See also: 

To create a spot channel 



To convert an alpha channel to a spot channel 

To edit a spot channel 

To change spot channel options 



Adding spot colors 

Adjusting overlapping spot colors 

To prevent overlapping spot colors from printing over, or knocking out, the underlying spot color, 
remove one of the spot colors where they overlap. To help you predict how colors will look when 
printed, use a printed sample of the overprinted inks to adjust your screen display.

Note: In some cases, you may want colors to overprint, such as in varnishes and bump plates.

To remove an underlying spot color:

1    In the Channels palette, select the spot channel whose color you want to print.

2    Choose Select > Load Selection.
To quickly select an image in a channel, hold down Ctrl (Windows) or Command (Mac OS), and click 

the channel in the Channels palette.

3    For Channel, choose the spot channel from step 1 and click OK.

4    To create trap when knocking out the underlying color, choose Select > Modify > Expand or 
Contract depending on whether the overlapping spot color is darker or lighter than the spot color 
beneath it. For more information on trapping, see Creating color traps.

5    In the Channels palette, select the underlying spot channel that contains areas you want to knock 
out. Press Delete.

This method can be used to knock out areas from any channels under a spot color, such as the CMYK 
channels.

6    If a spot color in one channel overlaps more than one other spot color, repeat this process for each 
channel that contains areas you want removed. 



Using Channels and Masks 

About masks

Masks let you isolate and protect areas of an image as you apply color changes, filters, or other 
effects to the rest of the image. When you select part of an image, the area that is not selected is 
“masked” or protected from editing. You can also use masks for complex image editing such as 
gradually applying color or filter effects to an image.

In addition, masks let you save and reuse time-consuming selections as alpha channels. (Alpha 
channels can be converted to selections and then used for image editing.) Because masks are stored 
as 8-bit grayscale channels, you can refine and edit them using the full array of painting and editing 
tools.

When a mask channel is selected in the Channels palette, foreground and background colors appear 
as grayscale values. (See Using Quick Mask mode.)

A. Opaque mask used to protect the background and color the shell.    B. Opaque mask used to protect the shell 
and color the background.    C. Semitransparent mask used to color the background and part of the shell.

In Photoshop, you can create masks, all stored at least temporarily as grayscale channels, in three 
ways:
•      Quick Mask mode lets you create and view a temporary mask for an image (see Using Quick 
Mask mode).
•      Alpha channels let you save and load a selection to be used as a mask (see Using alpha 
channels).
•      Layer masks let you create a mask for a specific layer (see Using layer masks).



Using Channels and Masks 

Using Quick Mask mode

Quick Mask mode lets you edit any selection as a mask without using the Channels palette and while 
viewing your image. The advantage of editing your selection as a mask is that you can use almost any
Photoshop tool or filter to modify the mask. For example, if you create a rectangular selection with the 
marquee tool, you can enter Quick Mask mode and use the paintbrush to extend or contract the 
selection, or use a filter to distort the edges of the selection. You can also use selection tools, because
the quick mask is not a selection.

Start with a selected area and use Quick Mask mode to add to or subtract from it to make the mask, or
create the mask entirely in Quick Mask mode. Color differentiates the protected and unprotected 
areas. When you leave Quick Mask mode, the unprotected areas become a selection.

A temporary Quick Mask channel appears in the Channels palette while you work in Quick Mask 
mode. However, you do all mask editing in the image window. 

To create a quick mask:

1    Using any selection tool, select the part of the image you want to change.

2    Click the Quick Mask mode button ( ) in the toolbox.

Selected area, and Quick Mask mode applied

A color overlay (similar to a piece of rubylith) covers and protects the area outside the selection. The 
original selection is left unprotected by this mask. By default, Quick Mask mode colors the protected 
area using a red, 50% opaque overlay. 

3    To edit the mask, select a painting or editing tool from the toolbox, or select a filter or adjustment 
command from the menu bar. By default, painting with black adds to the mask, shrinking the selection.
Painting with white removes areas from the mask, expanding the selection. Painting with gray or 
another color creates a semitransparent area, useful for feathering or anti-aliased effects.

Quick Mask, and edited with paintbrush tool

4    Click the Standard mode button ( ) in the toolbox to turn off the quick mask and return to your 
original image. A selection border now surrounds the unprotected area of the quick mask.

The selection boundary indicates where 50% of the pixels are selected. That is, if a feathered mask is 
converted into a selection, the boundary line runs halfway between the black pixels and the white pixels of
the mask gradient.



5    Apply the desired changes to the image. Changes affect only the selected area. 

Edited mask, and adjustment applied

6    Choose Select > None to deselect the selection, or save the selection as described in the saving 
procedures on Creating and saving alpha channels. 

To change the Quick Mask options:

1    Double-click the Quick Mask mode button ( ) in the toolbox.
2    Choose from the following display options:

•      Masked Areas (the default) to have masked (protected or unselected) areas appear black 
(opaque), and to have selected areas appear white (transparent). Painting with black increases the 
masked, protected area; painting with white increases the selected area.

With this option, the Quick Mask button in the toolbox appears as a white circle on a gray background 
( ).
•      Selected Areas to have masked or protected areas appear white (transparent) and to have 
selected areas appear black (opaque). Painting with white increases the masked, protected area; 
painting with black increases the selected area.

With this option, the Quick Mask button in the toolbox appears as a gray circle on a white background 
( ).

To toggle between the Masked Areas and Selected Areas options for quick masks, Alt-click (Windows) or Option-
click (Mac OS) the Quick Mask mode button.

3    To choose a new mask color, click the color box and choose a new color as described in Using the 
Adobe Photoshop Color Picker. 

4    To change the opacity, enter a value between 0% and 100%. 

Both the color and opacity settings affect only the appearance of the mask and have no effect on how 
underlying areas are protected. Changing these settings may make the mask more easily visible 
against the colors in the image.

5    Click OK.



Using Channels and Masks 

Using alpha channels

In addition to the temporary masks of Quick Mask mode, you can create more permanent masks by 
storing and editing selections in alpha channels (see About masks).

An alpha channel has these properties:
•      Each image can contain up to 24 channels, including all color and alpha channels.
•      All channels are 8-bit grayscale images, capable of displaying 256 levels of gray.
•      You can add and delete alpha channels.
•      You can specify a name, color, mask option, and opacity for each channel. (The opacity affects the
preview of the channel, not the image.)
•      All new channels have the same dimensions and number of pixels as the original image.
•      You can edit the mask in an alpha channel using the painting and editing tools.
•      Storing selections in alpha channels makes the selections permanent, so that they can be used 
again in the same image or in a different image.

See also: 

Creating and saving alpha channels 

Loading a selection into an image 



Using alpha channels 

Creating and saving alpha channels

You create a new alpha channel as a mask. For example, you can create a gradient fill in a blank 
channel, and then use it as a mask. Or you can save a selection to either a new or existing channel. 

To create a new alpha channel using current options:

Click the New Channel button ( ) at the bottom of the Channels palette. The new channel is named 
according to the sequence in which it was created.

To create a new alpha channel and specify options:

1    Do one of the following:
•      Alt-click (Windows) or Option-click (Mac OS) the New Channel button ( ) at the bottom of the 
palette. 

•      Choose New Channel from the Channels palette menu.

2    Type a name for the channel. 

3    Select display options for the channel, as described in steps 2 through 4 of the procedure on Quick
Mask options in Using Quick Mask mode. Alpha channel options are identical to Quick Mask options. 

4    Click OK. 

A new channel appears at the bottom of the Channels palette and is the only channel visible in the 
image window.

To edit an alpha channel:

Use a painting or editing tool to paint in the image. Paint with black to add to the channel; paint with 
white to remove from the channel; paint with a lower opacity or a color to add to the channel with lower
opacities. 

To save a selection to a new channel with default options:

1    Select the area or areas of the image that you want to isolate.

2    Click the Save Selection button ( ) at the bottom of the Channels palette. A new channel 
appears, named according to the sequence in which it was created.

To save a selection to a new or existing channel:

1    Select the area or areas of the image that you want to isolate. 

2    Choose Select > Save Selection.

3    For Document, choose a destination image for the selection.

By default, the selection is placed in a channel in your active image. You can choose to save the 
selection to a channel in another open image with the same pixel dimensions or to a new image.

4    Choose a destination channel for the selection. 

By default, the selection is saved in a new channel. You can choose to save the selection to any 
existing channel in the selected image or to a layer mask if the image contains layers. 

5    If you’re saving the selection to an existing channel, select how to combine the selections: 
•      Replace Channel to replace the current selection in the channel.
•      Add to Channel to add the selection to the current channel contents.
•      Subtract from Channel to delete the selection from the channel contents.
•      Intersect with Channel to keep the areas of the new selection that intersect with the channel 



contents.

6    Click OK.

7    Select the channel in the Channels palette to see the saved selection displayed in grayscale.

To change options for a channel:

1    Do one of the following:
•      Select the channel in the Channels palette, and choose Channel Options from the palette menu.
•      Double-click the channel name in the Channels palette.

2    Enter a new name for the channel.

3    Choose display options, as explained in steps 2 through 4 of the procedure on Quick Mask options 
in Using Quick Mask mode.

See Using spot channels for information on changing Spot Color channel options.

Note: You cannot modify options for the default color channels. 



Using alpha channels 

Loading a selection into an image

When you have finished modifying an alpha channel or simply want to use a previously saved 
selection, you can load the selection into the image.

See also: 

To load a saved selection using shortcuts 

To load a saved selection into an image 

To load a selection from another image 



Loading a selection into an image 

To load a saved selection using shortcuts:

Do one of the following in the Channels palette:
•      Select the alpha channel, click the Load Selection button ( ) at the bottom of the palette, and 
then click the composite color channel near the top of the palette.

•      Ctrl-click (Windows) or Command-click (Mac OS) the channel containing the selection you want to 
load.
•      To add the mask to an existing selection, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), 
and click the channel.
•      To subtract the mask from an existing selection, press Ctrl+Alt (Windows) or Command+Option (Mac 
OS), and click the channel.

•      To load the intersection of the saved selection and an existing selection, press Ctrl+Alt+Shift 
(Windows) or Command+Option+Shift (Mac OS), and select the channel.

See also: 

To load a saved selection into an image 

To load a selection from another image 



Loading a selection into an image 

To load a saved selection into an image:

1    Choose Select > Load Selection. For Document, the active filename is selected.

2    For Channel, choose the channel containing the selection you want to load.

3    Click Invert to make the nonselected areas selected and vice versa.

4    If the destination image already has a selection, indicate how to combine the selections. (For 
information on these options, see step 5 of the procedure on saving a selection to a new or existing 
channel in Creating and saving alpha channels.)

5    Click OK to load the selection.

See also: 

To load a saved selection using shortcuts 

To load a selection from another image 



Loading a selection into an image 

To load a selection from another image:

1    Open the two images you want to use. 

Note: The images must have identical pixel dimensions. See Changing the pixel dimensions of an image.

2    Make the destination image active, and choose Select > Load Selection.

3    For Document, choose the source image.

4    For Channel, choose the channel containing the selection you want to use as a mask.

5    Click Invert if you want to make the nonselected areas selected and vice versa.

6    If the destination image already has a selection, indicate how to combine the selections. (For 
information on these options, see step 5 of the procedure on saving a selection to a new or existing 
channel in Creating and saving alpha channels.)

7    Click OK to load the selection.

See also: 

To load a saved selection using shortcuts 

To load a saved selection into an image 



Using Layers

See also: 

Using the Layers palette 

Understanding Layers 

Creating a layered image 

Moving and aligning layer contents 

Managing layered images 

Editing layers 

Specifying layer options 

Using channel calculations to blend layers and channels 

Creating clipping groups 

Using layer masks 

Selecting opaque areas on a layer 

Using adjustment layers 

Using layer effects 



Using Layers 

 Using the Layers palette

The Layers palette lists all layers in an image, starting with the topmost layer. A thumbnail of layer 
contents appears to the left of the layer name. It is updated as you edit. Use the scroll bars or resize 
the palette to see additional layers.

You use the Layers palette to create, hide, display, copy, merge, and delete layers. (Additional 
commands appear in the menu.) Changes to an image affect only the highlighted or active layer. You 
select a layer to make it active, and only one layer can be active at a time. The active layer’s name 
appears in the image window’s title bar, and a paintbrush icon appears next to the layer in the Layers 
palette, indicating that the layer can be modified. 

To display the Layers palette:

Choose Window > Show Layers.

To select a layer:

Do one of the following:
•      In the Layers palette, click a layer to make it active.
•      Select the move tool, right-click (Windows) or Control-click (Mac OS) in the image, and choose the
layer you want from the context menu. The context menu lists all the layers that contain pixels under 
the current pointer location.

You can also select layers interactively as you use the move tool (see Moving selections and layers 
within an image).

See also: 

Viewing layers 

Changing the stacking order of layers 

Linking layers 



Using the Layers palette 

Viewing layers

With the Layers palette, you can control whether a layer is visible, whether a preview or thumbnail of 
its contents is displayed, and also how transparency is displayed. Turning off thumbnails or reducing 
their size can speed performance and save monitor space.

See also: 

To show or hide a layer 

To change the display of layer thumbnails 

To change the transparency display 



Viewing layers 

To show or hide a layer:

Do one of the following:
•      In the Layers palette, click the eye icon next to a layer to hide that layer. Click in the column again 
to redisplay the layer. 
•      Drag through the eye column to show or hide multiple layers.
•      Alt-click (Windows) or Option-click (Mac OS) the eye icon for a layer to display just that layer. 
Alt/Option-click in the eye column again to redisplay all the layers. 

Only visible layers are printed. Making layers temporarily invisible can speed performance.

Note: You can make the active layer invisible. Keep in mind, however, that changes still affect the 
hidden, active layer.

Lion layer, and background hidden 

See also: 

To change the display of layer thumbnails 

To change the transparency display 



Viewing layers 

To change the display of layer thumbnails:

1    Choose Palette Options from the Layers palette menu.

2    Click a size or click None to turn off the thumbnails, and then click OK.

See also: 

To show or hide a layer 

To change the transparency display 



Viewing layers 

To change the transparency display:

1    Choose File > Preferences > Transparency & Gamut. By default, the transparent areas of a 
document appear as a checkerboard pattern.

2    For Grid Size, select a new size for the pattern. If you choose None, transparent areas in the layer 
appear white. 

3    For Grid Colors, select an option:
•      Light, Medium, or Dark to specify a gray pattern. 
•      Any other color from the list to display the checkerboard in that color.
•      Custom to choose a color that does not appear in the list. Then click either of the color selection 
boxes to specify a custom color.

4    Click OK.

See also: 

To show or hide a layer 

To change the display of layer thumbnails 



Using the Layers palette 

Changing the stacking order of layers

The stacking order determines whether a layer appears in front of or behind other layers.

See also: 

To change the order of a layer 

To change the order of layers by dragging 



Changing the stacking order of layers 

To change the order of a layer:

1    In the Layers palette, select the layer that you want to move.

2    Choose Layer > Arrange, and choose an option from the submenu to arrange the layer:
•      Bring to Front to make the layer the topmost layer.
•      Bring Forward to move the layer one level up in the stacking order.
•      Send Backward to move the layer one level down in the stacking order.
•      Send to Back to make the layer the bottommost layer in the image (except for the background).
 To move a selected layer one level up in the Layers palette, press Ctrl+] (Windows) or Command+] 

(Mac OS). To move one level down, press Ctrl+[ or Command+[. To move to the topmost level, press 
Ctrl+Shift+] or Command+Shift+]. To move to the bottommost level (above the background), press 
Ctrl+Shift+[ or Command+Shift+[.

See also: 

To change the order of layers by dragging 



Changing the stacking order of layers 

To change the order of layers by dragging:

1    In the Layers palette, select the layer that you want to move.

2    Drag the layer up or down in the Layers palette. When the highlighted line appears in the desired 
position, release the mouse button. 

Original image

Zebra layer dragged below Lion layer

Note: By default, the background cannot be moved from the bottom of the layer list. To move the 
background, first convert it to a layer as described in the procedure To convert a background into a layer.

See also: 

To change the order of a layer 



Using the Layers palette 

Linking layers

By linking two or more layers, you can move their contents together. You can also perform the 
following tasks on linked layers:
•      Apply transformations (see Transforming objects in two dimensions).
•      Align layer contents (see Moving and aligning layer contents).
•      Merge layers (See Merging layers).
•      Create clipping groups (see Creating clipping groups).

To link layers:

1    Select a layer in the Layers palette.

2    Click in the column immediately to the left of any layers you want to link to the selected layer. The 
link icon appears in the column. 

To unlink layers:

In the Layers palette, click the link icons to remove them.



Using Layers 

Understanding Layers

Think of layers as sheets of acetate stacked one on top of the other. Where there is no image on a 
layer, you can see through to the layers below. Behind all of the layers is the background. In the 
illustration below, each animal and the map are on separate layers. The dark texture is the 
background. All layers in a file share the same resolution, the same number of channels, and the 
same image mode (RGB, CMYK, or Grayscale).

Zebra is on topmost layer.

Transparent areas on a layer let you see through to the layers below.



Using Layers 

Creating a layered image

Adobe Photoshop lets you create up to 100 layers in an image, each with its own blending mode and 
opacity. However, the amount of memory in your system may put a lower limit on the number of layers 
possible in a single image. 

Note: Images created using the Transparent option in the New dialog box are created without a 
background. Images with no background, as well as images with layers, can be saved only in the 
Photoshop format.

See also: 

Adding layers 

Duplicating layers 



Creating a layered image 

Adding layers

Newly added layers appear above the selected layer in the Layers palette. You can add layers to an 
image in a variety of ways:
•      By creating new layers or turning selections into layers. 
•      By converting a background to a regular layer or adding a background to an image. 
•      By pasting selections into the image (see Copying selections or layers).
•      By creating type using the horizontal type tool or vertical type tool (see Using Type).

See also: 

To create a new layer using default options 

To add a new layer and specify options 

To turn a selection into a new layer 

To convert a background into a layer 

To add a background to an image 



Adding layers 

To create a new layer using default options:

Click the New Layer button ( ) at the bottom of the Layers palette. The layer uses Normal mode with 
100% opacity and is named according to its order of creation. 

See also: 

To add a new layer and specify options 

To turn a selection into a new layer 

To convert a background into a layer 

To add a background to an image 



Adding layers 

To add a new layer and specify options:

1    Do one of the following:
•      Choose Layer > New > Layer.
•      Choose New Layer from the Layers palette menu.
•      Alt-click (Windows) or Option-click (Mac OS) the New Layer button at the bottom of the Layers 
palette.

2    Name the layer, and select mode, opacity, and fill options as described in Specifying layer options. 
Then click OK.

See also: 

To create a new layer using default options 

To turn a selection into a new layer 

To convert a background into a layer 

To add a background to an image 



Adding layers 

To turn a selection into a new layer: 

1    Make a selection. 

2    Choose Layer > New, and choose a command from the submenu:
•      To copy the selection into a new layer, choose Layer Via Copy.
•      To cut the selection and paste it into a new layer, choose Layer > New > Layer Via Cut. 

The selection contents appear in the same position relative to the image boundaries.

Selection cut and pasted into new layer

See also: 

To create a new layer using default options 

To add a new layer and specify options 

To convert a background into a layer 

To add a background to an image 



Adding layers 

To convert a background into a layer:

1    Double-click Background in the Layers palette. 

2    Enter a name, opacity, and mode for the layer. See the section, Specifying layer options. 

3    Click OK.

See also: 

To create a new layer using default options 

To add a new layer and specify options 

To turn a selection into a new layer 

To add a background to an image 



Adding layers 

To add a background to an image:

Choose Layer > New > Background to create a Background layer filled with the current background 
color. (See Choosing the foreground and background colors.)

You cannot change the stacking order of a background or apply a blending mode or opacity. 

See also: 

To create a new layer using default options 

To add a new layer and specify options 

To turn a selection into a new layer 

To convert a background into a layer 



Creating a layered image 

Duplicating layers 

You can duplicate any layer (including the background) within the same image. And you can copy any 
layer (including the background) from one image to another. 

When copying layers between images, keep in mind that the printed size of the copied layer depends 
on the resolution of the destination image. For example, if the source image has a lower resolution 
than the destination image, the copied layer will appear smaller in the destination image when printed. 
For more information, see About image size and resolution.

See also: 

To duplicate a layer in an image 

To copy a layer between images 

To copy multiple layers into another image 

To duplicate a layer into another image or a new image 



Duplicating layers 

To duplicate a layer in an image:

1    Select the layer in the Layers palette. 

2    Duplicate the layer:
•      To duplicate and rename the layer, choose Layer > Duplicate Layer or choose Duplicate Layer 
from the Layers palette menu. Name the duplicate layer, and click OK.
•      To duplicate without naming, drag the layer name in the Layers palette to the New Layer button (

) at the bottom of the palette. The new layer is named according to its order of creation.

See also: 

To copy a layer between images 

To copy multiple layers into another image 

To duplicate a layer into another image or a new image 



Duplicating layers 

To copy a layer between images:

1    Open the two images you want to use.

2    In the Layers palette of the source image, select the name of the layer that you want to copy.

3    Copy the layer:
•      Choose Select > All to select all of the pixels on the layer that fall inside the canvas boundaries, 
and choose Edit > Copy. Make the destination image active, and choose Edit > Paste. 
•      Drag the layer’s name from the Layers palette into the destination image.
•      Use the move tool ( ) to drag the layer from the source image to the destination image. The 
copied layer appears in the destination image where you release the mouse button (and above the 
active layer in the Layers palette). If the layer you’re dragging is larger than the destination image, only
part of the layer is visible, but its contents remain available. Use the move tool to drag other sections 
of the layer into view. 

Layer dragged and dropped between images
 Hold down Shift as you drag a layer to copy it in the same position it occupied in the source image (if the source 

and destination images have the same pixel dimensions) or to the center of the destination image (if the source and 
destination images have different pixel dimensions).

See also: 

To duplicate a layer in an image 

To copy multiple layers into another image 

To duplicate a layer into another image or a new image 



Duplicating layers 

To copy multiple layers into another image:

1    Make sure that both the source and destination images are open, and select one of the layers you 
want to copy.

2    In the Layers palette, click in the column immediately to the left of any additional layers you want to
move. The link icon appears in the column. 

3    Use the move tool ( ) to drag the linked layers from the source image to the destination image.

See also: 

To duplicate a layer in an image 

To copy a layer between images 

To duplicate a layer into another image or a new image 



Duplicating layers 

To duplicate a layer into another image or a new image:

1    If you plan to copy a layer to an existing image, open both the source and destination images.

2    In the source document’s Layers palette, select the name of the layer you want to duplicate.

3    Duplicate the layer:
•      Choose Layer > Duplicate Layer.
•      Choose Duplicate Layer from the Layers palette menu. 

4    Type a name for the duplicate layer.

5    For Document, choose a destination for the layer. To create a new document for the layer, choose 
New, and type a name for the new document. 

6    Click OK.

An image created by duplicating a layer has no background. 

See also: 

To duplicate a layer in an image 

To copy a layer between images 

To copy multiple layers into another image 



Using Layers 

Moving and aligning layer contents

You can also reposition the contents of individual layers or groups of layers within the image’s 
boundaries.

The Align Linked commands let you align the contents of linked layers to the contents of the active 
layer or to a selection border. The Distribute Linked commands let you position the contents of linked 
layers at evenly spaced intervals.

See also: 

To reposition a layer in an image 

To reposition multiple layers 

To align or distribute layers 



Moving and aligning layer contents 

To reposition a layer in an image:

1    In the Layers palette, select the layer that you want to move.

2    Select the move tool ( ). To activate the move tool when any other tool is selected, hold down Ctrl
(Windows) or Command (Mac OS).

3    Drag anywhere in the image to move the selected layer into the desired position. To constrain the 
direction of movement to a multiple of 45°, hold down Shift as you drag.

 To reposition the layer in 1-pixel increments when the move tool is selected, press the arrow keys on 
the keyboard. To move the layer in 10-pixel increments (or to move one frame if you’re editing a filmstrip 
file), press Shift and an arrow key.



Moving and aligning layer contents 

To reposition multiple layers:

1    In the Layers palette, link the layers you want to move, as described in Linking layers.

2    Use the move tool ( ) to move the linked layers in the image window.

Lion and zebra layers linked and moved



Moving and aligning layer contents 

To align or distribute layers:

1    To align layers to a selection border, make a selection.

2    In the Layers palette, specify the layers you want to align or distribute:
•      To align a single layer to a selection, make the layer active.
•      To align multiple layers to a selection or to the active layer, link together two or more layers.
•      To distribute multiple layers, link together three or more layers.

For more information, see Linking layers.

3    To align layers, choose Layer > Align Linked (or Align To Selection if you made a selection), and 
choose an option from the submenu:
•      Top to align the topmost pixel on the linked layers to the topmost pixel on the active layer or the 
topmost edge of the selection border.
•      Vertical Center to align the vertical centermost pixel on the linked layers to the vertical centermost 
pixel on the active layer or the vertical center of the selection border.
•      Bottom to align the bottommost pixel on the linked layers to the bottommost pixel on the active 
layer or the bottommost edge of the selection border.
•      Left to align the leftmost pixel on the linked layers to the leftmost pixel on the active layer or the 
leftmost edge of the selection border.
•      Horizontal Center to align the horizontal centermost pixel on the linked layers to the horizontal 
centermost pixel on the active layer or the horizontal center of the selection border.
•      Right to align the rightmost pixel on the linked layers to the rightmost pixel on the active layer or 
the rightmost edge of the selection border.

Original, and vertical centers aligned

4    To distribute layers, choose Layer > Distribute Linked, and choose an option from the submenu:
•      Top to space the linked layers evenly starting from the top pixel on each layer.
•      Vertical Center to space the linked layers evenly starting from the vertical centermost pixel on 
each layer.
•      Bottom to space the linked layers evenly starting from the bottom pixel on each layer.
•      Left to space the linked layers evenly starting from the leftmost pixel on each layer.
•      Horizontal Center to space the linked layers evenly starting from the horizontal centermost pixel on
each layer.
•      Right to space the linked layers evenly starting from the rightmost pixel on each layer.

Note: Photoshop aligns and distributes only those layers whose pixels have greater than 50% opacity.
For example, the Align Linked > Top command aligns to the topmost pixel on the active layer that is 
more than 50% opaque.



Using Layers 

Managing layered images

Adding nontransparent layers to an image increases its file size. To conserve disk space, you can 
delete layers, merge two or more layers, or flatten all layers in an image into one layer. 

See also: 

To track file size 

To delete a layer 

Merging layers 

Flattening all layers 

Saving layered documents 



Managing layered images 

To track file size:

Check the values in the Document Sizes box at the lower left corner of the screen (Windows) or the 
image window (Mac OS). For more information on displaying file size, see Changing image size and 
resolution.

The first (left) value indicates the size of the file if flattened. The second (right) value shows the 
estimated file size of the unflattened file, including any layers and channels.
 To track the use of the Adobe Photoshop scratch disk (temporary disk space used for storing data 

when RAM is insufficient), position the pointer over the triangle at the bottom of the image window, hold 
down the mouse button, and choose Scratch Sizes. (See Using RAM, scratch disks, and system virtual 
memory.)



Managing layered images 

To delete a layer:

1    Select the layer in the Layers palette.

2    Delete the layer:
•      Click the Trash button at the bottom of the Layers palette, and click Yes.
•      Choose Layer > Delete Layer.
•      Choose Delete Layer from the Layers palette menu. 
 To delete a selected layer automatically, Alt-click (Windows) or Option-click (Mac OS) the Trash button 

at the bottom of the Layers palette. You can also drag the layer name in the Layers palette to the Trash 
button.



Managing layered images 

Merging layers

Merging layers combines several layers into one and keeps file size manageable. When you’ve 
finalized the characteristics and positioning of a layer’s contents, you can merge the layer with one or 
more layers to create partial versions of your composite image. The intersection of all transparent 
areas in the merged layers remains transparent. You can also merge the layers in a linked group or 
clipping group. For information on creating clipping groups, see Creating clipping groups. 

For information on merging adjustment layers, see Merging adjustment layers.

See also: 

To merge a layer with the layer below it 

To merge all visible linked layers 

To merge a clipping group 

To merge all the visible layers in an image 



Merging layers 

To merge a layer with the layer below it:

1    Make sure that the two layers you want to merge are visible. Select the top layer of the pair in the 
Layers palette.

2    Merge the layer:
•      Choose Layer > Merge Down.
•      Choose Merge Down from the Layers palette menu.

See also: 

To merge all visible linked layers 

To merge a clipping group 

To merge all the visible layers in an image 



Merging layers 

To merge all visible linked layers:

1    Make visible all layers you want to merge, and link them together, as described in Linking layers. 

2    Choose Layer > Merge Linked.

See also: 

To merge a layer with the layer below it 

To merge a clipping group 

To merge all the visible layers in an image 



Merging layers 

To merge a clipping group:

1    Make visible all the layers in the group that you want to merge (any hidden layers in the group are 
discarded when you merge). 

2    Select the base layer in the group.

3    Choose Layer > Merge Group.

See also: 

To merge a layer with the layer below it 

To merge all visible linked layers 

To merge all the visible layers in an image 



Merging layers 

To merge all the visible layers in an image:

1    Hide any layers you do not want to merge. Make sure that no layers are linked.

2    Do one of the following:
•      Choose Layer > Merge Visible.
•      Choose Merge Visible from the Layers palette menu.
 To merge all visible layers into a new layer, create a new empty layer, hold down Alt (Windows) or 

Option (Mac OS), and choose Layer > Merge Visible.

See also: 

To merge a layer with the layer below it 

To merge all visible linked layers 

To merge a clipping group 



Managing layered images 

Flattening all layers

In a flattened image, all visible layers are merged into the background, greatly reducing file size. 
Flattening an image discards all hidden layers and fills the remaining transparent areas with white. In 
most cases, you won’t want to flatten a file until you have finished editing individual layers. 

Note: Converting an image between some color modes flattens the file. Be sure to save a copy of 
your file that includes all layers if you want to edit the original image after the conversion.

To flatten an image:

1    Make sure that all the layers you want to keep are visible.

2    Flatten the image:
•      Choose Layer > Flatten Image.
•      Choose Flatten Image from the Layers palette menu.

Layered file, and flattened file



Managing layered images 

Saving layered documents

You may want to save two versions of your file—a flattened version for final use and a second version 
with layers intact for future edits. 

The Save a Copy command makes it possible to save a copy to your disk (in this case a flattened 
copy) without replacing the active window. For more information on saving documents and 
determining file formats, see Saving files.



Using Layers 

Editing layers

A newly created layer is transparent. You can add color values to the layer using the painting and 
editing tools, and then apply filters or use special effects to modify the layer. All painting and editing 
occurs on the active layer (and in the active channel).

See also: 

Preserving a layer’s transparency 

Sampling from all layers 

Filling a new layer with a neutral color 



Editing layers 

Preserving a layer’s transparency

You can confine your painting and editing to those areas of a layer already containing pixels. For 
example, you may want to edit an object (adding special effects, changing color) without adding pixels 
to the transparent area outside the object.

To confine editing to the opaque portions of a layer:

1    Select the layer in the Layers palette.

2    Select Preserve Transparency in the Layers palette.

Note: For type layers, Preserve Transparency is on by default and cannot be turned off.

Painting with Preserve Transparency on



Editing layers 

Sampling from all layers

By default, when working with the magic wand, smudge, blur, sharpen, rubber stamp, or pattern stamp
tool, you are applying color sampled only from pixels on the active layer. This means you can smudge 
or sample in a single layer even when other layers are visible, and you can sample from one layer and
paint in another one. 

Alternatively, you can choose to paint using sampled data from all the visible layers. For example, you 
can use the rubber stamp tool to clone an area containing pixels from all the visible layers.

To sample from all visible layers:

1    Double-click the magic wand tool ( ), smudge tool (
), blur tool (
), sharpen tool (
), rubber stamp tool (
), or pattern stamp tool (
) to display its Options palette.

2    Select Use All Layers in the tool’s Options palette.

Cloning with zebra layer, and with merged data from all layers

Note: Unless you are using the rubber stamp tool, painting or editing in a new layer produces the best 
results when Use All Layers is selected.



Editing layers 

Filling a new layer with a neutral color

Some Adobe Photoshop effects (such as the Lighting Effects filter) cannot be applied to layers with no 
pixels. Selecting Fill with Neutral Color in the New Layer dialog box resolves this problem by first filling
the layer with a preset, neutral color. If no effect is applied, filling with a neutral color has no effect on 
the remaining layers. The Fill with Neutral Color option is not available for layers that use the Normal, 
Dissolve, Hue, Saturation, Color, or Luminosity modes. For more information, see Adding layers

Note: Not all filters produce a visible effect when applied to a layer filled with a neutral color.



Using Layers 

Specifying layer options

The layer options let you change a layer’s name and opacity and control how the pixels in the layer 
blend with the layers underneath. It’s important to remember that the opacity and blending modes 
chosen for a specific layer interact with the opacity and mode settings for the tools you use to paint 
and edit the pixels on the layer.

For example, suppose you are working on a layer that uses the Dissolve mode and an opacity of 50%.
If you paint on this layer using the paintbrush tool set to Normal mode with an opacity of 100%, the 
paint will appear in Dissolve mode with a 50% opacity because this is the maximum the layer can 
display.

On the other hand, suppose you are working on a layer created using Normal mode and 100% 
opacity. If you use the eraser tool with an opacity of 50%, only 50% of the paint will disappear as you 
erase. For more information on painting blending modes, see Selecting a blending mode.

See also: 

To choose options for a layer 

Specifying opacity 

Specifying layer blending modes 

Specifying a range for blending layers 



Specifying layer options 

To choose options for a layer:

1    Do one of the following:
•      Double-click the layer’s name in the Layers palette. (This method does not apply to most 
adjustment layers.)
•      Select the layer in the Layers palette, and choose Layer > Layer Options.
•      Select the layer in the Layers palette, and choose Layer Options from the palette menu.

2    If desired, type a new name for the layer. 

3    To turn off previewing as you choose layer options, deselect Preview. 

4    Click OK. 



Specifying layer options 

Specifying opacity

You can change the opacity of each layer using either the Opacity option in the Layer Options dialog 
box or the Opacity slider in the Layers palette. A layer with 1% opacity appears nearly transparent, one
with 100% opacity completely opaque.

Zebra layer with 50% opacity

You cannot change the opacity of an image that has only a background.

To specify opacity for a layer:

Do one of the following:
•      In the Layers palette, enter a value for Opacity or drag the slider.
•      In the Layer Options dialog box, enter a value for Opacity.
 If you have selected a tool without an opacity option in its Options palette, use the following shortcuts 

to change the opacity of the active layer: 
• Press a number key to set the opacity in multiples of 10% (pressing 1 sets to 10%, pressing 0 sets to 
100%). 
• To specify an exact opacity, type the desired value.



Specifying layer options 

Specifying layer blending modes

You use layer blending modes to determine how the pixels in a layer are blended with underlying 
pixels on other layers. By applying modes to individual layers, you can create a variety of special 
effects. 

Note: There is no Clear blending mode for layers. In addition, the Color Dodge, Color Burn, Darken, 
Lighten, Difference, and Exclusion modes are unavailable for Lab images.
Normal 
Dissolve 
Multiply 
Screen 
Overlay 
Soft Light 
Hard Light 
Color Dodge 
Color Burn 
Darken 
Lighten 
Difference 
Exclusion 
Hue 
Saturation 
Color 
Luminosity 



Specifying layer options 

Specifying a range for blending layers

The sliders in the Layer Options dialog box let you control which pixels from the active layer and which
from the underlying visible layers blend and appear in the final image. For example, you can drop dark
pixels out of the active layer or force bright pixels from the underlying layers to show through. You can 
also define a range of partially blended pixels to produce a smooth transition between blended and 
unblended areas. 

To define a range for the blending operation: 

1    In the Layer Options dialog box, select a Blend If option:
•      Gray to specify a blending range for all channels. 
•      An individual color channel (for example, red, green, or blue in an RGB image) to specify blending 
in that channel. For more information, see Color channels.

2    Use the This Layer and Underlying sliders to set the brightness range of the blended pixels—
measured on a scale from 0 (black) to 255 (white). Drag the white slider to set the high value of the 
range. Drag the black slider to set the low value of the range. 

3    To define a range of partially blended pixels, hold down Alt (Windows) or Option (Mac OS), and 
drag one half of a slider triangle. The two values that appear above the divided slider indicate the 
partial blending range. 

Keep the following guidelines in mind when specifying blending ranges:
•      Use the This Layer sliders to specify the range of pixels on the active layer that will blend and 
therefore appear in the final image. For example, if you drag the white slider to 235, pixels with 
brightness values higher than 235 will remain unblended and be excluded from the final image. 
•      Use the Underlying sliders to specify the range of pixels in the underlying visible layers that will 
blend in the final image. Blended pixels are combined with pixels in the active layer to produce 
composite pixels, while unblended pixels show through overlying areas of the active layer. For 
example, if you drag the black slider to 19, pixels with brightness values lower than 19 will remain 
unblended and show through the active layer in the final image.



Using Layers 

Using channel calculations to blend layers and channels

You can use the blending effects associated with layers to combine channels within and between 
images into new images using the Calculations command (on single channels only) and the Apply 
Image command (on single and composite channels). These commands offer two additional blending 
modes not available in the Layers palette: Add and Subtract. Although it’s possible to combine 
channels into new combinations by copying channels into layers in the Layers palette, you may find it 
quicker to use the calculations commands to blend channel information. 

The calculation commands perform mathematical operations on the corresponding pixels of two 
channels (the pixels with identical locations on the image) and then combine the results in a single 
channel. Two concepts are fundamental to understanding how the calculation commands work:
•      Each pixel in a channel has a brightness value from 0 (off or black) to 255 (on or white). The 
Calculations and Apply Image commands manipulate these values to produce the resulting composite 
pixels. 
•      These commands overlay the pixels in two or more channels. Thus, the images used for 
calculations must have the same pixel dimensions. For information on adjusting an image’s pixel 
dimensions, see Changing image size and resolution.

See also: 

Using the Apply Image command 

Using the Calculations command 

Calculations blending options 



Using channel calculations to blend layers and channels 

Using the Apply Image command

The Apply Image command lets you blend one image’s layer and channel (the source) with a layer 
and channel of the active image (the destination). 

To use the Apply Image command: 

1    Open the source and destination images, and make active the desired layer and channel in the 
destination image.

Pixel dimensions must match for the image names to appear in the Apply Image dialog box.

Note: If the color modes of the two images differ (for example, an RGB and a CMYK image), you can 
copy a single channel to another channel, but you cannot copy a composite channel to another 
image’s composite channel in another image. 

2    Choose Image > Apply Image.

3    Choose the source image, layer, and channel you want to combine with the destination. To use all 
layers in the source image, select Merged for Layer. 

4    Select Preview to preview the results in the image window.

5    Select Invert to use the negative of the channel contents in the calculation.

6    For Blending, choose the blending option you want to apply.

Descriptions of the Add and Subtract options appear at the end of this section. Other blending options 
are the same ones listed in the Options palette of the painting and editing tools and in the Layers 
palette (see Selecting a blending mode).

7    Enter an opacity for the effect’s strength. 

8    Select Preserve Transparency to apply the results only to opaque areas in the result layer.

9    Select Mask if you want to apply the blending through a mask. Then choose the image and layer 
containing the mask. For Channel, you can choose any color or alpha channel to use as the mask. 
You can also use a mask based on the active selection or the boundaries of the chosen layer 
(Transparency). Select Invert to reverse the masked and unmasked areas of the channel. (See About 
masks.)

10    Click OK to apply the blending effect.



Using channel calculations to blend layers and channels 

Using the Calculations command

The Calculations command lets you blend two individual channels from one or more source images. 
You can then apply the results to a new image or to a new channel or selection in the active image. 
You cannot apply the Calculations command to composite channels.

To use the Calculations command:

1    Open the source image or images. The pixel dimensions of the images must match for image 
names to appear in the Calculations dialog box.

2    Choose Image > Calculations. 

3    To preview the calculation results in the image window, select Preview.

4    Choose the first source image, layer, and channel. To use all the layers in the source image, 
choose Merged for Layer. 

Select Invert to use the reversed contents, or negative, of the channel. For Channel, choose Gray to 
get the same effect as converting the image to a grayscale image.

5    Choose the second source image, layer, and channel, specifying further options as described in 
the previous step.

6    For Blending, choose the blending option you want to apply. 

A description of the Add and Subtract options appears at the end of this section. Other blending 
options are the same ones listed in the Options palette of the painting and editing tools and in the 
Layers palette (see Selecting a blending mode).

7    Enter an opacity for the effect’s strength. 

8    Select Mask if you want to apply the blending through a mask. Then choose the image and layer 
containing the mask. For Channel, you can choose any color or alpha channel to use as the mask. 
You can also use a mask based on the active selection or the boundaries of the chosen layer 
(Transparency). Select Invert to reverse the masked and unmasked areas of the channel. (See About 
masks.)

9    For Result, specify whether to place the blending results in a new image, or in a new channel or 
selection in the active image. 

10    Click OK to perform the calculation.



Using channel calculations to blend layers and channels 

Calculations blending options

The Add and Subtract blending modes are available only with the Apply Image and Calculations 
commands. For a description of the remaining blending options, see Selecting a blending mode.

Add
Adds the pixel values in two channels. This is a good way to combine nonoverlapping images in two 
channels.

Because higher pixel values represent lighter colors, adding channels with overlapping pixels lightens 
the image. Black areas in both channels remain black (0 + 0 = 0). White in either channel results in 
white (255 + any value = 255 or greater).

The Add option divides the sum of the pixel values by the Scale amount and then adds the Offset 
value to the sum. For example, if you wanted to find the average of the pixels in two channels, you 
would add them, divide by 2, and enter no Offset value.

The Scale factor may be any number between 1.000 and 2.000. Entering a higher Scale value 
darkens the image. 

The Offset value lets you lighten or darken the pixels in the destination channel by any brightness 
value between +255 and –255. Negative values darken the image; positive values lighten the image. 

Subtract
Subtracts the pixel values in the source channel from the corresponding pixels in the target channel. 
As with the Add option, the result is then divided by the Scale factor and added to the Offset value.

The Scale factor may be any number between 1.000 and 2.000. The Offset value lets you lighten or 
darken the pixels in the destination channel by any brightness value between +255 and –255.



Using Layers 

Creating clipping groups

In a clipping group, the bottommost layer, or base layer, acts as a mask for the entire group. For 
example, you might have a shape on one layer, a texture on the overlying layer, and some text on the 
topmost layer. If you define all three layers as a clipping group, the texture and the text appear only 
through the shape on the base layer and take on the opacity of the base layer.

Note that only successive layers can be included in a clipping group. When you create a clipping 
group, dotted lines appear between the grouped layers in the Layers palette. The name of the base 
layer in the group is underlined, and the thumbnails for the overlying layers are indented. Applying a 
blending mode to an indented layer affects only the blending of the layers within the group. Applying a 
blending mode to the base layer determines how the entire clipping group blends with the underlying 
layers. 

Clipping group with Layer 1 and lion layers

To create a clipping group:

1    Do one of the following:
•      Hold down Alt (Windows) or Option (Mac OS), position the pointer over the solid line dividing two 
layers in the Layers palette (the pointer changes to two overlapping circles), and click.
•      Select a layer in the Layers palette and choose Layer > Group with Previous.
•      Link together the desired layers in the Layers palette, as described in Linking layers. Then choose 
Layer > Group Linked.

The clipping group is assigned the opacity and mode attributes of the bottommost layer in the group. 

To remove a layer from a clipping group:

Do one of the following:
•      Hold down Alt (Windows) or Option (Mac OS), position the pointer over the dotted line separating 
two grouped layers in the Layers palette (the pointer changes to two overlapping circles), and click.
•      In the Layers palette, select a layer in the clipping group and choose Layer > Ungroup. This 
command removes the selected layer and any layers above it from the clipping group.

To ungroup all layers in a clipping group:

1    In the Layers palette, select the base layer in the clipping group.

2    Choose Layer > Ungroup.



Using Layers 

Using layer masks 

You can create a layer mask to control how different areas within a layer are hidden and revealed. By 
making changes to the layer mask, you can apply a variety of special effects to the layer without 
actually affecting the pixels on that layer. You can then apply the mask and make the changes 
permanent or remove the mask without applying the changes. You can save all layer masks with a 
layered document.

See also: 

Adding and editing layer masks 

Unlinking layers and layer masks 

Viewing layer masks 

Applying and discarding layer masks 



Using layer masks 

Adding and editing layer masks

In the Layers palette, a layer mask appears as an additional thumbnail to the right of the layer 
thumbnail. This thumbnail represents the grayscale (alpha) channel created by Adobe Photoshop 
when you add the layer mask. (See Using Channels and Masks.)

A. Layer mask selected    B. Mask link icon    C. Layer mask    D. New Layer Mask

See also: 

To add a mask that shows or hides the entire layer 

To add a mask that shows or hides a selection 

To edit a layer mask 



Adding and editing layer masks 

To add a mask that shows or hides the entire layer:

1    If needed, choose Select > Deselect to clear any selection borders in the image.

2    In the Layers palette, select the layer to which you want to add a mask.

3    Do one of the following:
•      To create a mask that reveals the entire layer, click the New Layer Mask ( ) button at the bottom 
of the Layers palette, or choose Layer > Add Layer Mask > Reveal All.

•      To create a mask that hides the entire layer, Alt-click (Windows) or Option-click (Mac OS) the New 
Layer Mask button, or choose Layer > Add Layer Mask > Hide All. 

See also: 

To add a mask that shows or hides a selection 

To edit a layer mask 



Adding and editing layer masks 

To add a mask that shows or hides a selection:

1    In the Layers palette, select the layer to which you want to add a mask.

2    Select the desired area in the image.

3    Do one of the following:
•      To create a mask that reveals the selected area and hides the remaining portion of the layer, click 
the New Layer Mask button ( ) , or choose Layer > Add Layer Mask > Reveal Selection.

•      To create a mask that hides the selected area and reveals the remaining portion of the layer, Alt-click 
(Windows) or Option-click (Mac OS) the New Layer Mask button, or choose Layer > Add Layer Mask > 
Hide Selection.

Selection

Layer mask revealing selection

For information on viewing the contents of the layer mask channel, see Viewing layer masks.

See also: 

To add a mask that shows or hides the entire layer 

To edit a layer mask 



Adding and editing layer masks 

To edit a layer mask:

1    Click the layer mask thumbnail in the Layers palette to make it active (the mask icon appears to the
left of the layer thumbnail).

2    Select any of the editing or painting tools.

Because the layer mask is a grayscale alpha channel, the foreground and background colors default 
to grayscale values when the mask is active. As you edit, the mask thumbnail displays the changes. 

3    Do one of the following:
•      To hide the layer and add to the mask, paint the mask with black.

Head and background painted with black
•      To reveal the layer and subtract from the mask, paint the mask with white.

Head painted with white
•      To make the layer partially visible, paint the mask with gray.

Neck painted with gray

To edit the layer instead of the layer mask, make the layer active by clicking its thumbnail in the Layers
palette. The paintbrush icon appears to the left of the thumbnail to indicate that you are editing the 
layer.



 To paste a selection into a layer mask, Alt-click (Windows) or Option-click (Mac OS) the layer mask 
thumbnail in the Layers palette to select and display the mask channel. Choose Edit > Paste, drag the 
selection in the image to produce the desired masking effect, and choose Select > Deselect. Click the 
layer thumbnail in the Layers palette to deselect the mask channel.

See also: 

To add a mask that shows or hides the entire layer 

To add a mask that shows or hides a selection 



Using layer masks 

Unlinking layers and layer masks

By default, a layer is linked to its layer mask, as indicated by the link icon between the thumbnails in 
the Layers palette. The layer and layer mask move together in the image when you move either one 
with the move tool.

You can unlink the layer from its layer mask by clicking the link icon. Unlinking the two lets you move 
them independently and shift the mask boundaries separately from the layer. To reestablish the link, 
click between the layer and layer mask thumbnails.



Using layer masks 

Viewing layer masks

By default, the layer mask channel does not appear in the image. You can view and edit the contents 
of the mask or temporarily turn off its effects. You can also change the display options for the mask.

See also: 

To select and display the layer mask channel 

To turn off the layer mask temporarily 

To change the rubylith display for a layer mask 



Viewing layer masks 

To select and display the layer mask channel:

Do one of the following:
•      Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to view only the grayscale 
mask. The eye icons in the Layers palette are dimmed because all layers are hidden. To redisplay the 
layers, again Alt/Option-click the layer mask thumbnail, or click an eye icon.
•      Hold down Alt+Shift (Windows) or Option+Shift (Mac OS), and click the layer mask thumbnail to 
view the mask on top of the layer in a rubylith masking color. Hold down Alt+Shift/Option+Shift and 
click the thumbnail again to turn off the color display.

See also: 

To turn off the layer mask temporarily 

To change the rubylith display for a layer mask 



Viewing layer masks 

To turn off the layer mask temporarily:

1    Do one of the following:
•      Press Shift and click the layer mask thumbnail in the Layers palette. 
•      Choose Layer > Disable Layer Mask.

A red X appears over the layer mask thumbnail in the Layers palette, and the entire underlying layer 
appears without masking effects. 

Layer mask off 

2    To turn on the mask, do one of the following:
•      Click the layer mask thumbnail in the Layers palette.
•      Choose Layer > Enable Layer Mask.

See also: 

To select and display the layer mask channel 

To change the rubylith display for a layer mask 



Viewing layer masks 

To change the rubylith display for a layer mask:

1    Do one of the following:
•      Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to select the layer mask 
channel; then double-click the layer mask thumbnail. 
•      Double-click the layer mask channel in the Channels palette.

2    To choose a new mask color, click the color swatch and choose a new color as described in Using 
the Adobe Photoshop Color Picker.

3    To change the opacity, enter a value between 0% and 100%.

Both the color and opacity settings affect only the appearance of the mask and have no effect on how 
underlying areas are protected. For example, changing these settings might make the mask more 
easily visible against the colors in the image.

4    Click OK.

See also: 

To select and display the layer mask channel 

To turn off the layer mask temporarily 



Using layer masks 

Applying and discarding layer masks

When you have finished creating a layer mask, you can either apply the mask and make the changes 
permanent or discard the mask without applying changes. Because layer masks are stored as alpha 
channels, applying and discarding layer masks may help reduce file size. For more information, see 
About channels and file size. 

To apply or discard a layer mask:

1    Click the layer mask thumbnail in the Layers palette.

2    Do one of the following:
•      Click the Trash button at the bottom of the Layers palette.
•      Choose Layer > Remove Layer Mask.

3    Remove the mask:
•      To remove the layer mask and make the changes permanent, click Apply.
•      To remove the layer mask without applying the changes, click Discard.



Using Layers 

Selecting opaque areas on a layer

By loading a transparency mask, you can quickly select all the opaque areas on a layer—that is, the 
areas within the layer boundaries. This is useful when you want to exclude transparent areas from a 
selection. You can also load the boundaries of a layer mask as a selection.

To load a layer or layer mask’s boundaries as a selection:

Do one of the following:
•      In the Layers palette, Ctrl-click (Windows) or Command-click (Mac OS) the layer or layer mask 
thumbnail.

Layer pixels loaded as selection
•      To add the pixels to an existing selection, press Ctrl+Shift/Command+Shift, and click the layer or 
layer mask thumbnail in the Layers palette.
•      To subtract the pixels from an existing selection, press Ctrl+Alt/Command+Option, and click the 
layer or layer mask thumbnail in the Layers palette.
•      To load the intersection of the pixels and an existing selection, press 
Ctrl+Alt+Shift/Command+Option+Shift, and click the layer or layer mask thumbnail in the Layers 
palette.
 To move all the contents of a layer, you can use the move tool without loading a transparency mask.



Using Layers 

Using adjustment layers

An adjustment layer lets you experiment with color and tonal adjustments to an image without 
permanently modifying the pixels in the image. The color and tonal changes reside within the 
adjustment layer, which acts as a veil through which the underlying image layers appear.

When you create an adjustment layer, its effect appears on all the layers below it. This lets you correct
multiple layers by making a single adjustment, rather than making the adjustment to each layer 
separately. 
 To confine the effects of an adjustment layer to the layers immediately below it, create a clipping group

consisting of these layers (see Creating clipping groups).

Original

Levels adjustment applied to image

Levels adjustment clipped to zebra layer

See also: 



Creating an adjustment layer 

Merging adjustment layers 



Using adjustment layers 

Creating an adjustment layer

Adjustment layers have the same opacity and blending mode options as image layers and can be 
rearranged in order, deleted, hidden, and duplicated in the same manner as well. However, you also 
specify a color adjustment type for an adjustment layer. Depending on your choice, the dialog box for 
the selected adjustment command may appear. (See Making Color and Tonal Adjustments.) The 
adjustment layer takes the name of the adjustment type and is indicated in the Layers palette by a 
partially filled circle to the right of the name. 

Adjustment layers are also layer masks, as indicated by the mask icon to the left of the layer 
thumbnail. When an adjustment layer is active, the foreground and background colors default to 
grayscale values. By painting the adjustment layer, you can apply the adjustment to just portions of the
underlying layers. 

Adjustment layer with triangular mask added

See also: 

To create an adjustment layer 

To edit an adjustment layer 

To edit an adjustment layer mask 



Creating an adjustment layer 

To create an adjustment layer:

1    To confine the effects of the adjustment layer to a selected area, first make a selection.

2    Do one of the following:
•      Ctrl-click (Windows) or Command-click (Mac OS) the New Layer button ( ) at the bottom of the 
Layers palette.

•      Choose Layer > New > Adjustment Layer.

3    In the New Adjustment Layer dialog box, type a name for the layer.

4    For Type, choose the adjustment you want to make. 

5    Choose layer options as desired, and then click OK. (See Specifying layer options.)

6    If needed, make the desired adjustments, as described in Making Color and Tonal Adjustments, 
and click OK. 

See also: 

To edit an adjustment layer 

To edit an adjustment layer mask 



Creating an adjustment layer 

To edit an adjustment layer:

1    Do one of the following:
•      Double-click the adjustment layer’s name in the Layers palette.
•      Select the adjustment layer’s name, and then choose Layer > Adjustment Options.

2    Make the desired adjustments, and click OK.

Note: If an adjustment layer has no associated adjustment dialog box (for example, the Invert 
adjustment), double-clicking the layer’s name opens the Layer Options dialog box.

See also: 

To create an adjustment layer 

To edit an adjustment layer mask 



Creating an adjustment layer 

To edit an adjustment layer mask:

1    Select the adjustment layer in the Layers palette.

2    Select any painting or editing tool.

3    Edit the adjustment layer mask:
•      To remove the adjustment effect, paint the adjustment layer with black.
•      To display the full effect of the adjustment over the image layers beneath, paint the adjustment 
layer with white.
•      To partially remove the adjustment effect, paint the adjustment layer with gray.

4    Use the following methods to view the adjustment layer mask:
•      Alt-click (Windows) or Option-click (Mac OS) the adjustment layer thumbnail to view only the 
grayscale mask. Alt/Option-click the thumbnail again to redisplay the other layers.
•      Hold down Alt+Shift (Windows) or Option+Shift (Mac OS), and click the adjustment layer thumbnail
to view the mask in a rubylith masking color. Hold down Alt+Shift/Option+Shift and click the thumbnail 
again to turn off the rubylith display.
•      Shift-click the adjustment layer thumbnail to turn off the masking effects temporarily; click the 
thumbnail again to turn on the mask.

Note: If you paint the adjustment layer mask with black or gray, you can modify the boundaries and 
effects of the mask (by applying a filter, for example). Adjustment layer masks that contain only white 
values are unaffected by most filters. 

See also: 

To create an adjustment layer 

To edit an adjustment layer 



Using adjustment layers 

Merging adjustment layers

You can merge an adjustment layer with the image layer below it, the layers in its clipping or linking 
group, or all other visible layers in the image. You cannot, however, merge an adjustment layer 
exclusively with another adjustment layer. When you merge an adjustment layer with the layer below 
it, the adjustments become permanent and apply only within the merged layer. (See Merging layers.) 

Adjustment layers whose masks contain only white values do not add significantly to the file size. As a 
result, it is not necessary to merge these adjustment layers in an effort to conserve file space.



Using Layers 

Using layer effects

Adobe Photoshop includes a number of automated effects that you can apply to layers, including drop 
shadows, glows, bevelling, and embossing. When you apply a layer effect, an “f” icon ( ) appears to 
the right of the layer’s name in the Layers palette. Layer effects are linked to the layer contents. When 
you move or edit the contents on the layer, the effects are modified correspondingly. Layer effects are 
especially useful for enhancing type layers.

Note: You cannot apply layer effects to a background.

Layer effect added

See also: 

Viewing and clearing layer effects 

Adding layer effects 

Specifying options for layer effects 

Editing and removing layer effects 

Converting layer effects to layers 



Using layer effects 

Viewing and clearing layer effects

To hide or show all layer effects in the image:

Choose Layer > Effects > Hide All Effects or Show All Effects.



Using layer effects 

Adding layer effects

Photoshop has numerous different effects that you can apply in any combination to a layer.
•      The Drop Shadow effect lets you add a shadow that falls behind the contents on the layer. 
•      The Inner Shadow effect lets you add a shadow that falls just inside the edges of the layer 
contents, giving the layer a recessed appearance.
•      The Outer Glow and Inner Glow effects let you add glows that emanate from the outside or inside 
edges of the layer contents.
•      The Bevel and Emboss effect lets you add various combinations of highlights and shadows to a 
layer.

See also: 

To apply a drop shadow or inner shadow 

To apply an outer or inner glow 

To apply bevelling or embossing 

To apply additional layer effects 



Adding layer effects 

To apply a drop shadow or inner shadow:

1    Select the layer you want to use, and choose Layer > Effects > Drop Shadow or Inner Shadow.

2    Specify blending mode, opacity, color, lighting angle, blur, and intensity options, as described in 
Specifying options for layer effects.

3    Specify the displacement of the shadow from the layer contents:
•      For Distance, enter a value or drag the slider. 
•      Drag the shadow in the image to reposition it. The distance and lighting angle values update as 
you drag. 

4    Click OK.

See also: 

To apply an outer or inner glow 

To apply bevelling or embossing 

To apply additional layer effects 



Adding layer effects 

To apply an outer or inner glow:

1    Select the layer you want to use, and choose Layer > Effects > Outer Glow or Inner Glow.

2    Specify blending mode, opacity, color, blur, and intensity options, as described in Specifying 
options for layer effects.

3    If you are applying an inner glow, select a glow source option:
•      Center to apply a glow that emanates from the center of the layer contents.
•      Edge to apply a glow that emanates from the inside edges of the layer contents.

4    Click OK.

Inner glow, and outer glow

See also: 

To apply a drop shadow or inner shadow 

To apply bevelling or embossing 

To apply additional layer effects 



Adding layer effects 

To apply bevelling or embossing:

1    Select the layer you want to use, and choose Layer > Effects > Bevel and Emboss.

2    Specify blending mode, opacity, and color options for the highlight and shadow, as described in 
Specifying options for layer effects.

Outer bevel, and pillow emboss

3    For Style, choose one of the following:
•      Outer Bevel to create bevelling along the outside edges of the layer contents.
•      Inner Bevel to create bevelling along the inside edges of the layer contents.
•      Emboss to create the effect of embossing the layer contents against the underlying layers.
•      Pillow Emboss to create the effect of stamping the edges of the layer contents into the underlying 
layers.

4    Specify lighting angle and blur options, as described in Specifying options for layer effects.

5    For Depth, enter a value or drag the slider. A higher value results in a more accentuated bevel.

6    Select Up or Down to indicate the position of the highlight in relation to the layer contents.

7    Click OK.

See also: 

To apply a drop shadow or inner shadow 

To apply an outer or inner glow 

To apply additional layer effects 



Adding layer effects 

To apply additional layer effects:

Do one of the following:
•      Choose another layer effect from the menu at the top of the Effects dialog box, or click Prev or 
Next to cycle through the effects list. Select Apply, and specify options as described in the previous 
procedures.
•      Choose another layer effect from the Layer > Effects submenu, and specify options as described 
in the previous procedures.

See also: 

To apply a drop shadow or inner shadow 

To apply an outer or inner glow 

To apply bevelling or embossing 



Using layer effects 

Specifying options for layer effects

When applying layer effects, you can specify a number of common options.

Preview
Displays a preview of the layer effect in the image as you change the layer effect settings.

Mode
Determines how the layer effect blends with the underlying layers, which may or may not include the 
active layer. For example, an inner shadow blends with the active layer because the effect is drawn on
top of that layer, but a drop shadow blends only with the layers beneath the active layer. In most 
cases, the default mode for each effect produces the best results. For more information on blending 
modes, see Specifying layer blending modes.

Opacity
Sets the opacity of the layer effect as you enter a value or drag the slider.

Color
Specifies the color of a shadow, glow, or highlight as you click the color box and choose a color, as 
described in Using the Adobe Photoshop Color Picker.

Angle
Determines the lighting angle at which the effect is applied to the layer. You can define a global angle 
that applies to all layer effects in the image; you can also assign a local angle that applies only to a 
specific layer effect. Using a global angle gives the appearance of a consistent light source shining on 
the image.

Lighting angle: -45° and 45°

See also: 

To set a global lighting angle 

To set a local lighting angle 



Specifying options for layer effects 

To set a global lighting angle:

Do one of the following:
•      In the layer effects dialog box, select Use Global Angle. For Angle, enter a value or drag the slider.
•      Choose Layer > Effects > Global Angle. Enter a value or drag the angle radius, and click OK.

The new lighting angle appears as the default for each layer effect that uses the global lighting angle.

See also: 

To set a local lighting angle 



Specifying options for layer effects 

To set a local lighting angle:

In the layer effects dialog box, deselect Use Global Angle. For Angle, enter a value or drag the angle 
radius.

Blur
Creates a diffuse, softened effect as you enter a value or drag the slider.

Intensity
Adjusts the strength of the effect as you enter a value or drag the slider. A higher value increases the 
strength of the effect.

See also: 

To set a global lighting angle 



Using layer effects 

Editing and removing layer effects

You can edit the options for the effects you have applied to a layer at any time. You can also copy 
effects between layers and remove an effect that you have applied to a layer.

To edit the layer effects applied to a layer:

1    Double-click the layer effects icon ( ) in the Layers palette.
2    Choose the desired layer effect from the top of the Effects dialog box, or click Prev or Next to cycle 
through the effects list. Edit options as described in Adding layer effects.

To copy effects between layers:

1    In the Layers palette, select the source layer containing the effects you want to copy.

2    Choose Layer > Effects > Copy Effects.

3    Do one of the following:
•      To paste into a single layer, select the destination layer in the palette and choose Layer > Effects >
Paste Effects.
•      To paste into multiple layers, link the destination layers as described in Linking layers. Then 
choose Layer > Effects > Paste to Linked.

The pasted effects will replace any existing effects on the destination layer or layers.

To remove a layer effect:

1    In the Layers palette, select the layer containing the effect you want to remove.

2    Do one of the following:
•      Hold down Alt (Windows) or Option (Mac OS), and choose the desired layer effect from the Layer 
> Effects menu. Applied effects have checkmarks next to their command names; removing a layer 
effect removes the checkmark. 
•      Choose the desired layer effect from the top of the Effects dialog box, and deselect Apply.

To remove all layer effects applied to a layer:

1    In the Layers palette, select the layer containing the effects you want to remove.

2    Choose Layer > Effects > Clear Effects.



Using layer effects 

Converting layer effects to layers

To customize or fine-tune the appearance of layer effects, you can convert the effects to regular image
layers. Once you have converted an effect to image layers, you can enhance the effect by painting or 
applying commands and filters. However, you can no longer edit the effect using the Effects dialog 
box, and the effect will no longer update as you change the original image layer.

To convert a layer effect to image layers:

1    In the Layers palette, select the layer containing the effect you want to convert.

2    Choose Layer > Effects > Create Layer(s).

You can now modify and restack the new layers just like regular layers. Some effects (for example, 
inner glow) convert to layers within a clipping group.

Layer effect converted to image layers
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See also: 

About type 

Creating type 

Setting type attributes 



Using Type 

About type

Graphics applications create two different kinds of type:

Outline type

Drawing or page-layout programs such as Adobe Illustrator or Adobe PageMaker create outline type. 
Outline type consists of mathematically defined shapes and can be scaled to any size without losing 
its crisp, smooth edges. When opening an image that contains outline type, Photoshop rasterizes the 
type into pixel or bitmap type. 

Bitmap type

Paint and image-editing programs such as Adobe Photoshop create bitmap type composed of pixels. 
The sharpness of bitmap type depends on the type size and the resolution of the image. For example, 
type that has been scaled up in size may show jagged edges. High-resolution images can display 
higher-resolution (and therefore smoother) type than low-resolution images.

If you want to create scaleable type or text containing many type characters, import your Photoshop 
image into an application that supports outline type and create the type using that application.

Bitmap type and outline type; inset zoom 300%
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Creating type

Use these tools to create type in an image:
•      The type ( ) and vertical type (
) tools let you create colored type that is stored in a new type layer. You can edit the text at any time 

using the type layer.
•      The type mask ( ) and vertical type mask (

) tools let you create selection borders in the shape of type. Type selections appear on the active 
layer, and can be moved, copied, filled, or stroked just like any other selection.

Text created by type tool, and by type mask tool

See also: 

Entering text 

Editing type layers 



Creating type 

Entering text

You enter text by selecting a type tool and clicking in the image to set an insertion point. The Type Tool
dialog box lets you enter the text and specify formatting attributes.

See also: 

To enter text 

To create a type selection border 



Entering text 

To enter text:

1    Select the type ( ) or vertical type (
) tool. The pointer changes to an I-beam pointer.

The small line through the I-beam marks the position of the type baseline. For horizontal type, the 
baseline marks the line on which the type rests; for vertical type, the baseline marks the center axis of the
type characters.
2    Click in the image to set an insertion point for the type.
3    To display a preview of the type in the image, select Preview. (This option is not available for images in
multichannel, Bitmap, or indexed-color mode.)

4    Specify type attributes, as described in Setting type attributes.

5    To change the color of the type, click the color box, choose a color as described in Using the Adobe
Photoshop Color Picker, and click OK.

6    Click inside the text area at the bottom of the dialog box, and enter your text. To create a line 
break, press Enter (Windows) or Return (Mac OS) while the cursor is in the text area.

7    To control the display of type in the text area, do any of the following:
•      To resize the text area, drag the lower right corner of the dialog box.
•      To change the view magnification, click the zoom buttons at the bottom of the dialog box. Click the 
percentage value to specify a 100% view.
•      To scale the magnification so that the type always fits in the text area, select Fit in Window. 
Selecting this option makes the zoom buttons unavailable.

8    To adjust the placement of the type, drag the type preview in the image. This option is only 
available if you have selected Preview.

9    Click OK. The type appears in the image on a new type layer, and a type icon appears next to the 
layer name.



Important: A type layer is not created for images in multichannel, Bitmap, or indexed-color mode, 
because these modes do not support layers. In these image modes, type appears on the background 
and cannot be edited. 

See also: 

To create a type selection border 



Entering text 

To create a type selection border:

1    Select the type mask tool ( ) or the vertical type mask tool (
).

2    Click where you want the type selection border to appear.
For best results, create the type selection border on a regular image layer, not a type layer.
3    Specify type attributes, as described in Setting type attributes.
4    Click inside the text area at the bottom of the dialog box, and enter the text you want. To create a line 
break, press Enter (Windows) or Return (Mac OS) while the cursor is in the text area.

To control the display of type in the text area, see the instructions in step 7 of the procedure To enter 
text.

5    Click OK. The type selection border appears in the image on the active layer.

Type border, and selection contents adjusted with Levels

See also: 

To enter text 
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Editing type layers

Once you have created type, you can edit the contents, attributes, and orientation at any time by using
its type layer. Type layers save with the image. You can move, restack, copy, and change the layer 
options of a type layer just as for a regular layer (see Chapter 11 for general layers information). You 
can also apply these commands to a type layer and still be able to edit the text:
•      Transformation commands under the Edit menu, except for Perspective and Distort. (To transform 
just part of the type layer, you must convert the type layer to a regular layer.)
•      Layer effects
•      Fill shortcuts (see Filling and stroking selections and layers).

To apply the full range of Photoshop effects (such as filters) to a type layer, you can convert the type 
layer to a regular layer. Converting a type layer makes its contents uneditable as text.

See also: 

To edit a type layer 

To select text 

To change the orientation of a type layer 

To convert a type layer to a regular layer 



Editing type layers 

To edit a type layer:

1    Double-click the name of the type layer in the Layers palette. 

2    Make the desired changes in the Type Tool dialog box, as described in the procedure for creating a
type layer in To enter text.

3    Click OK.

See also: 

To select text 

To change the orientation of a type layer 

To convert a type layer to a regular layer 



Editing type layers 

To select text:

Position the cursor in the text area of the Type Tool dialog box, and do one of the following:
•      Drag to select the text you want to change.
•      Click to define the beginning of the selected text, and Shift-click to define the end of the selection.
•      Position the cursor in a word, and double-click to select that word.
•      Press Ctrl+A (Windows) or Command+A (Mac OS) to select all the characters in the text area.

Selecting characters in text area

See also: 

To edit a type layer 

To change the orientation of a type layer 

To convert a type layer to a regular layer 



Editing type layers 

To change the orientation of a type layer:

1    Select the type layer in the Layers palette.

2    Choose Layer > Type > Horizontal or Vertical to change the orientation of the layer contents.

See also: 

To edit a type layer 

To select text 

To convert a type layer to a regular layer 



Editing type layers 

To convert a type layer to a regular layer:

1    Select the type layer in the Layers palette.

2    Choose Layer > Type > Render Layer.

See also: 

To edit a type layer 

To select text 

To change the orientation of a type layer 
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Setting type attributes

Adobe Photoshop gives you precise control over type attributes, including font, type size, leading, 
kerning, tracking, baseline shift, alignment, and rotation. In addition, you can specify anti-aliasing for 
the type. To apply most attribute changes to existing type, you must first select the desired characters.

See also: 

Choosing a font family 

Choosing a type size and measurement unit 

Specifying leading 

Specifying kerning and tracking 

Specifying characters with auto-kerning 

Specifying baseline shift 

Specifying alignment 

Specifying anti-aliasing 

Rotating character direction 



Setting type attributes 

Choosing a font family

A font family is a complete set of characters, letters, and symbols of a particular typeface design. For 
example, the font used in this paragraph is Minion. In addition to choosing a font, you can choose a 
type style (for example, Regular, Bold, Italic). The range of available type styles varies with each font.

Note: In addition to the fonts installed on your system, Photoshop uses font files in the local Fonts 
folder, located inside the application folder. Installing a Type 1, TrueType, or CID font into the local 
Fonts folder causes the font to appear in the Photoshop application only.

To change the font and type style:

1    In the Type Tool dialog box, select the characters you want to adjust, as described in the procedure
To select text.

2    For Font, choose a font family. Choose a type style from the menu to the right of the Font menu.



Setting type attributes 

Choosing a type size and measurement unit

The type size determines how large the type appears in the image. The default type size is 12 points, 
where one PostScript point is equal to 1/72 of an inch in a 72-ppi image. You can switch between 
using the PostScript and traditional definitions of point size.

To choose a type size and measurement unit:

1    In the Type Tool dialog box, select the characters you want to adjust, as described in the procedure
To select text.

2    In the Type Tool dialog box, enter a value for Size. Choose a measurement unit from the menu.

To specify the point size definition:

1    Choose File > Preferences > Units & Rulers.

2    Select an option for Point/Pica Size. Traditional points are slightly smaller than PostScript points.



Setting type attributes 

Specifying leading

Leading specifies the spacing between baselines and is measured in the units you specify in the Type 
Tool dialog box.

5-point type with 5-point leading, and with 10-point leading

To change the leading:

1    In the Type Tool dialog box, select the line of type you want to adjust, as described in the 
procedure To select text.

2    For Leading, enter a value. 



Setting type attributes 

Specifying kerning and tracking

Kerning controls the spacing between two characters. You can control kerning manually, or you can 
turn on the kerning built into the font by the font designer (see the following section). Tracking inserts 
uniform spacing between more than two characters in selected type. Use tracking to adjust the 
spacing of a selected word or of an entire block of type.

Positive kerning or tracking values move characters apart; negative values move characters closer 
together. Kerning and tracking values are measured in units that are 1/1000 of an em space. The 
width of an em space is relative to the current type size. In a 1-point font, 1 em corresponds to 1 point;
in a 10-point font, 1 em corresponds to 10 points. Because kerning and tracking units are 1/1000 em, 
100 units in a 10-point font are equivalent to 1 point. 

Default, and tracking set to 350

To specify manual kerning:

1    In the text area of the Type Tool dialog box, click to set an insertion point between two characters.

2    Deselect Auto Kern.

3    Enter a kerning value.

To specify tracking:

1    In the Type Tool dialog box, select the desired characters, as described in the procedure To select 
text.

2    Enter a tracking value.



Setting type attributes 

Specifying characters with auto-kerning

To use a font’s kerning information to space characters better, select the Auto Kern option in the Type 
Tool dialog box. Many fonts have information about the spacing of character pairs. For example, the 
spacing between an A and a W often is less than the spacing between an A and an F.

For the best performance, choose a specific kerning value rather than auto-kerning until you have 
finished creating your type. Then select the type and apply auto-kerning to it.



Setting type attributes 

Specifying baseline shift

Baseline shift controls the distance that type appears from its baseline, either raising or lowering the 
selected type to create superscripts or subscripts. 

To specify baseline shift:

1    In the text area of the Type Tool dialog box, select the characters you want to adjust, as described 
in the procedure To select text.

2    For Baseline, enter a value.

A positive value moves horizontal type above, and vertical type to the right of, the baseline; a negative 
value moves type below or to the left of the baseline. Baseline shift is measured in the units you 
specify in the Type Tool dialog box.

Default, and baseline shift of -10 points



Setting type attributes 

Specifying alignment

Alignment controls the position of each line of type in reference to the insertion point in the image you 
clicked with the type tool. 

To specify alignment:

1    In the Type Tool dialog box, select a horizontal (vertical) alignment option:
•      The left (top) alignment option begins each line of type at the insertion point.
•      The center (center) alignment option centers the type around the insertion point.
•      The right (bottom) alignment option ends each line of type at the insertion point.



Setting type attributes 

Specifying anti-aliasing

Anti-aliasing lets you produce smooth-edged type by partially filling the edge pixels. As a result, the 
edges of the type blend into the background. You’ll probably want to use anti-aliased type in your 
images, unless you are working with small type sizes (anti-aliasing can make small type sizes appear 
blurry). 

Anti-aliasing on and off; inset zoom 200%
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Rotating character direction

When you create vertical type, you can select the Rotate option to rotate the character direction by 
90°. The Rotate option does not affect double-byte characters.

Original, and with vertical rotation 90°
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See also: 

About plug-in filters 

Previewing and applying filters 

Tips for creating special effects 

Improving performance with filters 

Photoshop Filter Sample Gallery 

Artistic filters 

Blur filters 

Brush Stroke filters 

Distort filters 

Noise filters 

Pixelate filters 

Render filters 

Sharpen filters 

Sketch filters 

Stylize filters 

Texture filters 

Video filters 

Other filters 

Digimarc Filters 

Using the Lighting Effects filter 
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About plug-in filters

Adobe Photoshop also supports plug-in filters developed by non-Adobe software developers. Once 
installed, plug-in filters appear at the bottom of the Filter menu and work the same as built-in filters. 

If you are interested in creating Photoshop-compatible plug-in modules, contact Adobe Systems 
Developer Support. (See Using plug-in modules.)

Note: If you have problems or questions about third-party plug-ins, contact the plug-in’s manufacturer 
for support.
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Previewing and applying filters

To use a filter, choose the appropriate submenu command from the Filter menu. These guidelines can 
help you in choosing filters:
•      The last filter chosen appears at the top of the menu.
•      Filters are applied to the active, visible layer.
•      Filters cannot be applied to Bitmap-mode, indexed-color, or 16-bit per channel images.
•      Some filters only work on RGB images.
•      Some filters are processed entirely in RAM.
•      Applying filters—especially to large images—can be time-consuming. Previewing effects can save 
time and prevent unintended results. Depending on the filter, you may have a preview window or the 
option to preview effects on the entire layer.
 To save time when trying various filters, experiment on a small, representative part of your image or a 

low-resolution copy. 

See also: 

To preview and apply a filter 

Blending filter effects 

Using filter shortcuts 

Loading images and textures 

Defining undistorted areas 

Using texture and glass surface controls 



Previewing and applying filters 

To preview and apply a filter:

1    To apply a filter to an area of a layer, select that area. To apply a filter to the entire layer, leave the 
image unselected.

2    Choose a filter from the submenus in the Filter menu. If a filter name is followed by ellipses (…), a 
dialog box appears.

3    If a dialog box appears, enter values or select options.

4    If the dialog box contains a preview window, use the following navigation methods to preview the 
effect:
•      Click in the image window to center a specific area of the image in the preview window. 

Note: This does not work with all preview windows.
•      Drag in the preview window to center a specific area of the image in the window. 
•      Use the + or – button under the preview window to zoom in or zoom out on the preview. 

Previewing a filter    A. Click and drag to move image in preview window.    B. Click + to zoom in or - to zoom out 
on image in preview window.

A flashing line beneath the preview size indicates that Adobe Photoshop is still rendering the preview. 

5    If available, select the Preview option to preview the filter effect on the entire image.

6    Click OK to apply the filter. 

A progress indicator in the status bar (Windows) or progress bar (Mac OS) lets you gauge the time 
remaining until the filter is applied.



Previewing and applying filters 

Blending filter effects

The Fade command fades the effect of a filter, painting tool, or color adjustment. You choose a 
blending opacity and a mode to determine how pixels are modified. The blending modes available are 
a subset of those in the painting and editing tools Options palette (excluding the Behind and Clear 
modes). (See Making Color and Tonal Adjustments for more on color adjustment commands.)

Applying the Fade command is similar to applying the filter effect on a separate layer and then using 
the layer opacity and blending mode controls. (See Using adjustment layers.)

Note: The Fade command can also be applied to Brush Strokes filters and any other painting tool.

Original, and Note Paper filter applied

Screen mode applied using Fade command, and 50% opacity applied using Fade command

To fade the effect of a filter, painting tool, or color adjustment:

1    Apply a filter or an Image > Adjust command to an image or selection.

2    With the affected area still selected, choose Filter > Fade.

3    Select the Preview option to preview the effect.

4    Drag the slider to adjust the opacity, from 0% (transparent) to 100%. (See Specifying the opacity, 
pressure, or exposure.)

5    For Mode, choose a blending mode. (See Selecting a blending mode.)

Note: The Color Dodge, Color Burn, Lighten, Darken, Difference, and Exclusion modes do not work 
on Lab images.

6    Click OK. 



Previewing and applying filters 

Using filter shortcuts

These techniques can help save time when working with filters:
•      To cancel a filter as it is being applied, press Esc or Command-(.) (period) (Mac OS only). 
•      To undo a filter, press Ctrl+Z (Windows) or Command+Z (Mac OS).
•      To reapply the most recently used filter with its last values, press Ctrl+F (Windows) or 
Command+F (Mac OS).
•      To display the dialog box for the last filter you applied, press Ctrl+Alt+F (Windows) or 
Command+Option+F (Mac OS).



Previewing and applying filters 

Loading images and textures

To produce their effects, some filters load and use other images, such as textures and displacement 
maps. These filters include the Conté Crayon, Displace, Glass, Lighting Effects, Rough Pastels, 
Texture Fill, Texturizer, Underpainting, and Custom filters.

To load images and textures:

1    Choose the filter you want from the appropriate submenu.

2    For Texture, choose Load Texture, and locate and open a texture image. 

All textures must be in the Photoshop format. Most filters use only the grayscale information of a color 
file.

3    Click OK.



Previewing and applying filters 

Defining undistorted areas

The Displace, Shear, and Wave filters in the Distort submenu and the Offset filter in the Other 
submenu let you treat areas undefined by the filter in the following ways:
•      Wrap Around fills the undefined space with content from the opposite edge of the image.
•      Repeat Edge Pixels extends the colors of pixels along the image’s edge in the direction specified. 
Banding may result if the edge pixels are different colors.
•      Available for the Offset filter only, Set to Background fills the selected area with the current 
background color.



Previewing and applying filters 

Using texture and glass surface controls

The Conté Crayon, Glass, Rough Pastels, Texturizer, and Underpainting filters have texturizing 
options. These options make images appear painted onto textures such as canvas and brick or 
viewed through glass blocks.

To use texture and glass surface controls:

1    From the Filter menu, choose Artistic > Rough Pastels or > Underpainting; Distort > Glass; Sketch 
> Conté Crayon; or Texture > Texturizer.

2    For Texture, choose a texture type or choose Load Texture to specify a Photoshop file.

3    Drag the Scaling slider to enlarge or reduce the effect on the image surface. 

4    Drag the Relief slider (if available) to adjust the depth of the texture’s surface.

5    Select Invert to reverse the surface’s light and dark colors.

6    For Light Direction, indicate the direction of the light source on the image.

7    Click OK.

Original, and with Rough Pastels filter applied using Canvas texture
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Tips for creating special effects

Try the following techniques to create special effects with filters.

See also: 

Create edge effects 

Apply filters to layers 

Apply filters to individual channels 

Create backgrounds 

Combine multiple effects with masks or with duplicate images 

Improve image quality and consistency 



Tips for creating special effects 

Create edge effects

You can use various techniques to treat the edges of an effect applied to only part of an image. To 
leave a distinct edge, simply apply the filter. For a soft edge, feather the edge, and then apply the filter.
For a transparent effect, apply the filter, and then use the Fade command to adjust the selection’s 
blending mode and opacity. (See Blending filter effects.)

Distinct edge and Feathered edge



Tips for creating special effects 

Apply filters to layers

You can apply filters to individual layers or to several layers in succession to build up an effect. For a 
filter to affect a layer, the layer must be visible and must contain pixels—for example, a neutral fill 
color. (See Filling a new layer with a neutral color.)



Tips for creating special effects 

Apply filters to individual channels

You can apply a filter to an individual channel, apply a different effect to each color channel, or apply 
the same filter but with different settings.

Grayscale image converted to RGB, and with Graphic Pen filter applied to green and blue channels



Tips for creating special effects 

Create backgrounds 

By applying effects to solid-color or grayscale shapes, you can generate a variety of backgrounds and 
textures. You might then blur these textures. Although some filters have little or no visible effect when 
applied to solid colors (for example, Glass), others produce interesting effects. You might try: Add 
Noise, Chalk & Charcoal, Clouds, Conté Crayon, Craquelure, Difference Clouds, Glass, Grain, 
Graphic Pen, Halftone Pattern, Mezzotint, Mosaic Tiles, Note Paper, Patchwork, Pointillize, 
Reticulation, Rough Pastels, Sponge, Stained Glass, Texture Fill, Texturizer, and Underpainting. 



Tips for creating special effects 

Combine multiple effects with masks or with duplicate images

Using masks to create selection areas gives you more control over transitions from one effect to 
another. For example, you can filter the selection created with a mask. 

Mask with radial gradient, and Radial Blur filter applied through mask

You can also use the history brush tool to paint a filter effect onto part of the image. First, apply the 
filter to an entire image. Next, step back in the History palette to the image state before applying the 
filter, and set the history brush source to the filtered state. Then, paint the image. (See Reverting to 
any state of the image.)



Tips for creating special effects 

Improve image quality and consistency

You can disguise faults, alter or enhance, or make a series of images look related by applying the 
same effect to each. Use the Actions palette to record the process of modifying one image, and then 
use this action on the other images.(See Automating Tasks.)

Originals

Noise filter applied
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Improving performance with filters

Some filter effects can be memory intensive, especially when applied to a high-resolution image. You 
can use these techniques to improve performance:
•      Try out filters and settings on a small portion of an image.
•      Apply the effect to individual channels—for example, to each RGB channel—if the image is large 
and you’re having problems with insufficient memory. (With some filters, effects vary if applied to the 
individual channel rather than the composite channel, especially if the filter randomly modifies pixels.)
•      Experiment on a low-resolution copy of your file and note the filters and settings used. Then apply 
the filters and setting to the high-resolution original.
•      Free up memory before running the filter by using the Purge command. For more information, see 
Correcting mistakes.
•      Allocate more RAM to Photoshop. If necessary, exit from other applications to make more memory
available to Photoshop.
•      Try changing settings to improve the speed of memory-intensive filters, such as Lighting Effects, 
Cutout, Stained Glass, Chrome, Ripple, Spatter, Sprayed Strokes, and Glass filters. (For example, 
with the Stained Glass filter, increase cell size. With the Cutout filter, increase Edge Simplicity, or 
decrease Edge Fidelity, or both.)
•      If you plan to print to a grayscale printer, convert a copy of the image to grayscale before applying 
filters. However, applying a filter to a color image and then converting to grayscale may not have the 
same effect as applying the filter to a grayscale version of the image.
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Photoshop Filter Sample Gallery

The Adobe Photoshop filters fall into 14 general categories. In addition, third-party filters appear at the 
bottom of the Filter menu. 
Artistic filters 
Blur filters 
Brush Strokes filters 
Distort filters 
Noise filters 
Pixelate filters 
Render filters 
Sharpen filters 
Sketch filters 
Stylize filters 
Texture filters 

Artistic filters
Apply a painterly or special effect for a fine-arts or commercial project. For example, use the Cutout 
filter for collages or type treatment. These filters replicate natural or traditional media effects. For 
information on the Rough Pastels and Underpainting filters, see Using texture and glass surface 
controls.

Blur filters
Soften a selection or an image. Blur filters are useful for retouching. They smooth transitions by 
averaging the pixels next to the hard edges of defined lines and shaded areas in an image. 

Note: To apply a Blur filter to the edges of a layer, be sure to turn off the Preserve Transparency 
option in the Layers palette.

Brush Strokes filters
Like the Artistic filters, the Brush Strokes filters give a painterly or fine-arts look using different brush 
and ink stroke effects. Some of the filters add grain, paint, noise, edge detail, or texture to an image 
for a pointillist effect. 

Distort filters
Geometrically distort an image, creating 3-D or other reshaping effects. Note that these filters can be 
very memory intensive. For information on the Glass filter, see Using texture and glass surface 
controls. For more on the Displace filter, see Defining undistorted areas.

Noise filters
Add or remove noise, or pixels with randomly distributed color levels. This helps to blend a selection 
into the surrounding pixels. Noise filters can create unusual textures or remove problem areas, such 
as dust and scratches, from an image. The Add Noise filter can be used to reduce banding in 
feathered selections or graduated fills or to give a more realistic look to heavily retouched areas. 

Pixelate filters
Sharply define a selection by clumping pixels of similar color values in cells. 

Render filters
Create 3-D shapes, cloud patterns, refraction patterns, and simulated light reflections in an image. You
can also manipulate objects in 3-D space, create 3-D objects (cubes, spheres, and cylinders), and 



create texture fills from grayscale files to produce 3-D-like effects for lighting. For information on the 
3D Transform filter, see Transforming objects in three dimensions.
 When using the Clouds filter, generate a more stark cloud pattern by holding down Alt (Windows) or 

Option (Mac OS) as you choose Filter > Render > Clouds. 

Sharpen filters
Focus blurry images by increasing the contrast of adjacent pixels. They include the Sharpen Edges 
and Unsharp Mask filters, which find and sharpen areas where significant color changes occur (such 
as at the edges). The Unsharp Mask filter is commonly used for high-end color correction (see Step 6: 
Sharpen the image).

Sketch filters
Add texture to images, often for a 3-D effect. The filters also are useful for creating a fine-arts or hand-
drawn look. Many of the Sketch filters use the foreground and background color as they redraw the 
image. For information on the Conté Crayon filter, see Using texture and glass surface controls.
 For a truer effect when using the Conté Crayon filter, change the foreground color to one of the 

common Conté Crayon colors (black, sepia, sanguine) before applying the filter. 

Stylize filters 
Produce a painted or impressionistic effect on a selection by displacing pixels and by finding and 
heightening contrast in an image. After using filters like Find Edges and Trace Contour that highlight 
edges, you can apply the Invert command to outline the edges of a color image with colored lines or to
outline the edges of a grayscale image with white lines. (See Using the Invert command.)

Texture filters
Give images the appearance of depth or substance, or to add an organic look. (See Using texture and 
glass surface controls.)

Video filters
Include the NTSC (National Television Standards Committee) Colors filter, which restricts the gamut of
colors to those acceptable for television reproduction, and the De-Interlace filter, which smooths 
moving images captured on video. 

Other filters
Let you create your own filters, use filters to modify masks, offset a selection within an image, and 
make quick color adjustments. For more on the Offset filter, see Defining undistorted areas.

Digimarc filters
Embed a digital watermark into an image to store copyright information.
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Artistic filters

Choose a filter from the Artistic submenu to achieve a painterly or special effect for a fine arts or 
commercial project. For example, use the Cutout filter for collages or type treatment. These filters 
replicate natural or traditional media effects and include:

Colored Pencil
Draws an image using colored pencils on a solid background. Important edges are retained and given 
a rough crosshatch appearance; the solid background color shows through the smoother areas.
 For a parchment effect, change the background color just before applying the Colored Pencil filter to a 

selected area.

Cutout
Portrays an image as though it were made from roughly cut-out pieces of colored paper. High-contrast
images appear as if in silhouette, while colored images are built up from several layers of colored 
paper.

Dry Brush
Paints the edges of the image using a dry brush technique (between oil and watercolor). The filter 
simplifies an image by reducing its range of colors to areas of common color.

Film Grain
Applies an even pattern to the shadow tones and midtones of an image. A smoother, more saturated 
pattern is added to the image’s lighter areas. This filter is useful for eliminating banding in blends and 
visually unifying elements from various sources.

Fresco
Paints an image in a coarse style using short, rounded, and hastily applied dabs.

Neon Glow
Adds various types of glows to the objects in an image and is useful for colorizing an image while 
softening its look. To select a glow color, click the glow box and select a color from the color picker.

Paint Daubs
Lets you choose from various brush sizes (from 1 to 50) and types for a painterly effect. Brush types 
include simple, light rough, light dark, wide sharp, wide blurry, and sparkle.

Palette Knife
Reduces detail in an image to give the effect of a thinly painted canvas that reveal the texture 
underneath.

Plastic Wrap
Coats the image in shiny plastic, accentuating the surface detail.

Poster Edges
Reduces the number of colors in (posterizes) an image according to the posterization option you set, 
and finds the edges of the image and draws black lines on them. Large broad areas of the image have
simple shading while fine dark detail is distributed throughout the image.

Rough Pastels
Makes an image appear as if stroked with colored pastel chalk on a textured background. In areas of 
bright color, the chalk appears thick with little texture; in darker areas, the chalk appears scraped off to
reveal the texture. For more on the filter options, see Using texture and glass surface controls.



Smudge Stick
Softens an image using short diagonal strokes to smudge or smear the darker areas of the images. 
Lighter areas become brighter and lose detail.

Sponge
Creates images with highly textured areas of contrasting color, appearing to have been painted with a 
sponge.

Underpainting
Paints the image on a textured background, and then paints the final image over it. For more on the 
filter options, see Using texture and glass surface controls.

Watercolor
Paints the image in a watercolor style, simplifying details in an image, using a medium brush loaded 
with water and color. Where significant tonal changes occur at edges, the filter saturates the color.
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Blur filters

The six blur filters soften a selection or an image, and are useful for retouching. They smooth 
transitions by averaging the pixels next to the hard edges of defined lines and shaded areas in an 
image. 

Note: To apply a Blur filter to the edges of a layer, be sure to turn off the Preserve Transparency 
option in the Layers palette.

Blur and Blur More
Eliminate noise where significant color transitions occur in an image. Blur filters smooth transitions by 
averaging the pixels next to the hard edges of defined lines and shaded areas. The Blur More filter 
produces an effect three or four times stronger than that of the Blur filter.

Gaussian Blur
Quickly blurs a selection by an adjustable amount. Gaussian refers to the bell-shaped curve that is 
generated when Adobe Photoshop applies a weighted average to the pixels. This filter adds low-
frequency detail and can produce a hazy effect.

Motion Blur
Blurs in a particular direction (from –360º to +360º) and at a specific intensity (from 1 to 999). The 
filter’s effect is analogous to taking a picture of a moving object with a fixed exposure time.

Radial Blur
Simulates the blur of a zooming or rotating camera to produce a soft blur. Choose Spin, to blur along 
concentric circular lines, and then specify a degree of rotation; or Zoom to blur along radial lines, as if 
zooming in or out of the image, and specify an amount from 1 to 100. Blur quality ranges from Draft for
the fastest but grainy results; or Good and Best for smoother results, which are indistinguishable 
except on a large selection. Specify the origin of the blur by dragging the pattern in the Blur Center 
box.

Smart Blur
Precisely blurs an image. You can specify a radius, to determine how far the filter searches for 
dissimilar pixels to blur; a threshold, to determine how different the pixels’ values should be before 
they are eliminated; and a blur quality.You also can set a mode for the entire selection (Normal), or for 
the edges of color transitions (Edge Only and Overlay). Where significant contrast occurs, Edge Only 
applies black-and-white edges and Overlay Edge applies white.



Using Filters 

Brush Stroke filters

Like the Artistic filters, the Brush Stroke filters give a painterly or fine-arts look using different brush 
and ink stroke effects. Some of the filters add grain, paint, noise, edge detail, or texture to an image 
for a pointillist effect. 

Accented Edges
Accentuates the edges of an image. When the edge brightness control is set to a high value, the 
accents resemble white chalk; when set to a low value, the accents resemble black ink.

Angled Strokes
Repaints an image using diagonal strokes. The lighter areas of the image are painted in strokes going 
in one direction while the darker areas are painted in strokes going the opposite direction.

Crosshatch
Preserves the details and features of the original image while adding texture and roughening the 
edges of the colored areas in the image with simulated pencil hatching. The Strength option controls 
the number of hatching passes, from 1 to 3.

Dark Strokes
Paints dark areas of an image closer to black with short, tight strokes, and paints lighter areas of the 
image with long, white strokes.

Ink Outlines
Redraws an image with fine narrow lines over the original details, in pen-and-ink style.

Spatter
Replicates the effect of a spatter airbrush. Increasing the options simplifies the overall effect.

Sprayed Strokes
Repaints an image using its dominant colors with angled, sprayed strokes of color.

Sumi-e
Paints an image in Japanese style as if with a wet brush full of black ink on rice paper. The effect is 
soft blurry edges with rich blacks.
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Distort filters

The Distort filters geometrically distort an image, creating 3-D or other reshaping effects. Note that 
these filters can be very memory intensive.

Diffuse Glow
Renders an image as though it were viewed through a soft diffusion filter. The filter adds see-through 
white noise to an image, with the glow fading from the center of a selection.

Displace filter
Uses an image, called a displacement map, to determine how to distort a selection. For example, 
using a parabola-shaped displacement map, you can create an image that appears to be printed on a 
cloth held at its corners.

Create displacements maps using a flattened file saved in Adobe Photoshop format (except Bitmap 
mode images) or one that is saved with the Include Composite Image With Layered Files option 
turned on in the Saving Files preferences. You can also use the files included with your software 
(search for the Dispmaps folder in Windows or the Displacement Maps folder in Mac OS). 

To use the Displace filter:

1    Choose Filter > Distort > Displace.

2    Enter the scale for the magnitude of the displacement.

When the horizontal and vertical scale are set to 100%, the greatest displacement is 128 pixels 
(because middle gray produces no displacement).

3    If the displacement map is not the same size as the selection, choose how the map will fit the 
image: Stretch to Fit to resize the map, or Tile to fill the selection by repeating the map in a pattern.

4    Choose Wrap Around or Repeat Edge Pixels to determine how undistorted areas of the image will 
be treated. (See Defining undistorted areas.)

5    Click OK.

6    Select and open the displacement map. The distortion is applied to the image.

The Displace filter shifts a selection using a color value from the displacement map: 0 is the maximum 
negative shift, 255 the maximum positive shift, and a gray value of 128 produces no displacement. If a
map has one channel, the image shifts along a diagonal defined by the horizontal and vertical scale 
ratios. If the map has more than one channel, the first channel controls the horizontal displacement, 
and the second channel controls the vertical displacement.

Glass
Makes an image appear as if it is being viewed through different types of glass.You can choose a 
glass effect or create your own glass surface as a Photoshop file, and apply it. You can adjust scaling, 
distortion, and smoothness settings. When using surface controls with a file, follow the instructions for 
the Displace filter. (See the Displace filter in online help.) For more information about Glass filter 
controls, see Using texture and glass surface controls.

Ocean Ripple
Adds randomly spaced ripples to the images surface, making the image look as if it were under water.

Pinch
Squeezes a selection. A positive value up to 100% shifts a selection toward its center; a negative 
value up to –100% shifts a selection outward.

Polar Coordinates



Converts a selection from its rectangular to polar coordinates, and vice versa, according to selected 
option. You can use this filter to create a cylinder anamorphosis—art popular in the 18th century—in 
which the distorted image appears normal when viewed in a mirrored cylinder.

Ripple
Creates an undulating pattern on a selection, like ripples on the surface of a pond. For greater control, 
use the Wave filter. Options include the amount and size of ripples.

Shear
Distorts an image along a curve. Specify the curve by dragging the line in the box to form a curve for 
the distortion. You can adjust any point along the curve. Click Default to return the curve to a straight 
line. In addition, you choose how to treat undistorted areas. For more information, see Defining 
undistorted areas.

Spherize
Gives objects a 3-D effect by wrapping a selection around a spherical shape, distorting the image and 
stretching it to fit the selected curve.

Twirl 
Rotates a selection more sharply in the center than at the edges. Specifying an angle produces a twirl 
pattern.

Wave
Works in a similar way to the Ripple filter, but with greater control. Options include the number of wave
generators, the wave-length (distance from one wave crest to the next), the height of the wave, and 
the wave type: Sine (rolling), Triangle, or Square. The Randomize option applies random values. You 
can also define undistorted areas (see Defining undistorted areas for more information.)
 To replicate wave results on other selections, click Randomize, set the Number of Generators to 1, and

set the minimum and maximum Wavelength and Amplitude parameters to the same value.

ZigZag
Distorts a selection radially, depending on the radius of the pixels in your selection. The Ridges option 
sets the number of direction reversals of the zigzag from the center of the selection to its edge. You 
also choose how to displace the pixels: Pond Ripples displaces pixels to the upper left or lower right, 
Out From Center displaces pixels toward or away from the center of the selection, and Around Center 
rotates pixels around the center.
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Noise filters

The Noise filters add or remove noise, or pixels with randomly distributed color levels. This helps to 
blend a selection into the surrounding pixels. Noise filters can create unusual textures or remove 
problem areas, such as dust and scratches, from an image. 

Add Noise
Applies random pixels to an image, simulating the effect of shooting pictures on high-speed film. The 
Add Noise filter can also be used to reduce banding in feathered selections or graduated fills or to give
a more realistic look to heavily retouched areas.Options include noise distribution: Uniform distributes 
color values of noise using random numbers between 0 and plus or minus the specified value, for a 
subtle effect; Gaussian distributes color values of noise along a bell-shaped curve for a speckled 
effect. The Monochromatic option applies the filter to only the tonal elements in the image without 
changing the colors.

Despeckle
Detects the edges in an image (areas where significant color changes occur) and blurs all of the 
selection except those edges. This blurring removes noise while preserving detail.

Dust & Scratches
Reduces noise by changing dissimilar pixels. To achieve a balance between sharpening the image 
and hiding defects, try various combinations of radius and threshold settings. Or apply the filter on 
selected areas in the image.

To use the Dust & Scratches filter:

1    Choose Filter > Noise > Dust & Scratches.

2    If necessary, adjust the preview zoom ratio until the area containing noise is visible. 

3    Drag the Threshold slider left to 0 to turn off the value, so that all pixels in the selection or image 
can be examined. 

The Threshold determines how different the pixels’ values should be before they are eliminated. 

Note: The Threshold slider gives greater control for values between 0 and 128—the most common 
range for images—than for values between 128 and 255.

4    Drag the Radius slider left or right, or enter a value in the text box from 1 to 16 pixels. The Radius 
determines how far the filter searches for differences among pixels. 

Adjusting the radius makes the image blurry. Stop at the smallest value that eliminates the defects.

5    Increase the threshold gradually by entering a value or by dragging the slider to the highest value 
possible that eliminates defects.

6    Click OK.

Median
Reduces noise in an image by blending the brightness of pixels within a selection. The filter searches 
the radius of a pixel selection for pixels of similar brightness, discarding pixels that differ too much 
from adjacent pixels, and replaces the center pixel with the median brightness value of the searched 
pixels. This filter is useful for eliminating or reducing the effect of motion on an image.
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Pixelate filters

The filters in the Pixelate submenu sharply define a selection by clumping pixels of similar color values
in cells.

Color Halftone
Simulates the effect of using an enlarged halftone screen on each channel of the image. For each 
channel, the filter divides the image into rectangles and replaces each rectangle with a circle. The 
circle size is proportional to the brightness of the rectangle. 

To use the Color Halftone filter:

1    Choose Filter > Pixelate > Color Halftone.

2    Enter a value in pixels for the maximum radius of a halftone dot, from 4 to 127.

3    Enter a screen-angle value (the angle of the dot from the true horizontal) for one or more channels:
•      For Grayscale images use only channel 1. 
•      For RGB images, use channels 1, 2, and 3, which correspond to the red, green, and blue 
channels. 
•      For CMYK images, use all four channels, which correspond to the cyan, magenta, yellow, and 
black channels. 
•      Click Defaults to return all the screen angles to their default values. 

4    Click OK.

Crystallize
Clumps pixels into a solid color in a polygon shape.

Facet
Clumps pixels of solid or similar colors into blocks of like-colored pixels. You can use this filter to make
a scanned image look hand painted, or to make a realistic image resemble an abstract painting.

Fragment
Creates four copies of the pixels in the selection, averages them, and offsets them from each other.

Mezzotint
Converts an image to a random pattern of black-and-white areas or of fully saturated colors in a color 
image. To use the filter, choose a dot pattern from the Type pop-up menu in the Mezzotint dialog box.

Mosaic
Clumps pixels into square blocks. The pixels in a given block are the same color, and the colors of the 
blocks represent the colors in the selection.

Pointillize
Breaks up the color in an image into randomly placed dots, as in a pointillist painting, and uses the 
background color as a canvas area between the dots.
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Render filters

The Render filters create 3-D shapes, cloud patterns, refraction patterns, and simulated light 
reflections in an image. You can also manipulate objects in 3-D space, create 3-D objects (cubes, 
spheres, and cylinders), and create texture fills from grayscale files to produce 3-D-like effects for 
lighting. 

3D Transform
Maps images to cubes, spheres, and cylinders, which you can then rotate in three dimensions. For 
more information, see Transforming objects in three dimensions.

Clouds
Generates a soft cloud pattern using random values that vary between the foreground and the 
background colors. To generate a more stark cloud pattern, hold down Alt (Windows) or Option (Mac 
OS) as you choose Filter> Render > Clouds.

Difference Clouds
Uses randomly generated values that vary between the foreground and background color to produce a
cloud pattern. The filter blends the cloud data with the existing pixels in the same way that the 
Difference mode blends colors. The first time you choose this filter, portions of the image are inverted 
in a cloud pattern. Applying the filter several times creates rib and vein patterns that resemble a 
marble texture.

Lens Flare
Simulates the refraction caused by shining a bright light into the camera lens. Specify a location for the
center of the flare by clicking anywhere inside the image thumbnail or by dragging its crosshair. 

Lighting Effects
Lets you produce myriad lighting effects on RGB images by varying 17 light styles, 3 light types, and 4
sets of light properties. You can also use textures from grayscale files (called bump maps) to produce 
3-D-like effects and save your own styles for use in other images. 

Texture Fill
Fills a selection with a grayscale file or part of a file. To add the texture to the document or selection, 
you open the grayscale document you want to use as the texture fill.
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Sharpen filters

The Sharpen filters focus blurry images by increasing the contrast of adjacent pixels.

Sharpen and Sharpen More
Focus a selection and improve its clarity. The Sharpen More filter applies a stronger sharpening effect 
than does the Sharpen filter.

Sharpen Edges and Unsharp Mask
Find the areas in the image where significant color changes occur and sharpen them. The Sharpen 
Edges filter sharpens only edges while preserving the overall smoothness of the image. Use this filter 
to sharpen edges without specifying an amount. For professional color-correction, use the Unsharp 
Mask filter to adjust the contrast of edge detail and produce a lighter and darker line on each side of 
the edge, to emphasize the edge and create the illusion of a sharper image. (See Step 6: Sharpen the 
image.)
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Sketch filters

Filters in the Sketch submenu add texture to images, often for a 3-D effect. The filters also are useful 
for creating a fine-arts or hand-drawn look. Many of the Sketch filters use the foreground and 
background color as they redraw the image.

Bas Relief
Transforms an image to appear carved in low relief and lit to accent the surface variations. Dark areas 
of the image take on the foreground color, light colors use the background color.

Chalk & Charcoal
Redraws an image’s highlights and midtones with a solid midtone gray background drawn in coarse 
chalk. Shadow areas are replaced with black diagonal charcoal lines. The charcoal is drawn in the 
foreground color, the chalk in background color.

Charcoal
Redraws an image to create a posterized, smudged effect. Major edges are boldly drawn while 
midtones are sketched using a diagonal stroke. Charcoal is the foreground color, and the paper is the 
background color.

Chrome
Treats the image as if it were a polished chrome surface. Highlights are high points and shadows are 
low points in the reflecting surface. After applying the filter, use the Levels dialog box to add more 
contrast to the image.

Conté Crayon
Replicates the texture of dense dark and pure white Conté crayons on an image. The Conté Crayon 
filter uses the foreground color for dark areas and the background color for light areas. For a truer 
effect, change the foreground color to one of the common Conté Crayon colors (black, sepia, 
sanguine) before applying the filter. For a muted effect, change the background color to white with 
some foreground color added to it before applying the filter. (See Using texture and glass surface 
controls.)

Graphic Pen 
Uses fine, linear ink strokes to capture the details in the original image and is especially striking with 
scanned images. The filter replaces color in the original image using the foreground color for ink and 
background color for paper.

Halftone Screen
Simulates the effect of a halftone screen while maintaining the continuous range of tones. 

Note Paper
Creates an image that appears to be constructed of handmade paper. The filter simplifies an image, 
and combines the effects of the Texture > Emboss and Grain filters. Dark areas of the image appear 
as holes in the top layer of paper, revealing the background color.

Photocopy
Simulates the effect of photocopying an image. Large areas of darkness tend to copy only around their
edges and midtones fall away to either solid black or white.

Plaster
Molds an image from 3-D plaster, and then colorizes the result using the foreground and background 
color. Dark areas are raised, light areas are sunken (or reverse the effect by choosing the Invert 



option).

Reticulation
Simulates the controlled shrinking and distorting of film emulsion, to create an image that appears 
clumped in the shadow areas and lightly grained in the highlights.

Stamp
Is best used with black-and-white images. The filter simplifies the image to appear stamped with a 
rubber or wood stamp.

Torn Edges
Is particularly useful for images consisting of text or high-contrast objects. The filter reconstructs the 
image as ragged, torn pieces of paper, and then colorizes the image using the foreground and 
background colors.

Water Paper
Uses blotchy daubs that appear painted onto fibrous, damp paper, causing the colors to flow and 
blend.
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Stylize filters

The Stylize filters produce a painted or impressionistic effect on a selection by displacing pixels and by
finding and heightening contrast in an image. After using filters like Find Edges and Trace Contour that
highlight edges, you can apply the Invert command to outline the edges of a color image with colored 
lines or to outline the edges of a grayscale image with white lines. (See Using the Invert command.

Diffuse
Shuffles pixels in a selection to make the selection look less focused according to the selected option: 
Normal moves pixels randomly, ignoring color values; Darken Only replaces light pixels with darker 
pixels; and Lighten Only replaces dark pixels with lighter pixels.

Emboss
Makes a selection appear raised or stamped by converting its fill color to gray and tracing the edges 
with the original fill color. Options include an embossing angle (from –360° to lower (stamp) the 
surface to +360° to raise the surface to ); height; and a percentage (1% to 500%) for the amount of 
color within the selection. To retain color and detail when embossing, use the Fade command after 
applying the Emboss filter.

Extrude
Gives a 3-D texture to a selection or layer. 

To use the Extrude filter:

1    Choose Filter > Stylize > Extrude. 

2    Choose a 3-D object:
•      Blocks creates objects with a square front face and four side faces. To fill the front face of each 
block with the average color of the block, select the Solid Front Faces option. To fill the front face with 
the image, keep deselected the Solid Front Faces option. 
•      Pyramids creates objects with four triangular sides that meet at a point.

3    Enter a value in the Size text box to determine the length of any side of the object’s base, from 2 to
255.

4    Enter a value in the Depth text box to indicate how far the tallest object appears to protrude from 
the screen, from 0 to 255.

5    Choose a depth option: 
•      Random to give each block or pyramid an arbitrary depth
•      Level-based to make each object’s depth correspond to its brightness—bright protrudes more than
dark.

6    Select Mask Incomplete Blocks to hide any object extending beyond the selection.

7    Click OK.

Find Edges
Identifies the areas of the image with significant transitions and emphasizes the edges. Like the Trace 
Counter filter, Find Edges outlines the edges of an image with dark lines against a white background 
and is useful for creating a border around an image. 

Glowing Edges
Identifies the edges of color and adds a neon-like glow to them.

Solarize



Blends a negative and a positive image—similar to exposing a photographic print briefly to light during 
development.

Tiles
Breaks up an image into a series of tiles, off-setting the selection from its original position. You can 
choose with what to fill the area between the tiles: the background color; the foreground color; a 
reverse version of the image; or an unaltered version of the image, which puts the tiled version of the 
image on top of the original and reveals part of the original image underneath the tiled edges.

Trace Contour
Finds the transitions of major brightness areas and thinly outlines them for each color channel for an 
effect similar to the lines in a contour map.

To use the Trace Contour filter:

1    Choose Filter > Stylize > Trace Contour.

2    Choose an Edge option to outline areas in the selection: Lower outlines where the color values of 
pixels fall below the specified level; Upper outlines where the color values fall above. 

3    Enter a threshold (Level) for evaluating color values (tonal level), from 0 to 255. Experiment to see 
what values bring out the best detail in the image. 

Use the Info palette in Grayscale mode to identify a color value that you want traced. Then enter the 
value in the Level text box. (See Using the Info palette.)

4    Click OK.

Wind
Creates tiny horizontal lines in the image to simulate a wind effect. Methods include Wind; Blast, for a 
more dramatic wind effect; and Stagger offsets the wind lines in the image.
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Texture filters

Use the Texture filters to give an image the appearance of depth or substance, or to add an organic 
look. 

Craquelure
Paints an image onto a high-relief plaster surface, producing a fine network of cracks that follow the 
contours of the image. Use this filter to create an embossing effect with images that contain a broad 
range of color or grayscale values.

Grain
Adds texture to an image by simulating different kinds of grain—regular, soft, sprinkles, clumped, 
contrasty, enlarged, stippled, horizontal, vertical, and speckle.

Mosaic Tiles
Draws the image as if it had been made up of small chips or tiles and adds grout between the tiles. (In 
contrast, the Pixelate > Mosaic filter breaks up an image into blocks of different colored pixels.)

Patchwork
Breaks up an image into squares filled with the predominant color in that area of the image. The filter 
randomly reduces or increases the tile depth to replicate the highlights and shadows.

Stained Glass
Repaints an image as single-colored adjacent cells outlined in the foreground color. 

Texturizer
Applies a texture you select or create to an image. (See Using texture and glass surface controls.)
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Video filters

The Video submenu contains the De-Interlace and NTSC Colors filters. 

De-Interlace 
Smooths moving images captured on video by removing either the odd or even interlaced lines in a 
video image. You can choose to replace the discarded lines by duplication or interpolation.

NTSC Colors
Restricts the gamut of colors to those acceptable for television reproduction to prevent oversaturated 
colors from bleeding across television scan lines.
 When creating images for use on television or video, use the Color Settings > RGB Setup command to

set your RGB space to NTSC (1953).
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Other filters

Filters in the Other submenu let you create your own filters, use filters to modify masks, offset a 
selection within an image, and make quick color adjustments.

Custom 
Lets you design your own filter effect. With the Custom filter, you can change the brightness values of 
each pixel in the image according to a predefined mathematical operation known as convolution. Each
pixel is reassigned a value based on the values of surrounding pixels. This operation is similar to the 
Add and Subtract calculations for channels. (See Calculations blending options.) 

You can save the custom filters you create and use them with other Adobe Photoshop images. 

To create a Custom filter: 

1    Choose Filter > Other > Custom. 

2    Select the center text box, which represents the pixel being evaluated. Enter the value by which 
you want to multiply that pixel’s brightness value, from –999 to +999.

3    Select a text box representing an adjacent pixel. Enter the value by which you want the pixel in this
position multiplied. 

For example, to multiply the brightness value of the pixel to the immediate right of the current pixel by 
2, enter 2 in the text box to the immediate right of the center text box. 

4    Repeat steps 2 and 3 for all pixels to include in the operation. You don’t have to enter values in all 
the text boxes.

5    For Scale, enter the value by which to divide the sum of the brightness values of the pixels 
included in the calculation. 

6    For Offset, enter the value to be added to the result of the scale calculation. 

7    Click OK. The custom filter is applied to each pixel in the image, one at a time. 

Use the Save and Load buttons to save and reuse custom filters. 

High Pass
Retains edge details in the specified radius where sharp color transitions occur and suppresses the 
rest of the image (A radius of 0.1 pixel keeps only edge pixels.) The filter removes low-frequency detail
in an image, and has the opposite effect of the Gaussian Blur filter. 

It is helpful to apply the High Pass filter to a continuous-tone image before using the Threshold 
command or converting the image to Bitmap mode. The filter is useful for extracting line art and large 
black-and-white areas from scanned images.

Minimum and Maximum
Are useful for modifying masks. The Minimum filter has the effect of applying a spread—spreading out
black areas and shrinking white areas. The Maximum filter has the effect of applying a choke—
spreading out white areas and choking in black areas. As does the Median filter, the Maximum and 
Minimum filters look at individual pixels in a selection. Within a specified radius, the Maximum and 
Minimum filters replace the current pixel’s brightness value with the greatest or least brightness value 
of the surrounding pixels.

Offset
Moves a selection a specified horizontal or vertical amount, leaving an empty space at the selection’s 
original location. You can fill the empty area with the current background color, with another part of the 
image, or with your choice of fill if the selection is near the edge of an image. (See Defining 



undistorted areas.)
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Digimarc Filters

The Digimarc filters embed a digital watermark into an image to store copyright information. (For more 
information, see Adding digital copyright information.)
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Using the Lighting Effects filter

The Lighting Effects filter lets you produce myriad lighting effects on RGB images by varying 17 light 
styles, 3 light types, and 4 sets of light properties. You can also use textures from grayscale files 
(called bump maps) to produce 3-D-like effects and save your own styles for use in other images.

Note: The Lighting Effects filter works only on RGB images.

To use the Lighting Effects filter:

1    Choose Filter > Render > Lighting Effects. 

2    For Style, choose a style. Press Tab to cycle through the lights in a style. (See Choosing a Lighting 
Effects style. )

3    For Light Type, choose a type. If you’re using multiple lights, select and deselect On to turn 
individual lights on and off. (See Choosing a Lighting Effects type.)

4    To change the color of the light, click the color box in the Light Type section of the dialog box. 

The color picker chosen in the General Preferences dialog box opens. For information on choosing a 
color picker, see Using the Adobe Photoshop Color Picker, or Using other color pickers.

5    To set light properties, drag the corresponding slider for the following options:
•      Gloss determines how much the surface reflects light (as on the surface of a piece of photographic
paper) from Matte (low reflectance) to Glossy (high reflectance). 
•      Material determines whether the light or the object on which the light is cast reflects more light. 
Plastic reflects the light’s color, Metallic reflects the object’s color.
•      Exposure increases the light (positive values) or decreases the light (negative values). A value of 0
has no effect.
•      Ambience diffuses the light as if it were combined with other light in a room, such as sunlight or 
fluorescent light. Choose a value of 100 to use only the light source, a value of –100 to remove the 
light source. To change the color of the ambient light, click the color box and use the color picker that 
appears.

To duplicate a light, Alt-drag (Windows) or Option-drag (Mac OS) the light within the preview window.

6    To use a texture fill, choose a channel for Texture Channel. (See Using a Lighting Effects texture.)

7    Click OK to apply the filter.

See also: 

Choosing a Lighting Effects type 

Choosing a Lighting Effects style 

Using a Lighting Effects texture 



Using the Lighting Effects filter 

Choosing a Lighting Effects type

You can choose from three light types.

Omni, Directional, and Spotlight
•      Omni shines light in all directions from directly above the image—like a light bulb over a piece of 
paper.
•      Directional shines light from far away so that the light angle doesn’t change—like the sun.
•      Spotlight casts an elliptical beam of light. The line in the preview window defines the light direction 
and angle, and the four handles define the edges of the ellipse. 

To adjust an Omni light:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Omni.

3    Adjust the light:
•      To move the light, drag the center circle. 
•      To increase or decrease the size of the light (like a light moving closer or farther away), drag one 
of the four handles defining the edges of the effect.

Increasing the size of the light

4    Click OK to apply the filter.

To adjust the angle and height of the directional light using the preview window:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Directional.

3    Adjust the light:
•      To move the light, drag the center circle. 
•      To change the direction of the light, drag the handle at the end of the line to rotate the light’s angle.
Ctrl-drag (Windows) or Command-drag (Mac OS) to keep the light’s height (line length) constant.
•      To change the light’s height, drag the square at the end of the line. Shorten the line for a bright 



light, lengthen for a less intense one. A very short line produces pure white light, a very long one no 
light. Shift-drag to keep the angle constant and change the light’s height (line length).

Changing the height of the light

4    Click OK to apply the filter.

To adjust the angle and height of the spotlight using the preview window:

1    Choose Filter > Render > Lighting Effects. 

2    For Light Type, choose Spotlight.

3    Adjust the light:
•      To move the light, drag the center circle. 
•      To increase the light angle, drag the black square to shorten the line. To decrease the light angle, 
drag to lengthen the line.
•      To stretch the ellipse or rotate the light, drag one of the four handles. Shift-drag to keep the angle 
constant and change only the size of the ellipse. Ctrl-drag (Windows) or Command-drag (Mac OS) to 
keep the size constant and change the angle or direction of the spotlight.

Stretching the ellipse
•      To set the light focus (or spotlight intensity) and control how much of an ellipse is filled with light, 
drag the Intensity slider: full intensity (a value of 100) is brightest; normal intensity is about 50; 
negative intensity takes away light; –100 intensity produces no light. Use the Focus slider to control 
how much of the ellipse is filled with light.

4    Click OK to apply the filter.
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Choosing a Lighting Effects style

Use the Style menu in the Lighting Effects dialog box to choose from 17 light styles. You can also 
create your own lighting style by adding lights to the Default setting. The Lighting Effects filter requires 
at least one light source. Only one light can be edited at a time, but all added lights will be used to 
create the effect.

2 o’clock Spotlight
A yellow spotlight with medium (17) intensity and wide (91) focus.

Blue Omni
A blue overhead omni light with full (85) intensity and no focus.

Circle of Light
Four spotlights. White has full (100) intensity and a concentrated (8) focus. Yellow has strong intensity 
(88) and a concentrated focus (3). Red has medium (50) intensity and a concentrated (0) focus. Blue 
has full (100) instensity and medium (25) focus. 

Crossing
A white spotlight with medium (35) intensity and a wide (69) focus.

Crossing Down
Two white spotlights with medium (35) intensity and wide (100) focus.

Default
A white spotlight with a medium intensity and a wide focus. 

Five Lights Down/Five Lights Up
Five white spotlights down or up with full (100) intensity and wide (60) focus.

Flashlight
An omni yellow light with medium (46) intensity.

Flood Light
A white spotlight with medium (35) intensity and wide (69) focus.

Parallel Directional
A directional blue light with full (98) intensity and no focus.

RGB Lights
Red, blue, and green lights that produce a light of medium (60) intensity and wide (96) focus.

Soft Direct Lights
Two unfocused white and blue directional lights. White has a soft (20) intensity. Blue has a medium 
(67) intensity.

Soft Omni
A soft omni light of medium (50) intensity.

Soft Spotlight
A white spotlight with full (98) intensity and white (100) focus.

Three Down



Three white spotlights with soft (35) intensity and wide (96) focus.

Triple Spotlight
Three spotlights with slight (35) intensity and wide (100) focus.

To add a light: 

In the Lighting Effects dialog box, drag the light icon at the bottom of the dialog box into the preview 
area. Repeat as desired for a maximum of 16 lights. 

To delete a light:

In the Lighting Effects dialog box, drag the light by its center circle to the Trash button at the bottom 
right of the preview window.

To create a new style:

1    In the Lighting Effects dialog box, choose Default for Style. 

2    Drag the light icon at the bottom of the dialog box into the preview area. Repeat as desired for a 
maximum of 16 lights. 

To save a style:

1    In the Lighting Effects dialog box, click Save. 

2    Name the style and click OK.

Saved styles include all of the settings for each light and appear in the Style menu whenever you open
the image. 

To delete a style:

1    In the Lighting Effects dialog box, choose a style for Style. 

2    Click Delete.
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Using a Lighting Effects texture

The Texture Channel in the Lighting Effects dialog box lets you use a grayscale texture such as paper 
or water to control how light reflects off an image. You can use any channel in your image (including a 
channel copied from a different image) as a texture or create your own texture. For an embossed text 
effect, use a channel with white text on a black background, or vice versa.

To use the Texture Channel in the Lighting Effects dialog box:

1    If necessary, create an alpha channel in your image and add texture. To use a texture from another
image, copy and paste the image into a new channel. (See Creating and saving alpha channels.)

2    In the Lighting Effects dialog box, choose a channel from the Texture Channel menu: the image’s 
Red, Green, or Blue channel or any channel added to the image.

3    Select White is High to raise the white parts of the channel from the surface. Turn off this option to 
raise the dark parts.

4    Drag the Height slider to vary the texture from Flat (0) to Mountainous (100). 

5    Click OK.
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See also: 

Saving files 

Adding digital copyright information 

Exporting images 

About file formats 

Placing Photoshop images in other applications 
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Saving files

Adobe Photoshop provides several ways to save files:
•      The Save command saves the file in its current file format.
•      The Save As command lets you save an alternate version of the file in a different format.
•      The Save a Copy command lets you save a copy of the file, leaving the original file intact. You can 
optionally flatten the file copy and exclude non-image data or alpha channels.

See also: 

Saving a file 

Setting preferences for saving files 

Adding file information 

Saving Adobe Photoshop files 

Saving files in Photoshop EPS or DCS format 

Saving files in JPEG format 
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Saving a file

To save a file in its current format:

Choose File > Save. 

To save a file in a different file format:

1    Choose File > Save As.

2    For Save As (Windows) or Format (Mac OS), choose a format. Unavailable formats are not visible 
(Windows) or dimmed (Mac OS).

Important: Only the Photoshop format is available for layered files. In addition, many formats do not 
support files in certain color modes or files with alpha channels (see About file formats). If you do not 
see the format you want, flatten the image or use the Save a Copy command. If the format still does 
not appear, install the format’s plug-in module following the instructions in Using plug-in modules.

3    Type a filename, and choose a location for the file.

4    Click Save.

With some image formats, a dialog box appears. For information on the options available for specific 
file formats, see About file formats.

To save a copy of a file:

1    Choose File > Save a Copy.

2    For Save As (Windows) or Format (Mac OS), choose a format.

3    To flatten all visible layers, select Flatten Image. (See Flattening all layers.)

4    To remove alpha channels from the image, select Exclude Alpha Channels.

5    To remove data such as paths, guides, grids, thumbnail previews, color and printing ink profiles, 
and file information (such as captions) from the image, select Exclude Non-Image Data. (This option 
may be unavailable to some formats.) Excluding non-image data can help reduce the image’s file size.

6    Click Save. 
 To copy an image without saving it to your hard disk, use the Duplicate command (see Duplicating 

images). To store a temporary version of the image in memory, use the History palette to create a 
snapshot (see Making a snapshot of the image).
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Setting preferences for saving files

The Saving Files Preferences dialog box lets you specify whether to include the following features 
when saving files:
•      Thumbnail image previews appear in the Open dialog box. In Mac OS you can also save desktop 
icon and low-resolution previews. 
•      Three-character file extensions append to the names of files and indicate a file’s format (for 
example, .JPG or .jpg for a JPEG file). File extensions are necessary for files that you want to use on 
or transfer to a Windows system.
•      Composited image data refers to a flattened image version that is saved with a layered file. 
Including flattened data adds to the file size, but lets you open the file in applications that do not 
support Photoshop layers, such as Adobe Illustrator.

See also: 

To set saving preferences in Windows 

To set saving preferences In Mac OS 

To display a preview file icon (Windows only) 
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To set saving preferences in Windows:

1    Choose File > Preferences > Saving Files.

2    For Image Previews, choose an option:
•      Never Save to save files without previews.
•      Always Save to save files with specified previews.
•      Ask When Saving to assign previews on a file-by-file basis. 

3    For File Extension, choose an option:
•      Use Upper Case to append file extensions using uppercase characters.
•      Use Lower Case to append file extensions using lowercase characters.

4    To include a flattened version of the file, select Include Composited Image With Layered Files.

Selecting this option makes the file available to applications that can support only the Adobe 
Photoshop 2.5 file format.

5    Click OK.

See also: 

To set saving preferences In Mac OS 

To display a preview file icon (Windows only) 
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To set saving preferences In Mac OS:

1    Choose File > Preferences > Saving Files.

2    For Image Previews, choose an option:
•      Never Save to save files without previews.
•      Always Save to save files with specified previews.
•      Ask When Saving to assign previews on a file-by-file basis. 

3    Select one or more of the following preview types:
•      Icon to use the preview as a file icon on the desktop.
•      Macintosh Thumbnail to display the preview in the Open dialog box.
•      Windows Thumbnail to save a preview that can display on Windows systems.
•      Full Size to save a 72-ppi version of the file for use in applications that can only open low-
resolution Photoshop images. For non-EPS files, this is a PICT preview. 

To speed the saving of files and minimize file size, select only the previews you need.

4    For Append File Extension, choose one of the following options:
•      Never to save files without file extensions.
•      Always to append file extensions to filenames.
•      Ask When Saving to append file extensions on a file-by-file basis. 

5    To append file extensions using lowercase characters, select Use Lower Case.

6    To include a flattened version of the file, select Include Composited Image With Layered Files.

Selecting this option makes the file available to applications that support only the Adobe Photoshop 
2.5 (or earlier) file format.

7    Click OK.
 In Mac OS, to append a file extension to the current file only, hold down Option as you choose a file 

format from the Save As or Save a Copy dialog box.

See also: 

To set saving preferences in Windows 

To display a preview file icon (Windows only) 
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To display a preview file icon (Windows only):

1    Save the file in Photoshop format with a thumbnail preview.

2    Position the pointer on the filename in the file list, click the right mouse button, and choose 
Properties from the context menu that appears.

3    Click the Photoshop Image tab.

4    For Icon Thumbnails, select a preview icon, and click OK.

Preview icons appear on the desktop and in file lists (when the view is set to Large Icons).

See also: 

To set saving preferences in Windows 

To set saving preferences In Mac OS 
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Adding file information

Adobe Photoshop supports the information standard developed by the Newspaper Association of 
America (NAA) and the International Press Telecommunications Council (IPTC) to identify transmitted 
text and images. This standard includes entries for captions, keywords, categories, credits, and 
origins. The captions and keyword entries can also be searched by some third-party image browsers.

In Windows, you can add file information to files saved in the Photoshop, TIFF, JPEG, EPS, and PDF 
formats. In Mac OS, you can add file information to files in any format. 

See also: 

To enter information about a file 

To load, save, or append file information 

File information sections 
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To enter information about a file:

1    Choose File > File Info.

2    For Section, choose an attribute. By default, the dialog box opens to the Caption section.    

3    Choose and fill in any additional sections. To move forward through the sections, click Next; to 
move backward, click Previous.

4    When you’ve finished, click OK.

See also: 

To load, save, or append file information 

File information sections 
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To load, save, or append file information:

In the File Info dialog box, do one of the following:
•      Click Load to replace the current information with information stored in a File Info file.
•      Click Save to save the current file information in a File Info file for later use.
•      Click Append to add information stored in a File Info file to the current file information.

See also: 

To enter information about a file 

File information sections 
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File information sections

The following list describes each of the sections in the File Info dialog box.

Caption

Provides headline text and special instructions for the image.

Note: To print the caption under an Adobe Photoshop image, choose File > Page Setup, and select 
Caption. Then print as usual. (See Printing for more information.)

Keywords

Provides a way for some image browsers to categorize and search for an image. Type in the text box, 
and click Add to see your text in the keyword list. To replace a keyword, select the word in the list, type
its replacement, and click Replace. To delete a keyword, select the word, and click Delete.

Categories

Enter an alphabetic category code of three characters. Where available, the local Associated Press 
regional registry maintains a list of categories. To include the image in supplemental categories, type 
the code and click Add. To replace a category, select the code, type its replacement, and click 
Replace. To delete a category, select the code, and click Delete. 

For Urgency, specify the editorial urgency of the image—not its handling priority. 

Credits

Provides the correct credit for a copyrighted image. Type byline, credit, and source information. 

Origin

Provides information on the history of the image. The Object Name field contains a short identification 
(for example, “Montgomery Street”). The date entry can be in any format. To enter the current date in a
short text format (for example, Oct. 25, 1998), click Today.

Copyright & URL
Provides copyright information not included as part of the IPTC specification. To display a copyright 
symbol in the image window’s title bar, select Mark as Copyrighted. Enter a copyright notice, and 
specify the URL if information about an image can be found on a Web site. If Photoshop detects a 
Digimarc watermark in the image, the Copyright & URL section is automatically updated.

See also: 

To enter information about a file 

To load, save, or append file information 
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Saving Adobe Photoshop files

Adobe Photoshop is the default file format for newly created images—and the only format supporting 
all available image modes (Bitmap, Grayscale, Duotone, Indexed Color, RGB, CMYK, Lab, and 
Multichannel), guides, alpha channels, spot channels, and layers (including adjustment layers, type 
layers, and layer effects).

If you’re exporting files to an application that doesn’t support the Adobe Photoshop format, use the 
Save a Copy command to save a duplicate file in a format supported by that application. 

Note: Only files that were created in Adobe Photoshop 5.0 support color samplers, editable type 
layers, layer effects, spot channels, embedded ICC profiles, and adjustment layers using the version 
5.0 Hue/Saturation or Channel Mixer type. If you edit or save a file using an earlier version of 
Photoshop, these features are discarded.

To save Adobe Photoshop 2.0 files (Macintosh only):

Choose the Photoshop 2.0 format to open a file in version 2.0 or to export to an application supporting 
only Photoshop 2.0 files. Saving in Photoshop 2.0 format flattens your file and discards layer 
information.
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Saving files in Photoshop EPS or DCS format

If you have a PostScript printer, you can use the Encapsulated PostScript (EPS) format to share 
Photoshop files effectively with many graphic, illustration, and page-layout programs. The Desktop 
Color Separations (DCS) format, a version of the standard EPS format, lets you save color 
separations of CMYK or multichannel files. You use the DCS 2.0 format to export images containing 
spot channels and single alpha channels.

To print EPS and DCS files, you must use a PostScript printer. For more information on the types of 
files supported by the EPS and DCS formats, see About file formats.

Note: If you plan to export an image to Adobe Illustrator or Adobe PageMaker for four-color process 
printing, convert the image to CMYK mode and save it in Photoshop EPS or TIFF format. Saving a 
CMYK file as TIFF lets you apply color management features to the placed image in Illustrator 7.0 or 
PageMaker 6.5.

To save a file in Photoshop EPS or DCS format:

1    Choose File > Save As or Save a Copy, and choose Photoshop EPS, Photoshop DCS 1.0, or 
Photoshop DCS 2.0 from the format list.

2    For Preview, choose a low-resolution preview type. To share an EPS file between Windows and 
Macintosh systems, use a TIFF preview. An 8-bit preview option results in better display quality but 
higher file size than does a 1-bit preview option. 

You must save a preview of an EPS image in order to view the image in the destination application.

Note: To use the JPEG preview option in Mac OS, you must have QuickTime installed. 

3    If you are saving to the DCS format, follow these guidelines when choosing a DCS option:
•      The DCS 1.0 format creates five files: one for each color channel in the CMYK image and a fifth 
master file corresponding to the composite channel. You can choose to include a 72-ppi grayscale or 
color version of the composite image in the master file. By printing the low-resolution composite from 
the destination application, you can proof the image. If you plan to print directly to film or want to 
reduce file size, choose No Composite PostScript. To view the composite file, you must keep all five 
files in the same folder location.
•      The DCS 2.0 format retains spot channels and a single alpha channel in the image. You can 
choose between saving color channel information as multiple files (as for DCS 1.0) or as a single file. 
The single-file option saves disk space. You can also include a 72-ppi grayscale or color composite 
with the image. 

4    Specify an encoding method when printing to a PostScript output device:
•      ASCII to use the most generic encoding method. Use ASCII encoding if you’re printing from a 
Windows system, or if you experience printing errors or other difficulties.
•      Binary to use a faster encoding method that produces a smaller output file and leaves the original 
data intact. Use Binary encoding if you’re printing from a Mac OS system. However, some page-layout
applications and some commercial print spooling and network printing software may not support 
binary Photoshop EPS files.
•      JPEG to use the fastest encoding method. JPEG encoding compresses the file by discarding 
some image data, thus reducing the quality of your printed output; for the best printed results, choose 
maximum quality compression. Files with JPEG encoding can be printed only on Level 2 (or later) 
PostScript printers and may not separate into individual plates.

5    Select Include Halftone Screen and Include Transfer Function to save the image’s halftone 
information (including the frequencies and angles of the screens) and transfer function information.

The PostScript language interpreter in some applications can use these screen settings when color 



separations are generated. You can also choose the Override Printer’s Default Functions option in the 
Transfer Functions dialog box. (See Compensating for dot gain in film using transfer functions.)

6    To display white areas in the image as transparent, select Transparent Whites. This option is 
available only for images in Bitmap mode. 

7    If you are printing to a PostScript printer, select PostScript Color Management to instruct the printer
to convert the file data to the printer’s color. Select this option only if you have not already converted 
the file to the printer’s color space.

Note: Only PostScript Level 3 printers support PostScript Color Management for CMYK images. To 
print a CMYK image using PostScript Color Management on a Level 2 printer, convert the image to 
Lab mode before saving in EPS format.
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Saving files in JPEG format

When saving in Joint Photographic Experts Group (JPEG) format, you can specify the image quality 
and compression level. To specify image quality and compression, enter a value between 0 and 10, or 
choose an option for Quality, or drag the slider. There’s always a trade-off between image quality and 
the amount of compression: higher-quality images use less compression (and more disk space) than 
lower-quality images.

You can also select a format option for the JPEG file. Select Baseline (“Standard”) to use a format 
recognizable to most Web browsers. The Baseline Optimized format optimizes the color quality of the 
image and can produce a slightly smaller file size, but is not supported by all Web browsers. The 
Progressive format causes the image to display gradually as it is downloaded—in a series of scans 
(you specify how many) showing increasingly detailed versions of the entire image. However, 
progressive JPEG images files are slightly larger in size, require more RAM for viewing, and are not 
supported by all applications and Web browsers.

Because the JPEG format discards data, it is important to save JPEG files only once. Edit and save 
your image in a format that does not discard data (such as the Photoshop format), and save in JPEG 
format only as a final step.

Note: Some applications may not be able to read a CMYK file saved in JPEG format. In addition, if 
you find that a Java application cannot read your JPEG file (in any color mode), try saving the file 
without a thumbnail preview.
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Adding digital copyright information

You can add copyright information to Photoshop images and notify users that an image is copyright-
protected via a digital watermark that uses Digimarc PictureMarc technology. The watermark—a digital
code added as noise to the image—is generally imperceptible to the human eye. The watermark is 
durable in both digital and printed forms, surviving typical image edits and file format conversions—
and is still detectable when the image is printed and then scanned back into a computer.

Embedding a digital watermark in an image lets viewers obtain complete contact information about the
creator of the image. This feature is particularly valuable to image creators who license their work to 
others. Copying an image with an embedded watermark also copies the watermark and any 
information associated with it.

For more detailed information on embedding Digimarc watermarks, refer to the Digimarc 
Watermarking Guide, downloadable for free from the Digimarc Web site at www.digimarc.com.

See also: 

Before adding a watermark 

Embedding digital watermarks 

Using the Watermark Durability setting 

Using the signal strength meter 
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Before adding a watermark

Keep in mind the following considerations before embedding a digital watermark in your image.

Color variation

The image must contain some degree of variation or randomness in color to embed the watermark 
effectively and imperceptively. The image cannot consist mostly or entirely of a single flat color. 

Pixel dimensions

The Digimarc technology requires a minimum number of pixels (but no maximum) to work. Digimarc 
recommends the following minimum pixel dimensions for the image to be watermarked:
•      100 pixels by 100 pixels if you don’t expect the image to be modified or compressed prior to its 
actual use. 
•      256 pixels by 256 pixels if you expect the image to be cropped, rotated, compressed, or otherwise 
modified after watermarking. 
•      750 pixels by 750 pixels, or 2.5 inches by 2.5 inches, if you expect the image to appear ultimately 
in printed form at 300 dpi or greater. 

There is no upper limit on pixel dimensions for watermarking.

File compression

In general, a Digimarc watermark will survive lossy compression methods such as JPEG, though it is 
advisable to favor image quality over file size (a JPEG compression setting of 4 or higher works best). 
In addition, the higher the Watermark Durability setting you choose when embedding the watermark 
(see “Using the Watermark Durability setting” later in this section), the better the chances that the 
watermark will survive compression. 

Workflow

Watermarking should be one of the very last tasks you perform, except for file compression. Use the 
following recommended workflow:
•      Make all necessary modifications to your image until it has the desired final appearance (this 
includes resizing, color correction, etc.).
•      Embed the watermark.
•      If needed, compress the image by saving it in JPEG or GIF format.
•      If the image is intended for printed output, perform the color separation.
•      Read the watermark and use the signal strength meter to verify that the image contains a 
watermark of sufficient strength for your purposes.
•      Publish the watermarked image.
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Embedding digital watermarks

To embed a watermark, you must first register with Digimarc Corporation—which maintains a 
database of artists, designers, and photographers and their contact information—to get a unique 
creator ID. You can then embed the creator ID in your images, along with information such as the 
copyright year or a restricted-use identifier. 

To embed a watermark:

1    Open the image that you want to watermark. You can embed only one watermark per image. The 
Embed Watermark filter won’t work on an image that has been previously marked. 

If you’re working with a layered image, you should flatten the image before marking it; otherwise, the 
watermark will affect the active layer only.

Note: You can add a watermark to an indexed-color image by first converting the image to RGB mode, 
embedding the watermark, and then converting the image back to indexed-color mode. However, the results may 
be inconsistent. To make sure that the watermark was embedded, run the Read Watermark filter (See Viewing 
copyright and file information).

2    Choose Filter > Digimarc > Embed Watermark. 

3    If you are using the filter for the first time, click the Personalize button. Get a Creator ID by clicking 
Register to launch your Web browser and visit the Digimarc Web site at www.digimarc.com, or by 
contacting Digimarc at the telephone number listed in the dialog box. Enter your PIN and ID number in
the Creator ID text box, and click OK.

(Once you have entered a Creator ID, the Personalize button becomes a Change button, allowing you 
to enter a new Creator ID.)

4    Enter a copyright year for the image.

5    Select any of the following image attributes:
•      Restricted Use to limit the use of the image.
•      Adult Content to label the image contents as suitable for adults only. (Within Photoshop, this option
does not limit access to adult-only images, but future versions of other applications may limit their 
display.)

6    For Target Output, specify whether the image is intended for monitor or print display.

7    For Watermark Durability, drag the slider or enter a value, as described in the next section.

8    Select Verify to automatically assess the watermark’s durability after it is embedded (See Using the
signal strength meter).

9    Click OK.
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Using the Watermark Durability setting

The default Watermark Durability setting is designed to strike a balance between watermark durability 
and visibility in most images. However, you can adjust the Watermark Durability setting yourself to suit
the needs of your images. Low values are less visible in an image, but less durable, and may be 
damaged by applying filters or by performing some image-editing operations, printing, and scanning 
operations. High values are more durable but may display some visible noise in the image.

Your setting should depend on the intended use of the image and on the goals you’ve set for your 
watermarks. For example, it may be quite acceptable to use a higher Watermark Durability setting with
JPEG images posted on a Web site. The higher durability helps to assure the persistence of the 
watermark, and the increased visibility often is not noticeable with medium-resolution JPEG images. 
Digimarc recommends experimenting with various settings as part of your testing process to 
determine which setting works best for the majority of your images.
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Using the signal strength meter

The signal strength meter helps you determine whether a watermark is durable enough to survive the 
intended use of the image. The signal strength meter is available only for images containing 
watermarks that you yourself have embedded.

Digimarc recommends that you check the signal strength meter before publishing your images. For 
example, if you often compress watermarked images for inclusion in a Web site, check the meter 
before posting the images. You can also use the signal strength meter to gauge the effectiveness of 
different Watermark Durability settings that you are experimenting with.

To check the signal strength meter:

Choose Filter > Digimarc > Read Watermark. The signal strength meter appears at the bottom of the 
dialog box. 

You can also display the meter automatically by selecting Verify while embedding the watermark (see 
Embedding digital watermarks).
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Exporting images 

Adobe Photoshop includes plug-in modules for creating Graphics Interchange Format (GIF) files for 
online display and exporting paths to Adobe Illustrator (see Exporting paths to Adobe Illustrator). 

See also: 

Using an export module 

Exporting RGB images to GIF 

Exporting indexed-color images to GIF 

JPEG or GIF? 
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Using an export module

The GIF89a Export module lets you convert an RGB or indexed-color image to GIF89a format and 
assign background transparency to the image. Background transparency lets you place a non-
rectangular foreground object on the colored background of a Web page. You can also save indexed-
color images as GIF files using the File > Save As command (see About file formats).
 For assistance with saving an image with transparency, choose Help > Export Transparent Image. This

interactive wizard helps you prepare images for export to the Web.

To use an export module:

Choose File > Export, and select an export format or method from the submenu.

See the following sections for a discussion of the GIF89a export module.
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Exporting RGB images to GIF

When you export an RGB image to GIF format, the export module creates a reduced color palette for 
the image. 

Note: To assign transparency to specific colors in the image, convert to indexed-color mode before 
exporting to GIF. See Exporting indexed-color images to GIF for more information.

To export an RGB image to GIF:

1    To create background transparency, select the foreground object of the image. Copy the selection 
onto a new, transparent layer. Be sure to hide any layers you don’t want included. (See Chapter 11, 
“Using Layers.”)

Original, and selection copied to transparent layer

2    Choose File > Export > GIF89a Export.

3    Select a background transparency preview:
•      To preview the background transparency as the gray background color used by most Web 
browsers, leave the Transparency Index Color box at the default color.
•      To preview the background transparency as a different color, click the Transparency Index Color 
box. Choose a color, as described in Using the Adobe Photoshop Color Picker, and click OK.

Note: The Transparency Index Color is used only to preview the background transparency, and does 
not affect the final appearance of the file.

Transparency previewed as default gray, and as blue

4    Specify a color palette:
•      For Palette, choose Exact to create a palette using the colors in the image. This option is visible 
(Windows) or not dimmed (Mac OS) only if the image contains 256 or fewer colors.
•      For Palette, choose Adaptive to create a palette using a representative sample of colors in the 
image. (This gives the best image quality if Exact is unavailable.) Then choose or enter the least 
number of colors that retains the necessary detail in your image.

The effect on file size of reducing the number of colors varies depending on dimensions and color 
content. For small-sized images, the effect on file size is insignificant.
•      For Palette, choose System to create a palette using the computer’s built-in color palette. Then 



select Use Best Match. The System palette option may produce unexpected results when the image is
displayed on an 8-bit monitor using a different built-in palette.
•      To use a custom palette, click Load, locate and select a custom palette, and click OK. Then select 
Use Best Match.

5    To view the color palette and see how the image will appear in the Web browser, click Preview. 

To navigate the preview, use the hand tool and zoom tool provided in the preview area. These tools 
have the same behavior and shortcuts as the hand and zoom tools in the toolbox (see Viewing 
images). Click OK to close the preview window.

6    If dissatisfied with the results, hold down Alt (Windows) or Option (Mac OS), and click Reset to 
restore the colors in the image. Repeat steps 4 and 5 as needed.

7    To display the image gradually in increasing detail as it is downloaded, select Interlaced. 

8    If the file contains a caption that you want to include as a comment in the GIF header, select Export
Caption. (See Adding file information.)

9    Click OK. Choose a location for the exported file, and click Save. 



Exporting images 

Exporting indexed-color images to GIF

When you export an indexed-color image to GIF, you can assign background transparency to areas in 
the image. All areas containing the colors you specify are recognized as transparency by Web 
browsers. 

For finer control, you may want to define background transparency using an alpha channel mask 
instead of assigning transparency to colored areas. For example, you may want to assign background 
transparency to only part of a colored area, keeping the other part visible on the Web page. See Using
Channels and Masks for more information on alpha channels.

Note: To reduce the number of colors in an indexed-color image, convert the image to RGB mode, 
and then export the image to GIF using the Exact palette option. 

To export an indexed-color image to GIF:

1    To define background transparency using a mask, select the area of the image you want to remain 
visible. Then click the Save Selection button ( ) at the bottom of the Channels palette to create an 
alpha channel based on your selection.

2    Choose File > Export > GIF89a Export.
3    If you created an alpha channel in step 1, choose the channel name for Transparency From. Hold 
down Alt (Windows) or Option (Mac OS) as you choose the channel name to reverse the mask contents. 
Skip to step 5.

4    If you did not create an alpha channel in step 1, assign transparency to desired colors in the image:

•      To add to the background transparency, click the eyedropper-plus tool ( ), and click the desired 
areas in the preview or the desired swatches. The selected colors appear highlighted in the swatches.

•      To remove a colored area from the background transparency, Alt-click (Windows) or Option-click (Mac
OS) the eyedropper-plus tool to toggle to the eyedropper-minus tool. Click the desired color swatch. 
•      To remove all areas from the background transparency, hold down Alt (Windows) or Option (Mac OS),
and click Reset.

•      To navigate the image preview, follow the guidelines described in step 5 of Exporting RGB images 
to GIF.
 To activate the eyedropper-minus tool while the eyedropper-plus tool is selected, press Ctrl (Windows) 

or Command (Mac OS). To activate the eyedropper-plus tool while the eyedropper-minus tool is selected, 
press Shift.

5    Do one of the following:
•      To preview the background transparency as the gray background color used by many Web 
browsers, leave the Transparency Index Color box at the default color.
•      To preview the background transparency as a different color, click the Transparency Index Color 
box. Specify a color, as described in Using the Adobe Photoshop Color Picker, and click OK.

Note: The Transparency Index Color is used only to preview the background transparency, and does 
not affect the final appearance of the file.

6    Specify Interlaced and Export Caption options, as described in steps 7 and 8 of “Exporting RGB 
images to GIF.” 

7    Click OK to export the file. Choose a location for the exported file, and click Save.



Exporting images 

JPEG or GIF?

For online display, such as on the World Wide Web, JPEG images give you the best continuous-tone 
color and the smallest file size. If your image contains line art or needs to have transparent areas, use 
the GIF89a Export command; GIF is also the preferred image format for use with Adobe PageMill. To 
keep file size to a minimum, choose Image > Mode > Indexed Color, and use the fewest number of 
colors that still give good results. For continuous-tone images, the Adaptive palette gives the best 
results
JPEG 
GIF, adaptive palette, diffusion dither 
GIF, adaptive palette, no dither 



Saving and Exporting Images 

About file formats

You can use various file formats to get images into and out of Adobe Photoshop. Graphic file formats 
differ in the way they represent graphic information— either as vector drawings or as bitmap images. 
Some formats contain only vector drawings or bitmap images, but many include both in the same file. 
See Getting Images into Photoshop for information on opening files and on vector and bitmap 
graphics; see the beginning of this chapter for information on saving files.

See also: 

About file compression 

BMP 

DCS 

Photoshop EPS 

EPS TIFF or EPS PICT Preview 

Filmstrip 

FlashPix 

GIF 

IFF 

JPEG format 

PCX 

PDF 

PICT File 

PICT Resource (Mac OS only) 

PIXAR 

PNG 

Raw 

Scitex CT 

Targa 

TIFF 



About file formats 

About file compression

Many image file formats use compression techniques to reduce the storage space required by bitmap 
image data. Compression techniques are distinguished by whether they remove detail and color from 
the image. Lossless techniques compress image data without removing detail; lossy techniques 
compress images by removing detail. The following are commonly used compression techniques:
•      Run Length Encoding (RLE) is a lossless compression technique supported by the Photoshop and
TIFF file formats and some common Windows file formats.
•      Lemple-Zif-Welch (LZW) is a lossless compression technique supported by TIFF, PDF, GIF, and 
PostScript language file formats. This technique is most useful in compressing images that contain 
large areas of single color, such as screenshots or simple paint images.
•      Joint Photographic Experts Group (JPEG) is a lossy compression technique supported by JPEG, 
PDF, and PostScript language file formats. JPEG compression provides the best results with 
continuous-tone images, such as photographs.
•      CCITT encoding is a family of lossless compression techniques for black-and-white images that is 
supported by the PDF and PostScript language file formats. (CCITT is an abbreviation for the French 
spelling of International Telegraph and Telekeyed Consultive Committee.)
•      ZIP encoding is a lossless compression technique supported by the PDF file format. Like LZW, ZIP
compression is most effective for images that contain large areas of single color.



About file formats 

BMP 

BMP is the standard Windows image format on DOS and Windows-compatible computers. The BMP 
format supports RGB, indexed-color, grayscale, and Bitmap color modes, and does not support alpha 
channels. You can specify either Microsoft® Windows or OS/2® format and a bit depth for the image. 
For 4-bit and 8-bit images using Windows format, you can also specify RLE compression. 



About file formats 

DCS

Desktop Color Separations (DCS), developed by Quark, is a version of the standard EPS format. The 
DCS 2.0 format supports multichannel and CMYK files with a single alpha channel and multiple spot 
channels; the DCS 1.0 format supports CMYK files without alpha channels. Both DCS 1.0 and DCS 
2.0 support clipping paths. (See Saving files in Photoshop EPS or DCS format.)



About file formats 

Photoshop EPS 

The Encapsulated PostScript (EPS) language file format can contain both vector and bitmap graphics 
and is supported by virtually all graphic, illustration, and page-layout programs. The EPS format is 
used to transfer PostScript language artwork between applications. When you open an EPS file 
containing vector graphics created in another application, Photoshop rasterizes the file, converting the 
vector graphics to pixels (see Importing Adobe Illustrator, PDF, and EPS files).

The EPS format supports Lab, CMYK, RGB, indexed-color, duotone, grayscale, and Bitmap color 
modes, and does not support alpha channels. EPS does support clipping paths. For more information 
on EPS options, see Saving files in Photoshop EPS or DCS format. 



About file formats 

EPS TIFF or EPS PICT Preview

These formats, which appear as options in the Open and Open As dialog boxes, let you open files 
saved in file formats that create previews but are not supported by Adobe Photoshop (such as 
QuarkXPress®). An opened preview file can be edited and used like any other low-resolution file. EPS
PICT Preview is available only in Mac OS.



About file formats 

Filmstrip

The Filmstrip format is used for RGB animation or movie files created by Adobe Premiere®. If you 
resize, resample, remove alpha channels, or change the color mode or file format of a Filmstrip file in 
Photoshop, you won’t be able to save it back to Filmstrip format. For further guidelines, see the Adobe 
Premiere User Guide.



About file formats 

FlashPix

The FlashPix format, developed by Kodak, is designed to speed the transfer and display of large, 
high-resolution files in applications that support the FlashPix technology. Although Photoshop is not a 
FlashPix-optimized application, it can open and save FlashPix files. The FlashPix format supports 
grayscale and RGB color modes, and does not support alpha channels.

When saving in FlashPix format, you can choose whether to use JPEG compression. See “JPEG” on 
JPEG format for information on JPEG compression options.



About file formats 

GIF 

The Graphics Interchange Format (GIF) is the file format commonly used to display indexed-color 
graphics and images in hypertext markup language (HTML) documents over the World Wide Web and
other online services. GIF is a LZW-compressed format designed to minimize file size and electronic 
transfer time. The GIF format does not support alpha channels.

You can convert files to GIF format using one of the following methods:
•      The File > Save As command lets you save a Bitmap-mode, grayscale, or indexed-color image in 
GIF format and specify an interlaced display. An interlaced image appears gradually in increasing 
detail as it is downloaded from the Web but can increase the file size. You cannot save alpha channels
with the image.
•      The GIF89a Export command lets you convert an RGB or indexed-color image to GIF89a format, 
specify interlacing, and define background transparency. (See Exporting images.) The GIF89a format 
supports single alpha channels.



About file formats 

IFF 

The Amiga™ Interchange File Format (IFF) is used for working with Video Toaster and transferring 
files to and from the Commodore Amiga system. In addition, this format is supported by a number of 
paint programs on IBM®-compatible computers. IFF is the best export format to use with DeluxePaint 
from Electronic Arts. The IFF format supports RGB, indexed-color, grayscale, and Bitmap color 
modes, and does not support alpha channels.



About file formats 

JPEG format

The Joint Photographic Experts Group (JPEG) format is commonly used to display photographs and 
other continuous-tone images in hypertext markup language (HTML) documents over the World Wide 
Web and other online services. The JPEG format supports CMYK, RGB, and grayscale color modes, 
and does not support alpha channels. Unlike the GIF format, JPEG retains all color information in an 
RGB image but compresses file size by selectively discarding data. 

A JPEG image is automatically decompressed when opened. A higher level of compression results in 
lower image quality, and a lower level of compression results in better image quality. In most cases, 
the Maximum quality option produces a result indistinguishable from the original. (See Saving files in 
JPEG format.)



About file formats 

PCX

The PCX format is commonly used by IBM PC-compatible computers. Most PC software supports 
version 5 of the PCX format. A standard VGA color palette is used with version 3 files, which do not 
support custom color palettes. 

The PCX format supports RGB, indexed-color, grayscale, and Bitmap color modes, and does not 
support alpha channels. PCX supports the RLE compression method. Images can have a bit depth of 
1, 4, 8, or 24.



About file formats 

PDF

Portable Document Format (PDF) is used by Adobe Acrobat, Adobe’s electronic publishing software 
for Windows, Mac OS, UNIX®, and DOS. You can view PDF files using the Acrobat Reader® software
included on the application CD-ROM. Identical to PostScript pages, PDF files can represent both 
vector and bitmap graphics, and can contain electronic document search and navigation features such
as electronic links. For more information on PDF and Adobe Acrobat, see the Electronic Publishing 
Guide included on the Tour & Training CD-ROM.

The Photoshop PDF format supports RGB, indexed-color, CMYK, grayscale, Bitmap, and Lab color 
modes, and does not support alpha channels. The format supports JPEG and ZIP compression, 
except for Bitmap-mode files, which use CCITT Group 4 compression when saved as Photoshop PDF.
When you open a PDF created by another application, Photoshop rasterizes the file (see Importing 
Adobe Illustrator, PDF, and EPS files).



About file formats 

PICT File

The PICT format is widely used among Macintosh graphics and page-layout applications as an 
intermediary file format for transferring files between applications. The PICT format supports RGB files
with a single alpha channel, and indexed-color, grayscale, and Bitmap files without alpha channels. 
The PICT format is especially effective at compressing images with large areas of solid color. This 
compression can be dramatic for alpha channels with their large areas of white and black. 

When saving an RGB image in PICT format, you can choose either a 16-bit or 32-bit pixel resolution. 
For a grayscale image, you can choose from 2, 4, or 8 bits per pixel. In Mac OS with QuickTime 
installed, four JPEG compression options are available.



About file formats 

PICT Resource (Mac OS only)

A PICT resource is a PICT file contained in a Mac OS file’s resource fork—for example, an 
applications’ splash screen or the contents of the Scrapbook. The PICT Resource format supports 
RGB files with a single alpha channel, and indexed-color, grayscale, and Bitmap files without alpha 
channels.

Open a PICT resource by choosing File > Import > PICT Resource. When saving a file as a PICT 
resource, you can specify the resource ID and resource name. As with other PICT files, you also 
specify bit depth and compression options. 



About file formats 

PIXAR 

The PIXAR format is designed specifically for exchanging files with PIXAR image computers. PIXAR 
workstations are designed for high-end graphics applications, such as those used for three-
dimensional images and animation. The PIXAR format supports RGB and grayscale files with a single 
alpha channel.



About file formats 

PNG

Developed as a patent-free alternative to GIF, the Portable Network Graphics (PNG) format is used for
losslessly compressing and displaying images on the World Wide Web. Unlike GIF, PNG supports 24-
bit images and produces background transparency without jagged edges; however, some older 
versions of Web browsers may not support PNG images. The PNG format supports grayscale and 
RGB color modes with a single alpha channel, and Bitmap and indexed-color modes without alpha 
channels. PNG uses the saved alpha channel to define transparency in the file; be sure to delete all 
but the desired alpha channel from your image before saving as PNG.

When saving in PNG format, you can select Adam7 to display the image in increasing detail as it is 
downloaded. You can also run the image through a filtering algorithm that prepares the image data for 
optimal compression:
•      None compresses the image without a filter, and is recommended for indexed-color and Bitmap-
mode images.
•      Sub optimizes the compression of images with even horizontal patterns or blends.
•      Up optimizes the compression of images with even vertical patterns.
•      Average optimizes the compression of low-level noise by averaging the color values of adjacent 
pixels.
•      Paeth optimizes the compression of low-level noise by reassigning adjacent color values.
•      Adaptive applies the filter—Sub, Up, Average, or Paeth—best-suited for the image. Select 
Adaptive if you are unsure of which filter to use.



About file formats 

Raw 

The Raw format is a flexible file format for transferring files between applications and computer 
platforms. This format supports CMYK, RGB, and grayscale files with alpha channels, and 
multichannel, Lab, indexed-color, and duotone files without alpha channels.

Raw format consists of a stream of bytes describing the color information in the file. Each pixel is 
described in binary format, with 0 equaling black and 255 white (for images with 16-bit channels, the 
white value is 65535). Adobe Photoshop designates the number of channels needed to describe the 
image, plus any additional channels in the file. You can specify the file extension (Windows), file type 
(Mac OS), file creator (MacOS), and header information.

In Mac OS, the file type is generally a four-character ID that identifies the file—for example, TEXT 
identifies the file as an ASCII text file. The file creator is also generally a four-character ID. Most 
Macintosh applications have a unique file creator ID that is registered with the Apple Computer 
Developer Services group. 

The header parameter specifies how many bytes of information appear in the file before actual image 
information begins. This value determines the number of zeroes inserted at the beginning of the file as
placeholders. By default, there is no header (header size = 0). You can enter a header when you open
the file in the Raw format. You can also save the file without a header and then use a file-editing 
program, such as HEdit (Windows) or Norton Utilities (MacOS), to replace the zeros with header 
information.

You can save the image in an interleaved or noninterleaved format. If you choose interleaved, the 
color values (red, green, and blue, for example) are stored sequentially. Your choice depends on 
requirements of the application that will open the file.



About file formats 

Scitex CT 

The Scitex Continuous Tone (CT) format is used for high-end image processing on Scitex computers. 
Contact Scitex to obtain utilities for transferring files saved in the Scitex CT format to a Scitex system. 
The Scitex CT format supports CMYK, RGB, and grayscale files, and does not support alpha 
channels.

CMYK images saved in Scitex CT format often have extremely large file sizes. These files are 
generated for input using a Scitex scanner. Files saved in Scitex CT format are printed to film using a 
Scitex rasterizing unit, which produces separations using a patented Scitex halftoning system. This 
system produces very few moiré patterns and is often demanded in professional color work—for 
example, ads in magazines.



About file formats 

Targa 

The TGA (Targa®) format is designed for systems using the Truevision video board and is commonly 
supported by MS-DOS color applications. The Targa format supports 32-bit RGB files with a single 
alpha channel, and indexed-color, grayscale, and 16-bit and 24-bit RGB files without alpha channels. 
When saving an RGB image in this format, you can choose a pixel depth. 



About file formats 

TIFF

The Tagged-Image File Format (TIFF) is used to exchange files between applications and computer 
platforms. TIFF is a flexible bitmap image format supported by virtually all paint, image-editing, and 
page-layout applications. Also, virtually all desktop scanners can produce TIFF images.

The TIFF format supports CMYK, RGB, and grayscale files with alpha channels, and Lab, indexed-
color, and Bitmap files without alpha channels. TIFF also supports LZW compression.

When you save an Adobe Photoshop image in TIFF, you can choose to save in a format that can be 
read either by IBM PC-compatible or Macintosh computers. To compress the file automatically, click 
the LZW Compression check box; compressing a TIFF file decreases its file size but increases the 
time required to open and save the file. Adobe Photoshop also reads and saves captions in TIFF files. 
For information on using captions, see Adding file information. 



Saving and Exporting Images 

Placing Photoshop images in other applications

Photoshop provides a number of features to help you use images in other applications. You can use 
clipping paths to define transparent areas in images you place in page-layout applications. In addition, 
Mac OS users can embed Photoshop images in many word-processor files.
 For assistance with clipping paths, choose Help > Export Transparent Image. This interactive wizard 

helps you prepare images with transparency for export to a page-layout application.

See also: 

Using clipping paths 

Printing clipping paths 

Exporting paths to Adobe Illustrator 

Object linking and embedding (OLE) (Windows 95 and Windows NT 4.0 only) 

Embedding Photoshop images in word-processor applications (Mac OS only) 



Placing Photoshop images in other applications 

Using clipping paths

When printing a Photoshop image or placing it in another application, you may want only part of the 
image to appear. For example, you may want to print or show a foreground object and exclude its 
rectangular background. A clipping path lets you isolate the foreground object and make everything 
outside the object transparent when the image is printed or placed in another application. Use the 
following methods to export and print files containing clipping paths:

Image imported into Illustrator without clipping path, and with clipping path

To save a path as a clipping path:

1    Draw and save a path or convert an existing selection into a path. See Selecting for information on 
creating selections and paths.

2    Choose Clipping Path from the Paths palette menu.

3    For Path, choose the path you want to save.

4    For good results with most images, leave the flatness value blank to print the image using the 
printer’s default value. If you experience printing errors, enter a new flatness value. 

Values can range from 0.2 to 100. In general, a flatness setting from 8 to 10 is recommended for high-
resolution printing (1200 dpi to 2400 dpi), a setting from 1 to 3 for low-resolution printing (300 dpi to 
600 dpi).

The PostScript interpreter creates curved segments by linking a series of straight line segments. The 
flatness setting for a clipping path determines how closely the straight line segments approximate the 
curve. The lower the flatness value, the greater is the number of straight lines used to draw the curve 
and the more accurate the curve. 

Flatness: 0.5 and 30

5    Click OK.

If you plan to print the file using process colors, convert the file to CMYK mode. (See Converting to 
CMYK.) 

6    Save the file:
•      To print the file using a PostScript printer, save in Photoshop EPS or DCS format as described in 
Saving files in Photoshop EPS or DCS format, and export to a page-layout application. 



•      To print the file using a non-PostScript printer, save in TIFF format and export to Adobe 
PageMaker 5.0 or higher.

Note: If you import an EPS or DCS file with a TIFF preview into applications such as Adobe Illustrator, 
the clipping path transparency will not display properly. This display affects the on-screen preview 
only; it does not affect the printing behavior of the clipping path on a PostScript printer.



Placing Photoshop images in other applications 

Printing clipping paths

Sometimes an imagesetter has difficulty interpreting clipping paths, or a printer finds the clipping path 
too complex to print, resulting in a Limitcheck error or a general PostScript error. Sometimes you can 
print a complex path on a low-resolution printer without difficulty but run into problems when printing 
the same path on a high-resolution printer. This is because the lower-resolution printer simplifies the 
path, using fewer line segments to describe curves than does the high-resolution printer. 

You can simplify a clipping path in the following ways:
•      By manually reducing the number of anchor points on the path (See Adding, deleting, and 
converting anchor points). 
•      By increasing the tolerance setting used to create the path (see the following procedure).

To simplify a clipping path with the tolerance setting:

1    Select the path in the Paths palette, and click the Make Selection button at the bottom of the 
palette to convert the path to a selection.

2    Click the Trash button at the bottom of the palette to delete the original path.

3    Choose Make Work Path from the Paths palette menu, and increase the tolerance setting (4 to 6 
pixels is a good starting point).

4    Name and save the work path. Then choose Clipping Path from the Paths palette menu.



Placing Photoshop images in other applications 

Exporting paths to Adobe Illustrator

The Paths to Illustrator command lets you export Photoshop paths as Adobe Illustrator files. This 
feature makes it easier to work with combined Photoshop and Illustrator artwork or to use Photoshop 
features on Illustrator artwork. For example, you may want to export a pen tool path and stroke it to 
use as a trap with a Photoshop clipping path you are printing in Illustrator. You can also use this 
feature to align Illustrator text or objects with Photoshop paths.

To use the Paths to Illustrator module:

1    In Adobe Photoshop, draw a path or convert an existing selection into a path; then save the path. 
(See Drawing freehand paths, Drawing with the pen tool, and Converting between paths and selection
borders.)

2    Choose File > Export > Paths to Illustrator. 

3    Choose a location for the exported path. In Mac OS, for Write, choose the path you want to export. 

4    Click Save.

5    Open the path in Adobe Illustrator as a new file. You can now manipulate the path or use the path 
to align Adobe Illustrator objects. 

Note that the crop marks in Adobe Illustrator reflect the dimensions of the Adobe Photoshop image. 
The position of the path within the Adobe Photoshop image is maintained, provided you don’t change 
the crop marks or move the path.

Path drawn in Photoshop, stroked with dashed line in Illustrator, and imported back to Photoshop



Placing Photoshop images in other applications 

Object linking and embedding (OLE) (Windows 95 and Windows NT 4.0 only)

Photoshop is an OLE 2.0 server, which means it supports embedding or linking an image in an OLE 
container application (usually a word-processor or page-layout program). For example, you can insert 
Adobe Photoshop files and selections into other OLE applications such as Adobe PageMaker 6.5 and 
Microsoft Word 7.0 using copy and paste or other methods.
•      Linking lets you place a link in the OLE container file that refers to the Photoshop file on the hard 
drive.
•      Embedding lets you insert the Photoshop file into the OLE container file.

Once in the container application, an image can be double-clicked for editing in Photoshop. When 
closed in Photoshop, the image is updated in the container application.

See also: 

To link or embed a selection or image in an OLE application 

To insert an unlinked screen-resolution bitmap into an OLE application 

To modify and update a linked or embedded image in an OLE application 



Object linking and embedding (OLE) (Windows 95 and Windows NT 4.0 only) 

To link or embed a selection or image in an OLE application:

Do one of the following:
•      Copy a selection in Photoshop, and insert it in your OLE container application using the 
application’s Paste Special command. Refer to your word-processing or page-layout application 
documentation for more instructions. Pasted selections can only be embedded, not linked.
•      Use your OLE container application’s Insert Object command to insert a new Photoshop image or 
existing Photoshop file as an OLE-embedded or OLE-linked object. Refer to your word-processing or 
page-layout application documentation for instructions.

See also: 

To insert an unlinked screen-resolution bitmap into an OLE application 

To modify and update a linked or embedded image in an OLE application 



Object linking and embedding (OLE) (Windows 95 and Windows NT 4.0 only) 

To insert an unlinked screen-resolution bitmap into an OLE application:

With the move tool ( ), use the left-mouse button to drag a selection to the OLE container 
application. When you drop the object, it appears as a 72-ppi bitmap, which cannot be automatically 
updated in Photoshop.

See also: 

To link or embed a selection or image in an OLE application 

To modify and update a linked or embedded image in an OLE application 



Object linking and embedding (OLE) (Windows 95 and Windows NT 4.0 only) 

To modify and update a linked or embedded image in an OLE application:

1    Double-click the linked or embedded image in your word-processor or page-layout application to 
launch Adobe Photoshop (if it is not already running), and open the image for editing.

2    Modify the image as desired.

3    Do one of the following:
•      For embedded images, close the file, or choose File > Update or File > Close & Return to 
<application name>.
•      For linked images, save and close the file.

Note: You can also modify linked files without first opening the container document. The linked image 
will be updated the next time you open the document in its OLE container application.

See also: 

To link or embed a selection or image in an OLE application 

To insert an unlinked screen-resolution bitmap into an OLE application 



Placing Photoshop images in other applications 

Embedding Photoshop images in word-processor applications (Mac OS only)

Adobe Photoshop supports the Edit Graphic Object (EGO) AppleEvent, which allows the embedding 
of Adobe Photoshop images in word-processor files. EGO is a simple solution when a word-processor 
file has many small images that need updating. 

Word-processor applications that work with EGO include Full Write Professional™, Nisus, MacWrite 
Pro®, WordPerfect®, and Claris® Works™.

To use the Edit Graphic Object (EGO) AppleEvent to update images in word-processor files:

1    Paste the Photoshop image into your word-processor file. 

2    Double-click the image in your word-processor application to launch Adobe Photoshop (if it is not 
already running), and open the image for editing. 

3    When you have finished making changes, close the Photoshop file to update the image in your 
word-processor application.



Printing

See also: 

Printing: an overview 

General printing options 

Selecting halftone screen attributes 

Additional printing options 

Converting the color space of images while printing 

Creating color traps 

Using monotones, duotones, tritones, and quadtones 

Printing color separations 



Printing 

Printing: an overview

In most instances, the default print settings in Adobe Photoshop produce good results. To ensure that 
your color images on-screen match your printed color images, it’s important to make sure that your 
system is correctly calibrated. Calibrating for variations in monitors, printing inks, and output devices is
described in Reproducing Color Accurately

Note: If you experience difficulties printing from Photoshop, export your image to a page-layout 
application, and print from that application.

The most common way to print images is to produce a positive or negative image on paper or film and
then to transfer the image to a printing plate to be run on a press. 

To print any type of image in Photoshop, you first select general printing options, including the halftone
screen, and then specify settings for a particular image type. For color separations, you can also 
adjust how the various plates are generated and create traps. You then print the image as one or 
several plates. When you print an image containing spot channels on a composite printer, the spot 
channels are printed as separate pages.

Important: Photoshop always prints images at the center of the page. To print an image at a different 
location on the page, export it to a page-layout program and reposition it there, or use the Canvas 
Size command to increase the canvas size and change the image’s placement (see Increasing the size 
of the work canvas).

By default, Adobe Photoshop prints a composite of all visible layers and channels. To print an 
individual layer or channel, make it the only visible layer or channel before choosing the Print 
command. (See Using Channels and Masks and Using Layers.)
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General printing options

Choose File > Page Setup to display general printing options. The exact appearance of this dialog box
varies with different printers, printer drivers, and operating systems. The main area of the dialog box 
contains the standard printing options for paper type, printer effects, reduction and enlargement, and 
orientation. See your printer documentation for more information on these options. 

Note: Labels, crop marks, calibration bars, and registration marks will only print if the paper size is larger than the
printed image dimensions.

A. Black overprint color bar    B. Label    C. Registration marks    D. Progressive color bar    E. Crop mark    F. 
Gradient tint bar    G. Star target

The Page Setup dialog box may include these options:

Orientation 

Prints the page using either the Landscape or Portrait setting. Because printing with the Portrait 
setting is much faster, you may want to rotate your landscape image 90 degrees by using the Rotate 
Canvas command, and then print using Portrait orientation. 

Properties or Options

Sets specific options for the printer you have selected. (The button name varies with different 
operating systems.) For more information on using the printing options, see your printer 
documentation.

Labels

Prints the filename and channel name on the image.

Crop Marks

Prints crop marks where the page is to be trimmed. You can print crop marks at the corners, at the 
center of each edge, or both.



Calibration Bars

Prints an 11-step grayscale, a transition in density from 0 to 100% in 10% increments. With a CMYK 
color separation, a gradient tint bar is printed on the left of each CMY plate, a progressive color bar on
the right.

Registration Marks

Prints registration marks on the image (including bull’s-eyes and star targets), used primarily for 
aligning color separations and duotones.

More general printing options

Negative

Prints an inverted version of the image. Unlike the Invert command in the Image menu, the Negative 
option converts the output, not the on-screen image, to a negative. If you print separations directly to 
film, you probably want a negative, although in many countries film positives are common. Check with 
your print shop to determine which is required. If printing to paper, print a positive. 

Emulsion Down

Makes type readable when the emulsion is down—that is, when the photosensitive layer on a piece of 
film or photographic paper is facing away from you. Normally, images printed on paper are printed with
emulsion up, with type readable when the photosensitive layer faces you. Images printed on film are 
often printed down.

To determine the emulsion side, examine the film under a bright light after it has been developed. The 
dull side is the emulsion; the shiny side is the base. Check whether your print shop requires film with 
positive emulsion up, negative emulsion up, positive emulsion down, or negative emulsion down.

Interpolation

Reduces the jagged appearance of a low-resolution image by automatically resampling up while 
printing. However, resampling may also reduce the sharpness of the image quality (see About 
resampling). Some PostScript Level 2 (or higher) printers have interpolation capability. If your printer 
doesn’t, this option has no effect.

Border

Lets you print a black border around an image, specifying its width in the unit of measurement you 
choose. 

Caption

Lets you print any caption text entered in the File Info dialog box. (See Adding file information.) 
Caption text always prints as 9-point Helvetica plain type. 

Background

Lets you select a background color to be printed on the page outside the image area. For example, a 
black or colored background may be desirable for slides printed to a film recorder. To use this option, 
click Background, and then select a color from the Color Picker dialog box. This is a printing option 
only and does not affect the image itself.

Bleed

Lets you print crop marks inside rather than outside the image. Use this when you want to trim the 
image within the graphic. You can specify the width of the bleed.

Transfer

Lets you adjust the transfer functions, traditionally used to compensate for dot gain or dot loss that 



may occur when an image is transferred to film. This option is recognized only when you print directly 
from Photoshop, or when you save the file as EPS and print to a PostScript printer. Generally, it’s best 
to adjust for dot gain using the settings in the CMYK Setup dialog box, but transfer functions also are 
useful for compensating for a poorly calibrated output device. (See Compensating for dot gain in film 
using transfer functions.)
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Selecting halftone screen attributes

Halftone screen attributes include the screen frequency and dot shape for each screen used in the 
printing process. For color separations, you must also specify an angle for each of the color screens. 
Setting the screens at different angles ensures that the dots placed by the four screens blend to look 
like continuous color and do not produce moiré patterns.

Before creating your halftone screens, check with your print shop for preferred frequency, angle, and 
dot settings. (Use the default angle settings unless your print shop specifies changes.) 

Note: Halftone screen attributes are recognized only when you print directly from Photoshop, or when 
you save the file as EPS and print to a PostScript printer.

See also: 

About halftones 
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About halftones

Halftone screens consist of dots that control how much ink is deposited at a specific location on-press.
Varying their size and density creates the illusion of variations of gray or continuous color. For a 
process color image, four halftone screens are used: cyan, magenta, yellow, and black—one for each 
ink used in the printing process.

Halftone screen with black ink

Halftone screens with process ink at different screen angles; correctly registered dots form rosettes

In traditional print production, a halftone is produced by placing a halftone screen between    a piece of 
film and the image and then exposing the film. In Photoshop, you specify the halftone screen attributes
just before producing the film or paper output. For best results, your output device (a PostScript 
imagesetter, for example) should be set to the correct density limit, and your processor should be 
properly calibrated. Otherwise results can be unpredictable. 

To define the screen attributes: 

1    In Mac OS, choose Adobe Photoshop 5.0 from the menu in the Page Setup dialog box.

2    Click Screens (Windows) or Screen (Mac OS). 

3    Choose whether to generate your own screen settings:
•      Deselect Use Printer’s Default Screens to choose your own screen settings.
•      Select Use Printer’s Default Screens to use the default halftone screen built into the printer. 
Photoshop then ignores the specifications in the Halftone Screens dialog box when it generates the 
halftone screens. 

4    For a grayscale halftone, enter a screen frequency from 1 to 999.999 for Frequency, and choose a 
unit of measurement. For Angle, enter a screen angle from –180 to +180 degrees.

5    For a color separation, choose from the following options:
•      To manually enter the screen frequency and angle, choose a color of the screen for Ink, and enter 
the frequency and angle; repeat for each color separation. 
•      To have Adobe Photoshop determine and enter the best frequencies and angles for each screen, 
click Auto. In the Auto Screens dialog box, enter the resolution of the output device and the screen 
frequency you intend to use; click OK. Photoshop enters the values in the Halftone Screens dialog 
box. Changing these values may result in moiré patterns.
•      If you are using a high-resolution output device equipped with PostScript Level 2 (or higher) or an 
Emerald controller, make sure that the Use Accurate Screens option is selected in the Auto Screens 



dialog box (or in the Halftone Screens dialog box if you’re entering the values manually). The Use 
Accurate Screen option lets the program access the correct angles and halftone screen frequencies 
for high-resolution output. If your output device is not equipped with PostScript Level 2 (or higher) or 
an Emerald controller, this option has no effect.

6    For Shape, choose the dot shape you want. If you want all four screens to have the same dot 
shape, select Use Same Shape For All Inks. 

Choosing Custom from the Shape menu displays the Custom Spot Function dialog box. You can 
define your own dot shapes by entering PostScript commands—useful for printing with nonstandard 
halftone algorithms. For information about using PostScript language commands, see the PostScript 
Language Reference Manual published by Addison-Wesley, or consult the imagesetter’s 
manufacturer.

For optimal output on a PostScript printer, the image resolution should be 1.5 to 2 times the halftone 
screen frequency. If the resolution is more than 2.5 times the screen frequency, an alert message 
appears (see About image size and resolution). If you are printing line art or printing to a non-
PostScript printer, see your printer documentation for the appropriate image resolutions to use.

7    To save your halftone screen settings for use with other Adobe Photoshop files, choose from the 
following options:
•      To save the settings, click Save in the Halftone Screens dialog box. Name and save the settings.
•      To save the new settings as the default, hold down Alt (Windows) or Option (Mac OS), and click 
the —> Default button. To return to the original default settings, hold down Alt/Option and click <—
Default. 

8    To load settings for use with another Photoshop file, click Load. Locate and select the settings.
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Additional printing options

You can also set printing options by using the Print dialog box, which appears when you choose File > 
Print (Windows), or when you choose File > Print and then choose Adobe Photoshop 5.0 from the 
dialog box menu (Mac OS). These options let you print only a selected area of an image, print multiple
separation files, and transfer image data to the output device in ASCII format. The appearance of this 
dialog box varies with different printers.

Printing a selected area

To print part of an image, use the rectangular marquee tool to select the part of an image you want to 
print. Then choose File > Print, and select the Print Selected Area option. 

Printing separations

By default, a single page is printed for CMYK and duotone images. For Space, choose Separations to 
print a separate page for each color.

Printing with print spoolers and across networks 

By default, the printer driver transfers binary information to printers. However, some print spooler 
programs, computer networks, and third-party printer drivers don’t support files that are binary or 
JPEG-encoded, and some PostScript output devices accept binary and JPEG-encoded image data 
only through their AppleTalk and Ethernet ports, not their parallel or serial ports. In addition, only 
PostScript Level 2 (or higher) output devices support JPEG encoding. Sending a JPEG-encoded file to
a Level 1 output device may result in PostScript language errors. 

In these situations, you can transfer the file by selecting ASCII in the Print dialog box. However, ASCII 
files contain about twice as many characters and require about twice as much time to transfer as 
binary files. 
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Converting the color space of images while printing

Photoshop has several color management features to help you print a composite image on a printer.

To convert the color space of an image while printing:

1    Choose File > Print. 

2    On the Macintosh, choose Adobe Photoshop 5.0 from the dialog box menu.

3    For Space, choose a color space profile:
•      Grayscale, RGB Color, CMYK Color, or Lab Color to have Photoshop convert the image to the 
specified color mode before the file data is sent to the printer. If you choose a profile other than the 
image’s current mode, Photoshop uses the conversion settings you specify in the Color Settings 
dialog boxes.
•      Any other option (except Separations) to match the file data to the color space of the specified 
profile or output device.

4    Select Printer Color Management to instruct the printer to convert the file data to the printer’s color 
space; for PostScript printers, the option changes to PostScript Color Management. Select this option 
only if you are printing to an RGB-based printer or if you have not already converted the file to the 
printer’s color space.

Only PostScript Level 3 printers support PostScript Color Management for images using CMYK color 
space. To print a CMYK image using PostScript Color Management on a Level 2 printer, go back to 
step 2 and choose Lab Color. 
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Creating color traps

After you have converted the image to CMYK, you can adjust the color trap. Trap is the overlap 
needed to ensure that a slight misalignment or movement of the plates while printing does not affect 
the final appearance of the print job. If any distinctly different colors in your image touch, you may 
need to overprint them slightly to prevent tiny gaps from appearing when the image is printed. This 
technique is known as trapping. In most cases, your print shop will determine if trapping is needed and
tell you what values to enter in the Trap dialog box.

Note: Trapping does not affect existing spot channels in the image.

Misregistration with no trap, and misregistration with trap

Keep in mind that trapping is intended to correct the misalignment of solid tints in CMYK images. In 
general, you should not create trap for continuous-tone images such as photographs. Excessive 
trapping may generate a keyline effect (or even cross-hair lines) in the C, M, and Y plates. These 
problems may not be visible in the composite channel and might show up only when you output to 
film. 

Trapping values determine how far overlapping colors are spread outward (not choked) to 
compensate for misregistration on the press. Adobe Photoshop uses standard rules for trapping: 
•      All colors spread under black. 
•      Lighter colors spread under darker colors.
•      Yellow spreads under cyan, magenta, and black.
•      Pure cyan and pure magenta spread under each other equally.

To create trap: 

1    Save a version of the file in RGB mode, in case you want to reconvert the image later. Then 
choose Image > Mode > CMYK Color to convert the image to CMYK mode. 

2    Choose Image > Trap.

3    For Width, enter the trapping value provided by your print shop. Then select a unit of 
measurement, and click OK. Consult your print shop to determine how much misregistration to expect.
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Using monotones, duotones, tritones, and quadtones

Photoshop lets you create monotones, duotones, tritones, and quadtones. Monotones are grayscale 
images printed with a single, nonblack ink. Duotones, tritones, and quadtones are grayscale images 
printed with two, three, and four inks. In these types of images, colored inks are used to reproduce 
tinted grays rather than different colors. 

This section uses the term duotone to refer to duotones, monotones, tritones, and quadtones.

See also: 

About duotones 

Specifying the duotone type and ink colors 

Modifying the duotone curve 

Specifying overprint colors 

Saving and loading duotone settings 

Viewing the individual printing plates 

Printing duotones 

Exporting duotone images to other applications 
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About duotones

Duotones are used to increase the tonal range of a grayscale image. Although a grayscale 
reproduction can display up to 256 levels of gray, a printing press can reproduce only about 50 levels 
of gray per ink. This means that a grayscale image printed with only black ink can look significantly 
coarser than the same image printed with two, three, or four inks, each individual ink reproducing up to
50 levels of gray. 

Sometimes duotones are printed using a black ink and a gray ink—the black for shadows and the gray
for midtones and highlights. More frequently, duotones are printed using a colored ink for the highlight 
color. This technique produces an image with a slight tint to it and significantly increases the image’s 
dynamic range. Duotones are ideal for two-color print jobs with a spot color (such as a PANTONE ink) 
used for accent. 

Because duotones use different color inks to reproduce different gray levels, they are treated in 
Photoshop as single-channel, 8-bit, grayscale images. In Duotone mode, you do not have direct 
access to the individual image channels (as in RGB, CMYK, and Lab modes). Instead, you manipulate
the channels through the curves in the Duotone Options dialog box.

To convert an image to duotone:

1    Convert the image to a grayscale image by choosing Image > Mode > Grayscale. Only 8-bit 
grayscale images can be converted to duotones. 

2    Choose Image > Mode > Duotone.

3    Select Preview to view the effects of the duotone settings on the image.

4    Specify the type of image, the ink colors, the duotone curves, and the overprint colors for the 
duotone image. These options are described in the following sections.

5    Click OK.
 To apply a duotone effect to only part of an image, convert the duotone image to Multichannel mode—

this converts the duotone curves to spot channels. You can then erase part of the spot channel for areas 
that you want printed as standard grayscale. (See Using spot channels.)
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Specifying the duotone type and ink colors

The duotone type—monotone, duotone, tritone, or quadtone—determines how many ink controls are 
active. 

To produce fully saturated colors, print darker inks before lighter inks. The order of inks in the duotone 
dialog boxes affects how Photoshop applies screens, so make sure that inks are specified in 
descending order—darkest at the top, lightest at the bottom. 

To specify the duotone type and its ink color:

1    In the Duotone Options dialog box, for Type specify monotone, duotone, tritone, or quadtone. 

2    Click the color box (the solid square) for an ink. 

3    Use the color picker or the Custom Colors dialog box to select the ink you want. When you close 
the dialog box, the ink color appears in the color box and the color name in the text box. (See Using 
the Adobe Photoshop Color Picker.)

4    If the ink is to be separated on a process color plate, name it “cyan,” “magenta,” “yellow,” or “black.”
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Modifying the duotone curve

A separate duotone curve specifies how each ink is distributed across the shadow and highlight areas 
of the image. This curve maps each grayscale value on the original image to the actual ink percentage
that will be used when the image is printed. A diagonal curve indicates equal values and even 
distribution of ink. 

To modify the duotone curve for a given ink:

1    To preview any adjustments, select the Preview option.

2    Click the curve box next to the ink color box.

The default duotone curve, a straight diagonal line across the grid, indicates that you are mapping the 
current grayscale value of every pixel to the same percentage value of the printing ink. At this setting, 
a 50% midtone pixel prints with a 50% dot of the ink, a 100% shadow with a 100% dot of the ink, and 
so on.

3    Adjust the duotone curve for each ink by dragging a point on the graph or by entering values for the
different ink percentages. 

The horizontal axis of the curve graph moves from highlights (at the left) to shadows (at the right). The
density of the ink increases as you move up the vertical axis. You can specify up to 13 points on the 
curve. When you specify two values along the curve, Adobe Photoshop calculates intermediate 
values. As you adjust the curve, values are automatically entered in the percentage text boxes.

The value you type in a text box indicates the percentage of the ink color that will be used to print that 
percentage of the image. For example, if you enter 70 in the 100% text box, a 70% dot of that ink color
will be used to print the 100% shadow areas of the image.

4    Click Save in the Duotone Curve dialog box to save curves created with this dialog box. 

5    Click Load to load these curves or curves created in the Curves dialog box (including curves 
created using the Arbitrary Map option). See Using the Curves command for more information on 
adjusting curves, and Saving and loading duotone settings.

You can use the Info palette to display ink percentages when you’re working with duotone images. Set
the readout mode to Actual Color to see the ink percentages that will be applied when the image is 
printed. These values reflect any changes you’ve entered in the Duotone Curve dialog box. (See 
Using the Options palette.)

Original image and default duotone curves



Adjusted image and adjusted duotone curves
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Specifying overprint colors

Overprint colors are two unscreened inks printed on top of each other. For example, when a cyan ink 
prints over a yellow ink, the resulting overprint is a green color. The order in which inks are printed, as 
well as variations in the inks and paper, can significantly affect the final results. 

To help you predict how colors will look when printed, use a printed sample of the overprinted inks to 
adjust your screen display. Just remember that this adjustment affects only how the overprint colors 
appear on-screen, not when printed. Before adjusting these colors, make sure that you have 
calibrated your system following the instructions in Reproducing Color Accurately 

To adjust the display of overprint colors:

1    Choose Image > Mode > Duotone.

2    Click Overprint Colors. The Overprint Colors dialog box displays the combinations that will result 
when the inks are printed.

3    Click the color swatch of the ink combination you want to adjust.

4    Select the color you want in the color picker, and click OK. 

5    Repeat steps 3 and 4 until the overprint inks appear as you want them. Then click OK. 
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Saving and loading duotone settings

Use the Save and Load buttons in the Duotone Options dialog box to save a set of duotone curves, 
ink settings, and overprint colors. You can then apply these settings to other grayscale images.

In addition, the Adobe Photoshop program includes several sample sets of duotone, tritone, and 
quadtone curves. These sets include some of the more commonly used curves and colors and are 
useful as starting points for creating your own combinations. 
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Viewing the individual printing plates

Because duotones are single-channel images, your adjustments to individual printing inks are 
displayed as part of the final composite image. In some cases, you may want to view the individual 
“printing plates” to see how the individual colors will separate when printed (as you can with CMYK 
images). 

To view the individual colors of a duotone image:

1    After specifying your ink colors, choose Image > Mode > Multichannel.

The image is converted to a multichannel image, with each channel represented as a spot-color 
channel that can be edited independently. The contents of each spot channel accurately reflect the 
duotone settings, but the on-screen composite preview may not be as accurate as the preview in 
Duotone mode.

Important: If you make any changes to the image in Multichannel mode, you will be unable to revert 
to the original duotone state. To adjust the distribution of ink and view its effect on the individual 
printing plates, make the adjustments in the Duotone Curves dialog box before converting to 
Multichannel mode. 

2    Select the channel you want to examine in the Channels palette. 

3    Choose Edit > Undo Multichannel to revert to Duotone mode.
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Printing duotones

When creating duotones, keep in mind that both the order in which the inks are printed and the screen
angles you use dramatically affect the final output. (See Specifying the duotone type and ink colors.)

Click the Auto button in the Halftone Screens dialog box to set the optimal screen angles and 
frequencies (see Selecting halftone screen attributes). Make sure that you select Use Accurate 
Screens in the Auto Screens dialog box if you’re printing to an imagesetter equipped with PostScript 
Level 2 (or higher) or an Emerald controller. 

Note: The recommended screen angles and frequencies for quadtones are based on the assumption 
that channel 1 is the darkest ink and channel 4 is the lightest ink. 

To print separations of a duotone image, choose File > Print. You do not have to convert duotone 
images to CMYK to create separations. Converting to CMYK mode converts any custom colors to their
CMYK equivalents. 
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Exporting duotone images to other applications

To prepare a duotone image for exporting to a page-layout application, save the image in EPS format. 
Keep in mind that it’s important to name custom colors so they’ll be recognized by the other 
application. Otherwise the image won’t print correctly—or might not print at all. 
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Printing color separations 

Once you’ve applied the spot color or colors you want to either a duotone or a CMYK image, you can 
print separations for color in the image. See Adding spot colors for more information.

If you are printing an image from another application and want to print spot channels to spot color 
plates, you must first save the file in DCS 2.0 format. DCS 2.0 preserves spot channels and is 
supported by applications such as Adobe PageMaker and QuarkXPress.

To print separations from Photoshop:

1    Choose File > Print.

2    On the Macintosh, choose Adobe Photoshop 5.0 from the dialog box menu.

3    For Space, choose Separations. 

4    Click OK. Separations are printed for each of the colors in the image. 

To prepare an image with spot channels for printing from another application:

1    In the General Preferences dialog box, select Short Pantone Names. (This step is not necessary if 
you are exporting to Adobe Illustrator 7.0 or Adobe PageMaker 6.5.)

2    If the image is a duotone, convert to Multichannel color mode.

3    Save the image in DCS 2.0 format. Be sure to deselect the Include Halftone Screen and the 
Include Transfer Function options.

(See Saving files in Photoshop EPS or DCS format.)

4    Open or import the image in the application you will be printing from and set your screen angles. 
Make sure that you’ve communicated to the printer the spot color you want for each of the color 
plates.
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See also: 
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Creating and recording actions 

Playing actions 

Editing actions 

Organizing sets of actions 

Using the Automate commands 

External automation 
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Using the Actions palette

Adobe Photoshop lets you automate tasks by grouping a series of commands into a single action. For 
example, you can create an action that applies a series of filters to reproduce a favorite effect or 
combine commands to prepare images for online publishing. Actions can be grouped into sets to help 
you better organize your actions. Using the example above, you could create a set of actions, where 
each action applied a different series of filters. You can use an action on a single file or on a batch 
(multiple files in the same folder).

You use the Actions palette to record, play, edit, and delete actions. It also lets you save, load, and 
replace action sets. 

To display the Actions palette:

Choose Window > Show Actions.

A. Toggles command on or off    B. Toggles modal  control on or off    C. Set    D. Action    E. Recorded command    
F. Stop Playing/Recording    G. Record    H. Play    I. New Set    J. New Action    K. Trash

You can display actions in the Actions palette in either list view or button view. In list view, sets can be 
expanded to display actions, which in turn can be expanded to display individual commands. 
Commands can then be expanded to display recorded values.

To display actions as buttons:

Choose Button Mode from the Actions palette menu. Choose Button Mode again to return to the list 
view.

To expand and collapse sets and commands:

Click the triangle to the left of the set or command in the Actions palette.
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Creating and recording actions

When you create an action, Photoshop records the commands (including any specified values) and 
tools you use, in the order you use them.

See also: 

Creating an action 

To create and record an action 

Recording paths 

Inserting nonrecordable commands 

Inserting stops 

Setting modal controls and excluding commands 
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Creating an action 

The following guidelines can help you in designing actions:
•      Most, but not all, commands can be recorded. However, you can allow for commands that cannot 
be recorded. (For more information, see Inserting nonrecordable commands.)
•      The gradient, marquee, crop, polygon, lasso, line, move, magic wand, paint bucket, and type tools,
and the Paths, Channels, Layers, and History palettes can be recorded.
•      Actions created in Photoshop 4 are compatible with this version of Photoshop, but not vice versa.
•      You can record the Play command listed on the Actions palette menu, and record the Batch 
command listed in the File > Automate menu to cause one action to play another.
•      Modal operations and tools, and any tools that record position use the units currently specified for 
the ruler. A modal operation or tool is one that requires you to press Enter or Return to apply its effect, 
such as the transformation commands or the crop tool. Tools that record position include the gradient, 
magic wand, lasso, marquee, and path tools.
•      When recording an action, keep in mind that playback results depend on such variables as the 
current background and foreground colors, and on file and program settings, such as the image color 
mode, resolution, and active layer. For example, a 3-pixel Gaussian blur won’t create the same effect 
on a 72-ppi file as on a 144-ppi file. Likewise, Color Balance won’t work on a grayscale file.
 Because Photoshop executes the commands as you record them, it’s a good idea to record a 

complicated action using a copy of a file, and then play the action on the original.
•      Until you specifically save a set of actions with the Save Actions command, actions are 
automatically saved in the file Actions Palette.psp (Windows) or Actions Palette (Mac OS) located in 
the Adobe Photoshop Settings folder within the Photoshop folder.

See also: 

Recording an action 
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Recording an action

Original when recording started

Diffuse Glow filter recorded

Texturize filter recorded



Creating and recording actions 

To create and record an action:

1    Open a file.

2    In the Actions palette, click a set or an item within a set.

3    In the Actions palette, click the New Action button ( ) or choose New Action from the pop-up 
menu on the palette.

4    Name the action, assign it to any combination of the Ctrl key (Windows) or Command key (Mac OS), 
the Shift key, and the Function keys (for example, Ctrl+Shift+F3), and choose a color for its display in the 
Actions palette.
5    Click Record. The Record button in the Actions palette turns red.

6    To guard against mistakes, record the Save a Copy command at the beginning of the action.
 As an option, if your action requires a file to be in a particular mode, choose File > Automate > 

Conditional Mode Change to change the mode of the image based on its original mode. 

7    Choose commands as you want them recorded. 

If the command you choose opens a dialog box, clicking OK records the command, clicking Cancel 
does not record it. If a chosen command is not recorded, it must be inserted in the action. See the 
section, “Inserting nonrecordable commands.”

Important: When recording the Save As or Save a Copy commands, do not enter a filename. If you 
enter a filename, Photoshop records the filename and uses that filename each time you run the action.
Before saving, however, if you go to a different folder, you can specify a different location without 
having to specify a filename.

8    Stop recording by clicking the Stop button.

9    If you want to keep the action for use in future work sessions, save the action (see Organizing sets 
of actions).



Creating and recording actions 

Recording paths

The Insert Path command lets you record a path as part of an action. When played back, the entire 
path is reproduced as part of the action.

To record a path:

1    Start recording an action.

2    Select a path.

3    Choose Insert Path from the Actions palette menu.



Creating and recording actions 

Inserting nonrecordable commands

The painting and toning tools, tool options, view commands, and preferences cannot be recorded. 
However, many commands that cannot be recorded can be inserted into an action using the Insert 
Menu Item command. 

An inserted command is not executed until the action is played. No values for the command are 
recorded in the action, so the file remains unchanged when the command is inserted. If the command 
has a dialog box, the dialog box appears during playback, and the action pauses until you click OK or 
Cancel. You can insert a command when recording an action or after it has been recorded.

Because you can assign a Ctrl key (Windows) or Command key (Mac OS), Function key, or Shift key 
combination to an action, the insert feature can re-create the functionality found in the Commands 
palette, which existed in earlier versions of Photoshop.

To insert a menu item in an action:

1    Choose where to insert the menu item:
•      Select an action’s name to insert the item at the end of the action.
•      Select a command to insert the item at the end of the command. 

2    Choose Insert Menu Item from the Actions palette menu.

3    Do one of the following:
•      Choose a command from its menu.
•      Enter a command in the Insert Menu Item dialog box, and click OK. If you don’t know the full name
of the command, enter part of it and click Find, then click OK.
•      To insert the Undo, Cut, Copy, Paste, or Clear command, enter its name. Choosing any of these 
commands from the menu applies the command to the action. 

4    Click OK.



Creating and recording actions 

Inserting stops

You may want to include a stop in your action so that you can perform a task that cannot be recorded 
(for example, using a painting tool). Once you’ve made the selection, you can then continue by 
clicking the Play button in the Actions palette. 

You can also display a short message when the action reaches the stop. For example, you can remind
yourself what you need to do before continuing with the action. A Continue button can be included in 
the message box. This way you can check for a certain condition in the file (for example, a selection) 
and continue if nothing needs to be done. You can insert a stop when recording an action or after it 
has been recorded.

To insert a stop:

1    Choose where to insert the stop:
•      Select an action’s name to insert the stop at the end of the action.
•      Select a command to insert the stop after the command. 

2    Choose Insert Stop from the Actions palette menu.

3    Type the message you want to appear. 

4    If you want the option to continue the action without stopping, select Allow Continue.

5    Click OK. 



Creating and recording actions 

Setting modal controls and excluding commands

After recording an action, you can insert a modal control. This lets you pause a command to display its
dialog box and specify different values, and to manipulate a modal tool to apply new settings. (A modal
tool requires pressing Enter or Return to apply its effect.)

If you do not use a modal control, Photoshop runs the command using the values specified when you 
first recorded the action (and the dialog box does not appear). 

You can also exclude commands that you don’t want to include as part of a recorded action or that you
don’t want to play when running the action.

To set a modal control:

1    Make sure that the Actions palette is in list view. If necessary, deselect Button mode in the Actions 
palette menu. 

2    Do one of the following:
•      Click the column to the left of the command name to display the dialog box icon. Click again to 
remove the modal control.
•      To turn on or disable modal controls for all commands in an action, click the column to the left of 
the action name.
•      To turn on or disable modal controls for all commands in an action or set, click the column to the 
left of the action or set name.

A. Action with a modal control    B. Modal control

To exclude or include a command:

Do one of the following: 
•      Click to clear the check mark to the left of the command name. Click again to include the 
command.
•      To exclude or include all commands in an action or set, click the checkbox to the left of the action 
or set name.

A. Action with excluded commands    B. Included command    C. Excluded command



Automating Tasks 

Playing actions

When you play an action, Photoshop executes the series of commands as you recorded them. But 
you can begin with any command, exclude commands, or play a single command in an action. If you 
have inserted a modal control in your action, you can specify values in a dialog box or reapply a modal
tool (any tool that requires you to press Enter or Return to apply it) when the action pauses. (See 
Setting modal controls and excluding commands.)

See also: 

Playing an action 

Slowing actions during playback 

Batch processing 



Playing actions 

Playing an action

In button view, clicking a button executes the entire action—though commands previously excluded 
are not executed. 

To play an action or set on a single file:

1    Open the file.

2    Specify what to play:
•      To play a set of actions, select the set name.
•      To play an entire action, select the action name.
•      To play only part of an action, select the command from which you want the action to start.

3    To exclude or include a command within an action from play, click the check box to the left of the 
action name. 

4    Click the Play button in the Actions palette or choose Play from the pop-up menu.

Note: Because an action is a series of commands, using the File > Undo command, you can undo 
only the last command in an action. However, you can undo an entire action by taking a snapshot in 
the History palette before you play an action, and then selecting the snapshot to undo the action.

To play a single command in an action:

1    Select the command you want to play.

2    Specify a speed:
•      Control-click (Windows) or Command-click (MacOS) the Play button in the Actions palette.
•      Hold down Control/Command, and double-click the command.
•      Choose Play from the Actions palette menu.

See also: 

Applying an action 



Playing an action 

Applying an action

Original

Action applied



Playing actions 

Slowing actions during playback

Sometimes a long, complicated action does not play properly, but it is difficult to tell where the problem
occurs. The Playback Options command gives you three speeds at which to play actions, so that you 
can watch each command as it is carried out.

To specify how fast actions should play:

1    Choose Playback Options from the pop-up menu.

2    Specify a speed:
•      Select Accelerated to play the action at normal speed (the default).
•      Select Step by Step to complete each command and redraw the image before going on to the next
command in the action.
•      Select Pause and enter the amount of time Photoshop should pause between carrying out each 
command in the action.

3    Click OK.



Playing actions 

Batch processing

The Batch command lets you play an action on a folder of files and subfolders. If you have a digital 
camera or a scanner with a document feeder, you can also import and process multiple images with a 
single action. Your scanner or digital camera may need an acquire plug-in module that supports 
actions. (If the third-party plug-in wasn’t written to import multiple documents at a time, it may not work
during batch-processing or if used as part of an action. Contact plug-in’s manufacturer for further 
information.)

When batch-processing files, you can leave all the files open, close and save the changes to the 
original files, or save modified versions of the files to a new location (leaving the originals unchanged).
If you are batch-processing a folder of files, copy all the desired files to the same level of a folder 
before starting the batch. If you are saving the processed files to a new location, you may want to 
create a new folder for the processed files before starting the batch.
 For better batch performance, reduce the number of saved history states and deselect the 

Automatically Create First Snapshot option in the History palette.

To batch-process files:

1    Choose File > Automate > Batch.

2    For Set, choose the desired set.

3    For Action, choose the desired action.

4    For Source, choose Folder to play an action on files (including subfolders) already stored on your 
computer. Click Choose to locate and select the folder.

5    To ensure that the files are opened from the specified folder, select Override Action “Open” 
Commands. Any Open commands that were recorded as part of the original action are ignored.

For information on using the Import option to batch-process imported files, see Getting Images into 
Photoshop. 

6    For Destination, choose an option:
•      None to leave the files open without saving changes (unless the action included a Save 
command).
•      Save and Close to save the files in their current location. 
•      Folder to save the altered files to another location. Click Choose to specify the destination folder.

If you chose Folder, select Override Action “Save In” Commands to ensure that the processed files are
saved to the specified destination folder and not to a location recorded with the Save As or Save a 
Copy commands.
 Saving files using the Batch command options always saves the files in the same format as the 

original files. To create a batch-process that saves files in a new format, record the Save As or Save a 
Copy command and then Close command as part of your original action. Then choose None for the 
Destination when setting up the batch process.

7    For Errors, choose an option:
•      Stop for Errors to suspend the batch process until you confirm the error message.
•      Log Errors to File to record each error in the file without stopping the batch process. If errors are 
logged to this file, a message appears after processing the files alerting you to review the error file. If 
you select this option, click Save As and name the error file. 
 To batch-process using multiple actions, create a new action and record the Batch command for each 

action you want to use. This technique also lets you process multiple folders in a single batch. To batch-
process multiple folders, create aliases within a folder to the other folders you want to process.
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Editing actions

You can edit actions in the following ways:
•      Rearrange actions, or rearrange commands within an action and their order of execution. 
•      Add commands to an action.
•      Record new commands or new values for actions with dialog boxes.
•      Change action options such as the action name, button color, and shortcut key. 
•      Duplicate actions and commands. This helps you experiment with changing an action without 
losing the original version, and for creating an action based on an existing one.
•      Delete actions and commands.
•      Reset the actions to the default list.

See also: 

To move an action to a different set 

To rearrange commands within an action 

To record additional commands 

To record an action again 

To record a single command again 

To change action options 

To duplicate a set, action, or command 

To delete a set, action, or command 

To delete all actions 

To reset actions to the default set 



Editing actions 

To move an action to a different set:

In the Actions palette, drag the action to a different set. When the highlighted line appears in the 
desired position, release the mouse button.

Dragging Sharpen command into different set



Editing actions 

To rearrange commands within an action:

In the Actions palette, drag the command to its new location within the same action. When the 
highlighted line appears in the desired position, release the mouse button.



Editing actions 

To record additional commands:

1    Do one of the following:
•      Select the action name to insert the new command at the end of the action.
•      Select a command in the action to insert the command after it.

2    Click the Record button on the Actions palette.

3    Record the additional commands.

4    Click the Stop button to stop recording.

Note: You can also insert nonrecordable commands (see Inserting nonrecordable commands), or drag
commands from other actions (see the procedure To duplicate a set, action, or command).



Editing actions 

To record an action again:

1    Select an action and choose Record Again from the Actions palette menu.

2    If a modal tool appears, do one of the following:
•      Use the tool differently and Press Enter (Windows) or Return (Mac OS) to change the tool’s effect.
•      Press Enter (Windows) or Return (Mac OS) to retain the same settings.

3    If a dialog box appears, do one of the following:
•      Change the values and click OK to record them.
•      Click Cancel to retain the same values. 



Editing actions 

To record a single command again:

1    In the Actions palette, double-click the command. 

2    Enter the new values, and click OK.



Editing actions 

To change action options:

1    Do one of the following:
•      Double-click the action name.
•      Select the action, and choose Action Options from the Actions palette menu.

2    If desired, type a new name for the action, choose a color for the action button, or assign a 
Function key, Shift-Function key, Ctrl-Function key (Windows) or Command-Function key (Mac OS), or
Ctrl-Shift-Function key (Windows) or Command-Shift Function key (Mac OS), to the action.

3    Click OK.



Editing actions 

To duplicate a set, action, or command:

Do one of the following:
•      Alt-drag (Windows) or Option-drag (Mac OS) the action or command to a new location in the 
Actions palette. When the highlighted line appears in the desired location, release the mouse button.
•      Select a single set, action, or command. You can Shift-click, Ctrl-click (Windows) or Option-click 
(Mac OS) to select multiple items. Then choose Duplicate from the Actions palette menu. The copied 
sets or actions appear at the bottom of the Actions palette. The copied commands appear after the 
original command.
•      Drag an action or command to the New Action button at the bottom of the Actions palette, or drag 
a set to the New Set button at the bottom of the Actions palette.The copied action appears at the 
bottom of the Actions palette. The copied command appears after the original command. The copied 
Set appears after the original set.



Editing actions 

To delete a set, action, or command:

1    In the Actions palette, select the set, action, or command you want to delete. You can Shift-click, 
Control-click (Windows) or Option-click (Mac OS) to select multiple commands within an action.

2    Do one of the following:
•      Click the Trash button on the Actions palette. Click OK to delete the action or command.
•      Drag the selection to the Trash button on the Actions palette.
•      Choose Delete from the Actions palette menu.



Editing actions 

To delete all actions:

Choose Clear Actions from the Actions palette menu. Click OK to delete all the actions.
 To delete a selected action or command automatically, Alt-click (Windows) or Option-click (Mac OS) 

the Trash button.



Editing actions 

To reset actions to the default set:

1    Choose Reset from the Actions palette menu.

2    Click Append to add the set of default actions to the current actions in the Actions palette, or OK to 
replace the current actions in the Actions palette with the default set.



Automating Tasks 

Organizing sets of actions

To help you organize your actions, you can create sets in which to place them and save the sets to 
disk. You can organize sets of actions for different types of work—for example, such as print 
publishing and online publishing—and transfer sets to other computers. You can save only the entire 
contents of the selected set in the Actions palette, not individual actions.

(Unsaved actions are automatically saved to a temporary file called Actions Palette.psp (Windows) or 
Actions Palette (Mac OS) in the Adobe Photoshop Settings folder within the Adobe Photoshop folder. If
this temporary file is lost or removed, any unsaved actions you may have created will be lost. Be sure 
to use the Save Actions command in the Actions palette to save your actions to a separate actions file 
so you can load them later, and to keep them safe.)

Replacing a saved set of actions replaces all existing actions. Loading a saved set adds to existing 
actions, with new ones appearing at the bottom of the Actions palette.

To create a new set of actions:

1    In the Actions palette, choose New Set from the pop-up menu.

2    Enter the name of the set, and click OK.

To rename a set of actions:

1    In the Actions palette, choose Set Options from the pop-up menu.

2    Enter the name of the set, and click OK.

To save a set of actions:

1    Select a set.

2    Choose Save Actions from the Actions palette menu.

3    Type a name for the set, choose a location, and click Save. By default, saved actions are saved in 
the file Default Actions in the Required folder within the Photoshop folder.

To replace a set of actions:

1    Choose Replace Actions from the Actions palette menu.

2    Locate and select the actions file.

3    Click Open.

To load a set of actions:

1    Choose Load Actions from the Actions palette menu.

2    Locate and select the actions file.

3    Click Open.
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Using the Automate commands

The Automate commands simplify complex tasks by combining them into one or more dialog boxes. 
Photoshop includes the following commands (third-party companies may provide additional 
commands as well):
•      Conditional Mode Change changes the color mode of a document to the mode you specify, based 
on the original mode of the document.
 By recording this command in an action, you can ensure that any actions that require an image to be 

in a specific color mode do not generate unwanted error messages.
•      Contact Sheet produces a series of thumbnail previews on a single sheet from the files in the 
selected folder.

Note: Make sure that the images are closed before applying this command.
•      Fit Image fits the current image to the width and height you specify, without changing its aspect 
ratio.

Note: This will resample the image, changing the amount of data in the image.
•      Multi-Page PDF to PSD converts each page of the PDF document you select to a separate 
Photoshop file.

To use an automated command:

Choose File > Automate, and then choose any of the commands listed under it.
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External automation

Photoshop supports some external automation using OLE Automation under Windows or AppleScript 
on the Macintosh. Using either of these methods lets you start Adobe Photoshop and execute actions 
externally.

Using external automation lets you perform such tasks as:
•      Having another scriptable application generate a series of files, and having Photoshop batch-
process them.
•      Having Photoshop batch-process files and save them to your Web site.
•      Writing a script that runs an action and then shuts down your computer late at night after you’ve 
gone home.

Additional information on OLE and AppleScript is available in the Technical Solutions database on the 
Adobe Web site. If you have further questions about OLE, contact Microsoft Corporation. For 
questions about AppleScript, see your Macintosh documentation or contact Apple Computer, Inc.



Improving Performance

A program’s “performance” is the amount of time that it takes the program to complete certain 
operations, such as opening a file, applying filter effects, or redrawing the screen after you edit an 
image. 

To a great extent, your computer processor speed and the amount of RAM you have available to 
Adobe Photoshop affect the program’s performance. Other factors that can dramatically affect the 
application’s performance are how you set up your software, virtual memory, and the size and 
complexity of your files.

See also: 

Using RAM, scratch disks, and system virtual memory 

Displaying file size and memory status 

Additional tips for improving performance with Windows 

Additional tips for improving performance in Mac OS 

Tips for working efficiently 



Improving Performance 

Using RAM, scratch disks, and system virtual memory

The best way to improve performance when using Adobe Photoshop is to increase the amount of 
random access memory (RAM) installed on your system. Testing at Adobe Systems has shown that 
increasing the amount of installed RAM tremendously improves the overall performance of Adobe 
Photoshop.

See also: 

Determining the amount of RAM required 

Determining the amount of scratch disk space required 

Assigning scratch disks 



Using RAM, scratch disks, and system virtual memory 

Determining the amount of RAM required

The amount of RAM that Photoshop requires for optimum performance depends on numerous factors,
including the pixel dimensions of your image (see Looking at the Work Area), its color mode (see 
Choosing a Color Mode), the number of layers in the file, (see Using Layers) as well as on the 
operations you’re performing. Copying part of an image or performing other operations in Photoshop 
may require 3 or more times the image size in RAM. 

The size of the file after it’s opened in Photoshop is what matters, not the approximated size of the 
unopened file as listed in the Windows Explorer or Mac OS Finder. For example, because many file 
formats utilize compression, files often open up many times larger than their compressed size.

Therefore, it’s a good idea to give Photoshop at least 3 to 5 times your file size in RAM, plus about 5 
to 10 MB. If you’re using many layers and channels, Photoshop will need even more RAM. 

Note: Bitmap mode files may require over 10 times the image size in RAM and scratch space.

The RAM available to Photoshop is determined in the following ways:
•      In Windows, Photoshop’s default setting allocates 60% of available RAM (i.e., RAM not being used
by the operating system or anything else) for its own use (50% of total physical RAM on Windows NT 
4). You can change this amount in the Memory & Image Cache Preferences dialog box (choose File > 
Preferences > Memory & Image Cache).

Note: In Windows NT, a RAM setting of 60% or lower may improve performance. To achieve optimal 
performance, experiment with different RAM settings.
•      In Mac OS, Photoshop’s default setting is listed in the Info dialog box. If you have more RAM 
available, you can increase the amount of RAM allocated to Photoshop in the Finder. For information 
on viewing the Info dialog box and increasing RAM, see Increase the application memory size.



Using RAM, scratch disks, and system virtual memory 

Determining the amount of scratch disk space required

When your system does not have enough RAM to perform an operation, Adobe Photoshop uses a 
proprietary virtual memory technology, also called the scratch disks. Virtual memory is disk space 
used for storing data during a work session when the amount of RAM is insufficient. (This scratch disk 
space is not a Windows swap file or Mac OS virtual memory, but is used only when working in 
Photoshop.)

Photoshop’s virtual memory technology lets you open and manipulate large images by swapping 
image data to a hard drive if there is not enough RAM to contain the data. Keep in mind, however, that
copying data to and from the scratch disks requires significantly more time than processing data in 
RAM. Allocating enough RAM to Photoshop to minimize using the scratch disks will keep Photoshop 
operating at peak performance.

The amount of free space on the scratch disk must be greater than or equal to the amount of RAM you
have allocated to Photoshop. To ensure good performance, Photoshop writes the entire RAM contents
to the scratch disks during idle times. If the scratch disks run out of free space, Photoshop quits taking
additional RAM—regardless of what you have allocated to the program. This means that if you’ve 
allocated 60 MB to Photoshop but you have only 10 MB of free space on your scratch disk, Photoshop
will use only 10 MB of RAM.



Using RAM, scratch disks, and system virtual memory 

Assigning scratch disks

By default, Photoshop uses the hard drive that the operating system is installed on as its primary 
scratch disk. You can change the primary scratch disk or designate a second, third, or fourth scratch 
disk, to be used when the primary disk is full. Your primary scratch disk should be your fastest hard 
disk, and should have plenty of defragmented space available. 

The following guidelines can help you assign scratch disks:
•      You can use up to four scratch disks of any size your file system supports. Photoshop lets you 
create up to 200 GB of scratch disk space using those scratch disks.
•      For best performance, scratch disks should be on a different disk than any large files you are 
editing.
•      Scratch disks should be on a different disk than the one used for virtual memory.
•      Scratch disks should be local. That is, they should not be accessed over a network.
•      Scratch disks should be conventional (non-removable) media.
•      Raid disks/disk arrays are good choices for dedicated scratch disk volumes.
•      Scratch disks should be defragmented regularly.

To change the scratch disk assignment:

1    Choose File > Preferences > Plug-Ins & Scratch Disks.

2    Select the desired disks from the menu (you can assign up to four scratch disks).

3    Click OK.

Important: The scratch disk file that is created by Photoshop must be in contiguous hard disk space. 
For this reason you should frequently optimize your hard disk. Adobe recommends that you use a disk
tool utility, such as Windows Disk Defragmenter or Norton Speed Disk, to defragment your hard drive 
on a regular basis. See your Windows or Mac OS documentation for information on defragmentation 
utilities.
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Displaying file size and memory status

The display in the lower left of the window lets you view different information related to disk space and 
memory. It’s important to note that the amount of data in an image and the amount of RAM the image 
is using may be very different values.

To display file size and memory status:

1    Move the pointer to the arrow in the lower left of the window, and hold down the mouse button.

2    Choose from the following options:
•      Document Sizes to display information on the amount of data in the image. (See the following 
section for more information.)
•      Scratch Sizes to display information on the amount of RAM used to process the image. See 
Scratch sizes for more information.
•      Efficiency to display an approximation of the percentage of Photoshop operations being performed
using RAM (as compared to using scratch disk space). An Efficiency display below 100% indicates 
that Photoshop is using the scratch disk and so is operating more slowly than if only RAM were being 
used. See Determining the amount of scratch disk space required for information on the scratch disk.
•      Timing to display the amount of time it took to complete the last operation. 
•      Current tool to display the name of the current tool.

Note: A copyright symbol (©) appears in the status area if the Mark As Copyrighted option is selected 
in the File Info dialog box.

See also: 

Document sizes 

Scratch sizes 



Displaying file size and memory status 

Document sizes 

When you display Document Sizes, the number on the left represents the flattened size of the image. 
The amount of data that will be sent to a printer if you print the file depends on whether the file is sent 
in binary or ASCII. A binary file will generally be the size listed on the left, and an ASCII file may be as 
much as three to five times larger. Other factors—such as your preview options, paths, File Info, and 
the type of disk you have—can add to the size of the file on disk. On the other hand, if you save in a 
compressed format, such as JPEG, the printing size displayed here may be significantly larger than 
the file size on disk.

A. Amount of data in the flattened image    B. Amount of data including layers.

The number on the right indicates the saved file’s approximate size in its layered format including 
alpha channels, but not including any flattened version of the file. This number is usually greater than 
the file size on disk because Photoshop is able to compress certain data, such as alpha channels, 
when it saves the file to disk. The larger the image, the greater the difference between this number 
and the saved file size. For more information on how layers affect file size, see Managing layered 
images.

Important: If the Include Composited Image with Layered Files option is turned off in the Saving Files 
Preferences dialog box (it’s on by default), the saved file size will be significantly smaller with layered 
files because the option saves a flattened version of the file with the layered file.However, to place a 
PSD (Photoshop Document) image into Adobe Illustrator, you must save the file with this option on or 
save it in another format, such as TIFF or JPEG.



Displaying file size and memory status 

Scratch sizes

When you display scratch sizes, the number on the left represents the amount of memory that is 
currently being used by the program to display all open images, including channels, layers, items in 
the History palette, the current Undo, saved patterns and snapshots as well as any information on the 
Clipboard.

A. Memory required for all open images, Clipboard, Undo, Pattern, Snapshot, and Histories. Asterisk (*) indicates 
asynchronous I/O is enabled and functioning (Mac OS only).    B. Total RAM available to Photoshop

The number on the right represents the total amount of RAM allocated to Photoshop for processing 
images. This number is equal to the amount of memory available to Photoshop minus the amount that 
Photoshop needs to run. See Determining the amount of RAM required for more information.

With Scratch Sizes, when the number on the left is greater than the number on the right, Photoshop is 
using the scratch disk in addition to RAM. At this point, you’ll probably notice a dramatic decline in 
Photoshop’s performance because Photoshop must read and write files to the scratch disk. See 
Determining the amount of scratch disk space required for more information.



Improving Performance 

Additional tips for improving performance with Windows

The first time you launch Adobe Photoshop, the program automatically checks the amount of RAM 
and warns you if you need to change the virtual memory allocation. By default, Adobe Photoshop 
allocates 60% of all available RAM (that is, RAM not being used by the operating system, other 
applications, or by disk-caching software) for its own use.

If more memory is needed to run other applications at the same time as Photoshop, you can lower the 
percentage of RAM allocated to Adobe Photoshop in the Memory & Image Cache Preferences dialog 
box. Adjusting the RAM percentage may degrade the program’s performance, but it may make it 
easier to run other applications with Adobe Photoshop.

See also: 

Decrease Photoshop’s virtual memory allocation 

Don’t automatically run applications 

Turn off software that “increases” RAM or disk drive space 

Set the Paging file and the scratch disk to different hard drives (Windows NT Only) 



Additional tips for improving performance with Windows 

Decrease Photoshop’s virtual memory allocation

Although you can’t improve the performance of Photoshop operations by decreasing the Windows 
virtual memory allocation, adequate virtual memory lets Windows swap Photoshop out of RAM when 
launching other applications, performing other Windows operations, or printing.



Additional tips for improving performance with Windows 

Don’t automatically run applications

Applications can be set to run automatically when Windows runs. All of these applications use RAM, 
and can degrade Photoshop’s performance.

To prevent applications from automatically running:

1    Using Windows Explorer, go to Windows/Start Menu/Programs/Startup.

Note: In Windows NT 4, use the Windows Explorer and go to WinNT4/Profiles/<UserName>/Start 
Menu/Programs/Startup.

2    Drag all of the listed files or icons—except NewGammaWinLoad.exe—from the right side of 
Windows Explorer (listed under Contents of “Startup”) to the desktop or to another folder on the disk 
drive.

Important: NewGammaWinLoad.exe contains your monitor calibration settings. Moving this file will 
prevent Photoshop from loading the settings and your monitor will be uncalibrated.

3    Restart Windows.



Additional tips for improving performance with Windows 

Turn off software that “increases” RAM or disk drive space

Software that “doubles” existing RAM or uses compression methods to increase disk drive space can 
degrade Photoshop’s performance if you assign more memory to Photoshop than you have installed 
as available, real RAM. Turn off these types of programs.



Additional tips for improving performance with Windows 

Set the Paging file and the scratch disk to different hard drives (Windows NT 
Only)

On Windows NT machines, it is best to set the Paging file (called the swap file in Windows 95) and the
scratch disks to different physical hard drives. Otherwise, performance can be seriously degraded. 
The “Initial Size” of the Paging file should be 12 MB larger than the amount of physical RAM on you 
computer. The “Maximum Size” should be twice the amount of physical RAM.



Improving Performance 

Additional tips for improving performance in Mac OS

You can optimize Adobe Photoshop’s performance in Mac OS by changing a variety of system 
settings.

See also: 

Increase the application memory size 

Turn off unnecessary applications 

Disabling virtual memory in Mac OS 

Turn on the Modern Memory Manager in the Memory control panel 

Decrease the disk cache setting 

Turn off system extensions and control panels 



Additional tips for improving performance in Mac OS 

Increase the application memory size

If your computer has more RAM than Photoshop’s default RAM allocation, you can significantly 
improve Photoshop’s performance by increasing the application memory size. See Determining the 
amount of RAM required for more information.

To change the application memory size:

1    Quit Adobe Photoshop if it is running.

2    Start all applications—except Adobe Photoshop—that you must use at the same time as Adobe 
Photoshop. Keep in mind, however, that running other applications with Photoshop uses RAM that 
could be allocated to Photoshop.

3    Return to the Finder. Choose About This Computer from the Apple menu. 

4    Note the Largest Unused Block value. (You will use this result in step 5.) This value shows the 
amount of memory currently available. 

5    In the Finder, select the Adobe Photoshop program icon (not the folder or the alias icon), and 
choose File > Get Info. 

6    In the Adobe Photoshop Info window, set the Preferred Size option to no more than 90% of the 
Largest Unused Block value you noted in step 3. 

7    Close the Adobe Photoshop Info window. 



Additional tips for improving performance in Mac OS 

Turn off unnecessary applications

Many of the options to increase Photoshop’s performance involve making more memory available to 
Photoshop. One way to free up memory for Photoshop is to turn off other applications where possible.

To turn off unnecessary applications:

1    Quit all applications that you don’t need to run.

2    Remove any unnecessary programs or aliases from the Startup folder in the System folder.

Note: You may want to leave Kodak Precision Startup to continue using it with Photoshop.



Additional tips for improving performance in Mac OS 

Disabling virtual memory in Mac OS

In addition to Photoshop’s virtual memory, both Windows and Apple System software 7.0 and later use
their own virtual memory technologies. These swap active application programs to a hard disk when 
there is not enough RAM to hold them all simultaneously. Although this is not a problem in Windows or
in Mac OS 8.1 and later, using the system virtual memory in earlier versions of Mac OS will not speed 
up operations in Photoshop. In fact, it will take needed scratch disk space from Photoshop and 
seriously degrade performance. Use the following guidelines for setting up system virtual memory: 

Unless you don’t have enough memory to run Photoshop otherwise, Adobe strongly recommends that 
you turn off virtual memory in System 7 through 8 for much better performance with Photoshop. (For 
instructions on using the Memory control panel, see your Mac OS documentation.)



Additional tips for improving performance in Mac OS 

Turn on the Modern Memory Manager in the Memory control panel

Adobe Photoshop is designed to use the Modern Memory Manager in System 7.5.1 and later. This 
capability enables applications to use more than 8 MB of RAM, thus allowing a larger portion of a file 
to be stored in RAM instead of on a comparatively slower hard disk. 

Only if RAM is so limited that Photoshop cannot run, it may be useful to turn on virtual memory to 
prevent RAM from being used up by the application code. Set the virtual memory to 1 MB more than 
physical memory.

If RAM is not this limited, Adobe strongly recommends that you turn off virtual memory in System 7 or 
later as described in Disabling virtual memory in Mac OS.



Additional tips for improving performance in Mac OS 

Decrease the disk cache setting

Some other applications and the operating system use a portion of RAM set aside as the disk cache to
speed up operations and quickly recall frequently accessed information. Photoshop does not use this 
system-level disk cache. Although allocating memory to the disk cache will not adversely effect 
Photoshop's performance, Photoshop gets no benefit from it, and any RAM that is dedicated to the 
disk cache will be unavailable to Photoshop. If you have a large amount of RAM, the disk cache will 
probably be insignificant, but if you have limited memory, you should lower the amount of disk cache, 
so more RAM is available for Photoshop.

To set the disk cache size:

1    Choose Control Panels > Memory from the Apple menu.

2    If necessary, click the arrow keys to change the disk cache size to no higher than 128K on 
operating systems earlier than OS 8, and to about 1/16 of the total RAM on OS 8 and later.

3    Close the Memory control panel.

4    Restart your Mac OS machine.



Additional tips for improving performance in Mac OS 

Turn off system extensions and control panels

Like any application running at the same time as Photoshop, system extensions and control panels 
use RAM that could be allocated to Photoshop. If you are running Photoshop with limited RAM and 
are using System 7.5 or later, use Extensions Manager to turn off as many extensions and control 
panels as possible. See your Mac OS documentation for instructions.



Improving Performance 

Tips for working efficiently

In addition to the amount of RAM and your system configuration, the single most important factor 
affecting performance is the size of your files. File size is determined chiefly by the pixel dimensions of
an image, and its color mode (see About image size and resolution and Color modes and models). In 
addition, the number of layers and channels in an image can significantly increase file size. 

See also: 

Minimize file size 

Clear data from RAM 

Turn off palette previews 

Turn off file previews 

Use shortcuts 

Save selections in channels 

Make complex selections in Grayscale mode 

Apply a filter to an individual channel 

Work in two windows 

Work on low-resolution copies of files 

Reduce the number of history states 

Turn off automatic snapshots 

Adjust the image cache setting 



Tips for working efficiently 

Minimize file size

The most important factor in determining file size is the pixel dimensions of the image. If you are 
preparing your image for printed output, make sure that the print resolution and dimensions are the 
size you need for your final file. For example, for users printing a color or grayscale image to a 
PostScript printer, the recommended image resolution is 1.5 to 2 times the screen frequency (not the 
pixel output resolution) you will use to print the image. 

Because this varies depending on your output device and halftoning options, see your print bureau or 
the documentation that came with your printer or printer driver for specific image resolution guidelines.
See About image size and resolution for more information. 

If you are preparing images for color separation, it’s also a good idea to work in RGB mode until you 
are ready to print the images. RGB images are approximately 75% the size of CMYK images. (For 
more information, see Converting images from one mode to another.)

Also, merge layers and delete channels as you no longer need them. Layers, channels, and masks 
can add significantly to the size of the file.



Tips for working efficiently 

Clear data from RAM

The images and selections you cut or copy to the Clipboard or that you define as patterns or 
snapshots are stored in RAM. Keeping large amounts of data in RAM can significantly degrade Adobe 
Photoshop’s performance. 

To clear cut and copied data from RAM:

Choose Edit > Purge and then choose an option from the submenu:
•      Undo to remove from RAM a copy of the image before the last-performed operation.
•      Clipboard to remove from RAM any data copied or cut from an image. 
•      Pattern to remove from RAM any defined patterns.

Note: To avoid filling the Clipboard with data, use the program’s drag-and-drop capability to drag 
elements (images, selections, channels, layers, and paths) from one file to another or from the Layers,
Channels, or Paths palette to another file.
•      Histories to delete all saved history information from all open documents. (You can also choose 
Clear History from the History palette menu to clear the history for the current document.)
•      All to purge all of the items listed in the Purge menu.



Tips for working efficiently 

Turn off palette previews

The preview thumbnails on the Layers, Channels, and Paths palettes can be turned off for a slight 
performance improvement. If you need to use thumbnails, choosing smaller ones can help as well.

To turn off or use smaller previews:

1    Choose Palette Options from the Layers, Channels, or Paths palette menu.

2    Select None or a smaller preview from the Thumbnail Size options.



Tips for working efficiently 

Turn off file previews

The preview thumbnails displayed in the Open dialog box can be turned off to decrease the size of the
file.

To turn off file previews:

1    Choose File > Preferences > Saving Files.

2    For Image Previews, select Never Save or Ask When Saving.



Tips for working efficiently 

Use shortcuts

Learn to use the command shortcuts that appear to the right of the commands in the menus. These 
are especially useful for operations that you perform frequently, such as displaying a specific 
command’s dialog box or adjusting color levels. You can also select frequently used commands or 
sets of commands or show and hide palettes by clicking buttons in the Actions palette. Buttons can 
easily be added to the button display of the Actions palette.



Tips for working efficiently 

Save selections in channels

Get into the habit of saving complex selections in channels until you have finished editing a file. You 
can then easily load the selections without reselecting. 



Tips for working efficiently 

Make complex selections in Grayscale mode

Making complex selections in Grayscale mode can save processing time, because grayscale images 
are about one-third the size of RGB images. Save the selection in a channel, and then copy the 
channel by dragging it from the Channels palette to the open color document. Note that if you increase
the contrast of a grayscale image, it’s easier to select shapes of different colors. When you’re working 
with selections in Bitmap mode, it’s even faster to save a complex selection as a path.



Tips for working efficiently 

Apply a filter to an individual channel

Some Photoshop filters, such as the Distort filters, work only in RAM and don’t use Photoshop’s 
scratch disk. If you’re having problems applying a filter to a color image, try applying it to each color 
channel individually. (Use Ctrl/Command+F to reapply a filter with the same settings.) Applying a filter 
to a single channel requires significantly less memory. (In a flattened file, each RGB channel is equal 
to about one-third the entire file size; a CMYK channel is about one-fourth the size of the entire file.)

Note: Some filters produce different results when applied to separate channels instead of to the 
composite image.



Tips for working efficiently 

Work in two windows

You can save time by using the View > New View command to open a second window for a document.
For example, you can work on a magnified version of an image in one window while viewing the entire
image in a second window, or you can use two windows to view the results of color corrections in the 
composite color channel and in an individual channel of an image.



Tips for working efficiently 

Work on low-resolution copies of files

Another way to save time and space is to create a low-resolution version of your file. Be sure to give 
this copy a unique name when you create it so that you don’t overwrite your original high-resolution 
image.

A low-resolution image is useful for making initial editing and color corrections. If you’re adjusting 
color, save the settings by using the Save buttons in the color-adjustment dialog boxes, or recording 
them as actions in the Action palette. Once you know which features and dialog box settings produce 
the results you want, open the original file and repeat the steps; then use the Load button to apply 
saved settings to the original file.



Tips for working efficiently 

Reduce the number of history states

You can improve performance by reducing the number of states saved in the History palette.

To reduce the number of history states:

1    Choose History Options from the History palette.

2    Enter a lower number for the Maximum History Items and click OK.



Tips for working efficiently 

Turn off automatic snapshots

Turning off the option to automatically create a snapshot of the image when you open it can open files 
faster. This is particularly useful when running actions in batch mode.

To turn off automatic snapshots:

1    Choose Window > Show History.

2    Choose History Options from the History palette menu.

3    Deselect Automatically Create First Snaphot and click OK.



Tips for working efficiently 

Adjust the image cache setting

Photoshop uses a technology called image caching to help speed the redraw of high-resolution 
images. With image caching, Photoshop uses lower-resolution versions of an image to update the 
image on-screen when performing basic operations, such as layering and applying color adjustments. 
You can adjust the image cache setting and determine whether or not Photoshop uses the image 
cache to display histograms.

Note: Using Image Cache can result in inaccurate previews when viewing high-frequency or noisy 
data. In these cases, Image Cache smooths this data away.

To change the cache settings:

1    Do one of the following:
•      In Windows, choose File > Preferences > Memory & Image Cache.
•      In Mac OS, choose File > Preferences > Image Cache.

2    For Cache Levels, enter a value between 1 and 8. A higher value results in more caching and 
quicker screen redraw, but also uses more hard disk space and RAM, and can increase the time it 
takes to open a file.

For on-screen previews that always match your output, view your images at 100% magnification. 
When viewing images at other magnifications when your image cache is set greater than 1, there may 
be differences between how your image appears: flattened versus unflattened, in preview dialogs 
versus in the document window, and on-screen versus when printed.

If you are working with small files (for example, frames of QuickTime movies or screen images), you 
may want to use a Cache Levels setting of 2 or 3. If you are working with large files (for example, files 
larger than 4096 pixels high or wide), you may want to use a setting higher than 4. To turn off image 
caching altogether, use a Cache Levels setting of 1.

3    To increase the speed of histogram displays, select Use Cache for Histograms. Selecting this 
option produces a faster, though slightly less accurate, histogram display when you choose Image > 
Adjust > Levels or Image > Histogram.

4    Click OK.
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See also: 

Additional resources 

Before you call Adobe Technical Support 

Setup and performance problems 

Problems starting Photoshop or opening or saving files (Windows 95 only) 

Problems with image appearance 



Troubleshooting 

Additional resources

•      For last-minute information not included in this user guide, see the Read Me file installed with the 
program.
•      For a list of technical support resources, see the notice that came with the program.
•      For additional information on technical support resources, see the files on the CD-ROM.
•      For additional technical and troubleshooting information, browse through the Adobe Technical 
Library on the application CD-ROM.



Troubleshooting 

Before you call Adobe Technical Support

There are several steps you can take before calling technical support to receive assistance. 
Performing these steps can solve many problems and often eliminates the need for telephone 
assistance.

See also: 

Reinstall Adobe Photoshop 

Check for new software or setting conflicts 

Check for the current video driver (Windows only) 

Check for a software conflict 

Deactivate the preferences file 

Check SCSI device connections 

Optimize your hard disk 



Before you call Adobe Technical Support 

Reinstall Adobe Photoshop 

Many operational problems can be solved by simply reinstalling Photoshop.

If you encounter problems installing or reinstalling Photoshop, delete all of your Photoshop 
applications files, including the preferences file. Do this by using Add/Remove Programs located in the
Control Panels Folder (Windows) or by dragging the files to the Trash folder (Mac OS). Then try the 
following:
•      If you are experiencing problems installing from the CD, copy the entire Photoshop installation 
folder (Photoshop on Windows; Adobe Photoshop® on the Mac OS) to your hard disk and then install 
from the hard disk after following the instructions in the next paragraphs. 
•      On Windows, remove all items from the StartUp folder (located in Windows/Start Menu/ 
Programs/StartUp). Then restart in Safemode (Windows 95) or in VGA mode (Windows NT). To 
display the Windows Startup screen, Press F8 when the message “Starting Windows 95” appears. 
See your Windows documentation for instructions on deactivating startup software and changing 
restart options. Reinstall Adobe Photoshop, and then restart Windows again in its normal mode. 
(Photoshop does not run in Safemode, VGA mode, or with the VGA driver.)

Note: Although the Photoshop installer (a separate program) can run in Windows 95 “Safe Mode” or in
fewer than 256 colors, Photoshop can only run when your Windows video is set to 256 colors or more.
•      On the Macintosh, use the Extensions Manager control panel or a third-party extension manager 
utility to temporarily turn off all extensions except your CD ROM extension. On most Macintoshes, this 
is the Apple CD ROM extension. Then reinstall Adobe Photoshop.



Before you call Adobe Technical Support 

Check for new software or setting conflicts

Problems with Adobe Photoshop can often be traced to recent installation of new software or utilities 
that are running at the same time as Photoshop. If you have recently installed new software or 
changed other system configuration settings, such as your monitor setting, try de-installing the 
software or restoring your original settings. (If you de-install software, you might need to reinstall 
Photoshop following the instructions in the previous section. This will ensure that any Photoshop files 
that might have been damaged by your new software installation are restored.) If the problem 
disappears, you can try reinstalling the problem software or system utility or contact the manufacturer 
for a new version and for compatibility information.



Before you call Adobe Technical Support 

Check for the current video driver (Windows only)

In Windows be sure you have a current video driver that’s written specifically for your video card. To 
obtain the latest video driver for your hardware, contact the manufacturer of your video card.



Before you call Adobe Technical Support 

Check for a software conflict

In Windows, remove items that will launch at startup. Use Windows Explorer to move the shortcut files
in the Windows\Start Menu\Programs\Startup folder to a different folder. On the Macintosh, hold down 
the Shift key and restart the computer to restart with extensions off. (See your Windows or Macintosh 
documentation for more information on deactivating startup software.) 

If the problem disappears after restarting Photoshop, try restarting your computer with selected startup
items reactivated until you have identified the problem software. You can then try reinstalling the 
software, or remove the software and contact the software manufacturer for a new version and for 
compatibility information.



Before you call Adobe Technical Support 

Deactivate the preferences file 

To check whether your problem is caused by a corrupted preferences file, quit Adobe Photoshop, 
deactivate the preferences file, and restart Photoshop. 

To deactivate the preferences file in Windows, rename the Adobe Photoshop 5 Prefs.psp and the 
Color Settings.psp files (located in your Photoshop\Adobe Photoshop Settings directory).

Note: To make it easier to figure out which files you are seeing, start Windows Explorer and choose 
View > Options. Then deselect the option Hide MS-DOS file extensions for file types that are    
registered.

To deactivate the preferences file on the Macintosh, drag the Adobe Photoshop Prefs file (located in 
the Adobe Photoshop/Adobe Photoshop Settings folder) to the Trash. If the problem disappears, 
delete the preferences. If the problem persists, restore the preferences file to its original names 
(Windows) or location (Mac OS) to preserve your preferences settings.



Before you call Adobe Technical Support 

Check SCSI device connections

Make sure that the devices you are using are securely and fully connected to your computer, that they 
are properly terminated, and that device cords are not damaged. The cause of the problem could be a 
bad connection.

You can also turn off all power and disconnect all SCSI devices. Then turn on your system and check 
if the problem disappears when you are no longer using a SCSI device. Test each device in the chain 
of SCSI devices.

Important: Be sure to turn off your computer and SCSI devices before connecting, disconnecting, or 
checking SCSI cable connections. Failure to do so can damage your hardware.

Remove all Photoshop plug-ins

In rare cases, third-party Photoshop plug-ins can conflict with other plug-ins, hardware, or other 
software on your system. To ensure that the cause of your problem is not a plug-in conflict, temporarily
remove all your plug-ins and restart Photoshop. To confirm that no plug-ins are loading, after restarting
Photoshop select About Plug-ins from the Help Menu (Windows) or the Apple menu (Mac OS). If 
About Plug-ins is unselectable (grayed out), no plug-ins are loaded.



Before you call Adobe Technical Support 

Optimize your hard disk 

Use a disk utility, such as Norton Utilities or Scandisk, to check whether your hard disk contains bad 
sectors that may be causing the crashes. You can then use a defragmenting utility to optimize the hard
drive. (Defragmenting orders data contiguously so that it can be accessed quickly.) For instructions, 
see the utility’s documentation. 
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Setup and performance problems

See also: 

Commands don’t appear in menus; Filter (or Import or Export) menu and submenus are gray or 
missing 

Operations seem unusually slow, or out-of-memory messages appear frequently 

Scratch disk full messages appear 

Space on hard disk appears lost 



Setup and performance problems 

Commands don’t appear in menus; Filter (or Import or Export) menu and 
submenus are gray or missing.

Photoshop recognizes only one plug-ins folder at a time. As a result, if you don’t put new plug-ins into 
that folder, Photoshop won’t know about them. Similarly, if you put new plug-ins into a folder outside of
the current plug-ins folder, and then set Photoshop to recognize the new folder, it will no longer know 
about the plug-ins in the old plug-ins folder. For convenience, you can nest plug-ins in folders within 
folders, as long as you select only one plug-in folder at a time.

Choose File > Preferences > Plug-Ins & Scratch Disks, and make sure that you have selected the 
plug-ins folder containing the modules that you want to use. See Setting preferences for information 
on choosing the plug-ins folder.



Setup and performance problems 

Operations seem unusually slow, or out-of-memory messages appear 
frequently.

Your system settings—such as the amount of RAM and use of the system’s virtual memory—may be 
slowing down Adobe Photoshop operations. For information on setting up RAM and virtual memory in 
Photoshop and for other tips on improving performance, see Improving Performance.”



Setup and performance problems 

Scratch disk full messages appear.

This error usually occurs when you are low on hard drive space, which Photoshop needs to process 
your images. Choose File > Preferences > Plug-Ins & Scratch Disks to determine where your scratch 
disks are located. Then use Windows Explorer or the Mac OS Finder to determine the amount of 
space available on those hard drives. Set the primary scratch disk space to a drive which contains 
contiguous free space that equals at least 3 to 5 times the size of your document in Photoshop.

For more information on the scratch disk, see Determining the amount of scratch disk space required.



Setup and performance problems 

Space on hard disk appears lost.

When a Photoshop file is open, the system creates a temporary (.tmp) file to hold the information 
about the open images. Normally, this temporary file is deleted when you quit the program. However, 
sometimes when the system crashes the file is not deleted. Undeleted temporary files can cause 
system, printing, scanning, and saving errors and can take up space unnecessarily on the scratch disk
volume.

Note: Before attempting to delete temporary files, quit Photoshop and any other applications currently 
running. In the unlikely event that another application uses the .tmp extension for anything other than 
Windows temp files, these files should not be deleted. 

To restore the hard disk space and fix these problems caused by temporary files in Windows, search 
for files ending in .tmp on all hard drives from the root directory, including subfolders. Then delete 
the .tmp files and run the Scandisk utility and a defragmentation utility as described in Before you call 
Adobe Technical Support. (Note that you will not be able to delete the active Windows .tmp file.) For 
more information, see your Windows documentation.

To restore the hard disk space and fix these problems caused by temporary files on your Macintosh, 
empty the Trash to delete the temporary files. For more information, see your Macintosh 
documentation.
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Problems starting Photoshop or opening or saving files (Windows 95 only)

When you start or work in Adobe Photoshop in Windows 95, one of these messages appears:

“Could not launch Photoshop because of a program error”

“Could not open file <filename> because of a program error.”

“Could not save file <filename> because of a program error.”

When Photoshop starts, and when it acquires, opens, scans, creates, or saves a file, it checks the 
default printer driver for information about that printer. For example, it checks for the page size, 
margins, and imageable area. 

If Photoshop can’t interpret this information, it displays an error message. This can occur if the printer 
driver is damaged, if it is incompatible with Windows 95, or if the driver is designed for a non-printer 
device (such as a fax machine) or for a non-PostScript printer (such as PCL).

To set an appropriate printer driver:

Do one of the following:
•      Specify a different default printer. To do so, choose Start > Settings > Printers from the Windows 
desktop. Then, right-click a PostScript printer other than the current default printer, and choose Set as 
Default from the pop-up menu. If a PostScript printer driver isn’t installed, you can select a non-
PostScript printer. However, don’t select a non-printer device, such as a fax or modem.
•      Install a PostScript printer driver (such as an Adobe PostScript printer driver or Microsoft 
PostScript printer driver) and set up that printer as your default printer. You don’t need a PostScript 
printer connected to your computer to install a PostScript printer driver. (For more information on 
installing printer drivers, see your Windows documentation.)
•      Remove and reinstall the printer driver for the default printer. For instructions, see the printer driver
documentation or contact the printer manufacturer.
•      Install an updated version of the printer driver for the default printer. Contact the printer driver 
manufacturer for availability.
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Problems with image appearance

Printed image appears different from image on-screen.

For accurate color printing, it is essential to calibrate your monitor and the Adobe Photoshop program 
for the various factors that affect the printed output. See Choosing a Color Mode and Reproducing 
Color Accurately for more information.

On-screen preview of image appears different after file is flattened.

When displaying an image at less than 100% magnification, the on-screen preview is an 
approximation of the actual pixels in the image. To maximize Photoshop’s performance, this 
approximation may be made slightly differently with layered files. In most cases, the differences are 
not noticeable, but files with many adjustment layers or extensive use of blending modes may look 
different on-screen after flattening. When printed or viewed at 100% or greater magnification, the file 
will be unchanged. To view a file at 100% magnification, choose View > Actual Pixels.

See also: 

CMYK colors displayed in the Info palette are different from those specified in RGB mode 

Painting tools don’t work 

The pointer disappears (Mac OS only) 

Only 16 pixels are available for the brush size (Mac OS only) 



Problems with image appearance 

CMYK colors displayed in the Info palette are different from those specified in 
RGB mode.

How colors are translated between CMYK and RGB modes is determined by the parameters specified
in the Profile Setup, RGB Setup, and CMYK Setup dialog boxes. Depending on the settings of these 
parameters, CMYK values specified in RGB mode may separate as different values. (If the colors are 
specified in CMYK mode, they will separate as specified.) See Choosing a Color Mode and 
Reproducing Color Accurately for detailed information on color in Adobe Photoshop.

To determine the actual values that will result from a separation in RGB mode, choose Window > 
Show Colors to display the Colors palette. Be sure to set the Colors palette to the CMYK mode. Use 
the eyedropper tool to display the color in the Colors palette. (The color values appear next to the 
sliders.)



Problems with image appearance 

Painting tools don’t work.

Painting tools work only on the target layer and inside areas that are parts of the current selection or 
when no part of the layer is selected. 

Check to make sure that you are not painting outside a selected area. Check to make sure that you 
have not previously hidden the edges of the selection by pressing Ctrl/Command+H, or press Q to 
switch to QuickMask mode, to see which pixels are selected. If you are painting outside a selected 
area, choose Select > Deselect to deselect everything or Select > Inverse to switch the selected and 
unselected areas. 

You might also be attempting to paint or fill a layer that has the Preserve Transparency option 
selected. In this case, painting is limited to the areas of the layer that contain pixels. Deselect this 
option in the Layers palette to edit anywhere on the layer.



Problems with image appearance 

The pointer disappears (Mac OS only).

Try either disabling or enabling the Direct Cursors extension in the Extensions folder. To turn off the 
extension, first create a new folder outside of the Photoshop folder; then drag the Direct Cursors 
extension out of the Extensions folder (located in the Plug-Ins folder) and into the new folder.



Problems with image appearance 

Only 16 pixels are available for the brush size (Mac OS only).

Disabling the Direct Cursors extension restricts the number of pixels available for the brush size. To fix
this problem, turn on the Direct Cursors extension by placing it in the Extensions folder within the 
Plug-Ins folder. 

Rectangular space appears around Photoshop images placed in other applications.

All exported Photoshop images are bitmaps on a rectangular grid of pixels. Therefore, by default, 
white backgrounds and transparent areas are visible when placed in other programs. To correct this 
problem, you need to create a clipping path for the image and save it in EPS or TIFF with the proper 
preview option. For more information, see Using clipping paths.

Some applications, such as Microsoft Word, also accept the PNG format. To save a file in PNG format 
with transparent areas, include an alpha channel that specifies the transparency.



Pixelate

Original Color Halftone



Pixelate

Original Crystallize



Pixelate

Original Facet



Pixelate

Original Fragment



Pixelate

Original Mezzotint



Pixelate

Original Mosaic



Pixelate

Original Pointillize



Render

Original Clouds



Render

Original Difference Clouds



Render

Original Lens Flare



Sharpen

Original Sharpen Edges



Sharpen

Original Sharpen More



Sharpen

Original Unsharp Mask



Sketch

Original Bas Relief



Sketch

Original Chalk & Charcoal



Sketch

Original Chrome



Sketch

Original Conté Crayon



Sketch

Original Graphic Pen



Sketch

Original Note Paper



Sketch

Original Photocopy



Sketch

Original Plaster



Sketch

Original Reticulation



Sketch

Original Stamp



Sketch

Original Water Paper



Stylize

Original Diffuse



Stylize

Original Emboss



Stylize

Original Extrude, pyramids



Stylize

Original Extrude, blocks



Stylize

Original Find Edges



Stylize

Original Glowing Edges



Stylize

Original Solarize



Stylize

Original Tiles, inverse image



Stylize

Original Tiles, background color



Stylize

Original Trace Contour



Stylize

Original Wind



Texture

Original Craquelure



Texture

Original Grain



Texture

Original Mosaic Tiles



Texture

Original Patchwork



Texture

Original Stained Glass



Texture

Original Texturizer, burlap texture



Texture

Original Texturizer, custom texture



JPEG

Original, 248K

Quality 10, 135K

Quality 5, 53K

Quality 0, 40K



GIF, adaptive palette, diffusion dither

Original, 248K

256 colors, 76K

64 colors, 55K

16 colors, 36K



GIF, adaptive palette, no dither

Original, 248K

256 colors, 66K

64 colors, 44K

16 colors, 30K



The rectangular marquee tool makes rectangular selections.



The move tool moves selections, layers, and guides.



The lasso tool makes freehand selections.



The magic wand tool selects similarly colored areas.



The airbrush tool paints soft-edged strokes.



The paintbrush tool paints brush strokes.



The clone stamp tool paints with a copy of an image.



The history brush tool paints with the selected state or snapshot.



The eraser tool erases pixels and restores parts of an image to a previously saved state.



The pencil tool draws hard-edged strokes



The blur tool blurs hard edges in an image.



The dodge tool lightens areas in an image.



The pen tool lets you draw smooth-edged paths.



The type tool creates type on an image.



The measure tool measures distances, locations, and angles.



The linear gradient tool creates a straight-line blend between colors.



The paint bucket tool fills similarly colored areas with the foreground color.



The eyedropper tool samples colors in an image.



The hand tool moves an image within its window.



The zoom tool magnifies and reduces the view of an image.



The elliptical marquee tool makes elliptical selections.



The single row and single column marquee tools make 1 - pixel wide selections.



The crop tool trims images.



The polygon lasso tool makes freehand and straight-edged selections.



The magnetic lasso tool draws selection borders that cling to the edges of objects.



The line tool draws straight lines.



The pattern stamp tool paints with the selection as a pattern.



The sharpen tool sharpens soft edges.



The smudge tool smudges data in an image.



The burn tool darkens areas in an image.



The sponge tool changes the color saturation of an area.



The magnetic pen tool draws paths that cling to the edges of objects.



The freeform pen tool draws paths directly as you drag.



The add-anchor-point tool adds anchor points to a path.



The delete-anchor-point tool deletes anchor points from a path.



The direct-selection tool selects and moves paths and parts of paths.



The convert-anchor-point tool converts straight line segments to curved segments, and vice versa.



The type mask tool creates selection borders in the shape of type.



The vertical type tool creates vertical type on an image.



The vertical type mask tool creates selection borders in the shape of the vertical type.



The radial gradient tool creates a circular blend between colors.



The angle gradient tool creates an angular blend between colors.



The reflected gradient tool creates symmetric straight-line blends between colors



The diamond gradient tool creates diamond-shaped blends between colors.



The color sampler tool samples up to four locations simultaneously.



Bitmap 12K

Bitmapped images are made up of 1 bit of color (black or white) per pixel, and require the least amount of 
disk space. 



RGB color 270K*

RGB images use three colors to reproduce up to 16.7 million colors on-screen. RGB images are three-
channel images, so they contain 24 (8 x 3) bits per pixel.



Grayscale 90K*

Grayscale images are made up of 8 bits of information per pixel and use 256 shades of gray to simulate 
gradations in color.



CYMK color 359K*

CMYK images consist of the four colors used to print color separations. They are four-channel images, 
containing 32 (8 x 4) bits per pixel. 



Duotone 90K

Duotone mode is used for monotones, duotones, tritones, and quadtones. These images are grayscale, 
single-channel images with 8 bits per pixel.



 Lab color 270K

Lab images use three components to represent color. They are three-channel images containing 24 (8 x 
3) bits per pixel. 



Indexed color 90K

Indexed color images are single-channel images (8 bits per pixel) that use a color lookup table containing 
256 colors. Limited editing is available in this mode.



Multichannel 90K

Multichannel images have 8 bits per pixel, and are used for specialized printing purposes. 



Flat image

Midpoint fixed: 1/4 and 3/4 tones adjusted in opposite directions to boost contrast

Original

Corrected



Light image

1/4 tone fixed: highlights, midtones and 3/4 tones adjusted to darken image

Original

Corrected



Dark image

Entire curve dragged to lighten image with emphasis in midtones

Original

Corrected



Blending Modes

Original Normal



Blending Modes

Original Normal, 50% opacity



Blending Modes

Original Dissolve



Blending Modes

Original Multiply



Blending Modes

Original Screen



Blending Modes

Original Soft Light



Blending Modes

Original Hard Light



Blending Modes

Original Color Dodge



Blending Modes

Original Color Burn



Blending Modes

Original Darken



Blending Modes

Original Lighten



Blending Modes

Original Difference



Blending Modes

Original Saturation



Blending Modes

Original Color



Blending Modes

Original Luminosity



Layer Blending Modes

Original Normal



Layer Blending Modes

Original Normal, 70% opacity



Layer Blending Modes

Original Dissolve



Layer Blending Modes

Original Multiply



Layer Blending Modes

Original Screen



Layer Blending Modes

Original Overlay



Layer Blending Modes

Original Overlay 50%



Layer Blending Modes

Original Soft Light



Layer Blending Modes

Original Hard Light



Layer Blending Modes

Original Color Dodge



Layer Blending Modes

Original Color Burn



Layer Blending Modes

Original Darken



Layer Blending Modes

Original Lighten



Layer Blending Modes

Original Difference



Layer Blending Modes

Original Exclusion



Layer Blending Modes

Original Hue



Layer Blending Modes

Original Saturation



Layer Blending Modes

Original Color



Layer Blending Modes

Original Luminosity



Artistic

Original Colored Pencil



Artistic

Original Cutout



Artistic

Original Dry Brush



Artistic

Original Film Grain



Artistic

Original Fresco



Artistic

Original Neon Glow



Artistic

Original Paint Daub



Artistic

Original Palette Knife



Artistic

Original Plastic Wrap



Artistic

Original Poster Edges



Artistic

Original Rough Pastels



Artistic

Original Smudge Stick



Artistic

Original Sponge



Artistic

Original Underpainting



Artistic

Original Watercolor



Blur

Original Blur More



Blur

Original Gaussian Blur, radius 4



Blur

Original Gaussian Blur, radius 8



Blur

Original Motion Blur



Blur

Original Radial Blur, spin



Blur

Original Radial Blur, zoom



Blur

Original Smart Blur



Brush Strokes

Original Accented Edges



Brush Strokes

Original Angled Strokes



Brush Strokes

Original Crosshatch



Brush Strokes

Original Dark Strokes



Brush Strokes

Original Ink Outlines



Brush Strokes

Original Spatter



Brush Strokes

Original Sprayed Strokes, diagonal



Brush Strokes

Original Sumi-e, high contrast



Distort

Original Diffuse Glow



Distort

Original Displace



Distort

Original Glass, tiny lens texture



Distort

Original Glass, blocks texture



Distort

Original Ocean Ripple



Distort

Original Pinch



Distort

Original Polar Coordinates



Distort

Original Ripple



Distort

Original Shear



Distort

Original Spherize



Distort

Original Twirl



Distort

Original Wave, sine type



Distort

Original Wave, square type



Distort

Original ZigZag, out from center



Distort

Original ZigZag, pond ripples



Noise

Original Add Noise, 25



Noise

Original Add Noise, 55



Noise

Original Median




